This is a good simplification but for a wrong implementation :). we know
that our current
implementation is wrong and needs to be done the opposite way to make
our code compliant with spec. i assume that it will then be a question
of when
this will be removed rather than if. In such a scenario
On 10/23/2015 3:31 PM, Ander Conselvan de Oliveira wrote:
Add a function for retrieving the current voltage swing being used for
link training. Using that function in the clock recovery code makes it a
bit more readable.
Signed-off-by: Ander Conselvan de Oliveira
---
drivers/gpu/drm/i915/i
Reviewed-by: Sivakumar Thulasimani
On 10/23/2015 3:31 PM, Ander Conselvan de Oliveira wrote:
The function name implies it should get intel_dp, and it mostly used
where there is an intel_dp in the context.
Signed-off-by: Ander Conselvan de Oliveira
---
drivers/gpu/drm/i915/intel_dp.c
Reviewed-by: Sivakumar Thulasimani
On 10/23/2015 3:31 PM, Ander Conselvan de Oliveira wrote:
In order to prepare for a link training with DDI, the state machine
would call intel_ddi_prepare_link_retrain(). To remove the dependency to
the hardware information, replace that direct call with a cal
Reviewed-by: Sivakumar Thulasimani
On 10/23/2015 3:31 PM, Ander Conselvan de Oliveira wrote:
No functional changes, just moving code around.
v2: Rebase
Signed-off-by: Ander Conselvan de Oliveira
---
drivers/gpu/drm/i915/Makefile | 1 +
drivers/gpu/drm/i915/intel_dp.c
Reviewed-by: Sivakumar Thulasimani
On 10/23/2015 3:31 PM, Ander Conselvan de Oliveira wrote:
Move register write from intel_dp_update_link_train() into
intel_dp_set_signal_levels(). This creates a better split between the
i915 specific code and the generic link training part. Note that this
cau
Reviewed-by: Sivakumar Thulasimani
On 10/23/2015 3:31 PM, Ander Conselvan de Oliveira wrote:
Move the call to intel_dp_get_adjust_train() out of
intel_dp_update_link_train() and call it instead from the clock recovery
and channel equalization features. A follow up patch will remove the DP
regis
Reviewed-by: Sivakumar Thulasimani
On 10/23/2015 3:31 PM, Ander Conselvan de Oliveira wrote:
Split the register write with the new link training pattern out of
intel_dp_set_link_train(), so that the i915 specific code is in a
separate function.
Signed-off-by: Ander Conselvan de Oliveira
---
Thanks for making the changes suggested :)
Reviewed-by: Sivakumar Thulasimani
On 10/23/2015 3:31 PM, Ander Conselvan de Oliveira wrote:
It just makes the code more confusing, so just reference intel_dp_>DP
directly.
Note that this also fix a bug where the value of intel_dp->DP could be
differ
On Fri, Oct 23, 2015 at 10:40:11PM +0100, Dave Gordon wrote:
> >@@ -732,6 +727,11 @@ intel_logical_ring_advance_and_submit(struct
> >drm_i915_gem_request *request)
> > if (intel_ring_stopped(ring))
> > return;
> >
> >+if (request->ctx != ring->default_context)
> >+i
10 matches
Mail list logo