No need to repeatedly call update_watermarks, or update_fbc.
For update_watermarks once should be enough after disabling crtc's
and swapping the state.
Down to a single call to update_watermarks in .crtc_enable
Signed-off-by: Maarten Lankhorst
---
There is no v1, this patch was added later to th
Assume the function is locked with drm_modeset_lock_all for now.
Signed-off-by: Maarten Lankhorst
---
Changes since RFC v1:
- Get rid of the crtc->state->active assignment in intel_crtc_control,
it caused the whole state to be confused.
- Convert some places that use state->enable to state->
This kills off most of the transitional sers and uses atomic plane updates
in the modeset path to update everything.
Signed-off-by: Maarten Lankhorst
---
Changes since v1:
- Add atomic and sprite planes during a modeset too so they
will be restored.
- Drop a WARN_ON(!crtc_state->enabled) in
Hi John,
Feel free to submit a new patch.
Regards,
Yongjun Wei
From: John Hunter [mailto:zhjw...@gmail.com]
Sent: 2015年4月22日 10:30
To: weiyj...@163.com; Daniel Vetter; Jani Nikula; David Airlie; Yongjun Wei
(RD-CN); intel-gfx@lists.freedesktop.org; dri-de...@lists.freedesktop.org; open
list
Su
Sure, but I need Daniel to admit that, because maybe include the two header
file make it easier to understand.
And after checked other files in drm/i915, I found that a lot other file do
the
same thing(include both header file). So I will just wait Daniel to wait up
and
give me the order :-)
On We
Hi,
I think maybe we should remove both of the two lines:
#include "intel_drv.h"
#include "i915_drv.h"
Because we have* two* "intel_drv.h" and *one* "i915_drv.h", and
"i915_drv.h" has already been included in the "intel_drv.h".
I not sure whether i am right. If you need me to do the patch,
let me
On Wed, 22 Apr 2015, Dave Gordon wrote:
> The kerneldoc for the functions doesn't match the code; the
> last two parameters (buflen, skip) have been transposed, which
> is confusing, especially as they're both integral types and the
> compiler won't warn about swapping them.
>
> These functions an
Tested-By: Intel Graphics QA PRTS (Patch Regression Test System Contact:
shuang...@intel.com)
Task id: 6248
-Summary-
Platform Delta drm-intel-nightly Series Applied
PNV
On Tue, Apr 21, 2015 at 2:09 PM, Todd Previte wrote:
> Displayport compliance test 4.2.2.6 requires that a source device be capable
> of
> detecting a corrupt EDID. The test specification states that the sink device
> sets up the EDID with an invalid checksum. To do this, the sink sets up an
> in
Tested-By: Intel Graphics QA PRTS (Patch Regression Test System Contact:
shuang...@intel.com)
Task id: 6249
-Summary-
Platform Delta drm-intel-nightly Series Applied
PNV
On 17 April 2015 at 23:10, Mike Mason wrote:
> Signed-off-by: Mike Mason
I've pushed this patch, but I'm not actually sure if this test should
actually be included in the test suite or part of the package check
scripts. Daniel might be able to confirm the original intention.
> ---
> tests/too
On 22 April 2015 at 14:37, Tvrtko Ursulin
wrote:
>
> Hi,
>
> On 04/22/2015 12:14 PM, Sonika Jindal wrote:
>>
>> Adding 90/270 rotation testcase for primary and sprite planes.
>>
>> v2: Added position test for sprite. Checking for gen > 9 for 90/270.
>> Some cleanup and rebase.
>> v3: Added test fo
"kms_plane_scaling" would be a better tag for this commit. You can
still make sure that "i-g-t" appears in the subject line by using the
--subject-prefix="PATCH i-g-t" option when using git send-email.
On 16 April 2015 at 00:19, Chandra Konduru wrote:
> From: chandra konduru
>
> Adding rotation
On Wed, Apr 22, 2015 at 05:23:11PM +0100, Tvrtko Ursulin wrote:
>
> Hi,
>
> On 04/22/2015 05:07 PM, Chris Wilson wrote:
> >On Wed, Apr 22, 2015 at 05:00:27PM +0100, Tvrtko Ursulin wrote:
> >>From: Tvrtko Ursulin
> >>
> >>This matches the behaviour in kernel patch
> >>"drm/i915/skl: Disallow tili
The current aliasing ppgtt implementation allocates
the page table structures on driver initialization
for the entire vm address space. Earlier the page tables
were allocated as array of struct pages, but introduction
of dynamic allocation of page structures changed the page
tables to be inside a p
On Wed, Apr 22, 2015 at 05:13:38PM +0100, Michel Thierry wrote:
> Aliasing ppgtt is fully allocated right after creation, thus shouldn't
> need to call allocate_va_range in i915_vma_bind.
And?
> This duplication started after commit 5c5f645773b6d147bf68c350674dc3ef4f8de83d
> ("drm/i915: drm/i915
Hi,
On 04/22/2015 05:07 PM, Chris Wilson wrote:
On Wed, Apr 22, 2015 at 05:00:27PM +0100, Tvrtko Ursulin wrote:
From: Tvrtko Ursulin
This matches the behaviour in kernel patch
"drm/i915/skl: Disallow tiling changes during page flip".
Signed-off-by: Tvrtko Ursulin
Cc: Chris Wilson
---
te
Aliasing ppgtt is fully allocated right after creation, thus shouldn't
need to call allocate_va_range in i915_vma_bind.
This duplication started after commit 5c5f645773b6d147bf68c350674dc3ef4f8de83d
("drm/i915: drm/i915: Unify aliasing ppgtt handling"), as aliasing ppgtt
now also uses allocate_va_
On 4/22/2015 12:36 AM, Linus Torvalds wrote:
So I just go the appended NULL pointer de-reference when trying to
look at a video from my GoPro.
The code disassembles to
0: 81 fb 00 04 00 00 cmp$0x400,%ebx
6: 41 89 07 mov%eax,(%r15)
9: 74 78 je
On Wed, Apr 22, 2015 at 05:00:27PM +0100, Tvrtko Ursulin wrote:
> From: Tvrtko Ursulin
>
> This matches the behaviour in kernel patch
> "drm/i915/skl: Disallow tiling changes during page flip".
>
> Signed-off-by: Tvrtko Ursulin
> Cc: Chris Wilson
> ---
> tests/kms_flip_tiling.c | 23 +
From: Tvrtko Ursulin
This matches the behaviour in kernel patch
"drm/i915/skl: Disallow tiling changes during page flip".
Signed-off-by: Tvrtko Ursulin
Cc: Chris Wilson
---
tests/kms_flip_tiling.c | 23 ++-
1 file changed, 14 insertions(+), 9 deletions(-)
diff --git a/tes
From: Tvrtko Ursulin
Signed-off-by: Tvrtko Ursulin
Cc: Sonika Jindal
---
tests/kms_rotation_crc.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/tests/kms_rotation_crc.c b/tests/kms_rotation_crc.c
index a523527..f871e2a 100644
--- a/tests/kms_rotation_crc.c
+++ b/tests/kms_rotation_crc.c
From: Tvrtko Ursulin
Saves a good amount of code duplication by supporting expected
failures from the main loop.
Signed-off-by: Tvrtko Ursulin
Cc: Sonika Jindal
---
tests/kms_rotation_crc.c | 106 +++
1 file changed, 33 insertions(+), 73 deletions(-
From: Tvrtko Ursulin
Signed-off-by: Tvrtko Ursulin
Cc: Sonika Jindal
---
tests/kms_rotation_crc.c | 19 +--
1 file changed, 9 insertions(+), 10 deletions(-)
diff --git a/tests/kms_rotation_crc.c b/tests/kms_rotation_crc.c
index eda66de..22bc554 100644
--- a/tests/kms_rotation_
From: Tvrtko Ursulin
Signed-off-by: Tvrtko Ursulin
Cc: Sonika Jindal
---
tests/kms_rotation_crc.c | 3 ---
1 file changed, 3 deletions(-)
diff --git a/tests/kms_rotation_crc.c b/tests/kms_rotation_crc.c
index ab13f70..a523527 100644
--- a/tests/kms_rotation_crc.c
+++ b/tests/kms_rotation_crc.
From: Tvrtko Ursulin
I thought I will need to add some page flipping tests here and wanted
to do some cleanups first.
Unfortunately (or fortunately), kms_flip_tiling already tests Y tiled
flips with CRC so the focus shifts to fixing that one.
But these cleanups are still an improvement in amoun
From: Tvrtko Ursulin
There can only be one, either a plane or a cursor, in each subtest so there
is no need for two framebuffer varilables and also some codepaths can be
unified.
Signed-off-by: Tvrtko Ursulin
Cc: Sonika Jindal
---
tests/kms_rotation_crc.c | 150 ---
From: Tvrtko Ursulin
Now that size is calculated in a single place and correct geometry passed in,
paint squares does not need to concern itself with it.
Signed-off-by: Tvrtko Ursulin
Cc: Sonika Jindal
---
tests/kms_rotation_crc.c | 10 --
1 file changed, 10 deletions(-)
diff --git a
From: Tvrtko Ursulin
It is just there to light up the display using the full modeset. Also renamed it
from fb_full to fb_modeset to be more descriptive.
Signed-off-by: Tvrtko Ursulin
Cc: Sonika Jindal
---
tests/kms_rotation_crc.c | 25 ++---
1 file changed, 10 insertions(+
Tested-By: Intel Graphics QA PRTS (Patch Regression Test System Contact:
shuang...@intel.com)
Task id: 6247
-Summary-
Platform Delta drm-intel-nightly Series Applied
PNV
On Wed, Apr 22, 2015 at 04:07:47PM +0200, Lukas Hejtmanek wrote:
> Hello,
>
> not sure whether this list is send-patch-only or for support as well.
>
> However, I have Lenovo X1 Carbon 3rd gen, with 2560x1440 local panel and 4k
> (3840x2160) external display connected via display port (directly o
Hello,
not sure whether this list is send-patch-only or for support as well.
However, I have Lenovo X1 Carbon 3rd gen, with 2560x1440 local panel and 4k
(3840x2160) external display connected via display port (directly on X1).
It has Intel HD 5500 graphics.
using xrandr, I can see:
xrandr
Scre
Op 22-04-15 om 13:24 schreef maarten.lankho...@linux.intel.com:
> From: Maarten Lankhorst
>
> Assume the function is locked with drm_modeset_lock_all for now.
>
> Signed-off-by: Maarten Lankhorst
> ---
> drivers/gpu/drm/i915/intel_display.c | 131
> ++-
> 1 file
On 17/04/15 22:21, yu@intel.com wrote:
> From: "Michael H. Nguyen"
>
> Move defines from intel_lrc.c to i915_reg.h so they are
> accessible by the guc files
>
> Issue: VIZ-4884
> Signed-off-by: Michael H. Nguyen
> ---
> drivers/gpu/drm/i915/i915_reg.h | 77
> +
Hi,
On 04/22/2015 12:14 PM, Sonika Jindal wrote:
Adding 90/270 rotation testcase for primary and sprite planes.
v2: Added position test for sprite. Checking for gen > 9 for 90/270.
Some cleanup and rebase.
v3: Added test for unsupported tiling and unsupported pixel format for 90/270
v4: Added
The kerneldoc for the functions doesn't match the code; the
last two parameters (buflen, skip) have been transposed, which
is confusing, especially as they're both integral types and the
compiler won't warn about swapping them.
These functions and the kerneldoc were introduced in commit:
df642
From: Maarten Lankhorst
Signed-off-by: Maarten Lankhorst
---
drivers/gpu/drm/i915/intel_atomic_plane.c | 49 +--
drivers/gpu/drm/i915/intel_display.c | 481 +-
drivers/gpu/drm/i915/intel_sprite.c | 33 +-
3 files changed, 353 insertions(+), 210 deletions
From: Maarten Lankhorst
Signed-off-by: Maarten Lankhorst
---
drivers/gpu/drm/i915/i915_debugfs.c | 18 --
drivers/gpu/drm/i915/intel_display.c | 68 +---
drivers/gpu/drm/i915/intel_drv.h | 1 -
3 files changed, 39 insertions(+), 48 deletions(-)
dif
From: Maarten Lankhorst
Assume the function is locked with drm_modeset_lock_all for now.
Signed-off-by: Maarten Lankhorst
---
drivers/gpu/drm/i915/intel_display.c | 131 ++-
1 file changed, 38 insertions(+), 93 deletions(-)
diff --git a/drivers/gpu/drm/i915/int
From: Maarten Lankhorst
Now that the dpll updates are (mostly) atomic, the .off() code is no longer
used,
and there are no more callers for intel_put_shared_dpll. Move all the updates
done in intel_crtc_disable to intel_modeset_update_state, one less special case
to worry about.
Signed-off-by:
From: Maarten Lankhorst
This prevents unnecessarily updating power domains, while still
enabling all power domains on initial setup.
Signed-off-by: Maarten Lankhorst
---
drivers/gpu/drm/i915/intel_display.c | 52
1 file changed, 41 insertions(+), 11 deletio
Adding 90/270 rotation testcase for primary and sprite planes.
v2: Added position test for sprite. Checking for gen > 9 for 90/270.
Some cleanup and rebase.
v3: Added test for unsupported tiling and unsupported pixel format for 90/270
v4: Added the legacy commit to initiate modeset in the negative
From: Maarten Lankhorst
This applies on top of the patch series:
"[PATCH 00/35] Make legacy modeset a lot more atomic-like"
after the last patch crtc will no longer be enabled/disabled except through
atomic updates, which should make it a lot easier to rely on the atomic state
in the future.
Ma
On 04/22/2015 05:51 AM, Jindal, Sonika wrote:
On 04/07/2015 09:29 AM, Sonika Jindal wrote:
Adding 90/270 rotation testcase for primary and sprite planes.
v2: Added position test for sprite. Checking for gen > 9 for 90/270.
Some cleanup and rebase.
v3: Added test for unsupported tiling and unsu
From: Tim Gore
test kms_legacy_colorkey depends on cairo, so add it to
the list of test not to build unless "ANDROID_HAS_CAIRO"
is set.
Signed-off-by: Tim Gore
---
tests/Android.mk | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/tests/Android.mk b/tests/Android.mk
index 0
45 matches
Mail list logo