On Thu, Sep 05, 2013 at 06:52:07PM +0100, Damien Lespiau wrote:
> It's totally unused, so remove the last mode_fixup appearance in i915.
>
> Signed-off-by: Damien Lespiau
Yeah! Queued for -next, thanks for the patch.
-Daniel
> ---
> drivers/gpu/drm/i915/dvo.h| 11 ---
> drivers/
On Thu, Sep 5, 2013 at 6:46 PM, Chris Wilson wrote:
> That's incorrect, the client will be told the object is busy.
Oh right, I've completely misread your patch and somehow thought
you're comparing the obj->last_rendering_seqno against the current
seqno ... Mea culpa.
We need at least a ACCESS_R
It's totally unused, so remove the last mode_fixup appearance in i915.
Signed-off-by: Damien Lespiau
---
drivers/gpu/drm/i915/dvo.h| 11 ---
drivers/gpu/drm/i915/intel_dvo.c | 5 -
drivers/gpu/drm/i915/intel_sdvo.c | 3 ---
3 files changed, 19 deletions(-)
diff --git a/dr
From: Ville Syrjälä
When transitioning away from vgacon the system tries to save the
current contents of the VGA memory, so that it can be cleanly handed
off to fbcon (or whatever comes afterwards).
The recent change
commit 81b5c7bc8de3e6f63419139c2fc91bf81dea8a7d
Author: Alex Williamson
Da
On Thu, Sep 05, 2013 at 06:37:42PM +0200, Daniel Vetter wrote:
> On Thu, Sep 5, 2013 at 6:30 PM, Chris Wilson wrote:
> >
> > It also a confusion that the kernel can't prevent.
> >
> > lock_mutex
> > A checks bo, reports it idle
> > unlock_mutex
> >
> > lock_mutex
> > B renders to bo
> > unlock_mut
On Thu, Sep 5, 2013 at 6:30 PM, Chris Wilson wrote:
>
> It also a confusion that the kernel can't prevent.
>
> lock_mutex
> A checks bo, reports it idle
> unlock_mutex
>
> lock_mutex
> B renders to bo
> unlock_mutex
>
> lock_mutex
> A uses bo, stalls
> unlock_mutex
>
> Whether or not the checking
On Thu, Sep 5, 2013 at 6:24 PM, Daniel Vetter wrote:
> On Thu, Sep 5, 2013 at 4:50 PM, Chris Wilson wrote:
>>> > + /* Do an optimistic check for activity - we don't care about userspace
>>> > +* racing with itself, that is always problematic.
>>> > +*/
>>> > + ring = obj->ring;
>>> >
On Thu, Sep 5, 2013 at 4:50 PM, Chris Wilson wrote:
>> > + /* Do an optimistic check for activity - we don't care about userspace
>> > +* racing with itself, that is always problematic.
>> > +*/
>> > + ring = obj->ring;
>> > + if (ring && obj->last_read_seqno == ring->outstanding_laz
On Thu, Sep 05, 2013 at 06:24:33PM +0200, Daniel Vetter wrote:
> On Thu, Sep 5, 2013 at 4:50 PM, Chris Wilson wrote:
> >> > + /* Do an optimistic check for activity - we don't care about
> >> > userspace
> >> > +* racing with itself, that is always problematic.
> >> > +*/
> >> > + rin
Thanks for the quick reply!
Yes. It means that HDMI black level is detected incorrectly.
Setting "HDMI black level" from the monitor is not a reasonable solution
for me since I dual boot with windows and I need to set it back again.
Also I will lose about 10% color space. xrandr solution will c
On Thu, Sep 5, 2013 at 4:51 PM, Thomas Richter wrote:
> Am 02.09.2013 16:18, schrieb Daniel Vetter:
>>
>> Hm, I've probably botched the watermarks again. Can you please retest with
>> the below diff?
>>
>> diff --git a/drivers/gpu/drm/i915/intel_pm.c
>> b/drivers/gpu/drm/i915/intel_pm.c
>> index d
On Thu, Sep 05, 2013 at 04:48:54PM +0200, Daniel Vetter wrote:
> On Thu, Sep 05, 2013 at 03:29:01PM +0100, Chris Wilson wrote:
> > The busy-ioctl is frequently called as it is used by clients treating
> > buffer objects like fences and polling for completion. These frequent
> > calls are especially
Am 02.09.2013 16:18, schrieb Daniel Vetter:
Hm, I've probably botched the watermarks again. Can you please retest with
the below diff?
diff --git a/drivers/gpu/drm/i915/intel_pm.c b/drivers/gpu/drm/i915/intel_pm.c
index dfdc7ad..b667ff0 100644
--- a/drivers/gpu/drm/i915/intel_pm.c
+++ b/drivers/
On Thu, Sep 05, 2013 at 04:44:44PM +0300, Jani Nikula wrote:
> In line with the rest of the code base. No functional changes.
>
> Signed-off-by: Jani Nikula
> ---
> drivers/gpu/drm/i915/intel_dp.c | 14 --
> 1 file changed, 8 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/
On Thu, Sep 05, 2013 at 04:48:54PM +0200, Daniel Vetter wrote:
> On Thu, Sep 05, 2013 at 03:29:01PM +0100, Chris Wilson wrote:
> > The busy-ioctl is frequently called as it is used by clients treating
> > buffer objects like fences and polling for completion. These frequent
> > calls are especially
On Thu, Sep 05, 2013 at 03:29:01PM +0100, Chris Wilson wrote:
> The busy-ioctl is frequently called as it is used by clients treating
> buffer objects like fences and polling for completion. These frequent
> calls are especially subject to contention with multiple clients leading
> to a lot of busy
On Wed, Sep 04, 2013 at 10:54:30AM +0100, Chris Wilson wrote:
> Once again we find that Valleyview is ever so subtlety different from
> the rest of its gen7 brethen. In this case, Valleyview has no support
> for pageflipping from the RCS ring.
>
> Fixes a regression from
> commit b0135d2b287424cce
On Wed, Sep 04, 2013 at 01:55:20PM -0700, Ben Widawsky wrote:
> Haswell changed the log registers to be WO, so we can no longer read
> them to determine the programming (which sucks, see later note). For
> now, simply use the cached value, and hope HW doesn't screw us over.
>
> Bugzilla: https://b
The busy-ioctl is frequently called as it is used by clients treating
buffer objects like fences and polling for completion. These frequent
calls are especially subject to contention with multiple clients leading
to a lot of busy-waiting due to mutex_spin_on_owner()). We can, in most
cases, report
On Mon, 2013-08-26 at 14:51 +0100, Chris Wilson wrote:
> When we switched to always using a timeout in conjunction with
> wait_seqno, we lost the ability to detect missed interrupts. Since, we
> have had issues with interrupts on a number of generations, and they are
> required to be delivered in a
VLV has per-pipe PP registers. Set up power sequencing on mode set. The
connector init time setup is problematic, since we don't have a pipe at
that time. Cook up something.
v2:
- use vlv_power_sequencer_pipe() also in _pp_{ctrl,stat}_reg()
- use PANEL_PORT_SELECT_DPC_VLV (Ville)
Signed-off-by:
Remove duplicates, add VLV specific macros for port B and C.
v2: also add PANEL_PORT_SELECT_DPC_VLV for clarity (Ville)
Signed-off-by: Jani Nikula
Reviewed-by: Ville Syrjälä
---
drivers/gpu/drm/i915/i915_reg.h |8 ++--
drivers/gpu/drm/i915/intel_dp.c |4 ++--
2 files changed, 4 ins
v2 of http://mid.gmane.org/cover.1378208439.git.jani.nik...@intel.com
BR,
Jani.
Jani Nikula (4):
drm/i915: name intel dp hooks per platform
drm/i915: move backlight enable later in vlv enable sequence
drm/i915: clean up power sequencing register port select definitions
drm/i915: add suppo
Follow-up to
commit 5004945f1d6c0282c0288afa89ad85d7f2bea4d5
Author: Jani Nikula
Date: Tue Jul 30 12:20:32 2013 +0300
drm/i915: move encoder->enable callback later in VLV crtc enable
v2: Rebase on the renamed enable hooks, adding clarity (Ville)
Reference:
http://mid.gmane.org/cakmk7ufs9
In line with the rest of the code base. No functional changes.
Signed-off-by: Jani Nikula
---
drivers/gpu/drm/i915/intel_dp.c | 14 --
1 file changed, 8 insertions(+), 6 deletions(-)
diff --git a/drivers/gpu/drm/i915/intel_dp.c b/drivers/gpu/drm/i915/intel_dp.c
index d6eba38..2abe
From: Ben Widawsky
Turn on hardware contexts for Ironlake. This leaves the code in an
awkward place where renderctx accomplishes nothing, but the code
compiles and runs, and it makes the series overall more bisectable.
Signed-off-by: Ben Widawsky
Reviewed-by: Chris Wilson
Tested-by: Chris Wils
From: Ben Widawsky
Put it with the other context code since upcoming rework/enabling will
be easier to handle with the similar code.
Also, remove the comment which is now common knowledge, and incorrect,
given that the powerctx is really the one that allows us to accomplish
this on Ironlake.
Si
From: Ben Widawsky
The ILK renderctx predates the generic i915 context code. With the
patches before this, I believe I have properly eased the transition to
simply using the regular default context instead of the special
renderctx.
This untangles the weirdness from the last commit, and finishes
From: Ben Widawsky
The medium term plan is to just use the existing context code on ILK as
well. The conversion just assists. Therefore, this is somewhat transient
as I plan to kill renderctx quite soon.
Signed-off-by: Ben Widawsky
Reviewed-by: Chris Wilson
Tested-by: Chris Wilson # X still w
From: Ben Widawsky
With the conversion to use the existing, well tested HW context code for
the ILK RC6 render context, let's once again try to enable RC6 by
default on ILK.
This is basically a revert of a revert and reapply of an existing patch.
RC6 has been enabled, and reverted several times
From: Ben Widawsky
This patch starts the migration to the core context code for Ironlake
renderctx. It is an excellent place for a bisection point due to
complaining hardware, though notice that our sample size is quite
limited given that only machines with RC6 turned on could notice
problems.
N
From: Ben Widawsky
It's similar enough to the other gens that we don't really need a
distinct function to do it.
NOTE: The new function removes the MI_FLUSH that was at the end of the
old Ironlake switching code. Recent docs can find neither the
requirement for the MI_FLUSH or the MI_SUSPEND_FLU
The extended state bits are stored in the LCA register and affect all
updates to the LCA register - i.e. the state on the old context is saved
when SAVE_EX_STATE_EN is currently set in the old context address before
the update, and the new context is restored when RESTORE_EX_STATE_EN is
set in the
A later patch adds yet another workaround for MI_SET_CONTEXT, at which
point we start to end up with more NOOPs than actual command dwords
along the non-workaround paths. It is time that we made the MI_SET_CONTEXT
a variable length block and only emit the dwords we truly need.
Signed-off-by: Chris
On Thu, Sep 05, 2013 at 03:59:22PM +0300, Jani Nikula wrote:
> On Thu, 05 Sep 2013, Chon Ming Lee wrote:
> > The patch doesn't contain functional change, but is to prepare for
> > future platform which has different DPIO phy. The additional pipe
> > parameter will use to select which phy to targe
On Wed, Sep 04, 2013 at 11:05:55AM +0200, Daniel Vetter wrote:
> Hi Stephen
>
> On Wed, Sep 4, 2013 at 1:45 AM, Stephen Rothwell
> Wrote:
> > This morning after fetching the drm-intel-fixes tree, I have discovered
> > that you have just added a whole set of patches on top of Dave's drm tree
> >
On Thu, 05 Sep 2013, Chon Ming Lee wrote:
> The patch doesn't contain functional change, but is to prepare for
> future platform which has different DPIO phy. The additional pipe
> parameter will use to select which phy to target for.
>
> Signed-off-by: Chon Ming Lee
Reviewed-by: Jani Nikula
The patch doesn't contain functional change, but is to prepare for
future platform which has different DPIO phy. The additional pipe
parameter will use to select which phy to target for.
Signed-off-by: Chon Ming Lee
v2: Update the commit message and add static for the new function.
(Jani/Ville)
On Thu, Sep 05, 2013 at 01:40:25PM +0100, Chris Wilson wrote:
> Paulo reported that if he set the amount of reserved memory to 0, then
> we emitted a warning about a conflict before disabling our use of stolen
> memory. This was introduced with
>
> commit eaba1b8f3379b5d100bd146b9a41d28348bdfd09
>
Paulo reported that if he set the amount of reserved memory to 0, then
we emitted a warning about a conflict before disabling our use of stolen
memory. This was introduced with
commit eaba1b8f3379b5d100bd146b9a41d28348bdfd09
Author: Chris Wilson
Date: Thu Jul 4 12:28:35 2013 +0100
drm/i915
On Wed, Sep 04, 2013 at 05:36:14PM +0200, Daniel Vetter wrote:
> Since we've started to clean up pending flips when the gpu hangs in
>
> commit 96a02917a0131e52efefde49c2784c0421d6c439
> Author: Ville Syrjälä
> Date: Mon Feb 18 19:08:49 2013 +0200
>
> drm/i915: Finish page flips and update
On Thu, Sep 05, 2013 at 03:21:01PM +0300, Ville Syrjälä wrote:
> On Thu, Sep 05, 2013 at 01:45:47PM +0200, Daniel Vetter wrote:
> > On Thu, Sep 05, 2013 at 02:33:20PM +0300, Ville Syrjälä wrote:
> > > On Wed, Sep 04, 2013 at 08:50:13PM +0200, Daniel Vetter wrote:
> > > > On Fri, Aug 30, 2013 at 1:5
On Thu, Sep 05, 2013 at 01:45:47PM +0200, Daniel Vetter wrote:
> On Thu, Sep 05, 2013 at 02:33:20PM +0300, Ville Syrjälä wrote:
> > On Wed, Sep 04, 2013 at 08:50:13PM +0200, Daniel Vetter wrote:
> > > On Fri, Aug 30, 2013 at 1:50 AM, wrote:
> > > > + /* Wait for 2 vertical blanks */
> > > >
On Tue, Sep 03, 2013 at 02:43:39PM +0300, Jani Nikula wrote:
> VLV has per-pipe PP registers. Set up power sequencing on mode set. The
> connector init time setup is problematic, since we don't have a pipe at
> that time. Cook up something.
>
> Signed-off-by: Jani Nikula
> ---
> drivers/gpu/drm/
On Tue, Sep 03, 2013 at 02:43:38PM +0300, Jani Nikula wrote:
> Remove dupes, add VLV port B.
>
> Signed-off-by: Jani Nikula
> ---
> drivers/gpu/drm/i915/i915_reg.h |7 +--
> drivers/gpu/drm/i915/intel_dp.c |4 ++--
> 2 files changed, 3 insertions(+), 8 deletions(-)
>
> diff --git a/
On Thu, Sep 05, 2013 at 02:33:20PM +0300, Ville Syrjälä wrote:
> On Wed, Sep 04, 2013 at 08:50:13PM +0200, Daniel Vetter wrote:
> > On Fri, Aug 30, 2013 at 1:50 AM, wrote:
> > > + /* Wait for 2 vertical blanks */
> > > + intel_wait_for_vblank(dev, pipe);
> > > + intel_wait_for_v
On Wed, Sep 04, 2013 at 08:50:13PM +0200, Daniel Vetter wrote:
> On Fri, Aug 30, 2013 at 1:50 AM, wrote:
> > + /* Wait for 2 vertical blanks */
> > + intel_wait_for_vblank(dev, pipe);
> > + intel_wait_for_vblank(dev, pipe);
> > +
> > + /* Disable audio PD. This is optional
On Thu, Sep 05, 2013 at 11:28:05AM +0100, Chris Wilson wrote:
> On Thu, Sep 05, 2013 at 12:16:13PM +0200, Daniel Vetter wrote:
> > On Wed, Sep 04, 2013 at 10:45:50AM +0100, Chris Wilson wrote:
> > > Whilst running the shrinker, we need to hold a reference as we unbind
> > > the objects, or else we
On Wed, Sep 04, 2013 at 02:20:10PM +0300, Jani Nikula wrote:
> Flat out skip anything to do with PLL if we have a DSI encoder (and thus
> DSI PLL). Also skip PLL computation if the encoder has already set
> clocks. This allows for some tidying up of the code, including a
> superfluous call to intel
On Thu, Sep 05, 2013 at 12:16:13PM +0200, Daniel Vetter wrote:
> On Wed, Sep 04, 2013 at 10:45:50AM +0100, Chris Wilson wrote:
> > Whilst running the shrinker, we need to hold a reference as we unbind
> > the objects, or else we may end up waiting for and retiring requests,
> > which in turn may re
On Wed, Sep 04, 2013 at 10:45:50AM +0100, Chris Wilson wrote:
> Whilst running the shrinker, we need to hold a reference as we unbind
> the objects, or else we may end up waiting for and retiring requests,
> which in turn may result in this object being freed.
>
> This is very similar to the evict
On Thu, 05 Sep 2013, "Lee, Chon Ming" wrote:
> On 09/05 11:35, Jani Nikula wrote:
>> On Thu, 05 Sep 2013, Chon Ming Lee wrote:
>> > The additional pipe parameter will use to select which phy to target
>> > for.
>> >
>> > Signed-off-by: Chon Ming Lee
>> > ---
>>
>> [snip]
>>
>> > diff --git a/d
On Thu, Sep 05, 2013 at 01:33:37PM +0800, Chon Ming Lee wrote:
> The additional pipe parameter will use to select which phy to target
> for.
>
> Signed-off-by: Chon Ming Lee
> ---
> drivers/gpu/drm/i915/i915_debugfs.c | 18 ++--
> drivers/gpu/drm/i915/i915_drv.h |4 +-
> dr
On Thu, Sep 5, 2013 at 10:40 AM, Lee, Chon Ming wrote:
> Yup, will update the message. This patch is to actually prepare for some
> future
> platform. Suggested by Daniel to upstream this first.
I've asked Ville to take a quick look at the patch. If he doesn't spot
anything I can amend the com
On 09/05 11:35, Jani Nikula wrote:
> On Thu, 05 Sep 2013, Chon Ming Lee wrote:
> > The additional pipe parameter will use to select which phy to target
> > for.
> >
> > Signed-off-by: Chon Ming Lee
> > ---
>
> [snip]
>
> > diff --git a/drivers/gpu/drm/i915/intel_sideband.c
> > b/drivers/gpu/dr
On Thu, 05 Sep 2013, Chon Ming Lee wrote:
> The additional pipe parameter will use to select which phy to target
> for.
>
> Signed-off-by: Chon Ming Lee
> ---
[snip]
> diff --git a/drivers/gpu/drm/i915/intel_sideband.c
> b/drivers/gpu/drm/i915/intel_sideband.c
> index 0a41670..12bbc28 100644
>
The additional pipe parameter will use to select which phy to target
for.
Signed-off-by: Chon Ming Lee
---
drivers/gpu/drm/i915/i915_debugfs.c | 18 ++--
drivers/gpu/drm/i915/i915_drv.h |4 +-
drivers/gpu/drm/i915/intel_display.c | 51 +
d
57 matches
Mail list logo