On Sat, Aug 10, 2013 at 10:13:20AM +0100, Chris Wilson wrote:
> On Fri, Aug 09, 2013 at 10:12:16PM -0700, Ben Widawsky wrote:
> > static int
> > i915_gem_execbuffer_move_to_gpu(struct intel_ring_buffer *ring,
> > - struct list_head *objects)
> > +
On Sat, Aug 10, 2013 at 09:45:05AM +0100, Chris Wilson wrote:
> On Fri, Aug 09, 2013 at 10:12:14PM -0700, Ben Widawsky wrote:
> > In upcoming code, it will be possible for a vma to have been created,
> > but no space reserved for it in the address space. The drm_mm semantics
> > are such that tryin
Cleanup the map and fenceable setting during bind to make more sense,
and not check i915_is_ggtt() 2 unnecessary times
v2: Move the bools into the if block (Chris) - There are ways to tidy
this function (fence calculations for instance) even further, but they
are quite invasive, so I am punting on
On Sat, Aug 10, 2013 at 09:41:16AM +0100, Chris Wilson wrote:
> On Fri, Aug 09, 2013 at 10:12:13PM -0700, Ben Widawsky wrote:
> > Cleanup the map and fenceable setting during bind to make more sense,
> > and not check i915_is_ggtt() 2 unnecessary times
> >
> > Recommended-by: Chris Wilson
> > Sig
Ideally we could use for_each_ring with the ring flags as I've done a
couple times
(http://lists.freedesktop.org/archives/intel-gfx/2013-June/029450.html).
Until Daniel merges that patch though, we can just use this.
Cc: Mika Kuoppala
Signed-off-by: Ben Widawsky
---
drivers/gpu/drm/i915/i915_gp
Cc: Mika Kuoppala
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=65387
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=67198
Signed-off-by: Ben Widawsky
---
drivers/gpu/drm/i915/intel_ringbuffer.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/drivers/gpu/drm/i915/intel_rin
2013/8/10 Chris Wilson :
> On Sat, Aug 10, 2013 at 09:55:14AM +0200, Daniel Vetter wrote:
>> On Fri, Aug 9, 2013 at 11:34 PM, Paulo Zanoni wrote:
>> > 2013/8/9 Chris Wilson :
>> >> Quick note...
>> >>
>> >> On Fri, Aug 09, 2013 at 05:10:05PM -0300, Paulo Zanoni wrote:
>> >>> + WARN_ON(!mutex_i
On Mon, Aug 12, 2013 at 02:02:09PM -0700, Ben Widawsky wrote:
> On Mon, Aug 12, 2013 at 11:46:17AM +0100, Chris Wilson wrote:
> > By our earlier reckoning, move from a snooped/llc setting to an uncached
> > setting, leaves the CPU cache in a consistent state irrespective of our
> > domain tracking
On Mon, Aug 12, 2013 at 11:46:17AM +0100, Chris Wilson wrote:
> By our earlier reckoning, move from a snooped/llc setting to an uncached
> setting, leaves the CPU cache in a consistent state irrespective of our
> domain tracking - so we can forgo the warning about the lack of
> invalidation. Simila
On Mon, Aug 12, 2013 at 02:56:53PM -0300, Paulo Zanoni wrote:
> From: Paulo Zanoni
>
> Caught by "make W=1 drivers/gpu/drm/i915/".
>
> Signed-off-by: Paulo Zanoni
Queued for -next, thanks for the patch.
-Daniel
--
Daniel Vetter
Software Engineer, Intel Corporation
+41 (0) 79 365 57 48 - http:/
> -Original Message-
> From: Daniel Vetter [mailto:daniel.vet...@ffwll.ch] On Behalf Of Daniel
> Vetter
> Sent: Sunday, August 04, 2013 4:50 PM
> To: Paulo Zanoni
> Cc: Ville Syrjälä; intel-gfx@lists.freedesktop.org; Zanoni, Paulo R
> Subject: Re: [Intel-gfx] [PATCH] drm/i915: VGA also requ
From: Paulo Zanoni
Caught by "make W=1 drivers/gpu/drm/i915/".
Signed-off-by: Paulo Zanoni
---
drivers/gpu/drm/i915/intel_display.c | 12 ++--
drivers/gpu/drm/i915/intel_dp.c | 3 ---
drivers/gpu/drm/i915/intel_hdmi.c| 2 --
3 files changed, 2 insertions(+), 15 deletions(-)
From: Paulo Zanoni
The machines that fall in this category are the SDVs that have a PCI
ID starting with 0x0C. These are very early pre-production machines
and may not fully work. Other Haswell SDVs have PCI IDs that match the
real Haswell machines and we expect them to work better.
Even though
On Fri, Aug 9, 2013 at 9:55 PM, Ben Widawsky wrote:
> On Fri, Aug 09, 2013 at 08:32:54PM -0700, Stéphane Marchesin wrote:
>> This is a partial revert of b4ae3f22d238617ca11610b29fde16cf8c0bc6e0
>> (drm/i915: load boot context at driver init time)
>>
>> This bit breaks hardware video decode for me
On Sun, Aug 11, 2013 at 3:15 AM, Daniel Vetter wrote:
> On Sun, Aug 11, 2013 at 10:50:17AM +0100, Chris Wilson wrote:
>> On Sun, Aug 11, 2013 at 12:44:02PM +0300, Jani Nikula wrote:
>> > Although I could not reproduce this (different compiler version,
>> > perhaps), reportedly we get:
>> >
>> > dr
On Sat, Aug 10, 2013 at 12:09:26PM +0200, Daniel Vetter wrote:
> On Thu, Aug 08, 2013 at 02:41:11PM +0100, Chris Wilson wrote:
> > This is primarily for the benefit of the create2 ioctl so that the
> > caller can avoid the later step of rebinding the bo with new PTE bits.
> > After introducing WT (
On Mon, Aug 12, 2013 at 02:03:40PM +0200, Daniel Vetter wrote:
> Upstream broke our dynamic creation of the testlist, and I think
> adding stupid .tests suffixes everywhere just to appease upstream
> autohell tools isn't that great. So scrap it, we can use piglit
> instead.
>
> References:
> http
Upstream broke our dynamic creation of the testlist, and I think
adding stupid .tests suffixes everywhere just to appease upstream
autohell tools isn't that great. So scrap it, we can use piglit
instead.
References:
https://lists.gnu.org/archive/html/help-debbugs/2013-06/msg0.html
Signed-off-
By our earlier reckoning, move from a snooped/llc setting to an uncached
setting, leaves the CPU cache in a consistent state irrespective of our
domain tracking - so we can forgo the warning about the lack of
invalidation. Similarly for any writes posted to the snooped CPU domain,
we know will be s
On Mon, Aug 12, 2013 at 12:20:24PM +0200, Daniel Vetter wrote:
> On Mon, Aug 12, 2013 at 11:26:49AM +0200, Daniel Vetter wrote:
> > On Mon, Aug 12, 2013 at 10:15:06AM +0100, Chris Wilson wrote:
> > > On Mon, Aug 12, 2013 at 11:09:56AM +0200, Daniel Vetter wrote:
> > > > Doesn't do more than an if (
On Mon, Aug 12, 2013 at 11:26:49AM +0200, Daniel Vetter wrote:
> On Mon, Aug 12, 2013 at 10:15:06AM +0100, Chris Wilson wrote:
> > On Mon, Aug 12, 2013 at 11:09:56AM +0200, Daniel Vetter wrote:
> > > Doesn't do more than an if (drmtest_run_test(name)) right now, but
> > > as soon as we get a bit of
On Mon, Aug 12, 2013 at 12:38:03PM +0300, Ville Syrjälä wrote:
> On Sun, Aug 11, 2013 at 11:17:28PM +0100, Chris Wilson wrote:
> > For unfathomable reasons this alignment appears to be required for tiled
> > scanouts being read from stolen memory. I can find no reference in the
> > w/a db to suppor
On Sun, Aug 11, 2013 at 11:17:28PM +0100, Chris Wilson wrote:
> For unfathomable reasons this alignment appears to be required for tiled
> scanouts being read from stolen memory. I can find no reference in the
> w/a db to support this requirement, but the evidence of my own eyes says
> this prevent
On Mon, Aug 12, 2013 at 11:15:53AM +0200, Daniel Vetter wrote:
> On Mon, Aug 12, 2013 at 11:09:54AM +0200, Daniel Vetter wrote:
> > Hi all,
> >
> > So I've grown fed-up with our add-hoc (and pretty much always buggy) return
> > value tracking for testcases with subtests. Furthermore sprinkling tes
On Mon, Aug 12, 2013 at 10:15:06AM +0100, Chris Wilson wrote:
> On Mon, Aug 12, 2013 at 11:09:56AM +0200, Daniel Vetter wrote:
> > Doesn't do more than an if (drmtest_run_test(name)) right now, but
> > as soon as we get a bit of infrastructure to handle test failures and
> > skipping, this will get
On Mon, Aug 12, 2013 at 11:09:56AM +0200, Daniel Vetter wrote:
> Doesn't do more than an if (drmtest_run_test(name)) right now, but
> as soon as we get a bit of infrastructure to handle test failures and
> skipping, this will get more interesting.
Just use drm_subtest("name") { }
drm_subtest_bloc
On Mon, Aug 12, 2013 at 11:09:54AM +0200, Daniel Vetter wrote:
> Hi all,
>
> So I've grown fed-up with our add-hoc (and pretty much always buggy) return
> value tracking for testcases with subtests. Furthermore sprinkling testcases
> with tons of if (kernel_has_some_optional_feature) return 77; is
To simplify things add a set of gem_check_ functions which take
care of this. Since I've opted for static inlines drmtest.h grew a few
more header includes which was a neat opportunity to dump a few redundant
#defines.
This kills all the skipped_all hand-rolled logic we have.
Signed-off-by: Danie
This way we can rip out all the skip handling from the test control flow,
and additionally (by using drmtest_retval()) even get correct exit codes.
The only tricky part is that when we only want ot skip parts of a test
(like for gem_pread and gem_pwrite) we need to split out those parts as
subtest
If we skip a test and and fail somewhere the parent might die before the
child. So add some cleanup to handle this case. Also make sure that the
parent indeed waits for the child to die.
This is required to make the latest version of the piglit runner happy,
it tends to wait for all zombies to dis
Exitcode handling in igt testcases has too ugly facets in combination
with subtests:
- When individual subtest needed to be skipped for different reasons
we need to painstakingly thread this information through the test to
make sure that we still succeed if just one testcase worked (for
runn
Signed-off-by: Daniel Vetter
---
tests/gem_caching.c | 21 +
1 file changed, 13 insertions(+), 8 deletions(-)
diff --git a/tests/gem_caching.c b/tests/gem_caching.c
index d67bbf6..259662f 100644
--- a/tests/gem_caching.c
+++ b/tests/gem_caching.c
@@ -110,7 +110,6 @@ int main(
Doesn't do more than an if (drmtest_run_test(name)) right now, but
as soon as we get a bit of infrastructure to handle test failures and
skipping, this will get more interesting.
Signed-off-by: Daniel Vetter
---
lib/drmtest.h | 1 +
tests/gem_basic.c
Signed-off-by: Daniel Vetter
---
lib/drmtest.c| 28 ++--
lib/drmtest.h| 6 +-
tests/.gitignore | 2 +-
tests/Makefile.am| 2 +-
tests/gem_cacheing.c | 303 ---
tests/gem_
Hi all,
So I've grown fed-up with our add-hoc (and pretty much always buggy) return
value tracking for testcases with subtests. Furthermore sprinkling testcases
with tons of if (kernel_has_some_optional_feature) return 77; isn't really
helping test case readability.
So I've gone ahead and impleme
On Fri, Aug 09, 2013 at 09:06:36PM +0100, Chris Wilson wrote:
> On Fri, Aug 09, 2013 at 09:17:11PM +0200, Daniel Vetter wrote:
> > On Fri, Aug 09, 2013 at 03:13:22PM +0100, Chris Wilson wrote:
> > > A simple modeset, where we only wish to switch over to a new framebuffer
> > > such as the transitio
36 matches
Mail list logo