This increases GEN6_RC6p_THRESHOLD from 10 to 15. For some
reason this avoids the gen6_gt_check_fifodbg.isra warnings and
associated GPU lockups, which makes my ivy bridge machine stable.
Signed-off-by: Stéphane Marchesin
---
drivers/gpu/drm/i915/intel_pm.c | 2 +-
1 file changed, 1 inse
On Tue, Jan 29, 2013 at 09:15:22PM +0100, Daniel Vetter wrote:
> On 29/01/2013 21:01, Jesse Barnes wrote:
> >Can you just post them externally tointel-...@lists.freedesktop.org?
> >It's best to use git send-email to do it, that way the changelogs are
> >preserved and posted to the ml along with the
On 29/01/2013 21:01, Jesse Barnes wrote:
Can you just post them externally tointel-...@lists.freedesktop.org?
It's best to use git send-email to do it, that way the changelogs are
preserved and posted to the ml along with the patches.
Public intel-gfx is already on the cc list, just in case you g
Can you just post them externally to intel-gfx@lists.freedesktop.org?
It's best to use git send-email to do it, that way the changelogs are
preserved and posted to the ml along with the patches.
Not sure if there's a bunch of duplication between the two, but you
could split them up a bit.
I still
The shift changed, hurray.
WARNING: only compile tested
Reported-by: Kenneth Graunke
Cc: Paulo Zanoni
Signed-off-by: Ben Widawsky
---
drivers/gpu/drm/i915/i915_debugfs.c | 10 +++---
drivers/gpu/drm/i915/i915_reg.h | 2 ++
2 files changed, 9 insertions(+), 3 deletions(-)
diff --git
From: Paulo Zanoni
Otherwise, if the BIOS did anything wrong, our first I915_{WRITE,READ}
will give us "unclaimed register" messages.
V2: Even earlier.
Bugzilla: http://bugs.freedesktop.org/show_bug.cgi?id=58897
Signed-off-by: Paulo Zanoni
---
drivers/gpu/drm/i915/i915_dma.c |4
1 f
On Tue, Jan 29, 2013 at 08:40:06AM +, Damien Lespiau wrote:
> On Thu, Jan 24, 2013 at 02:45:00PM -0800, Ben Widawsky wrote:
> > With the probe call in our dispatch table, we can now cut away two of
> > the remaining members in the intel_gtt shared struct.
> >
> > v2: Rebased on top of Daniel's
On Tue, Jan 29, 2013 at 01:55:46PM +0100, Daniel Vetter wrote:
> On Fri, Jan 25, 2013 at 04:41:05PM -0800, Ben Widawsky wrote:
> > This refactor clearly identifies the GEN specific portion of the aliased
> > ppgtt code. Aside from some of the gen specific parts being extracted,
> > it also preps us
On Tue, Jan 29, 2013 at 01:49:22PM +0100, Daniel Vetter wrote:
> On Fri, Jan 25, 2013 at 04:41:03PM -0800, Ben Widawsky wrote:
> > - i915_gem_init_aliasing_ppgtt should now be static
> > - move i915_gem_init_ppgtt declaration to the right place
> >
> > Reviewed-by: Chris Wilson
> > Signed-off-by:
From: Daniel Vetter
We can disable (almost) all the display hw if we only use pipe A, with
the integrated edp transcoder on port A. Because we don't set the cpu
transcoder that early (yet), we need to help us with a trick to simply
check for any edp encoders.
v2: Paulo Zanoni pointed out that we
From: Paulo Zanoni
If the power well is disabled, we should not try to read its
registers, otherwise we'll get "unclaimed register" messages.
V2: Don't check whether the power well is enabled or not, just check
whether we asked it to be enabled or not: if we asked to disable the
power well, don'
From: Paulo Zanoni
The DP_TP_STATUS register for PORT_A doesn't exist. Our documentation
will be fixed soon, so the code does not match it for now.
This solves "Timed out waiting for DP idle patterns" and "unclaimed
register" messages on eDP.
V1: Was called "drm/i915: don't read DP_TP_STATUS(PO
On Tue, Jan 29, 2013 at 08:52:36AM -0800, Ben Widawsky wrote:
> On Tue, 29 Jan 2013 09:54:18 +0100
> Daniel Vetter wrote:
>
> > On Tue, Jan 29, 2013 at 08:41:12AM +, Damien Lespiau wrote:
> > > On Mon, Jan 28, 2013 at 03:32:15PM -0800, Ben Widawsky wrote:
> > > > /sys/kernel/debug has more or
On Tue, 29 Jan 2013 09:54:18 +0100
Daniel Vetter wrote:
> On Tue, Jan 29, 2013 at 08:41:12AM +, Damien Lespiau wrote:
> > On Mon, Jan 28, 2013 at 03:32:15PM -0800, Ben Widawsky wrote:
> > > /sys/kernel/debug has more or less been the standard location of
> > > debugfs for several years now. O
On Tue, 29 Jan 2013 09:49:13 +0100
Daniel Vetter wrote:
> On Mon, Jan 28, 2013 at 03:32:16PM -0800, Ben Widawsky wrote:
> > It should only be used with caution...
> >
> > Signed-off-by: Ben Widawsky
>
> Isn't that like the general assumption of these module parameters that
> they can have pret
On Tue, Jan 29, 2013 at 05:39:46PM +0100, Daniel Vetter wrote:
> On Tue, Jan 29, 2013 at 06:13:32PM +0200, ville.syrj...@linux.intel.com wrote:
> > Someone mentioned on irc that intel_crtc_wait_for_pending_flips() was
> > getting stuck in some cases. This rang a bell since I was poking around
> > t
On Tue, Jan 29, 2013 at 06:13:32PM +0200, ville.syrj...@linux.intel.com wrote:
> Someone mentioned on irc that intel_crtc_wait_for_pending_flips() was
> getting stuck in some cases. This rang a bell since I was poking around
> that stuff last year.
>
> The issue that I'm trying to fix here is proc
Hi,
first, thanks a lot for advancing PM infrastructure!
> #define PM_SUSPEND_ON((__force suspend_state_t) 0)
> -#define PM_SUSPEND_STANDBY ((__force suspend_state_t) 1)
> +#define PM_SUSPEND_FREEZE((__force suspend_state_t) 1)
> +#define PM_SUSPEND_STANDBY ((__force susp
From: Ville Syrjälä
The pending flip mask no longer set anywhere, so trying to wait for
while it's non-zero is a no-op. Remove it completely.
Signed-off-by: Ville Syrjälä
---
drivers/gpu/drm/i915/i915_drv.h | 7 ---
drivers/gpu/drm/i915/intel_display.c | 6 --
2 files changed, 13
From: Ville Syrjälä
Since obj->pending_flips was never set, intel_pipe_set_base() never
actually waited for pending page flips to complete.
We really do want to wait for the pending flips, because otherwise the
mmio surface base address update could overtake the flip, and you
could end up with a
From: Ville Syrjälä
Move the functionality of intel_crtc_wait_for_pending_flips()
into intel_crtc_wait_for_pending_flips_locked().
intel_crtc_wait_for_pending_flips() is now just a wrapper that
grab struct_mutex and calls intel_crtc_wait_for_pending_flips_locked().
This changes the behaviour of
From: Ville Syrjälä
Just shuffle the code around. No functional changes.
Signed-off-by: Ville Syrjälä
---
drivers/gpu/drm/i915/intel_display.c | 38 ++--
1 file changed, 19 insertions(+), 19 deletions(-)
diff --git a/drivers/gpu/drm/i915/intel_display.c
b/driv
From: Ville Syrjälä
Someone may be waiting for a flip that will never complete due to a GPU
reset. Wake up all such waiters when the hang is first detected, and
after the reset processing has finished.
Signed-off-by: Ville Syrjälä
---
drivers/gpu/drm/i915/i915_irq.c | 4
1 file changed, 4
From: Ville Syrjälä
If a GPU reset occurs while a page flip has been submitted to the ring,
the flip will never complete once the ring has been reset.
The GPU reset can be detected by sampling the reset_counter before the
flip is submitted, and then while waiting for the flip, the sampled
counte
Someone mentioned on irc that intel_crtc_wait_for_pending_flips() was
getting stuck in some cases. This rang a bell since I was poking around
that stuff last year.
The issue that I'm trying to fix here is processes getting stuck in D
state when a GPU reset happens while page flips have been schedu
Hi Dave,
The holiday pull fresh from QA. Not much in in, everyone was on vacation.
Highlights:
- Broadcast RBG improvements and reduced color range fixes from Ville
- Ben is on a "kill legacy gtt code for good" spree, first pile of patches
included.
- no relocs and lut improvements for faster ex
On Mon, Jan 28, 2013 at 12:35:55PM -0800, Ben Widawsky wrote:
> Aside from being a nice prep for some work I'm doing in PPGTT, this also
> leaves us with a more accurate size in our gtt_total_entries member.
> Since we can't actually use the PPGTT reserved part of the GGTT.
>
> This will help some
On Fri, Jan 25, 2013 at 04:41:05PM -0800, Ben Widawsky wrote:
> This refactor clearly identifies the GEN specific portion of the aliased
> ppgtt code. Aside from some of the gen specific parts being extracted,
> it also preps us for an upcoming patch that pulls out the size, which
> has some nice b
On Fri, Jan 25, 2013 at 04:41:04PM -0800, Ben Widawsky wrote:
> When the PPGTT init fails, we may as well reuse the space that we were
> reserving for the PPGTT PDEs.
>
> This also fixes an extraneous mutex_unlock.
>
> Reviewed-by: Chris Wilson
> Signed-off-by: Ben Widawsky
Queued for -next, th
On Fri, Jan 25, 2013 at 04:41:03PM -0800, Ben Widawsky wrote:
> - i915_gem_init_aliasing_ppgtt should now be static
> - move i915_gem_init_ppgtt declaration to the right place
>
> Reviewed-by: Chris Wilson
> Signed-off-by: Ben Widawsky
I've tried to apply this patch on top of latest dinq, and t
On Mon, Jan 28, 2013 at 06:06:38PM +0800, Zhang Rui wrote:
> On Mon, 2013-01-28 at 09:31 +0100, Daniel Vetter wrote:
> > On Mon, Jan 28, 2013 at 3:36 AM, Zhang Rui wrote:
> > >> Given that this essentially requires users to manually set this module
> > >> option to make stuff work I don't like thi
On Tue, 29 Jan 2013, Daniel Vetter wrote:
> Queued for -next, thanks for the patch. Oh and fixed up a bikeshed from
> checkpatch.pl while applying:
>
> Applying: drm/i915: Error state should print /sys/kernel/debug
> WARNING: line over 80 characters
> #22: FILE: drivers/gpu/drm/i915/i915_irq.c:130
On Tue, Jan 29, 2013 at 07:42:57AM +, Damien Lespiau wrote:
> On Thu, Jan 24, 2013 at 02:44:55PM -0800, Ben Widawsky wrote:
> > From: Daniel Vetter
> >
> > We have a few too many differences here, so finally take the prepared
> > abstraction and run with it. A few smaller changes are required
On Tue, Jan 29, 2013 at 08:41:12AM +, Damien Lespiau wrote:
> On Mon, Jan 28, 2013 at 03:32:15PM -0800, Ben Widawsky wrote:
> > /sys/kernel/debug has more or less been the standard location of debugfs
> > for several years now. Other parts of DRM already use this location, so
> > we should as w
On Mon, Jan 28, 2013 at 03:32:16PM -0800, Ben Widawsky wrote:
> It should only be used with caution...
>
> Signed-off-by: Ben Widawsky
Isn't that like the general assumption of these module parameters that
they can have pretty massive bad side-effects? Meaning I'm routinely
checking these alread
On Mon, Jan 28, 2013 at 03:32:15PM -0800, Ben Widawsky wrote:
> /sys/kernel/debug has more or less been the standard location of debugfs
> for several years now. Other parts of DRM already use this location, so
> we should as well.
>
> Signed-off-by: Ben Widawsky
Reviewed-by: Damien Lespiau
--
On Thu, Jan 24, 2013 at 02:45:00PM -0800, Ben Widawsky wrote:
> With the probe call in our dispatch table, we can now cut away two of
> the remaining members in the intel_gtt shared struct.
>
> v2: Rebased on top of Daniel's series
>
> Signed-off-by: Ben Widawsky
Shouldn't the commit message be
On Thu, Jan 24, 2013 at 01:49:57PM -0800, Ben Widawsky wrote:
> The idea, and much of the code came originally from:
>
> commit 0712f0249c3148d8cf42a3703403c278590d4de5
> Author: Ben Widawsky
> Date: Fri Jan 18 17:23:16 2013 -0800
>
> drm/i915: Create a vtable for i915 gtt
>
> Daniel didn
38 matches
Mail list logo