Re: [Intel-gfx] [PATCH] drm/i915: Drop the msleep parameter to wait_for()

2010-08-23 Thread Peter Clifton
On Tue, 2010-08-24 at 00:33 +0100, Chris Wilson wrote: > On Tue, 24 Aug 2010 00:16:37 +0100, Peter Clifton wrote: > > I noticed that the patch changes the semantics of some of the wait_for > > calls. Previously, many were called with a zero msleep parameter - > > meaning the call would not msleep.

Re: [Intel-gfx] [PATCH] drm/i915: Drop the msleep parameter to wait_for()

2010-08-23 Thread Chris Wilson
On Tue, 24 Aug 2010 00:16:37 +0100, Peter Clifton wrote: > I noticed that the patch changes the semantics of some of the wait_for > calls. Previously, many were called with a zero msleep parameter - > meaning the call would not msleep. With this patch, the cases below will > now msleep(1), rather

Re: [Intel-gfx] [PATCH] drm/i915: Drop the msleep parameter to wait_for()

2010-08-23 Thread Peter Clifton
On Mon, 2010-08-23 at 17:56 +0100, Chris Wilson wrote: > Jesse's feedback from using the wait_for() macro was that the msleep > argument was that it was superfluous and made the macro more difficult > to use and to read. As the actually amount of time to sleep is not > critical, the crucial part is

Re: [Intel-gfx] [PATCH] drm/i915: Addin-offset is an unreliable indicator of LVDS present

2010-08-23 Thread Chris Wilson
On Mon, 23 Aug 2010 14:22:48 -0400, Adam Jackson wrote: > IWBNI we had the VBT in a sysfs or debugfs file, if we're not going to > be able to pull it out of the legacy ROM space reliably. I added it to debugfs, only to my surprise the header.size field which I thought was in KB (according to the

[Intel-gfx] 945 with SR doesn't need manual enable/disable

2010-08-23 Thread Alexander Lam
Hi all, Using 2.6.35.2, I changed 945's self refresh to work without the need for the driver to enable/disable self refresh manually based on the idle state of the gpu. Something must have been fixed in the driver between the initial implementation of 945 self refresh and now. (maybe 944001201ca0

[Intel-gfx] [PATCH] drm/i915: make sure panel is on for eDP detection

2010-08-23 Thread Jesse Barnes
DP AUX transactions on the panel won't work unless the panel is powered. This patch also fixes a merge error that snuck into the DP prepare function; we need to power on the panel for both CPU and PCH attached panels. Signed-off-by: Jesse Barnes diff --git a/drivers/gpu/drm/i915/intel_dp.c b/d

Re: [Intel-gfx] [PATCH] drm/i915: Addin-offset is an unreliable indicator of LVDS present

2010-08-23 Thread Adam Jackson
On Mon, 2010-08-23 at 16:23 +0100, Chris Wilson wrote: > On Mon, 23 Aug 2010 10:46:33 -0400, Adam Jackson wrote: > > AIM seems to be structured such that you have to have an addin to make > > LVDS work. I think the opregion change you posted is sufficient to find > > the real VBT; having done tha

[Intel-gfx] [PATCH] drm/i915: Drop the msleep parameter to wait_for()

2010-08-23 Thread Chris Wilson
Jesse's feedback from using the wait_for() macro was that the msleep argument was that it was superfluous and made the macro more difficult to use and to read. As the actually amount of time to sleep is not critical, the crucial part is to sleep and let the processor schedule something else whilst

Re: [Intel-gfx] [PATCH] drm/i915: Addin-offset is an unreliable indicator of LVDS present

2010-08-23 Thread Chris Wilson
On Mon, 23 Aug 2010 10:46:33 -0400, Adam Jackson wrote: > AIM seems to be structured such that you have to have an addin to make > LVDS work. I think the opregion change you posted is sufficient to find > the real VBT; having done that, the addin offset check is still valid. Sadly, I discovered

Re: [Intel-gfx] [PATCH 27/29] drm: Scan EDID for an audio-capable HDMI output

2010-08-23 Thread Adam Jackson
On Sun, 2010-08-22 at 12:05 +0100, Chris Wilson wrote: > Parse the EDID looking for a CEA-extension block that details whether > the connected monitor has audio support over HDMI. > > Signed-off-by: Chris Wilson > Cc: Dave Airlie > --- > drivers/gpu/drm/drm_edid.c | 27 +++

Re: [Intel-gfx] [PATCH] drm/i915: Addin-offset is an unreliable indicator of LVDS present

2010-08-23 Thread Adam Jackson
On Sun, 2010-08-22 at 19:06 +0100, Chris Wilson wrote: > On Sun, 22 Aug 2010 18:23:21 +0100, Chris Wilson > wrote: > > My Samsung N210 has a VBT with DEVICE_TYPE_INT_LFP with a zero > > addin-offset. With the check in place, the panel was declared absent. > > Reviewing the history, the addin-off

[Intel-gfx] 23.976Hz clarkdale at 1080p support

2010-08-23 Thread Craig Carnell
Does xf86-intel support 23.976Hz output under Linux? Or does it wrongly output 24.000Hz? My use is a HTPC and I would prefer stutter free playback. Thanks, Craig. ___ Intel-gfx mailing list Intel-gfx@lists.fr

Re: [Intel-gfx] [PATCH 1/2] drm/i915: ringbuffer: use defined get_head/tail method

2010-08-23 Thread Chris Wilson
On Tue, 24 Aug 2010 18:27:32 +0800, Yuanhan Liu wrote: > Use defined get_head/tail method to get the vaule of head/tail. Since each > ring buffer has it's own get_head/tail method defined, use it. > > Signed-off-by: Yuanhan Liu Reviewed-by: Chris Wilson > --- > drivers/gpu/drm/i915/i915_debug

Re: [Intel-gfx] [PATCH 2/2] drm/i915: ringbuffer: Add a helper function to update ring buffer space

2010-08-23 Thread Chris Wilson
On Tue, 24 Aug 2010 18:27:33 +0800, Yuanhan Liu wrote: > There are several places will calc the space of ring buffer. To make it clear > and simple, define a helper function called intel_ring_update_space to do > this. > > Signed-off-by: Yuanhan Liu Reviewed-by: Chris Wilson -- Chris Wilson,

[Intel-gfx] [PATCH 2/2] drm/i915: ringbuffer: Add a helper function to update ring buffer space

2010-08-23 Thread Yuanhan Liu
There are several places will calc the space of ring buffer. To make it clear and simple, define a helper function called intel_ring_update_space to do this. Signed-off-by: Yuanhan Liu --- drivers/gpu/drm/i915/i915_dma.c |4 +--- drivers/gpu/drm/i915/intel_ringbuffer.c | 14 ---

[Intel-gfx] [PATCH 1/2] drm/i915: ringbuffer: use defined get_head/tail method

2010-08-23 Thread Yuanhan Liu
Use defined get_head/tail method to get the vaule of head/tail. Since each ring buffer has it's own get_head/tail method defined, use it. Signed-off-by: Yuanhan Liu --- drivers/gpu/drm/i915/i915_debugfs.c |5 +++-- drivers/gpu/drm/i915/i915_dma.c |4 ++-- drivers/gpu/drm/i915