JBoss Tools M5 have an experimental version of the eclipse plugins that works
against both 3.6 and 4.0.
We'll get that merged into hibernate tools in the new year.
Problem is that it seems 4.1 will cause similar disjunct API so the problem
is just getting worse to keep up and keep a stable API/a
Which one do you prefer (line in bold for each sample)?
builder
.spatial()
.onCoordinates( "location" ) or
.forCoordinates("location") or .forLocation("location") or something else
My two cents :
- .onLocation("position")
- .onLatitude("lat").onLongitude("lng")
Niko
2011/12/21 Emmanuel Bernard
> Which one do you prefer (line in bold for each sample)?
>
>builder
>.spatial()
>.
On Dec 21, 2011, at 2:59 PM, Emmanuel Bernard wrote:
> Which one do you prefer (line in bold for each sample)?
>
> builder
> .spatial()
> .onCoordinates( "location" ) or
> .forCoordinates("location") or .
On 12/20/2011 11:40 AM, John Verhaeg wrote:
> On Dec 20, 2011, at 11:17 AM, Steve Ebersole wrote:
>
>> Which brings us to... do we really want to not allow Closed issues to be
>> reopened? I mean actually remove the transition? Or do we just want to
>> say that as a standard procedure we do not r
On 12/20/2011 01:18 PM, Hardy Ferentschik wrote:
> I agree with this as well. In HV and SEARCH we close the resolved issues
> after a release. While they are resolved they could be reopened and closed
> issues cannot be reopened again. A new issue should be created in this case.
>
> Closing the i
Hi Emmanuel,
My preference:
.forLocation("location")
.forLatitudeField("lat").forLongitudeField("long")
Btw, I quite like "LatLong" as an alternative for the term "Coordinates" or
"Location". It makes clear what the meaning is of the coordinates/location
interface/method, and conditions the re
On Dec 21, 2011, at 3:30 PM, Steve Ebersole wrote:
>> What is the problem with comments on closed issues? Some comments might even
>> be useful (aka "had the same problem, fixed now") However, if someone wants
>> to start a new discussion - tough luck. If the comment is legit we tell them
>> t
On 12/20/2011 02:55 PM, Sanne Grinovero wrote:
> I agree as well on interpreting "Closed" as "forever"; AFAIR new
> issues can be linked to the older closed ones so that while a comment
> might not be allowed, it's still possible to point to "follow ups" in
> case of need.
>
> I'm not sure however
Inline to both these, and some thoughts about subsequent mails:
On 21 December 2011 15:03, Nicolas Helleringer
wrote:
> My two cents :
>
> - .onLocation("position")
>
> - .onLatitude("lat").onLongitude("lng")
I'm confused on what the String represents. I'm going to assume index
fields? So I'm pr
On 21 déc. 2011, at 15:19, Hardy Ferentschik wrote:
>
> On Dec 21, 2011, at 2:59 PM, Emmanuel Bernard wrote:
>
>> Which one do you prefer (line in bold for each sample)?
>>
>> builder
>> .spatial()
>> .onCoo
One big problem we have is that forLocation is not really pointing to one or
even two (lat + long) fields in Lucene. It's pointing to a user property that
leads to a set of Lucene fields (one per grid level + lat + long. That's why we
have shied away from naming it Field.
I guess LatLong is the
>> On a side node, do we really need 'of()'. Sure it makes it sounds a little
>> more like real English, but then why is there no 'and()' between lat and
>> long.
>> The whole DSL part only carries so far when directly hosted in Java. If
>> there is no compelling reason for 'of()' i would argue
On 21 déc. 2011, at 17:30, Hardy Ferentschik wrote:
>>>
>>> what's about 'proximity' instead of 'spatial'?
>>
>> I am somewhat neutral, but I think the industry term is spatial queries.
>> Thoughts?
>
> The industry term is spatial, but I think the John Doe user might be more
> familiar with
On 21 déc. 2011, at 17:30, Hardy Ferentschik wrote:
>>
>> But we can reduce the number of methods called by doing something like this
>>
>> builder
>> .spatial()
>> .forLocation("location")
>> .within(500, Unit.KM)
>> .ofLatitude(48.8d).andLongitude(2.29d)
>> .crea
On Dec 21, 2011, at 5:34 PM, Emmanuel Bernard wrote:
>
> On 21 déc. 2011, at 17:30, Hardy Ferentschik wrote:
>
>>>
>>> But we can reduce the number of methods called by doing something like this
>>>
>>> builder
>>> .spatial()
>>> .forLocation("location")
>>> .within(500, Unit.KM
On 21 December 2011 17:34, Emmanuel Bernard wrote:
>
> On 21 déc. 2011, at 17:30, Hardy Ferentschik wrote:
>
>>>
>>> But we can reduce the number of methods called by doing something like this
>>>
>>> builder
>>> .spatial()
>>> .forLocation("location")
>>> .within(500, Unit.KM)
>>>
On 21 déc. 2011, at 17:36, Sanne Grinovero wrote:
> On 21 December 2011 17:34, Emmanuel Bernard wrote:
>>
>> On 21 déc. 2011, at 17:30, Hardy Ferentschik wrote:
>>
But we can reduce the number of methods called by doing something like this
builder
.spatial()
On 21 December 2011 17:58, Emmanuel Bernard wrote:
>
> On 21 déc. 2011, at 17:36, Sanne Grinovero wrote:
>
>> On 21 December 2011 17:34, Emmanuel Bernard wrote:
>>>
>>> On 21 déc. 2011, at 17:30, Hardy Ferentschik wrote:
>>>
>
> But we can reduce the number of methods called by doing some
On Dec 21, 2011, at 6:02 PM, Sanne Grinovero wrote:
> And where do I find a markdown rendering plugin for gmail ?
Markdown support in Apple Mail wouldn't be so bad either :-)
___
hibernate-dev mailing list
hibernate-dev@lists.jboss.org
https://lists.j
On 21 déc. 2011, at 18:02, Sanne Grinovero wrote:
> On 21 December 2011 17:58, Emmanuel Bernard wrote:
>>
>> On 21 déc. 2011, at 17:36, Sanne Grinovero wrote:
>>
>>> On 21 December 2011 17:34, Emmanuel Bernard wrote:
On 21 déc. 2011, at 17:30, Hardy Ferentschik wrote:
>>
On 21 déc. 2011, at 18:10, Hardy Ferentschik wrote:
>
> On Dec 21, 2011, at 6:02 PM, Sanne Grinovero wrote:
>
>> And where do I find a markdown rendering plugin for gmail ?
>
> Markdown support in Apple Mail wouldn't be so bad either :-)
I'm moving my mailbox to a Git repo on GitHub. If you w
On 21 déc. 2011, at 16:29, Sanne Grinovero wrote:
> wrote:
>> My two cents :
>>
>> - .onLocation("position")
>>
>> - .onLatitude("lat").onLongitude("lng")
>
> I'm confused on what the String represents. I'm going to assume index
> fields? So I'm preferring the "onLocation*Field* [..]" version
On 21 Dec 2011, at 18:32, Emmanuel Bernard wrote:
>
> Maybe `Coordinates` is a bad idea entirely and we should only use "free form
> properties" like this
Why not do this in two steps. Use the "free form properties" now for the first
implementation. Later, after integration of Hibernate Spati
24 matches
Mail list logo