Re: [hibernate-dev] Feature Proposal for Hibernate Search

2014-02-04 Thread Emmanuel Bernard
On Tue 2014-02-04 4:24, Martin Braun wrote: > /** >* @return a custom sort object or null >*/ > public Sort getSort(); > > > or how to facet, etc... > > > I want for this stuff to move to annotations (maybe) because I don't really > like > the fact that I have to i

Re: [hibernate-dev] Feature Proposal for Hibernate Search

2014-02-04 Thread Martin Braun
; instead > in the end just pass the parameter bean to > createQuery. Basically, instead of: But then you'd lose the part where your data is exactly with your parameter-wrapper. Martin Braun martinbraun...@aol.com www.github.com/s4ke -Original Message- From: Hardy Ferentschik To:

Re: [hibernate-dev] Feature Proposal for Hibernate Search

2014-02-04 Thread Hardy Ferentschik
On 4 Jan 2014, at 10:24, Martin Braun wrote: > Uhm. I totally forgot to add this functionality in my rewrite (I have > rewritten most of the code last weekend) > and I implemented a way to pass parameters into QueryTypes. You can even pass > parameters that are dynamically > determined by stat

Re: [hibernate-dev] Feature Proposal for Hibernate Search

2014-02-04 Thread Hardy Ferentschik
On 3 Jan 2014, at 22:22, Emmanuel Bernard wrote: >>> - I don't think annotations are the best way to express queries but you >>> probably >>> have your reasons, so let's discuss them :) >> Why? I think it's not hard to read an you have the query right with your >> ParameterWrapper-class which

Re: [hibernate-dev] Feature Proposal for Hibernate Search

2014-02-04 Thread Martin Braun
ould = {@Should(subQuery = "queryB"), @Should(subQuery = "queryC")}) ... //define query[A-E] here. }) Maybe it's because I don't like to work with the Junctions and put them together myself, and maybe it's only me that thinks this would be eas

Re: [hibernate-dev] Feature Proposal for Hibernate Search

2014-02-03 Thread Emmanuel Bernard
> Martin Braun > martinbraun...@aol.com > www.github.com/s4ke > > > -----Original Message- > From: Emmanuel Bernard > To: Martin Braun > Cc: hibernate-dev > Sent: Mon, Feb 3, 2014 9:45 pm > Subject: Re: [hibernate-dev] Feature Proposal for Hibernate Search >

Re: [hibernate-dev] Feature Proposal for Hibernate Search

2014-02-03 Thread Emmanuel Bernard
y an Example API would address your use cases ? > What do you mean by that? > Martin Braun > martinbraun...@aol.com > www.github.com/s4ke > > > -Original Message- > From: Emmanuel Bernard > To: Martin Braun > Cc: hibernate-dev > Sent: Mon, Feb 3,

Re: [hibernate-dev] Feature Proposal for Hibernate Search

2014-02-03 Thread Martin Braun
www.github.com/s4ke -Original Message- From: Emmanuel Bernard To: Martin Braun Cc: hibernate-dev Sent: Mon, Feb 3, 2014 9:45 pm Subject: Re: [hibernate-dev] Feature Proposal for Hibernate Search Hi Martin, That's interesting. I have a couple of questions for you. What is the

Re: [hibernate-dev] Feature Proposal for Hibernate Search

2014-02-03 Thread Emmanuel Bernard
Hi Martin, That's interesting. I have a couple of questions for you. What is the notion of profile and when would you use it? When do you need and use sub query ids? The issue you had was to map getters to query parameters in an easier way than currently possible, correct? It reminds me a litt

Re: [hibernate-dev] Feature Proposal for Hibernate Search

2014-02-03 Thread Martin Braun
I'd need to modify any core functionality. I hope I have done better this time :). Martin Braun martinbraun...@aol.com www.github.com/s4ke -----Original Message----- From: Hardy Ferentschik To: Martin Braun Cc: Hibernate Sent: Mon, Feb 3, 2014 9:13 pm Subject: Re: [hibernate-dev] Feature Pr

Re: [hibernate-dev] Feature Proposal for Hibernate Search

2014-02-03 Thread Hardy Ferentschik
Hi Martin, great that you like Hibernate Search and want to make it even easier to use. On 3 Jan 2014, at 19:08, Martin Braun wrote: > I am currently working on a new way to query in Hibernate Search. It's not > finished, but > it already works. I had a quick look at the code, but for the sak