Sounds reasonable to me.
On 11/25/2017 12:45 PM, Steve Ebersole wrote:
> I just updated the text for the Jira[1].
>
> Specifically, in the section on SEQUENCE and TABLE, at the moment I have
> kept the legacy behavior of using "hibernate_sequence" as the name of the
> table/sequence - users must o
I just updated the text for the Jira[1].
Specifically, in the section on SEQUENCE and TABLE, at the moment I have
kept the legacy behavior of using "hibernate_sequence" as the name of the
table/sequence - users must opt-in to the behavior of using
`@GeneratedValue#generator` as the sequence/table
That's a great idea. I stumbled on this issue many times, and it's very
good to simplify the mapping as you suggested.
+1
Vlad
On Sat, Nov 25, 2017 at 6:18 PM, Steve Ebersole wrote:
> The background is all in the Jira, but the crux is this... it is better to
> allow a user to do this:
>
>
Actually I just realized I was a little smarter than this back then :D
`IdGeneratorStrategyInterpreter#determineGeneratorName` is actually passed
the GenerationType and a "parameter object". I can add access to the
generator name to the parameter object.
On Sat, Nov 25, 2017 at 10:18 AM Steve Eb
The background is all in the Jira, but the crux is this... it is better to
allow a user to do this:
@GeneratedValue( strategy=SEQUENCE, generator="my_seq")
rather than:
@GeneratedValue( strategy=SEQUENCE, generator="my_seq")
@SequenceGenerator( name="my_seq", sequenceName="my_seq" )