I finally went for .List
@Max.List
On Feb 22, 2009, at 07:18, Elias Ross wrote:
List or Array or Many makes more sense than "Plural" which is really
defined to mean "more than one" but I think in some cases you might
just have a single element or none at all. For example, this would be
valid I
List or Array or Many makes more sense than "Plural" which is really
defined to mean "more than one" but I think in some cases you might
just have a single element or none at all. For example, this would be
valid I think:
@Max.Array( {
@Max(30, groups=JoeSixPack.class),
} )
although I don't kno
2009/2/19 Hardy Ferentschik :
> On Wed, 18 Feb 2009 16:35:30 +0100, Emmanuel Bernard
> wrote:
>
>> @Max.Plural( {
>>@Max(30, groups=JoeSixPack.class),
>>@Max(100, groups=PowerUser.class)
>> } )
>
> +1 for this approach from me as well. Instead of Plural we could also
> consider Many or Mul
On Wed, 18 Feb 2009 16:35:30 +0100, Emmanuel Bernard
wrote:
@Max.Plural( {
@Max(30, groups=JoeSixPack.class),
@Max(100, groups=PowerUser.class)
} )
+1 for this approach from me as well. Instead of Plural we could also
consider Many or Multiple.
--Hardy
I'm leaning towards the inner annotations. They fix the um
non-pretty :>) names and there is no doubt about the Plural intention.
John Griffin
On Feb 18, 2009 8:35am, Emmanuel Bernard wrote:
I have added the following plural forms
AssertFalses
AssertTrues
//Digits to be redefined
Fut
I'll go for the second notation (the one with the inner annotation).
On Wed, Feb 18, 2009 at 5:35 PM, Emmanuel Bernard wrote:
> I have added the following plural forms
> AssertFalses
> AssertTrues
> //Digits to be redefined
> Futures
> Maxs
> Mins
> NotNulls
> Nulls
> Pasts
> Patterns
> Sizes
>
>
I have added the following plural forms
AssertFalses
AssertTrues
//Digits to be redefined
Futures
Maxs
Mins
NotNulls
Nulls
Pasts
Patterns
Sizes
As you can see not all names are pretty. Any improvement proposal?
Alternatively, we could define inner annotations to define the plural,
ie
@interf