Re: [hibernate-dev] How best to eliminate the Javassist dependency from Hibernate applications...

2016-02-03 Thread Ales Justin
Perhaps check if the Classfilewriter is any better in this concern — it might not need any own classes in proxies. * https://github.com/jbossas/jboss-classfilewriter (Weld now uses this — it’s part of WildFly) But this means you would have to wr

Re: [hibernate-dev] document update change?

2015-04-03 Thread Ales Justin
https://github.com/infinispan/infinispan/commit/2d299745df1ce83c23ddc63e066ee820c184b8a7 <https://github.com/infinispan/infinispan/commit/2d299745df1ce83c23ddc63e066ee820c184b8a7> > On 03 Apr 2015, at 12:38, Ales Justin wrote: > > OK, found the culprit ... > > It is thi

Re: [hibernate-dev] document update change?

2015-04-03 Thread Ales Justin
tx)) { transactionContext = transactionContext == null ? makeTransactionalEventContext() : transactionContext; removeFromIndexes(previousValue, extractValue(command.getKey()), transactionContext); --- -Ales > On 03 Apr 2015, at 12:18, Ales Justin wrote: > > I think t

Re: [hibernate-dev] document update change?

2015-04-03 Thread Ales Justin
can then change UPDATE to ADD. -Ales > On 02 Apr 2015, at 21:00, Ales Justin wrote: > > When debugging, I see this -- it get "bbb" twice (old and new, where I would > actually expect stale "ccc"): > > results = {java.util.ArrayList@17380} size = 3 >

Re: [hibernate-dev] document update change?

2015-04-02 Thread Ales Justin
2015\nprop=STRING\n" 2 = {java.lang.String@17393} "040:bbb" 2 = {java.lang.Object[3]@17386} 0 = {com.google.appengine.api.datastore.Key@17387} "test(1)" 1 = {java.lang.String@17388} "#Thu Apr 02 20:53:33 CEST 2015\nprop=STRING\n" 2 = {java.lang.String@17389}

Re: [hibernate-dev] document update change?

2015-04-01 Thread Ales Justin
>>> I expect our Update routines to still work. I don't know what the code >>> you're showing does though, as those are not our APIs. >>> >>> If you could share a test using our APIs I'll look at it. >> >> What about if you run our test? :-) >> (it should be easy -- once you have all CD projects

Re: [hibernate-dev] document update change?

2015-04-01 Thread Ales Justin
> I expect our Update routines to still work. I don't know what the code > you're showing does though, as those are not our APIs. > > If you could share a test using our APIs I'll look at it. What about if you run our test? :-) (it should be easy -- once you have all CD projects checked-out and b

[hibernate-dev] document update change?

2015-04-01 Thread Ales Justin
Did entity updating changed in HS5 / Lucene4? (aka Document updating) Since this used to work for us (with HS4, Lucene3): --- @Test public void testProjectionQueriesHandleEntityModificationProperly() throws Exception { Entity e = createEntity("test", 1) .withProperty("prop", Arrays.a

Re: [hibernate-dev] Bytecode enhancement

2014-03-19 Thread Ales Justin
Perhaps see if this can be of any use to you: * https://github.com/alesj/maven-transformer-plugin I'm using this as part of CapeDwarf's GAE jar transformation. * https://github.com/capedwarf/capedwarf-blue/blob/master/bytecode/src/main/java/org/jboss/capedwarf/bytecode/CapedwarfTransformerMojo.ja

Re: [hibernate-dev] Hibernate Search being integrated in WildFly

2014-01-14 Thread Ales Justin
> Unfortunately, this comes at a non optimal point in time. Not only will it > take time from the > Lucene 4 migration (aka Search 5), but if Search 4.x gets included now we > probably will get very > quickly people asking on how to use Search 5 with Wildfly. If nothing else a > lot of dependen

Re: [hibernate-dev] Released Hibernate Search 4.4.2.Final and 4.5.0.Alpha2

2013-12-16 Thread Ales Justin
wrote: > I didn't know about this change either. Are there any WildFly unit tests > using HS? > > On 12/16/2013 09:16 AM, Ales Justin wrote: >> Infinispan Subsystem supported Indexing element. >> This then needed Query on the classpath to work properly. >> (i

Re: [hibernate-dev] Released Hibernate Search 4.4.2.Final and 4.5.0.Alpha2

2013-12-16 Thread Ales Justin
e next > season because it was possible to introduce more flexibility in the > configuration parsing: > if we decide it's going to be there, let's make sure it's going to be > there for a long time. > > What's the deadline to get fixes - and possibly significant >

Re: [hibernate-dev] Released Hibernate Search 4.4.2.Final and 4.5.0.Alpha2

2013-12-16 Thread Ales Justin
> What is the consumer of the base technology? Infinispan in WF does not > require HSearch for the base clustering features right? > > Emmanuel > > On Mon 2013-12-16 11:19, Ales Justin wrote: >> Did you create a PR in WildFly, with the upgrade. >> As HS is now par

Re: [hibernate-dev] Released Hibernate Search 4.4.2.Final and 4.5.0.Alpha2

2013-12-16 Thread Ales Justin
ntegrations which I guess your team is using). > > Also, this will require some documentation and packaging changes in > Hibernate Search, probably for Infinispan/Server too. > > Sanne > > > On 16 December 2013 10:19, Ales Justin wrote: > > Did you create a PR i

Re: [hibernate-dev] Released Hibernate Search 4.4.2.Final and 4.5.0.Alpha2

2013-12-16 Thread Ales Justin
Did you create a PR in WildFly, with the upgrade. As HS is now part of upstream master. ;-) On 16 Dec 2013, at 00:14, Sanne Grinovero wrote: > Hello all, > both releases where done specifically to address one bug, as explained > on the traditional release blog post: > > http://in.relation.to/B

Re: [hibernate-dev] ArrayIndexOutOfBoundsException in ReflectionHelper.parametersResolveToSameTypes

2013-12-12 Thread Ales Justin
> Can you confirm that some static method is involved here (which was the case > for HV-818)? I can't see one on your Email class but maybe there is one on > AbstractEntity? AbstractEntity -- static method at the bottom: (but Email is not the only one that extends AbstractEntity, where my issue

Re: [hibernate-dev] ArrayIndexOutOfBoundsException in ReflectionHelper.parametersResolveToSameTypes

2013-12-11 Thread Ales Justin
rn false; return true; } @Override public int hashCode() { int result = super.hashCode(); result = 31 * result + (email != null ? email.hashCode() : 0); return result; } } On 11 Dec 2013, at 11:23, Ales Justin wrote: > @Hardy, Emmanuel: https://gist.

[hibernate-dev] ArrayIndexOutOfBoundsException in ReflectionHelper.parametersResolveToSameTypes

2013-12-11 Thread Ales Justin
@Hardy, Emmanuel: https://gist.github.com/alesj/7908062 Imo, any AIOOBE is a bug. -Ales ___ hibernate-dev mailing list hibernate-dev@lists.jboss.org https://lists.jboss.org/mailman/listinfo/hibernate-dev

Re: [hibernate-dev] JPA 2.1 in WildFly 8

2013-10-30 Thread Ales Justin
Afaik, this is _not_ *user* forum. ;-) --- "This means that you are trying to access a weld deployment with a Thread Context ClassLoader that is not associated with the deployment." It looks like JPA stuff is trying to access some CDI bean, but the TCCL is not app's CL. On 30 Oct 2013, at 13:3

Re: [hibernate-dev] [HSEARCH] Geo queries in ElasticSearch

2013-07-03 Thread Ales Justin
Can you then also easily (aka really fast) know which are those points -- even with really big number of data? On Jul 3, 2013, at 2:14 PM, Emmanuel Bernard wrote: > I'm more interested in something like > > Within 10 kms (23) > Between 10 and 50 kms (45) > Above 50 kms (75) > > > On Wed 2013

Re: [hibernate-dev] [jdf-dev] JBoss Modules dependency vs pain POM dependency + exclusions

2013-06-06 Thread Ales Justin
Next time ping me for any issues, as I've done this ages ago for CapeDwarf. :-) On Jun 6, 2013, at 1:37 PM, Emmanuel Bernard wrote: > Below is an email describing the issues i had to get Hibernate Search run in > WildFly / EAP. A possibility to make life easier for Hibernate Search users > in

Re: [hibernate-dev] A synchronous JGroups backend for Hibernate Search

2013-05-03 Thread Ales Justin
> I did not think of that but an "implicit" or "auto" setting makes some > sense. > Just to be sure, the new immplicit setting / behavior will break the > semantic of what's going on so it should at least but a minor version > bump. Correct? > > BTW, did you guys even found out why using sync was

Re: [hibernate-dev] A synchronous JGroups backend for Hibernate Search

2013-04-15 Thread Ales Justin
What's (again) the magic property to set all indexes backends in a cache to async? -Ales On Apr 15, 2013, at 7:00 PM, Sanne Grinovero wrote: > In my first draft for HSEARCH-1296 I was automatically enabling the > blocking behaviour on JGroups if the worker backend was configured to > be synchr

Re: [hibernate-dev] HSEARCH-1296

2013-04-13 Thread Ales Justin
int size = dispatcher.getChannel().getView().getMembers().size(); RequestOptions options = RequestOptions.SYNC(); options.setRspFilter( new WaitAllFilter( size ) ); } else { options = RequestOptions.ASYNC(); } -Ales On Apr 13, 2013, at 11:25

Re: [hibernate-dev] HSEARCH-1296

2013-04-13 Thread Ales Justin
ext log from today in a > graphical sequence diagram. > Big thanks to Mircea who helped me figuring this out. > > Sanne > > On 12 April 2013 21:10, Ales Justin wrote: >> I think we need more fine-grained config for this new JGroups sync feature. >> >> I added

Re: [hibernate-dev] HSEARCH-1296

2013-04-12 Thread Ales Justin
hen we can help you with > better configuration options. > > > On 11 April 2013 20:47, Ales Justin wrote: >> What do you mean? >> >> On Apr 11, 2013, at 21:41, Sanne Grinovero wrote: >> >> You could try the new sync version but setting the blackhole

Re: [hibernate-dev] HSEARCH-1296

2013-04-11 Thread Ales Justin
e you sure that the async version actually had applied all writes to the >> index in the measured interval? >> On Apr 11, 2013 8:13 PM, "Ales Justin" wrote: >>> Although this change fixes query lookup, >>> it adds horrible performance: >>> >&

Re: [hibernate-dev] HSEARCH-1296

2013-04-11 Thread Ales Justin
in the measured interval? > On Apr 11, 2013 8:13 PM, "Ales Justin" wrote: >> Although this change fixes query lookup, >> it adds horrible performance: >> >> Running CapeDwarf cluster QueryTest: >&g

[hibernate-dev] HSEARCH-1296

2013-04-11 Thread Ales Justin
Although this change fixes query lookup, it adds horrible performance: Running CapeDwarf cluster QueryTest: with HSEARCH-1296 21:00:27,188 INFO [org.hibernate.search.indexes.impl.DirectoryBasedIndexManager] (http-/192.168.1.102:8080-1) HSEARCH000168: Serialization service Avro SerializationP

Re: [hibernate-dev] Scanner contract

2013-03-16 Thread Ales Justin
> I should point out this is based on what we saw when Brett initially worked > with Karaf, especially in the Enterprise OSGi use cases. The incoming > PersistenceUnitInfo contained no urls other than the root url, which happened > to be an osgi bundle url (the protocol was "bundle"). To me, i

Re: [hibernate-dev] Scanner contract

2013-03-16 Thread Ales Justin
It's probably best if the SPI would take the ClassLoader as parameter, instead of having to guess it, or depend on proper TCCL (think OSGi ;-)). e.g. for this reason Infinispan introduced AdvancedCache::withClassLoader. -Ales On Mar 16, 2013, at 8:48 PM, Steve Ebersole wrote: > I should clarif

Re: [hibernate-dev] HSearch Projection queries & multiple fields with same name

2013-01-03 Thread Ales Justin
I think anything handled by not-Lucene is wrong. >>> >>> I'm afraid Lucene won't do it, so we have no option. It's definitely >>> not designed to do this: even a custom Collector can't return more >>> results than Documents in its segment, as all representations work by >>> using int as relat

Re: [hibernate-dev] HSearch Projection queries & multiple fields with same name

2013-01-03 Thread Ales Justin
>> I think anything handled by not-Lucene is wrong. > > I'm afraid Lucene won't do it, so we have no option. It's definitely > not designed to do this: even a custom Collector can't return more > results than Documents in its segment, as all representations work by > using int as relative ids. Ev

Re: [hibernate-dev] HSearch Projection queries & multiple fields with same name

2013-01-03 Thread Ales Justin
I think anything handled by not-Lucene is wrong. As Lucene, in this case, is the only engine that can properly address all query details - order, filtering, ... So, imo, the only way to do this is by having multiple documents, one per cartesian product element. How to go from there, is a big TOD

[hibernate-dev] Lucene: @Indexed -> @FullText

2006-11-08 Thread Ales Justin
no biggie, but neither name indicates "i'm searchable" to me ;) Totally agree. What about plain @Searchable?Rgds, Ales Indexed maybe, FullText notFullTextIndexed ? that i can understand. /max / I want to rename @Indexed to @FullText to mark a class as "searchable" />>/ The name is more

[hibernate-dev] Re: Hibernate Lucene - forum issue

2006-10-16 Thread Ales Justin
ou check the code in > http://anonsvn.jboss.org/repos/hibernate/branches/Lucene_Integration/> I'm interested in seeing some additional issue if any. >> What is additional POJO handling?>> PS I remember an old JIRA issue of you talking about a filter > capability. I thing it&#