[hibernate-dev] hibernate-tools jira HBX-577

2009-02-18 Thread Ing. Arturo Frappé Muñoz
Hi, This is my proposal to solve JIRA issue HBX-577 "hbm2java for annotation from existing inheritance mapping" I figured out how-to do   "joined-subclass" and "table-per-class-herarchy" but  couldn't test it. This solution relies on tag,  example:         single-table-per-class-herarch

[hibernate-dev] [Bean Validation] Same instance validated only once and determinism

2009-02-18 Thread Emmanuel Bernard
I would like to revive the subject of reaching the same instance multiple times in an object graph. Assuming the following example A |-> C -> B |-> D -> B Each arrow is an association marked as @Valid Today, the second time an instance is reached, it is ignored. So assuming B is invalid

Re: [hibernate-dev] [Bean Validation] Constraints plural

2009-02-18 Thread johng . sst
I'm leaning towards the inner annotations. They fix the um non-pretty :>) names and there is no doubt about the Plural intention. John Griffin On Feb 18, 2009 8:35am, Emmanuel Bernard wrote: I have added the following plural forms AssertFalses AssertTrues //Digits to be redefined Fut

Re: [hibernate-dev] [Bean Validation] Constraints plural

2009-02-18 Thread Alaa Mohsen
I'll go for the second notation (the one with the inner annotation). On Wed, Feb 18, 2009 at 5:35 PM, Emmanuel Bernard wrote: > I have added the following plural forms > AssertFalses > AssertTrues > //Digits to be redefined > Futures > Maxs > Mins > NotNulls > Nulls > Pasts > Patterns > Sizes > >

Re: [hibernate-dev] [Bean Validation] @Digits => @DecimalRepresentation

2009-02-18 Thread johng . sst
Sorry if I'm repeating information that someone else may have brought up and I hope I'm not throwing a wrench into the works. What about @Interface NumericRepresentations? This could leave room for hex and octal numbers. Just my 2 cents. John Griffin On Feb 18, 2009 8:01am, Emmanuel Berna

[hibernate-dev] [Bean Validation] Constraints plural

2009-02-18 Thread Emmanuel Bernard
I have added the following plural forms AssertFalses AssertTrues //Digits to be redefined Futures Maxs Mins NotNulls Nulls Pasts Patterns Sizes As you can see not all names are pretty. Any improvement proposal? Alternatively, we could define inner annotations to define the plural, ie @interf

[hibernate-dev] [Bean Validation] @Digits => @DecimalRepresentation

2009-02-18 Thread Emmanuel Bernard
I am considering renaming @Digits to @DecimalRepresentation to make room for the plural form @interface DecimalRepresentations { DecimalRepresentation[] value() } Any better name? ___ hibernate-dev mailing list hibernate-dev@lists.jboss.org https

Fwd: [hibernate-dev] Hibernate Search: configure the LockingFactory

2009-02-18 Thread Emmanuel Bernard
Begin forwarded message: From: Sanne Grinovero Date: February 18, 2009 15:41:06 CEST To: Emmanuel Bernard Subject: Re: [hibernate-dev] Hibernate Search: configure the LockingFactory 2009/2/18 Emmanuel Bernard : On Feb 18, 2009, at 11:49, Sanne Grinovero wrote: The "none" doesn't pr

Re: [hibernate-dev] Hibernate Search: configure the LockingFactory

2009-02-18 Thread Emmanuel Bernard
On Feb 18, 2009, at 11:49, Sanne Grinovero wrote: The "none" doesn't protect at all, so you have to make sure to never open a second indexwriter or use any indexwriter when you are using an indexreader to make changes. Sounds a bit dangerous IMHO but I don't think we should stop people s

Re: [hibernate-dev] Hibernate Search: configure the LockingFactory

2009-02-18 Thread Emmanuel Bernard
On Feb 18, 2009, at 11:49, Sanne Grinovero wrote: Also 2 of the base Lucene implementations are missing a public no- args constructor, so I would use only simple names: simple -> org.apache.lucene.store.SimpleFSLockFactory native -> org.apache.lucene.store.NativeFSLockFactory single -> o

Re: [hibernate-dev] Hibernate Search: configure the LockingFactory

2009-02-18 Thread Sanne Grinovero
The issue is closed already: http://fisheye.labs.jboss.com/browse/Hibernate/search/trunk I'll add support to create LockFactories by fqcn later, I didn't consider that important at first. answers inline: 2009/2/18 Emmanuel Bernard : > > On Feb 16, 2009, at 15:06, Sanne Grinovero wrote: > >> Hi al

Re: [hibernate-dev] Hibernate Search: configure the LockingFactory

2009-02-18 Thread Emmanuel Bernard
On Feb 16, 2009, at 15:06, Sanne Grinovero wrote: Hi all, to solve HSEARCH-284 (Lucene locks left around in application restart/crash) I am investigating the differences in all Lucene's LockFactory implementations; some of them are interesting and I would like to add a configuration opti

[hibernate-dev] Exception model

2009-02-18 Thread Emmanuel Bernard
I spent a long time scrutinizing the spec for exception cases. This email list exceptional cases and propose to associate specific exceptions to them or not. Please review and tell me: - if you think I forgot cases that needs additional consideration. - which model you favor (see B) A. EXC

Re: [hibernate-dev] hibernate-tools JUnit template

2009-02-18 Thread Max Rydahl Andersen
Hi, Good evening Lords & Ladies: This is a simple .ftl template to generate a trivial JUnit test code. Any ideas & improvements are welcome ;) thanks for the template, but it looks *very* system specific so not sure what you want me to comment on ? /max _