Not quite...
Note this change in fieldget function:
...
if ::FieldType(nNum) == "C"
- return PadR(::aRow[nNum], ::aFieldStruct[nNum][MYSQL_FS_LENGTH])
+ return PadR(::aRow[nNum], ::aFieldStruct[nNum][MYSQL_FS_MAXLEN])
...
Now the method returns exact character value as stored in MySQL table.
On Wed, 04 Feb 2009, Pritpal Bedi wrote:
Hi Pritpal
> HB_FUNC( WAPI_PRINTDLG )
> {
>PRINTDLG *pd = hb_parc( 1 ); // structure WHEREEVER possible
>...
>wapi_retstruct( pd );
> }
Passing C structures as string is also bad idea.
If we do not need support for direct updating C structure
Hi all,
I plan to commit this long time planned modification,
to clear up some last non prefixed public envvars
needed to configure Harbour:
HB_USER_LIBS -> HB_USR_LIBLIST
PRG_USR -> HB_USR_PRG
C_USR-> HB_USR_C
L_USR-> HB_USR_L (or HB_USR_LINK ?)
A_USR-> HB_USR_A (or
Have you a little sample?
2009/2/4 Barry Jackson :
> Yes - I used memo fields to hold HTML to generate web pages from stock
> records in Clipper! :-)
>
> Przemyslaw Czerpak wrote:
>>
>> On Wed, 04 Feb 2009, Massimo Belgrano wrote:
>>>
>>> Which data type will be used to store XML/html documents in
Revision: 10182
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=10182&view=rev
Author: snaiperis
Date: 2009-02-05 00:21:08 + (Thu, 05 Feb 2009)
Log Message:
---
2009-02-04 02:20 UTC+0200 Mindaugas Kavaliauskas (dbtopas/at/dbtopas.lt)
* harbour/contrib
>
> hbwapi.h
> ===
> #define wapi_parwparam( n ) ( ( WPARAM ) ( HB_PTRDIFF ) hb_parnint( n ) )
> #define wapi_parlparam( n ) ( ( LPARAM ) ( HB_PTRDIFF ) hb_parnint( n ) )
> #define wapi_parhandle( n ) ( ( HANDLE ) ( HB_PTRDIFF ) hb_parnint( n ) )
> #define wapi_parhwnd( n )( ( HWND )
Hi
wapi_gdi32.c OR wapi_gdi.c ( removing 32, may contain gdi32 or gdi++
functions )
hbwapi.h
===
#define wapi_parwparam( n ) ( ( WPARAM ) ( HB_PTRDIFF ) hb_parnint( n ) )
#define wapi_parlparam( n ) ( ( LPARAM ) ( HB_PTRDIFF ) hb_parnint( n ) )
#define wapi_parhandle( n ) ( ( HANDLE )
Hi,
It is thread safe. All reference counters in Harbour core code are updated
by atomic inc/dec operations (see hbatomic.h) so they are protected and MT
safe.
Oh, yes. I should remember it myself. Thanks.
Regards,
Mindaugas
___
Harbour mailing l
Can someone confirm whether this patch is valid?
https://sourceforge.net/tracker/index.php?func=detail&aid=2308998&group_id=681&atid=100681
It changes MYSQL_FS_LENGTH to MYSQL_FS_MAXLEN in tmysql.prg.
Brgds,
Viktor
___
Harbour mailing list
Harbour@harbo
On Thu, 05 Feb 2009, Mindaugas Kavaliauskas wrote:
Hi,
> one more thread question:
> STATIC mtx := hb_mutexCreate()
> Thread1:
> LOCAL xI
> xI := some_value
> hb_mutexNotify(mtx, xI)
> xI := NIL // or xI := another_value
> Thread2:
> LOCAL xI, xParam
> hb_mutexSubscribe(mtx,, @xParam)
Revision: 10181
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=10181&view=rev
Author: vszakats
Date: 2009-02-04 22:56:18 + (Wed, 04 Feb 2009)
Log Message:
---
2009-02-04 23:55 UTC+0100 Viktor Szakats (harbour.01 syenar hu)
* harbour-win-spec
! Fi
Okay, we're on the same page.
Maybe "wapi_" is the most convenient and a good
middle ground between w_ and winapi_. My vote goes
for this one, but it's not a very strong preference.
More opinions? Pritpal?
Brgds,
Viktor
On Wed, Feb 4, 2009 at 10:20 PM, Francesco Saverio Giudice <
i...@fsgiudice.
Revision: 10180
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=10180&view=rev
Author: vszakats
Date: 2009-02-04 22:40:18 + (Wed, 04 Feb 2009)
Log Message:
---
2009-02-04 23:39 UTC+0100 Viktor Szakats (harbour.01 syenar hu)
* source/compiler/cmdcheck.
Revision: 10179
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=10179&view=rev
Author: vszakats
Date: 2009-02-04 22:24:35 + (Wed, 04 Feb 2009)
Log Message:
---
2009-02-04 23:23 UTC+0100 Viktor Szakats (harbour.01 syenar hu)
* include/hbwince.h
* inc
Hi,
one more thread question:
STATIC mtx := hb_mutexCreate()
Thread1:
LOCAL xI
xI := some_value
hb_mutexNotify(mtx, xI)
xI := NIL // or xI := another_value
Thread2:
LOCAL xI, xParam
hb_mutexSubscribe(mtx,, @xParam)
xI := xParam
Is this code thread safe? The problem is that, if
Revision: 10178
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=10178&view=rev
Author: vszakats
Date: 2009-02-04 22:14:46 + (Wed, 04 Feb 2009)
Log Message:
---
2009-02-04 23:13 UTC+0100 Viktor Szakats (harbour.01 syenar hu)
* source/rtl/tget.prg
* s
Yes - I used memo fields to hold HTML to generate web pages from stock
records in Clipper! :-)
Przemyslaw Czerpak wrote:
On Wed, 04 Feb 2009, Massimo Belgrano wrote:
Which data type will be used to store XML/html documents in dbf by harbour?
The same as for any other text or binary objects:
Okay, I'll simply remove the HB* versions then.
Brgds,
Viktor
On Wed, Feb 4, 2009 at 11:06 PM, Przemyslaw Czerpak wrote:
> On Wed, 04 Feb 2009, Szak�ts Viktor wrote:
>
> Hi Viktor,
>
> > This is brand new information, so essentially the whole
> > assumption was false, that we should get rid of GE
Revision: 10177
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=10177&view=rev
Author: vszakats
Date: 2009-02-04 22:06:57 + (Wed, 04 Feb 2009)
Log Message:
---
2009-02-04 23:04 UTC+0100 Viktor Szakats (harbour.01 syenar hu)
* contrib/examples/hbsqlit2
Revision: 10176
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=10176&view=rev
Author: vszakats
Date: 2009-02-04 22:02:35 + (Wed, 04 Feb 2009)
Log Message:
---
2009-02-04 23:00 UTC+0100 Viktor Szakats (harbour.01 syenar hu)
* bin/hb-func.sh
* bin/hb
On Wed, 04 Feb 2009, Szak�ts Viktor wrote:
Hi Viktor,
> This is brand new information, so essentially the whole
> assumption was false, that we should get rid of GET(), is this
> the case?
Yes. I'm really sorry - my fault. I should check it first.
Just simply I forgot about it.
> How about addi
Hi Przemek,
> > As the last step of cleaning Harbour from "win32", "w32" and similar
> > from '32', I'd like to move forward and switch "w32" HB_ARCHITECTURE
> > to simply "win".
> > Currently "w32" covers Windows 32-bit, Windows 64-bit, Windows CE,
> > and in the future might also cover Itanium
On Wed, 04 Feb 2009, Szak�ts Viktor wrote:
Hi Viktor,
> As the last step of cleaning Harbour from "win32", "w32" and similar
> from '32', I'd like to move forward and switch "w32" HB_ARCHITECTURE
> to simply "win".
> Currently "w32" covers Windows 32-bit, Windows 64-bit, Windows CE,
> and in the
Il 04/02/2009 10.45, Viktor Szakáts ha scritto:
Ok for using *.ch, *.h, but if it is possible, to see immediately
where put a new addition, as per c api file I would like to mantain
ms naming convention, so for me it will be better to use, f.e.,
w_winuser.ch or winuserapi.ch
W
Revision: 10175
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=10175&view=rev
Author: vszakats
Date: 2009-02-04 21:12:12 + (Wed, 04 Feb 2009)
Log Message:
---
2009-02-04 22:11 UTC+0100 Viktor Szakats (harbour.01 syenar hu)
* bin/hbmk.bat
* make_gcc
Revision: 10174
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=10174&view=rev
Author: vszakats
Date: 2009-02-04 20:59:47 + (Wed, 04 Feb 2009)
Log Message:
---
2009-02-04 21:59 UTC+0100 Viktor Szakats (harbour.01 syenar hu)
* include/hbgtcore.h
* co
Revision: 10173
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=10173&view=rev
Author: vszakats
Date: 2009-02-04 20:48:45 + (Wed, 04 Feb 2009)
Log Message:
---
2009-02-04 21:48 UTC+0100 Viktor Szakats (harbour.01 syenar hu)
* contrib/rddado/tests/hbmk
Hi all,
As the last step of cleaning Harbour from "win32", "w32" and similar
from '32', I'd like to move forward and switch "w32" HB_ARCHITECTURE
to simply "win".
Currently "w32" covers Windows 32-bit, Windows 64-bit, Windows CE,
and in the future might also cover Itanium (IA64) (*), so the naming
On Wed, 04 Feb 2009, Massimo Belgrano wrote:
> Which data type will be used to store XML/html documents in dbf by harbour?
The same as for any other text or binary objects: MEMO
> SQL Server 2005 have a data type called XML. These XML values are
> stored in an internal format as large binary obje
Revision: 10172
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=10172&view=rev
Author: vszakats
Date: 2009-02-04 18:21:23 + (Wed, 04 Feb 2009)
Log Message:
---
2009-02-04 19:20 UTC+0100 Viktor Szakats (harbour.01 syenar hu)
* include/hbextern.ch
*
http://en.wikipedia.org/wiki/XML_database
2009/2/4 Massimo Belgrano :
> Which data type will be used to store XML/html documents in dbf by harbour?
>
> SQL Server 2005 have a data type called XML. These XML values are
> stored in an internal format as large binary objects (BLOB)
> you can query a
Which data type will be used to store XML/html documents in dbf by harbour?
SQL Server 2005 have a data type called XML. These XML values are
stored in an internal format as large binary objects (BLOB)
you can query and update XML documents
dbf world seen not have this fields, also VFP seem not ha
On Wed, 04 Feb 2009, Miguel Angel Marchuet wrote:
Hi Miguel,
>>> (Foxpro) Code page: These values follow the DOS / Windows Code Page values.
>>> Value Description Code page
>>> 01h DOS USA code page 437
>>> 02h DOS Multilingualcode page 850
>>> 03h Window
>
> The problem is that we need (at least we already had) GET()
> for Xbase++ compatibility. Exact same problems we have with
> TBrowse() and TBColumn(), which aren't Clipper public symbols.
>
> Since Xbase++ is less important, how about naming the
> XPP compatible (or so intended) extended classes
>
> For me much more important is basic Clipper compatibility and here
> we touch sth what may break pure CL5.2 code which does not even use
> any external OOP system.
> The problem with repeating xbasee++ class function names is much
> bigger and apeears in other places. I'm not xbase++ user so I
>
> * Not detected when you include CODEPAGE=AUTO in your configuration file.
>
> http://msdn.microsoft.com/en-us/library/8t45x02s(VS.71).aspx
Isn't this the kind of collation which needs the Windows API
specific non-portable function call to be implemented properly?
[ this was discussed a few t
On Wed, 04 Feb 2009, Szak�ts Viktor wrote:
> The problem is that Xbase++ has a public symbol named GET(), while plain
> Clipper doesn't. If XPP compatibility is turned on, we
> should provide GET(), if it isn't, we shouldn't.
For me much more important is basic Clipper compatibility and here
we to
Przemyslaw Czerpak escribió:
On Tue, 03 Feb 2009, Miguel Angel Marchuet wrote:
Hi Miguel,
the offset 1Dh at DBF/foxpro header tables has ( Language driver ) as follow:
(Foxpro) Code page: These values follow the DOS / Windows Code Page values.
Value Description Code page
01h DOS US
The problem is that Xbase++ has a public symbol named GET(), while plain
Clipper doesn't. If XPP compatibility is turned on, we
should provide GET(), if it isn't, we shouldn't.
I intentionally didn't replace Get():New() with GetNew(), to not
add an unnecessary layer of function call here. [ if ther
On Wed, 04 Feb 2009, vszak...@users.sourceforge.net wrote:
Hi Viktor,
> + CA-Cl*pper compatible GET class renamed to HBGet and
> is now always available regardless of feature settings.
Now we have different problem:
? getNew():className
which will break code which checks class name,
Hi Frank and all,
Nice concept, thanks. We'll need something which makes sure our own type
names never collide with anything else.
Your abbrev system has its advantages, it's short and
easy to work with once you've got used to it, the drawback
I see is that it makes it a bit difficult to grep for
Revision: 10171
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=10171&view=rev
Author: vszakats
Date: 2009-02-04 13:45:09 + (Wed, 04 Feb 2009)
Log Message:
---
2009-02-04 14:42 UTC+0100 Viktor Szakats (harbour.01 syenar hu)
* include/hbextern.ch
* c
On Tue, 03 Feb 2009, Miguel Angel Marchuet wrote:
Hi Miguel,
> the offset 1Dh at DBF/foxpro header tables has ( Language driver ) as follow:
> (Foxpro) Code page: These values follow the DOS / Windows Code Page values.
> Value Description Code page
> 01h DOS USA code page 437
> 02h
Hello Viktor,
Since some time i'm switched to using a simple scheme; a letter to indicate the
base type (for templates), and additionally a number expressing the precision
(for concrete types)
cchar (as genuine char)
c0 normal char
c1 unicode char
uunsigned int
u0 8 bit
On Wed, 04 Feb 2009, Szak�ts Viktor wrote:
> I'll look into it.
Thank you,
best regards,
Przemek
___
Harbour mailing list
Harbour@harbour-project.org
http://lists.harbour-project.org/mailman/listinfo/harbour
I'll look into it.
Brgds,
Viktor
On Wed, Feb 4, 2009 at 12:31 PM, Przemyslaw Czerpak wrote:
> On Wed, 04 Feb 2009, Barry Jackson wrote:
>
> Hi Barry,
>
> > OK not to worry - I changed my function name and it's working.
> > Easier than I expected with search and replace.
> >> Hi - this is probably
On Wed, 04 Feb 2009, Barry Jackson wrote:
Hi Barry,
> OK not to worry - I changed my function name and it's working.
> Easier than I expected with search and replace.
>> Hi - this is probably my fault, but I am trying to port a large Clipper
>> 5.1 application to Harbour that has run well since
There is a Multiplatform way to do it?
func test(x_cmd)
x_cmd=curdrive()+":\"+curdir(curdrive())+"\mytest.pdf"
SHELLEXECUTE( 0, "OPEN" ,ALLTRIM(X_CMD))
RETURN .T.
#pragma BEGINDUMP
#include "windows.h"
#include "hbapi.h"
HB_FUNC( SHELLEXECUTE )
{
hb_retnl( ( LONG ) ShellExecute( (
Przemyslaw,
make install fails as well :( with this error:
(E:\repository\harbour-svn)make install
make -C doc install
make[1]: Entering directory `E:/repository/harbour-svn/doc'
make -C en install
make[2]: Entering directory `E:/repository/harbour-svn/doc/en'
make[2]: Nothing to be done for `ins
>-Original Message-
>From: Mindaugas Kavaliauskas [mailto:dbto...@dbtopas.lt]
>Sent: Tuesday, February 03, 2009 5:43 PM
>To: Harbour Project Main Developer List.
>Subject: Re: [Harbour] Out-of-Box usable Harbour Distribution with
XMate Project Builder
[...]
>I've done some mingw tests in
>
>
>> Ok for using *.ch, *.h, but if it is possible, to see immediately where
> put a new addition, as per c api file I would like to mantain ms naming
> convention, so for me it will be better to use, f.e., w_winuser.ch or
> winuserapi.ch
We can do this. I personally prefer "w_winuser.ch".
Or
Hi Viktor,
Il 04/02/2009 10.14, Viktor Szakáts ha scritto:
In contrary, I'm happy you've joined the thread :)
Thanks
2) using, as above, header defines in *.api files (winuser.api,
wingdi.api)
Here I don't agree, because usually I find it better
to use standard extensions, so if s
Hi Viktor,
Il 04/02/2009 10.14, Viktor Szakáts ha scritto:
In contrary, I'm happy you've joined the thread :)
Thanks
2) using, as above, header defines in *.api files (winuser.api,
wingdi.api)
Here I don't agree, because usually I find it better
to use standard extensions, so if s
On Wed, Feb 4, 2009 at 9:51 AM, Massimo Belgrano wrote:
>
> http://apps.sourceforge.net/mediawiki/harbour-project/index.php?title=Main_Page
> I am logged as mbelgrano but i not found any way add page
Indeed, rights have to be given, or somehow editing must be
set to be unrestricted, but couldn't
Hi Francesco, Pritpal,
5) Further cleanup hbwin.lib (naming, better separation of API, additional
>> convenience functions and classes).
>> 6) Remove hbwhat.lib altogether.
>>
>>
> sorry to jump in and probably missing some infos, but only as suggestion
> may I propose to adopt this naming conve
Hi Viktor,
VS> hbtpathy doesn't have a complete implementation
VS> for Windows. There is however a comm subsystem
VS> for Windows in hbwin.lib. See testprt1.prg and testprt2.prg
VS> for example code.
Thanks for explanations.
--
Regards,
Jaroslaw Kadziola
_
>
> >4. Copy *.ch and *.h files from HARBOUR\CONTRIB\*.* to HARBOUR\INCLUDE
>
> Imo you must add to lib and include the path of contrib that you want use
> and not move inside harbour structure
No, that's not necessary, nor recommended, "make install"
should be used to copy everything to a fina
Hi Viktor, Pritpal,
Il 04/02/2009 3.35, Viktor Szakáts ha scritto:
To put it shortly: IMO hbwin should be a pure wrapper for
the Windows API and closely Windows API related features,
nothing more, nothing less. It's also important that
64-bit, Unicode and GCC/MSVC/POCC/OW compatibility be
k
http://apps.sourceforge.net/mediawiki/harbour-project/index.php?title=Main_Page
I am logged as mbelgrano but i not found any way add page
2009/2/4 Viktor Szakáts :
>> Rule as this are important (also if not jet approved)
>> How give importance to this info?
>> How we can know this rule to future h
Revision: 10170
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=10170&view=rev
Author: vszakats
Date: 2009-02-04 08:49:22 + (Wed, 04 Feb 2009)
Log Message:
---
2009-02-04 09:49 UTC+0100 Viktor Szakats (harbour.01 syenar hu)
* contrib/hbwin/win_tprn.pr
>4. Copy *.ch and *.h files from HARBOUR\CONTRIB\*.* to HARBOUR\INCLUDE
Imo you must add to lib and include the path of contrib that you want use
and not move inside harbour structure
I think that a little visual utility who made this will be useful who
set path for lib,include,obj choice c co
Przemyslaw Czerpak wrote:
> Interesting. Now it looks like GNU make problem.
> Maybe some trick with eval function can help, f.e. something like:
>
>define lib_object
>echo ADDMOD $(1) >> __lib__.tmp
>endef
>
>define create_library
>IF EXIST $(OS2_LIB_ARCH) $(RM) $(OS2_LIB_ARC
>
> Rule as this are important (also if not jet approved)
> How give importance to this info?
> How we can know this rule to future harbour developer without reading
> all messages post in mailing list
> can restructure doc with information for harbour prg level user from
> harbour c level develop
Hi Jaroslaw,
> 1. Run make_b32.bat in HARBOUR folder
> 2. Run make_b32_all.bat in \HARBOUR\CONTRIB folder
> 3. Move all files from w32 folders to up-one-level folders
> (HARBOUR\LIB, HARBOUR\BIN)
> 4. Copy *.ch and *.h files from HARBOUR\CONTRIB\*.* to HARBOUR\INCLUDE
You can replace 3. and
Rule as this are important (also if not jet approved)
How give importance to this info?
How we can know this rule to future harbour developer without reading
all messages post in mailing list
can restructure doc with information for harbour prg level user from
harbour c level developer?
Can adopt
Hello,
Where is the mistake ?
1. Run make_b32.bat in HARBOUR folder
2. Run make_b32_all.bat in \HARBOUR\CONTRIB folder
3. Move all files from w32 folders to up-one-level folders
(HARBOUR\LIB, HARBOUR\BIN)
4. Copy *.ch and *.h files from HARBOUR\CONTRIB\*.* to HARBOUR\INCLUDE
5. For example i
>
> Now the another guideline:
>
> Many functions of WINAPI accept structures as their
> parameters. Should we use them to be compatible with
> WINAPI exactly or should we use arrays?
> Both approaches have merits and demerits.
> I personally propose to use STRUCTURES where ever
> possible. What gr
Wich disadvantaage using structure ?
http://api.farmanager.com/en/winapi/index.html
2009/2/4 Pritpal Bedi :
> Many functions of WINAPI accept structures as their
> parameters. Should we use them to be compatible with
> WINAPI exactly or should we use arrays?
> Both approaches have merits and dem
68 matches
Mail list logo