The next_buf is the offset to the next cached block rounded to the size of
bufio->block_size. However the calculation needs the block_size to be in power
of 2 is not always valid. As an example, files with smaller size than
block_size will have the block_size leveled to the size of file which can b
On Wed, Apr 11, 2018 at 07:45:01AM -0700, Nick Vinson wrote:
> On 04/11/2018 01:31 AM, Daniel Kiper wrote:
> > On Tue, Apr 10, 2018 at 08:00:04PM -0700, Nick Vinson wrote:
> >> On 04/10/2018 01:52 PM, Daniel Kiper wrote:
> >>> On Sat, Apr 07, 2018 at 04:28:13PM -0700, Nicholas Vinson wrote:
>
Well, to be honest, I don't think I'll have the time to dive into
grub-probe to see where the breakage comes from etc. so as far as I'm
concerned, I'll just archive the discussion.
If people really want to see the Hurd work for them, they'll have to do
a bit of the work. People can't just rely on
On 04/16/2018 04:47 AM, Daniel Kiper wrote:
> On Wed, Apr 11, 2018 at 07:45:01AM -0700, Nick Vinson wrote:
>> On 04/11/2018 01:31 AM, Daniel Kiper wrote:
>>> On Tue, Apr 10, 2018 at 08:00:04PM -0700, Nick Vinson wrote:
On 04/10/2018 01:52 PM, Daniel Kiper wrote:
> On Sat, Apr 07, 2018 at 0
Summary of Changes:
- Defined print_gpt_puid()
- Updated grub-probe.c to use print_gpt_guid()
- Renamed struct grub_gpt_part_type to struct grub_gpt_part_guid.
- Updated struct typedef to use grub_gpt_part_guid
- Replaced grub_gpt_part_type_t type with grub_gpt_part_guid_t i
Update grub-mkconfig.in and 10_linux.in to support grub-probe's new
partuuid target. Update grub.texi documentation. The following table
shows how GRUB_DISABLE_LINUX_UUID, GRUB_DISABLE_LINUX_PARTUUID, and
initramfs detection interact:
Initramfs GRUB_DISABLE_LINUX_PARTUUID GRUB_DISABLE_LINUX_UU
Define print_gpt_guid(), so there is a central function for printing
GUID strings. This change is a precursor for later patches which rely
on this logic.
Signed-off-by: Nicholas Vinson
Reviewed-by: Daniel Kiper
---
util/grub-probe.c | 30 +++---
1 file changed, 15 inse
Add PARTUUID detection support grub-probe for MBR and GPT partition
schemes.
Signed-off-by: Nicholas Vinson
Reviewed-by: Daniel Kiper
---
util/grub-probe.c | 46 ++
1 file changed, 46 insertions(+)
diff --git a/util/grub-probe.c b/util/grub-probe.c
Rename grub_gpt_part_type to grub_gpt_part_guid and update
grub_gpt_partentry to use this type for both the partition type GUID
string and the partition GUID string entries. This change ensures that
the two GUID fields are handled more consistently and helps to simplify
the changes needed to add L