Sorry for the delay in responding. I just now saw these replies.
On 02/20/2018 09:30 AM, Daniel Kiper wrote:
> On Sun, Feb 04, 2018 at 11:47:35AM -0800, Nicholas Vinson wrote:
>> To help clean the code and simplify the code in util/grub-probe.c, this
>> patch renames grub_gpt_part_type to grub_gp
On 02/20/2018 09:41 AM, Daniel Kiper wrote:
> On Sun, Feb 04, 2018 at 11:47:36AM -0800, Nicholas Vinson wrote:
>> Add PARTUUID detection support grub-probe for MBR and GPT partition
>> schemes. The Linux kernel supports mounting the root filesystem by
>> Linux device name or by the Partition [GU]U
On 02/20/2018 09:45 AM, Daniel Kiper wrote:
> On Sun, Feb 04, 2018 at 11:47:37AM -0800, Nicholas Vinson wrote:
>> Update grub-mkconfig.in and 10_linux.in to support grub-probe's new
>> partuuid target. Update grub.texi documenation.
>
> As earlier lack of SOB. Otherwise LGTM.
Will be added in V6
Define print_gpt_guid(), so there is a central function for printing
GUID strings. This change is a precursor for later patches which rely
on this logic.
Signed-off-by: Nicholas Vinson
---
util/grub-probe.c | 30 +++---
1 file changed, 15 insertions(+), 15 deletions(-)
Changes from Patch v5:
- Added sign-off by lines
- Fixed formatting errors found by Daniel Kiper
Changes from Patch v4:
- Updated grub.texi to reflect new behavior for
GRUB_ENABLE_LINUX_PARTUUID
- Updated 10_linux.in logic to favor the PARTUUID when
GRUB_ENABLE_LINUX_P
Update grub-mkconfig.in and 10_linux.in to support grub-probe's new
partuuid target. Update grub.texi documenation.
Signed-off-by: Nicholas Vinson
---
docs/grub.texi | 9 +
util/grub-mkconfig.in | 3 +++
util/grub.d/10_linux.in | 12 +---
3 files changed, 21 inserti
Rename grub_gpt_part_type to grub_gpt_part_guid and update
grub_gpt_partentry to use this type for both the partition type GUID
string and the partition GUID string entries. This change ensures that
the two GUID fields are handled more consistently and helps to simplify
the changes needed to add L
Add PARTUUID detection support grub-probe for MBR and GPT partition
schemes.
Signed-off-by: Nicholas Vinson
---
util/grub-probe.c | 51 +++
1 file changed, 51 insertions(+)
diff --git a/util/grub-probe.c b/util/grub-probe.c
index 21cb80fbe..0ae73c
On 17/03/18 11:09, TJ wrote:
> On 14/03/18 09:44, John Lane wrote:
>> --- a/grub-core/disk/cryptodisk.c
>> +++ b/grub-core/disk/cryptodisk.c
>> @@ -880,7 +882,7 @@ grub_cryptodisk_cheat_mount (const char *sourcedev,
>> const char *cheat)
>>
>>FOR_CRYPTODISK_DEVS (cr)
>>{
>> -dev = cr
On 17/03/18 11:10, TJ wrote:
> On 14/03/18 09:44, John Lane wrote:
>> --- a/grub-core/disk/cryptodisk.c
>> +++ b/grub-core/disk/cryptodisk.c
>> @@ -949,6 +954,45 @@ grub_cmd_cryptomount (grub_extcmd_context_t ctxt, int
>> argc, char **args)
>> hdr = NULL;
>>
>>have_it = 0;
>> + key = N
On 17/03/18 11:10, TJ wrote:
> On 14/03/18 09:45, John Lane wrote:
>> --- a/grub-core/disk/luks.c
>> +++ b/grub-core/disk/luks.c
>> @@ -321,10 +321,10 @@ configure_ciphers (grub_disk_t disk, const char
>> *check_uuid,
>>
>> static grub_err_t
>> luks_recover_key (grub_disk_t source,
>> -
+1 for F2FS integration, which I also requested a few months back and
which I know has also been requested by other people before that.
While I understand that the GRUB project's priorities might be
elsewhere, I'm just going to point out that I am growing a bit tired of
having had to keep and
12 matches
Mail list logo