On Sun, Jun 16, 2019 at 6:17 PM Derrick Stolee wrote:
>
> Thanks for catching this. I wonder if there is a compiler setting or
> static analysis that caught this so we can avoid the issue in the future.
-Wsign-compare would definitely raise a warning about this, but we have
currently 956 of those
On 06/16, Rohit Ashiwal wrote:
> git am or rebase have a --skip flag to skip the current commit if the
> user wishes to do so. During a cherry-pick or revert a user could
> likewise skip a commit, but needs to use 'git reset' (or in the case
> of conflicts 'git reset --merge'), followed by 'git (ch
On 06/16, Rohit Ashiwal wrote:
> Yet another iteration of my patch. We have changed the series a little bit. We
> now have a commit that rename `reset_for_rollback` to `reset_merge`. A lot of
> nit-picks were handled in this revision.
Thanks for your work! I allowed myself to nitpick a bit more a
On 17/06/2019 03:02, Elijah Newren wrote:
> On Sun, Jun 16, 2019 at 6:29 AM Phillip Wood
> wrote:
>>
>> From: Phillip Wood
>>
>> The synopsis for am shows the command mode options as
>> (--continue | --skip | --abort | --quit)
>> They are on a single line and in parenthesis as they are not
>
On 16/06/2019 23:33, Junio C Hamano wrote:
> Phillip Wood writes:
>
>> From: Phillip Wood
>>
>> The synopsis for am shows the command mode options as
>> (--continue | --skip | --abort | --quit)
>> They are on a single line and in parenthesis as they are not
>> optional. Fix the merge and reb
From: Phillip Wood
The synopsis for am shows the command mode options as
(--continue | --skip | --abort | --quit)
They are on a single line and in parenthesis as they are not
optional. Fix the merge and rebase docs to match this style.
Signed-off-by: Phillip Wood
---
Notes:
This patch
When writing commit-graph files, we append path data to an
object directory, which may be specified by the user via the
'--object-dir' option. If the user supplies a trailing slash,
or some other alternative path format, the resulting path may
be usable for writing to the correct location. However,
On 6/16/19 4:44 PM, mich...@platin.gs wrote:
From: Michael Platings
Use an intermediate file between between git blame and sed to avoid
git blame's exit code being hidden.
Thanks, Michael. I'll squash this for the next version.
Barret
Signed-off-by: Michael Platings
---
t/t8014-blame
On 6/17/2019 11:02 AM, Derrick Stolee wrote:
> - strbuf_setlen(&path, dirnamelen);
> - strbuf_addstr(&path, de->d_name);
> + char *filename = get_split_graph_filename(path.buf, de->d_name);
Please ignore this patch for now, as this line is incredibly stupid and
The userdiff.c has been rewritten to avoid hard-coded built-in
driver patterns. Now we ship
$(sharedir)/git-core/templates/userdiff that can be read using
git_config_from_file() interface, using a very narrow callback
function that understands only diff.*.xfuncname,
diff.*.wordregex, and diff.*.reg
Christian Couder writes:
> On Mon, Jun 17, 2019 at 6:33 AM Masahiro Yamada
> wrote:
>>
>> On Sat, Jun 15, 2019 at 5:41 PM Christian Couder
>> wrote:
>> >
>> > > I do wonder if the trailer code is correct to always respect it, though.
>> > > For example, in "git log" output we'd expect to see co
Hi Junio,
On Fri, 14 Jun 2019, Junio C Hamano wrote:
> * js/gcc-8-and-9 (2019-06-13) 4 commits
> - config: avoid calling `labs()` on too-large data type
> - winansi: simplify loading the GetCurrentConsoleFontEx() function
> - kwset: allow building with GCC 8
> - poll (mingw): allow compiling
Hi Junio & Phillip,
On Fri, 14 Jun 2019, Junio C Hamano wrote:
> * pw/rebase-abort-clean-rewritten (2019-05-15) 4 commits
> - rebase --abort/--quit: cleanup refs/rewritten
> - sequencer: return errors from sequencer_remove_state()
> - rebase: warn if state directory cannot be removed
> - reba
When writing commit-graph files, we append path data to an
object directory, which may be specified by the user via the
'--object-dir' option. If the user supplies a trailing slash,
or some other alternative path format, the resulting path may
be usable for writing to the correct location. However,
Hi Junio,
On Fri, 14 Jun 2019, Junio C Hamano wrote:
> * sg/rebase-progress (2019-06-11) 4 commits
> - progress: use term_clear_line()
> - rebase: fix garbled progress display with '-x'
> - pager: add a helper function to clear the last line in the terminal
> - t3404-rebase-interactive: use t
On Fri, Jun 14, 2019 at 09:12:50AM -0700, Junio C Hamano wrote:
> SZEDER Gábor writes:
>
> >> Now, the proper thing to do would be to switch to `size_t`. But this
> >> would make us deviate from the "upstream" code even further,
> >
> > This is not entirely true: upstream already uses 'size_t', s
On Fri, Jun 14, 2019 at 09:30:20PM +0100, Ramsay Jones wrote:
>
>
> On 14/06/2019 11:00, SZEDER Gábor wrote:
> > Update 'compat/obstack.{c,h}' from upstream, because they already use
> > 'size_t' instead of 'long' in places that might eventually end up as
> > an argument to malloc(), which might
On Fri, Jun 14, 2019 at 08:42:29PM +0200, Johannes Schindelin wrote:
> > > > However, if the terminal were smart, then we would have to deal with
> > > > ANSI escape suddenly popping up...
> > >
> > > And I fear that is *exactly* what makes
> > > https://dev.azure.com/gitgitgadget/git/_build/resul
Hi Dscho & Junio
On 17/06/2019 19:06, Johannes Schindelin wrote:
Hi Junio & Phillip,
On Fri, 14 Jun 2019, Junio C Hamano wrote:
* pw/rebase-abort-clean-rewritten (2019-05-15) 4 commits
- rebase --abort/--quit: cleanup refs/rewritten
- sequencer: return errors from sequencer_remove_state()
Hi brian,
On Sun, 16 Jun 2019, brian m. carlson wrote:
> diff --git a/t/test-lib-functions.sh b/t/test-lib-functions.sh
> index 8270de74be..11a6abca2e 100644
> --- a/t/test-lib-functions.sh
> +++ b/t/test-lib-functions.sh
> @@ -1314,6 +1314,12 @@ test_oid () {
> eval "printf '%s' \"\${$var}
On Fri, Jun 14, 2019 at 08:42:29PM +0200, Johannes Schindelin wrote:
> The `SHELL` thing here is important, as t/t3404-rebase-interactive.sh sets
> this to the empty value explicitly:
>
> https://github.com/git/git/blob/v2.22.0/t/t3404-rebase-interactive.sh#L63-L68
Hmm, hang on for a sec. Why d
[resend to Matthieu's current email address]
On Mon, Jun 17, 2019 at 09:13:28PM +0200, SZEDER Gábor wrote:
> On Fri, Jun 14, 2019 at 08:42:29PM +0200, Johannes Schindelin wrote:
>
> > The `SHELL` thing here is important, as t/t3404-rebase-interactive.sh sets
> > this to the empty value explicitly
Johannes Schindelin writes:
> Hi Junio,
>
> On Fri, 14 Jun 2019, Junio C Hamano wrote:
>
>> * js/gcc-8-and-9 (2019-06-13) 4 commits
>> - config: avoid calling `labs()` on too-large data type
>> - winansi: simplify loading the GetCurrentConsoleFontEx() function
>> - kwset: allow building with G
On Mon, Jun 17, 2019 at 7:31 PM Junio C Hamano wrote:
>
> Christian Couder writes:
>
> > On Mon, Jun 17, 2019 at 6:33 AM Masahiro Yamada
> > wrote:
> >>
> >> On Sat, Jun 15, 2019 at 5:41 PM Christian Couder
> >> wrote:
> >> >
> >> > > I do wonder if the trailer code is correct to always respect
On Fri, Jun 07, 2019 at 03:15:53PM -0400, Jeff Hostetler wrote:
>
>
> On 6/6/2019 9:08 PM, Emily Shaffer wrote:
> > Demonstrate how filter specs can be used when performing a revision walk
> > of all object types. In this case, tree depth is used. Contributors who
> > are following the revision w
On 15/06/2019 09:19, Ævar Arnfjörð Bjarmason wrote:
On Sat, Jun 15 2019, Phil Hord wrote:
I know name-scrubbing is already covered in filter-branch and other
places. But we have a scenario becoming more common that makes it a
more sensitive topic.
At $work we have a long time employee who has
Emily Shaffer writes:
> Allow easier parsing by cat-file by giving rev-list an option to print
> only the OID of a non-commit object without any additional information.
> This is a short-term shim; later on, rev-list should be taught how to
> print the types of objects it finds in a format simila
On Mon, Jun 17 2019, Philip Oakley wrote:
> On 15/06/2019 09:19, Ævar Arnfjörð Bjarmason wrote:
>> On Sat, Jun 15 2019, Phil Hord wrote:
>>
>>> I know name-scrubbing is already covered in filter-branch and other
>>> places. But we have a scenario becoming more common that makes it a
>>> more sen
Phillip Wood writes:
> I'm not sure I'd argue too hard one way or the other, but I do think the
> documentation for the various commands should try to be consistent and
> the am, cherry-pick, rebase and revert man pages all use a single line
> for these options (although rebase is missing the par
On Fri, Jun 07, 2019 at 02:21:07AM -0400, Eric Sunshine wrote:
> On Thu, Jun 6, 2019 at 9:08 PM Emily Shaffer wrote:
> > [...]
> > The tutorial covers a basic overview of the structs involved during
> > revision walk, setting up a basic commit walk, setting up a basic
> > all-object walk, and addi
On Mon, Jun 10, 2019 at 01:49:41PM -0700, Junio C Hamano wrote:
> Emily Shaffer writes:
>
> > +My First Revision Walk
> > +==
> > +
> > +== What's a Revision Walk?
> > +
> > +The revision walk is a key concept in Git - this is the process that
> > underpins
> > +operations li
On Mon, Jun 10, 2019 at 01:25:14PM -0700, Junio C Hamano wrote:
> Emily Shaffer writes:
>
> > I'll also be mailing an RFC patchset In-Reply-To this message; the RFC
> > patchset should not be merged to Git, as I intend to host it in my own
> > mirror as an example. I hosted a similar example for
Matthew DeVore writes:
> I had to rebase this onto the latest master rev. master now has the patch
> which
> disables the sparse:path filter, and v3 of this patch set has conflicts with
> it.
> This version does not so it can be patched in and tried out by others.
>
> I have re-run the test sui
On 2019-06-17 at 19:05:03, Johannes Schindelin wrote:
> I guess it does not *really* matter all that much, but this does spawn a
> new process (and I think it actually spawns 4 on Windows, for reasons, and
> spawning processes is super expensive on Windows).
>
> We might actually want to think abo
On Tue, Jun 18, 2019 at 5:08 AM Christian Couder
wrote:
>
> On Mon, Jun 17, 2019 at 7:31 PM Junio C Hamano wrote:
> >
> > Christian Couder writes:
> >
> > > On Mon, Jun 17, 2019 at 6:33 AM Masahiro Yamada
> > > wrote:
> > >>
> > >> On Sat, Jun 15, 2019 at 5:41 PM Christian Couder
> > >> wrote:
Hello dear,
We are in the market for your products after meeting at your stand during last
expo.
Please kindly send us your latest catalog and price list so as to start a new
project/order as promised during the exhibition.
I would appreciate your response about the above details required
Phillip Wood writes:
> Yes I sent it just before I went offline, but that's a while ago now
Yup. IIRC, you told us not to look at the patch "for now" as you
would be offline, and I was fully expecting that a regular review
exchange would happen after you come back.
I do not recall seeing much
Hi!
Sparse checkout is a great start but I wish that clone, fetch, commit,
and merge also had sparse functionality to skip operating on objects
associated with directories not listed in the sparse-checkout (or
similar) configuration file. To clarify, this is different from
shallow clone or fetch w
after b46054b374 ("xdiff: use git-compat-util", 2019-04-11), two system
headers added in 2012 to xutils where no longer needed and could conflict
as shown below:
In file included from xdiff/xinclude.h:26:0,
from xdiff/xutils.c:25:
./git-compat-util.h:4:0: warning: "_FILE_OFFSET_BI
Am 18.06.19 um 03:29 schrieb brian m. carlson:
> On 2019-06-17 at 19:05:03, Johannes Schindelin wrote:
>> I guess it does not *really* matter all that much, but this does spawn a
>> new process (and I think it actually spawns 4 on Windows, for reasons, and
>> spawning processes is super expensive o
40 matches
Mail list logo