I request your connsent for an urgent bussiness deal for you.
Kindly get back to me for details.
Chana
Example:
tom1 ~/emacs/spacemacs/.emacs.d $ export LANG=en_US.utf8
tom1 ~/emacs/spacemacs/.emacs.d $ git ls-remote -h
usage: git ls-remote [--heads] [--tags] [--refs] [--upload-pack=]
[-q | --quiet] [--exit-code] [--get-url]
[--symref] [ [...]]
-q, -
On 15 October 2017 at 12:02, Thomas Rikl wrote:
> Example:
>
> tom1 ~/emacs/spacemacs/.emacs.d $ export LANG=en_US.utf8
>
> tom1 ~/emacs/spacemacs/.emacs.d $ git ls-remote -h
> usage: git ls-remote [--heads] [--tags] [--refs] [--upload-pack=]
> [-q | --quiet] [--exit-code] [--
Am 15.10.2017 um 13:08 schrieb Martin Ågren:
> On 15 October 2017 at 12:02, Thomas Rikl wrote:
>> Example:
>>
>> tom1 ~/emacs/spacemacs/.emacs.d $ export LANG=en_US.utf8
>>
>> tom1 ~/emacs/spacemacs/.emacs.d $ git ls-remote -h
>> usage: git ls-remote [--heads] [--tags] [--refs] [--upload-pack=]
>>
The pager 'less' escapes some characters when calling 'git diff'. This
is what I might get:
$ git diff --cached
diff --git a/some_file b/some_file
new file mode 100644
index 000..357323f
--- /dev/null
+++ b/some_file
@@ -0,0 +1 @@
+Hello
\ No newline at end of file
This example is a simple fi
Am 13.10.2017 um 12:51 schrieb Ævar Arnfjörð Bjarmason:
On Thu, Oct 05 2017, Johannes Sixt jotted:
Am 05.10.2017 um 21:33 schrieb Stefan Beller:
* Is it a good design choice to have a different command, just because the
target branch is [not] checked out?
I would not want to make it a sub
Hi Steve,
On Fri, 13 Oct 2017, Steve Hoelzer wrote:
> On Thu, Oct 12, 2017 at 5:53 PM, Johannes Schindelin
> wrote:
> >
> > It is my pleasure to announce that Git for Windows 2.14.2(3) is available
> > from:
> >
> > https://git-for-windows.github.io/
> >
> > Changes since Git for Window
> -Original Message-
> From: Joris Valette
> Sent: Sunday, October 15, 2017 9:34 AM
> To: git@vger.kernel.org
> Subject: Consider escaping special characters like 'less' does
>
> The pager 'less' escapes some characters when calling 'git diff'. This
> is what I might get:
>
> $ git diff -
Hi Ralf,
On Fri, 13 Oct 2017, Ralf Thielow wrote:
> When ftruncate() in rearrange_squash() fails, we write
> that we couldn't finish the operation on the todo file.
> It is more accurate to write that we couldn't truncate
> as we do in other calls of ftruncate().
>
> While at there, remove a ful
On Okt 15 2017, "Jason Pyeron" wrote:
>> -Original Message-
>> From: Joris Valette
>> Sent: Sunday, October 15, 2017 9:34 AM
>> To: git@vger.kernel.org
>> Subject: Consider escaping special characters like 'less' does
>>
>> The pager 'less' escapes some characters when calling 'git diff'
Hi Junio,
On Fri, 13 Oct 2017, Junio C Hamano wrote:
> Johannes Schindelin writes:
>
> >> (The funny "squash!" followed by a complete version of the
> >> rewritten commit message is what I do until I -- or anybody else
> >> -- comes up with a patch to implement support for "reword!".)
>
> I ha
Hi,
On Sat, 14 Oct 2017, Junio C Hamano wrote:
> Kevin Daudt writes:
>
> > On Thu, Oct 05, 2017 at 02:19:15PM +0200, Johannes Schindelin wrote:
> >> From: J Wyman
> >> [..]
> >>
> >> diff --git a/Documentation/git-for-each-ref.txt
> >> b/Documentation/git-for-each-ref.txt
> >> index 39f50bd
2017-10-15 17:46 GMT+02:00 Andreas Schwab :
> On Okt 15 2017, "Jason Pyeron" wrote:
>
>>> -Original Message-
>>> From: Joris Valette
>>> Sent: Sunday, October 15, 2017 9:34 AM
>>> To: git@vger.kernel.org
>>> Subject: Consider escaping special characters like 'less' does
>>>
>>> The pager '
When the write opertion fails, we write that we could
not read. Change the error message to match the operation
and remove the full stop at the end.
When ftruncate() fails, we write that we couldn't finish
the operation on the todo file. It is more accurate to write
that we couldn't truncate as we
2017-10-13 23:12 GMT+02:00 René Scharfe :
> Am 13.10.2017 um 19:51 schrieb Ralf Thielow:
>> When ftruncate() in rearrange_squash() fails, we write
>> that we couldn't finish the operation on the todo file.
>> It is more accurate to write that we couldn't truncate
>> as we do in other calls of ftrun
On Sun, Oct 15, 2017 at 06:39:45PM +0200, Joris Valette wrote:
> > It's your MUA's fault that you get a ?, the mail didn't contain any.
>
> Actually, the original mail contained the special BOM sequence but
> it's generally invisible. His MUA shows it with a '?', mine doesn't
> show anything, nei
2017-10-15 22:06 GMT+02:00 Jeff King :
> Git's diff generation will never do such escaping by default, because it
> means creating a patch that cannot be applied to get back the original
> content.
Indeed this would be a problem. That's where my knowledge of git's
source code ends, but in that cas
Signed-off-by: brian m. carlson
---
refs.c| 10 +-
refs/packed-backend.c | 6 +++---
refs/ref-cache.c | 2 +-
refs/refs-internal.h | 4 ++--
4 files changed, 11 insertions(+), 11 deletions(-)
diff --git a/refs.c b/refs.c
index 72c45a513b..6546346b6a 100644
--- a/
Convert these two functions and the functions that underlie them to take
pointers to struct object_id. This is a prerequisite to convert
resolve_gitlink_ref. Fix a stray tab in the middle of the index_mem
call in index_pipe by converting it to a space.
Signed-off-by: brian m. carlson
---
sha1_
Update the ref transaction code to use struct object_id. Remove one
NULL pointer check which was previously inserted around a dereference;
since we now pass a pointer to struct object_id directly through, the
code we're calling handles this for us.
Signed-off-by: brian m. carlson
---
branch.c
Convert check_connected and the callbacks it takes to use struct
object_id.
Signed-off-by: brian m. carlson
---
builtin/clone.c| 4 ++--
builtin/fetch.c| 4 ++--
builtin/receive-pack.c | 10 +-
connected.c| 18 +-
connected.h| 4
Convert peel_ref (and its corresponding backend) to struct object_id.
This transformation was done with an update to the declaration,
definition, comments, and test helper and the following semantic patch:
@@
expression E1, E2;
@@
- peel_ref(E1, E2.hash)
+ peel_ref(E1, &E2)
@@
expression E1, E2;
All of the callers of these functions just pass the hash member of a
struct object_id, so convert them to use a pointer to struct object_id
directly. Insert a check for NULL in expand_ref on a temporary basis;
this check can be removed when resolve_ref_unsafe is converted as well.
Signed-off-by:
Convert the remaining uses of unsigned char [20] to struct object_id.
This conversion is needed for dwim_log.
Signed-off-by: brian m. carlson
---
builtin/reflog.c | 18 +-
1 file changed, 9 insertions(+), 9 deletions(-)
diff --git a/builtin/reflog.c b/builtin/reflog.c
index 2067
Several of the refs functions take NULL to indicate that the ref is not
to be updated. If refs_update_ref were called with a NULL new object
ID, we could pass that NULL pointer to write_pseudoref, which would then
segfault when it dereferenced it. Instead, simply return successfully,
since if we
Convert the unsigned char * parameter to struct object_id * for
files_read_raw_ref and packed_read_raw_ref. Update the documentation.
Switch from using get_sha1_hex and a hard-coded 40 to using
parse_oid_hex.
Signed-off-by: brian m. carlson
---
refs.c| 8
refs/files-ba
This is the tenth in a series of patches to convert from unsigned char
[20] to struct object_id. This series mostly involves changes to the
refs code. After these changes, there are almost no references to
unsigned char in the main refs code.
In this iteration, I chose to skip the ALLOC_ARRAY co
Change the member of this struct to be a struct object_id.
Signed-off-by: brian m. carlson
---
refs/files-backend.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/refs/files-backend.c b/refs/files-backend.c
index 014dabb0bf..9db9237f1e 100644
--- a/refs/files-backend.c
This is one of the last unconverted callers to peel_ref. While we're
fixing that, convert the rest of the file, since it will need to be
converted at some point anyway.
Signed-off-by: brian m. carlson
---
builtin/pack-objects.c | 135 +
1 file cha
All of the callers already pass the hash member of struct object_id, so
update them to pass a pointer to the struct directly,
This transformation was done with an update to declaration and
definition and the following semantic patch:
@@
expression E1, E2, E3, E4;
@@
- resolve_refdup(E1, E2, E3.ha
Convert the head_sha1 member to be head_oid instead. This is required
to convert resolve_ref_unsafe.
Signed-off-by: brian m. carlson
---
builtin/worktree.c | 6 +++---
worktree.c | 2 +-
worktree.h | 2 +-
3 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/builtin/wo
Convert the declaration and definition of resolve_gitlink_ref to use
struct object_id and apply the following semantic patch:
@@
expression E1, E2, E3;
@@
- resolve_gitlink_ref(E1, E2, E3.hash)
+ resolve_gitlink_ref(E1, E2, &E3)
@@
expression E1, E2, E3;
@@
- resolve_gitlink_ref(E1, E2, E3->hash)
Convert the callers and internals, including struct read_ref_at_cb, of
read_ref_at to use struct object_id.
Signed-off-by: brian m. carlson
---
builtin/show-branch.c | 4 ++--
refs.c| 34 +-
refs.h| 2 +-
sha1_name.c |
Convert resolve_ref_unsafe to take a pointer to struct object_id by
converting one remaining caller to use struct object_id, removing the
temporary NULL pointer check in expand_ref, converting the declaration
and definition, and applying the following semantic patch:
@@
expression E1, E2, E3, E4;
reflog_expire already used struct object_id internally, but it did not
take it as a parameter. Adjust the parameter (and the callers) to pass
a pointer to struct object_id instead of a pointer to unsigned char.
Remove the temporary inserted earlier as it is no longer required.
Signed-off-by: bria
Convert several static functions to take pointers to struct object_id.
Change the relevant parameters to write_packed_entry to be const, as we
don't modify them. Rename lock_ref_sha1_basic to lock_ref_oid_basic to
reflect its new argument. Update the docstring for verify lock to
account for the n
Signed-off-by: brian m. carlson
---
builtin/reflog.c | 4 ++--
reflog-walk.c| 2 +-
refs.c | 8
refs.h | 2 +-
sha1_name.c | 2 +-
5 files changed, 9 insertions(+), 9 deletions(-)
diff --git a/builtin/reflog.c b/builtin/reflog.c
index 302fafbeef..cd4c4847b7
Signed-off-by: brian m. carlson
---
walker.c | 24
1 file changed, 12 insertions(+), 12 deletions(-)
diff --git a/walker.c b/walker.c
index 274f1a4935..2d83254bc0 100644
--- a/walker.c
+++ b/walker.c
@@ -7,7 +7,7 @@
#include "blob.h"
#include "refs.h"
-static unsigne
Convert delete_ref and refs_delete_ref to take a pointer to struct
object_id. Update the documentation accordingly, including referring to
null_oid in lowercase, as it is not a #define constant.
Signed-off-by: brian m. carlson
---
builtin/branch.c | 2 +-
builtin/replace.c |
All but two of the call sites already have parameters using the hash
parameter of struct object_id, so convert them to take a pointer to the
struct directly. Also convert refs_read_refs_full, the underlying
implementation.
Signed-off-by: brian m. carlson
---
builtin/checkout.c | 6 +++---
Convert traverse_bitmap_commit_list and the callbacks it takes to use a
pointer to struct object_id.
Signed-off-by: brian m. carlson
---
builtin/pack-objects.c | 8
builtin/rev-list.c | 4 ++--
pack-bitmap.c | 8
pack-bitmap.h | 2 +-
4 files changed, 11 i
Signed-off-by: brian m. carlson
---
diff-lib.c | 4 ++--
dir.c | 8
read-cache.c | 6 +++---
unpack-trees.c | 8
4 files changed, 13 insertions(+), 13 deletions(-)
diff --git a/diff-lib.c b/diff-lib.c
index 4e0980caa8..af4f1b7865 100644
--- a/diff-lib.c
+++ b/dif
Convert update_ref, refs_update_ref, and write_pseudoref to use struct
object_id. Update the existing callers as well. Remove update_ref_oid,
as it is no longer needed.
Signed-off-by: brian m. carlson
---
bisect.c | 5 +++--
builtin/am.c | 14 +++---
buil
Johannes Schindelin writes:
>> >> -Also respects `:remotename` to state the name of the *remote* instead of
>> >> -the ref.
>> >> +Also respects `:remotename` to state the name of the *remote* instead
>> >> +of the ref, and `:remoteref` to state the name of the *reference* as
>> >> +locally known
Ralf Thielow writes:
> When the write opertion fails, we write that we could
> not read. Change the error message to match the operation
> and remove the full stop at the end.
>
> When ftruncate() fails, we write that we couldn't finish
> the operation on the todo file. It is more accurate to wri
"brian m. carlson" writes:
> This is the tenth in a series of patches to convert from unsigned char
> [20] to struct object_id. This series mostly involves changes to the
> refs code. After these changes, there are almost no references to
> unsigned char in the main refs code.
>
> In this itera
My script to build Git dies during cleanup. Cleanup removes the
downloaded tarball and the unpacked directory:
** Cleanup **
rm: cannot remove 'git-2.14.2/perl/blib/lib/.exists': Permission denied
rm: cannot remove 'git-2.14.2/perl/blib/lib/Git/SVN/Fetcher.pm':
Permission denied
r
Christian Couder writes:
> It is error prone and tiring to use many long environment
> variables to give parameters to the 'run' script.
This topic has been sitting in the list archive without getting much
reaction from list participants. Is anybody happy with these
patches?
The -Xours/-Xtheirs merge options were originally defined as a way
to "force" the resolution of 3way textual merge conflicts to take
one side without using your editor, hence did not even trigger in
situations where you would normally not get the <<< === >>> conflict
markers.
This was improved for
Am 16.10.2017 um 07:05 schrieb Jeffrey Walton:
My script to build Git dies during cleanup. Cleanup removes the
downloaded tarball and the unpacked directory:
** Cleanup **
rm: cannot remove 'git-2.14.2/perl/blib/lib/.exists': Permission denied
rm: cannot remove 'git-2.14.2/perl/
Jeff King writes:
> On Mon, Jul 17, 2017 at 10:27:09AM -0700, Jonathan Nieder wrote:
>> ...
>> I don't think it's right. Today I can do
>>
>> $ cd /tmp
>> $ git check-ref-format --branch master
>> master
>>
>> You might wonder why I'd ever do such a thing. But that's what "git
Here are the topics that have been cooking. Commits prefixed with
'-' are only in 'pu' (proposed updates) while commits prefixed with
'+' are in 'next'. The ones marked with '.' do not appear in any of
the integration branches, but I am still holding onto them.
2.15-rc1 has been tagged, but 2.15
52 matches
Mail list logo