On 18 April 2016 at 16:26, Johannes Schindelin
wrote:
>
> > The command only works as expected when also adding the --no-ff flag.
>
> Then you need to fix your expectations ;-)
I *think* the core of this problem is that the intent of the end-user
does not align with the command options available.
Hi Junio,
On Fri, 15 Apr 2016, Junio C Hamano wrote:
> Michael Weiser writes:
>
> > Make git fully relocatable at runtime extending the runtime prefix
> > calculation. Handle absolute and relative paths in argv0. Handle no path
> > at all in argv0 in a system-specific manner. Replace assertion
My expectations from what should happen came mainly from the
description of the --no-commit flag in the help:
With --no-commit perform the merge but pretend the merge failed
and do not autocommit, to give the user a chance to inspect and
further tweak the merge result before committing.
So
On 18 April 2016 at 17:23, Christoph Paulik wrote:
> My expectations from what should happen came mainly from the description of
> the --no-commit flag in the help:
>
> With --no-commit perform the merge but pretend the merge failed and do not
> autocommit, to give the user a chance to inspect and
Hi,
I have question regarding Git for Windows Portable in version 2.8.1 32bit that
can be downloaded from https://git-scm.com/download/win . What is the minimum
version of .NET and OS that is necessary to successfully run it?
Thank you
for your answer.
Best Regards
Lukáš Rumpala--
To unsubsc
I am Capt. Lawrence Tyman, an officer in US Army,and also a West Point
Graduate, serving in the Military with the 82nd Air Borne Division
Peace keeping force deployed from Afganistan to Syria.
We were moved to Syria from Iraq as the last batch just left,and i
really need your help in assisting me
Greetings git
http://yozgatnakliyat.net/standard.php?theres=y1p39sb1ca7safkew
madhan...@yahoo.com
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Hello,
I've discovered bug in git. I'm used to add files by copying absolute
path from my IDE. Now on Windows 10 I discovered bug. Git says: "is
outside repository" when I use "git add C:\repo\file.txt". For "git
add c:\repo\file.txt" (drive letter is lower-case) it works like it
worked before on
From: "Johannes Schindelin"
Hi Wu,
On Sun, 17 Apr 2016, bin wu wrote:
There is still a question.Why not just post the the MD5 and SHA1 on
the download page?
We do: https://github.com/git-for-windows/git/releases
Thanks, I couldn't see it for looking (I was sure there was one somewhere).
t7008.12 is marked as an expected failure, but building Git on Cygwin
including a `make configure && ./configure` step has the test
unexpectedly passing. Building without the configure step has the test
failing as expected.
This appears to be behaviour specific to Cygwin; at least I get that
test
Andrew Ardill writes:
> Yes, I think the mis-alignment in expectations comes from a
> technicality in the description you quote. The fast forward is in some
> ways not really counted as a true merge, and no new commits are
> created.
Looking at 123ee3ca (Add --no-commit to git-merge/git-pull.,
2
Junio C Hamano writes:
> Andrew Ardill writes:
>
>> I do think that the --no-commit option should imply --no-ff (as this
>> would make the behaviour consistent for end-users). I don't know if
>> this is something that would break scripts etc, but if so you could
>> make it implied only if we det
When directories are moved using `git mv` all files in the directory
have been just moved, but no further action was taken on them. This
was done by assigning the mode = WORKING_DIRECTORY to the files
inside a moved directory.
submodules however need to update their link to the git directory as
we
On 18/04/16 16:21, Adam Dinwoodie wrote:
> t7008.12 is marked as an expected failure, but building Git on Cygwin
> including a `make configure && ./configure` step has the test
> unexpectedly passing. Building without the configure step has the test
> failing as expected.
>
> This appears to be
On Sun, Apr 17, 2016 at 6:26 PM, wrote:
> The run_gpg_verify() function has two variables, size and len.
>
> This may come off as confusing when reading the code. Clarify which
> one pertains to the length of the tag headers by renaming len to
> payload_length.
The commit message talks about 'p
Nguyễn Thái Ngọc Duy writes:
> First cut. I need opinions on 05/07, which converts
> wt_status_get_state() to support selecting any worktree. I'm not super
> happy with leaving "TODO: not supported yet" comments, even though
> strictly speaking this series does not need it.
It is a reasonable i
On Sun, Apr 17, 2016 at 6:26 PM, wrote:
> verify-tag: add sha1 argument to verify_tag()
Mentioned previously[1]: This subject is talking about low level
details of the change rather than giving a high-level overview. A
suggested replacement[1] would be:
verify-tag: prepare verify_tag() for
On Sun, Apr 17, 2016 at 6:27 PM, wrote:
> tag -v forks into verify-tag, which only calls gpg_verify_tag().
"forks into" sounds odd.
> Instead of forking to verify-tag, call gpg_verify_tag directly().
s/ directly()/() directly/
I found the commit message of your previous version[1] more
descri
On Sun, Apr 17, 2016 at 6:26 PM, wrote:
> This is a follow up of [1], [2], [3], [4], and [5]. patches 1/6, 2/6 and 3/6
> are the same as the corresponding commits in pu.
>
> v6:
> * As Junio suggested, updated 4/6, to include the name argument and the
>ternary operator to provide more descri
David Turner writes:
> Signed-off-by: David Turner
> ---
OK (it might be easier to read if you used the pushl form for the
"fixed initial segment" like these calls, though).
> http-backend.c | 12 +++-
> 1 file changed, 7 insertions(+), 5 deletions(-)
>
> diff --git a/http-backend.c b
David Turner writes:
> The local variable 'options' was shadowing a global of the same name.
>
> Signed-off-by: David Turner
> ---
OK. In general, giving a longer and more descriptive name to the
global would be a direction to lead to more readable code, though.
> remote-curl.c | 18
David Turner writes:
> Add parameters for a list of refspecs to transport_get_remote_refs and
> get_refs_list. These parameters are presently unused -- soon, we will
> use them to implement fetches which only learn about a subset of refs.
>
> Signed-off-by: David Turner
> ---
What the code tri
Jacob Keller writes:
> I think we're going to make use of xdl_blankline instead of this or
> our own "is_emptyline"
OK, so perhaps either of you two can do a final version people can
start having fun with?
By the way, I really do not want to see something this low-level to
be end-user tweakable
Stefan Beller writes:
> * squashed the fixes from Johannes Sixt to unbreak Windows tests.
> (I had encoding issues; so I manually integrated the changes)
> * fixed memleaks
> * the base to apply did not change (ee30f17805f51d37 Merge branch
> 'sb/submodule-path-misc-bugs' into sb/submodule-init
On Mon, Apr 18, 2016 at 12:22 PM, Junio C Hamano wrote:
> Jacob Keller writes:
>
>> I think we're going to make use of xdl_blankline instead of this or
>> our own "is_emptyline"
>
> OK, so perhaps either of you two can do a final version people can
> start having fun with?
Junios proposal seems
santi...@nyu.edu writes:
>I'm unsure about the 80-column
>on 4/6, the ternary operator is rather long.
You can do something like this:
type = sha1_object_info(sha1, NULL);
if (type != OBJ_TAG)
return error("%s: cannot verify a non-tag object of type %s.",
Eric Sunshine writes:
> On Sun, Apr 17, 2016 at 6:26 PM, wrote:
>> verify-tag: add sha1 argument to verify_tag()
>
> Mentioned previously[1]: This subject is talking about low level
> details of the change rather than giving a high-level overview. A
> suggested replacement[1] would be:
>
>
Stefan Beller writes:
> if (show_only || verbose)
> printf(_("Renaming %s to %s\n"), src, dst);
> - if (!show_only && mode != INDEX) {
> - if (rename(src, dst) < 0 && !ignore_errors)
> + if (!show_only) {
> +
In order to produce the smallest possible diff and combine several diff
hunks together, we implement a heuristic from GNU Diff which moves diff
hunks forward as far as possible when we find common context above and
below a diff hunk. This sometimes produces less readable diffs when
writing C, Shell
> OK, so perhaps either of you two can do a final version people can
> start having fun with?
Here we go. I squashed in your patch, although with a minor change:
- if ((flags & XDF_SHORTEST_LINE_HEURISTIC)) {
+ if ((flags & XDF_COMPACTION_HEURISTIC) && blank_lines) {
From: Jacob Keller
It is a common pattern in xdl_change_compact to check that hashes and
strings match. The resulting code to perform this change causes very
long lines and makes it hard to follow the intention. Introduce a helper
function recs_match which performs both checks to increase
code re
Junio C Hamano writes:
> If ignore-errors is set and rename fails, this would fall through
> and try to touch this codepath...
>
>> if (submodule_gitfile[i]) {
>> if (submodule_gitfile[i] !=
>> SUBMODULE_WITH_GITDIR)
>>
Stefan Beller writes:
>> OK, so perhaps either of you two can do a final version people can
>> start having fun with?
>
> Here we go. I squashed in your patch, although with a minor change:
>
> - if ((flags & XDF_SHORTEST_LINE_HEURISTIC)) {
> + if ((flags & XDF_COMPACT
On Mon, Apr 18, 2016 at 2:13 PM, Junio C Hamano wrote:
> Junio C Hamano writes:
>
>> If ignore-errors is set and rename fails, this would fall through
>> and try to touch this codepath...
>>
>>> if (submodule_gitfile[i]) {
>>> if (submodule_gitfil
On Mon, Apr 18, 2016 at 2:12 PM, Stefan Beller wrote:
> In order to produce the smallest possible diff and combine several diff
> hunks together, we implement a heuristic from GNU Diff which moves diff
> hunks forward as far as possible when we find common context above and
> below a diff hunk. Th
Jacob Keller writes:
> Thanks Stephan and Junio, this looks pretty good. I think before it's
> merged we'd probably want to implement some sort of attributes which
> allows per-path configuration, incase it needs to be configured at
> all.
My take on it is that we'd want to make sure that the sh
Here are the topics that have been cooking. Commits prefixed with
'-' are only in 'pu' (proposed updates) while commits prefixed with
'+' are in 'next'. The ones marked with '.' do not appear in any of
the integration branches, but I am still holding onto them.
The 'master' branch now has the fi
A single patch evolves into a series.
The second patch is essentially a resend with Junios suggestion squashed[1].
That patch alone doesn't quite fix it yet, as we need to make sure the
submodule code respects the ignore_errors flag as instructed by the user.
Patch 1 libifies the used functions fr
The error handling via passing around a strbuf is well exercised in the
refs code, so apply that pattern here, too.
Signed-off-by: Stefan Beller
---
builtin/mv.c | 15 ---
submodule.c | 33 -
submodule.h | 6 --
3 files changed, 40 insertions(+)
When directories are moved using `git mv` all files in the directory
have been just moved, but no further action was taken on them. This
was done by assigning the mode = WORKING_DIRECTORY to the files
inside a moved directory.
submodules however need to update their link to the git directory as
we
On Mon, Apr 18, 2016 at 2:22 PM, Junio C Hamano wrote:
> Stefan Beller writes:
>
>>> OK, so perhaps either of you two can do a final version people can
>>> start having fun with?
>>
>> Here we go. I squashed in your patch, although with a minor change:
>>
>> - if ((flags & XDF_SHORT
Stefan Beller writes:
> A single patch evolves into a series.
Power of code inspection to see bugs that are not reported, perhaps
;-)?
I wonder if we can come up with test cases to cover these potential
issues that are addressed in [1/2]?
Thanks.
--
To unsubscribe from this list: send the lin
On Tue, Apr 19, 2016 at 12:42 AM, Junio C Hamano wrote:
>> Another option is leave wt_status_get_state() alone, factor out the
>> rebase-detection code and use that for worktree/checkout. We save a
>> few syscalls this way too.
>>
>> Comments?
>>
>> [01/07] path.c: add git_common_path() and strb
Jan Durovec writes:
> When migrating from Perforce to git the information about P4 jobs
> associated with P4 changelists is lost.
>
> Having these jobs listed on messages of related git commits enables smooth
> migration for projects that take advantage of e.g. JIRA integration
> (which uses jobs
On Mon, Apr 18, 2016 at 02:12:30PM -0700, Stefan Beller wrote:
> +
> + /*
> + * If a group can be moved back and forth, see if there is an
> + * blank line in the moving space. If there is a blank line,
> + * make sure the last blank line is the e
On Sun, Apr 17, 2016 at 06:26:58PM -0400, santi...@nyu.edu wrote:
> diff --git a/builtin/verify-tag.c b/builtin/verify-tag.c
> index 77f070a..010353c 100644
> --- a/builtin/verify-tag.c
> +++ b/builtin/verify-tag.c
> @@ -21,20 +21,21 @@ static const char * const verify_tag_usage[] = {
> static in
On Sun, Apr 17, 2016 at 06:26:55PM -0400, santi...@nyu.edu wrote:
> From: Santiago Torres
>
> This is a follow up of [1], [2], [3], [4], and [5]. patches 1/6, 2/6 and 3/6
> are the same as the corresponding commits in pu.
Aside from the minor point I mentioned, and the ones from Eric, this
look
On Mon, Apr 18, 2016 at 10:03 PM, Jeff King wrote:
> On Mon, Apr 18, 2016 at 02:12:30PM -0700, Stefan Beller wrote:
>
>> +
>> + /*
>> + * If a group can be moved back and forth, see if there is an
>> + * blank line in the moving space. If there is a blank line
48 matches
Mail list logo