Re: difftool sends malformed path to exernal tool on Windows

2014-03-16 Thread David Aguilar
On Fri, Mar 7, 2014 at 8:07 AM, Paul Lotz wrote: > David, > > I investigated further and found that \"$LOCAL\" \"$REMOTE\" return the > remote and local files (reversed). (One can easily see this in my 2/28 > e-mail.) Reversing these (\"$REMOTE\" \"$LOCAL\") does indeed reverse the > output.

Re: [PATCH] Documentation/git-am: Document supported --patch-format options

2014-03-16 Thread Chris Packham
On 11/03/14 16:51, Chris Packham wrote: > The --patch-format option has been supported for a while but it is not > mentioned in the man page and the short help cannot tell the user what > the supported formats are. Add the option to the man page along with the > supported options. > > Signed-off-b

git sending messages to stderr on MacOS 10.8

2014-03-16 Thread Thomas Robitaille
I am using git version 1.8.4.2 installed on Mac using MacPorts. When e.g. cloning a repository, the cloning message is being sent to stderr, but I think it should be sent to stdout: In [8]: p = subprocess.Popen('git clone git://github.com/embray/astropy'.split(), stdout=subprocess.PIPE, stderr

Re: git sending messages to stderr on MacOS 10.8

2014-03-16 Thread Duy Nguyen
On Sun, Mar 16, 2014 at 4:15 PM, Thomas Robitaille wrote: > I am using git version 1.8.4.2 installed on Mac using MacPorts. When > e.g. cloning a repository, the cloning message is being sent to > stderr, but I think it should be sent to stdout: > > In [8]: p = subprocess.Popen('git clone > gi

[PATCH] index-pack: do not segfault when keep_name is NULL

2014-03-16 Thread Nguyễn Thái Ngọc Duy
keep_name is used to print error messages a couple lines down. Reset it to the real path returned by odb_pack_keep() if it's set to NULL by caller. Signed-off-by: Nguyễn Thái Ngọc Duy --- One of these moments I will make git log and friends optionally recognize "Diff-Options:" line in commit me

[PATCH] Make XDF_NEED_MINIMAL default in blame.

2014-03-16 Thread Michael Andreen
Currently git blame has a big problem finding copies and moves when you split up a big file into smaller ones. One example in the git repository is 2cf565c, which split the documentation into smaller files. In 582aa00 XDF_NEED_MINIMAL was removed as the default for performance reasons, mainly for

Re: [PATCH] Rewrite diff-no-index.c:read_directory() to use is_dot_or_dotdot() and rename it to read_dir()

2014-03-16 Thread Thomas Rast
Akshay Aurora writes: > Forgot to mention, this is one of the microprojects for GSoC this > year. Would be great to have some feedback. > > On Fri, Mar 14, 2014 at 6:09 PM, Akshay Aurora wrote: >> I have renamed diff-no-index.c:read_directory() to read_dir() to avoid name >> collision with dir.

Re: [PATCH] add: Use struct argv_array in run_add_interactive()

2014-03-16 Thread Thomas Rast
Fabian Ruch writes: > run_add_interactive() in builtin/add.c manually computes array bounds > and allocates a static args array to build the add--interactive command > line, which is error-prone. Use the argv-array helper functions instead. > > Signed-off-by: Fabian Ruch Thanks, this is a nicel

Loan Assistance / Credit Offer

2014-03-16 Thread Santander Group
We offer all purpose loan at 3% interest rate. Contact Us for more details by Email:santanderfinancegr...@gmail.com -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.

Re: [PATCH] Make XDF_NEED_MINIMAL default in blame.

2014-03-16 Thread Thomas Rast
Michael Andreen writes: > The --minimal flag is still there, but didn't want to break scripts > depending on it. If I specify --no-minimal, does that turn it off again? -- Thomas Rast t...@thomasrast.ch -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message

Loan Assistance / Credit Offer

2014-03-16 Thread Santander Finance
We offer all purpose loan at 3% interest rate. Contact Us for more details by Email:santanderfinancegr...@gmail.com -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.

Re: [PATCH] Make XDF_NEED_MINIMAL default in blame.

2014-03-16 Thread Michael Andreen
On Sunday, March 16, 2014 01:12:01 PM Thomas Rast wrote: > Michael Andreen writes: > > > The --minimal flag is still there, but didn't want to break scripts > > depending on it. > > If I specify --no-minimal, does that turn it off again? > Yes, that works. /Michael -- To unsubscribe from this

[PATCH] Rewrite the diff-no-index.c

2014-03-16 Thread ubuntu2012
From: 沈承恩 I am sorry for that I send this agian.Last patch I have some error.(Maybe this time will like the previous).It is apply for GSOC Signed-off-by: 沈承恩 --- diff-no-index.c |5 +++-- dir.h |3 ++- 2 files changed, 5 insertions(+), 3 deletions(-) diff --git a/diff-no-in

[PATCH 4/4] gc --aggressive: three phase repacking

2014-03-16 Thread Nguyễn Thái Ngọc Duy
As explained in the previous commit, current aggressive settings --depth=250 --window=250 could slow down repository access significantly. Notice that people usually work on recent history only, we could keep recent history more loosely packed, so that repo access is fast most of the time while the

[PATCH 0/4] Better "gc --aggressive"

2014-03-16 Thread Nguyễn Thái Ngọc Duy
See [1] for the discussion that led to this series. It attempts to pack the repo with two different depths: old history tightly packed (smaller but also takes longer time to access) and recent history on the opposite. First draft, probably still some bugs lurking in pack_old_history(). It would be

[PATCH] index-pack: do not segfault when keep_name is NULL

2014-03-16 Thread Nguyễn Thái Ngọc Duy
keep_name is used to print error messages a couple lines down. Reset it to the real path returned by odb_pack_keep() if it's set to NULL by caller. Signed-off-by: Nguyễn Thái Ngọc Duy --- One of these moments I will make git log and friends optionally recognize "Diff-Options:" line in commit me

[PATCH 2/4] pack-objects: support --keep

2014-03-16 Thread Nguyễn Thái Ngọc Duy
Signed-off-by: Nguyễn Thái Ngọc Duy --- Documentation/git-pack-objects.txt | 4 builtin/pack-objects.c | 26 ++ 2 files changed, 30 insertions(+) diff --git a/Documentation/git-pack-objects.txt b/Documentation/git-pack-objects.txt index cdab9ed..8aae3b5

[PATCH 3/4] gc --aggressive: make --depth configurable

2014-03-16 Thread Nguyễn Thái Ngọc Duy
When 1c192f3 (gc --aggressive: make it really aggressive - 2007-12-06) made --depth=250 the default value, it didn't really explain the reason behind, especially the pros and cons of --depth=250. An old mail from Linus below explains it at length. Long story short, --depth=250 is a disk saver and

[PATCH 1/4] environment.c: fix constness for odb_pack_keep()

2014-03-16 Thread Nguyễn Thái Ngọc Duy
Signed-off-by: Nguyễn Thái Ngọc Duy --- environment.c | 2 +- git-compat-util.h | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) diff --git a/environment.c b/environment.c index c3c8606..5c4815d 100644 --- a/environment.c +++ b/environment.c @@ -237,7 +237,7 @@ int odb_mkstemp(char *

Re: Trust issues with hooks and config files

2014-03-16 Thread Sitaram Chamarty
On 03/09/2014 10:57 PM, Julian Brost wrote: On 07.03.2014 22:04, Jeff King wrote: Yes, this is a well-known issue. The only safe operation on a repository for which somebody else controls hooks and config is to fetch from it (upload-pack on the remote repository does not respect any dangerous co

[PATCH] Documentation/gitk: Document new config file location

2014-03-16 Thread Astril Hayato
User configuration file is now stored at $XDG_CONFIG_HOME/git/gitk Signed-off-by: Astril Hayato --- Documentation/gitk.txt | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/Documentation/gitk.txt b/Documentation/gitk.txt index 1e9e38a..417a707 100644 --- a/Documentation/git

[PATCH] Removed subshell invocations in many of the tests when possible

2014-03-16 Thread David Tran
I am David Tran a graduating CS/Math senior from Sonoma State University, United States. I would like to work with git for GSoC'14, specifically the line options for git rebase --interactive. I have used git for a few years and know how destructive but important rebase is to git. I have created a f

Re: What's cooking in git.git (Mar 2014, #03; Fri, 14)

2014-03-16 Thread Philip Oakley
From: "Junio C Hamano" -- [Stalled] ... * po/everyday-doc (2014-01-27) 1 commit - Make 'git help everyday' work This may make the said command to emit something, but the source is not meant to be formatted into a manual pages to begin with, and a

[GSOC2014] History Repair Tools

2014-03-16 Thread TamerTas
Hello everyone, I'm Tamer Tas. I am studying computer engineering in Turkey. I'm about to complete my junior year in Middle East Technical University. After setting up my git development environment, I've submitted patches to a microproject [1][2][3]. I'm still getting feedbacks on the microproj

Credit Assistance / Financial Offer

2014-03-16 Thread Santander Finance
We offer all purpose loan at 3% interest rate. Contact Us for more details by Email:santanderfinancegr...@gmail.com -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.

[GSoC 2014] Refactoring git rebase --interactive

2014-03-16 Thread Quint Guvernator
Hi again, Git community! My name is Quint Guvernator, and I am participating in the Google Summer of Code program. I am in university at the College of William and Mary in Williamsburg, VA and plan to major in Computer Science and Linguistics. I have been working on a microproject [1][2] to get t

Re: [PATCH] mv: prevent mismatched data when ignoring errors.

2014-03-16 Thread Junio C Hamano
Jeff King writes: > On Sat, Mar 15, 2014 at 05:05:29PM +0100, Thomas Rast wrote: > >> > diff --git a/builtin/mv.c b/builtin/mv.c >> > index f99c91e..b20cd95 100644 >> > --- a/builtin/mv.c >> > +++ b/builtin/mv.c >> > @@ -230,6 +230,11 @@ int cmd_mv(int argc, const char **argv, const char >> > *p

[PATCH] branch.c: simplify chain of if statements

2014-03-16 Thread Dragos Foianu
This patch uses a table-driven approach in order to make the code cleaner. Although not necessary, it helps code reability by not forcing the user to read the print message when trying to understand what the code does. The rebase check has been moved to the verbose if statement to avoid making the

Should 'git reset --hard' keep a stashed backup?

2014-03-16 Thread Philip Oakley
A bike-shedding thought: Many inexperienced users do a 'git reset --hard' only to discover they have deleted something important and want it back. (e.g. git-users yesterday [1]) One possible option is that Git could "stash" the current work-tree contents (git stash create) into a commit and s

[GSoC 2014] git config API improvements

2014-03-16 Thread Dragos Foianu
Hello, My name is Dragos Foianu and I am an undergraduate student at University Politehnica of Bucharest in Romania. This is my final year and I'm planning on doing something more exciting than the simple assignments I get from the university. I have been working with git for quite some time n

[PATCH] Documentation/merge-strategies: avoid hyphenated commands

2014-03-16 Thread Ramkumar Ramachandra
Replace git-pull and git-merge with the corresponding un-hyphenated versions. While at it, use ` to mark it up instead of '. Signed-off-by: Ramkumar Ramachandra --- Documentation/merge-strategies.txt | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/Documentation/merge-stra

Re: [PATCH 3/4] gc --aggressive: make --depth configurable

2014-03-16 Thread Duy Nguyen
On Mon, Mar 17, 2014 at 12:10 AM, Jay Soffian wrote: > On Sun, Mar 16, 2014 at 9:35 AM, Nguyễn Thái Ngọc Duy > wrote: >> >> When 1c192f3 (gc --aggressive: make it really aggressive - 2007-12-06) >> made --depth=250 the default value, it didn't really explain the >> reason behind, especially the p

[PATCH pu] Documentation/giteveryday: fix some obvious problems

2014-03-16 Thread Ramkumar Ramachandra
Fix a few minor things. Signed-off-by: Ramkumar Ramachandra --- Philip, I spotted a few obvious issues with your giteveryday patch in pu. Maybe Junio can squash this into your patch? Contents are still a bit stale, but I'm not sure what other markup problems are there. Documentation/giteve

Re: What's cooking in git.git (Mar 2014, #03; Fri, 14)

2014-03-16 Thread Ramkumar Ramachandra
Philip Oakley wrote: >> * po/everyday-doc (2014-01-27) 1 commit >> - Make 'git help everyday' work >> >> This may make the said command to emit something, but the source is >> not meant to be formatted into a manual pages to begin with, and >> also its contents are a bit stale. It may be a good fi

Re: Should 'git reset --hard' keep a stashed backup?

2014-03-16 Thread Duy Nguyen
On Mon, Mar 17, 2014 at 5:17 AM, Philip Oakley wrote: > A bike-shedding thought: > Many inexperienced users do a 'git reset --hard' only to discover they have > deleted something important and want it back. (e.g. git-users yesterday [1]) > > One possible option is that Git could "stash" the curren

Re: [PATCH 3/6] l10n: Fix misuses of "nor"

2014-03-16 Thread Jiang Xin
2014-03-15 16:41 GMT+08:00 Justin Lebar : > Signed-off-by: Justin Lebar > --- > po/bg.po| 6 +++--- > po/de.po| 6 +++--- > po/fr.po| 6 +++--- > po/git.pot | 6 +++--- > po/it.po| 2 +- > po/pt_PT.po | 2 +- > po/sv.po| 6 +++--- > po/vi.po| 6 +++--- > po/zh_CN.po | 6 +

Re: [PATCH 3/6] l10n: Fix misuses of "nor"

2014-03-16 Thread Justin Lebar
Thanks. I'll remove this patch from the queue. On Sun, Mar 16, 2014 at 6:45 PM, Jiang Xin wrote: > 2014-03-15 16:41 GMT+08:00 Justin Lebar : >> Signed-off-by: Justin Lebar >> --- >> po/bg.po| 6 +++--- >> po/de.po| 6 +++--- >> po/fr.po| 6 +++--- >> po/git.pot | 6 +++--- >> po/i

Re: [PATCH] GSoC Change multiple if-else statements to be table-driven

2014-03-16 Thread Eric Sunshine
On Fri, Mar 14, 2014 at 12:54 PM, Junio C Hamano wrote: > Eric Sunshine writes: > >> On Thu, Mar 13, 2014 at 4:20 PM, Yao Zhao wrote: >>> Subject: [PATCH] GSoC Change multiple if-else statements to be table-driven >> >> It's a good idea to let reviewers know that this is attempt 2. Do so >> by s

Re: [PATCH] mv: prevent mismatched data when ignoring errors.

2014-03-16 Thread Junio C Hamano
Junio C Hamano writes: > Would it make sense to go one step further to introduce two macros > to make this kind of screw-up less likely? > ... > After letting my eyes coast over hits from "git grep memmove", there > do seem to be some places that these would help readability, but not > very many.

Re: Using "-" for "previous branch" failing with rebase

2014-03-16 Thread Junio C Hamano
Tim Chase writes: > Is this just an interface inconsistency or is there a some technical > reason this doesn't work (or, has it been addressed/fixed, and just > not pulled into Debian Stable's 1.7.10.4 version of git)? It is merely that nobody thought "rebase" would benefit from such a short-han

Re: [PATCH] Documentation/git-am: Document supported --patch-format options

2014-03-16 Thread Junio C Hamano
Chris Packham writes: > Ping? Hasn't it been already cooking in 'next' for a few days? -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html

Re: [PATCH][GSOC2014] install_branch_config: change logical chain to lookup table

2014-03-16 Thread Eric Sunshine
On Fri, Mar 14, 2014 at 5:30 PM, TamerTas wrote: > Signed-off-by: TamerTas > --- > Thanks again for the feedback it's been a great learning experience. Comments > Below :) > > I have refactored the commit [1] to * suggested changes [2]. > format-patch was placing 2 hyphens instead of 3 but it's