Thomas Rast writes:
> * Does libgit2 want to remain under the Git umbrella, or participate
> on its own?
>
> * Figure out the wiki situation. In previous years the project
> proposals and other important information were hosted at k.org [5] and
> github wikis [6]. Other options were float
On Thu, Nov 21, 2013 at 9:36 AM, Thomas Rast wrote:
> Thomas Rast writes:
>>
>> * Find an org admin and backup. In previous years Shawn and Peff did
>> this. Would you do it again?
If Shawn and Peff don't answer, it probably means that you should volunteer :-)
> Any opinions on these points
On Thu, Nov 21, 2013 at 09:36:37AM +0100, Thomas Rast wrote:
> Thomas Rast writes:
>
> > * Does libgit2 want to remain under the Git umbrella, or participate
> > on its own?
> >
> > * Figure out the wiki situation. In previous years the project
> > proposals and other important information
---
Documentation/git-svn.txt | 12 ++--
git-svn.perl | 46
--
2 files changed, 38 insertions(+), 20 deletions(-)
diff --git a/Documentation/git-svn.txt b/Documentation/git-svn.txt
index 30c5ee2..0c1cd46 100644
--- a/Documentatio
git-cherry(1)'s "description" section has never really managed to
explain to me what the command does. It contains too much explanation
of the algorithm instead of simply saying what goals it achieves, and
too much terminology that we otherwise do not use (fork-point instead
of merge-base).
Try a
On Wed, Nov 20, 2013 at 06:28:06PM -0400, Joey Hess wrote:
> Jeff King wrote:
> > As for your specific corruption, I can't make heads or tails of it. It
> > is not a single-bit error.
>
> Oh, I should have mentioned that I am generating corrupt git
> repositories mechanically for testing. I think
On Thu, Nov 21, 2013 at 06:41:58AM -0500, Jeff King wrote:
> The test objects removed are all binary. Git seems to guess a few as
> non-binary, though, because they don't contain any NULs, and includes
> gross binary bytes in the patch below. In theory the mail's transfer
> encoding will take care
On Thu, Nov 21, 2013 at 12:30:56PM +0100, Thomas Rast wrote:
> git-cherry(1)'s "description" section has never really managed to
> explain to me what the command does. It contains too much explanation
> of the algorithm instead of simply saying what goals it achieves, and
> too much terminology t
Hey everyone from Blender developers!
As you might already know, we've recently switched from SVN to Git to
host Blender sources. In general it works really awesome, but we've
got some issues with submodules.
in SVN we had separate repositories for addons and translations which
were attached to m
Thomas Rast writes:
> Junio C Hamano writes:
>
>>> OPTIONS
>>> ---
>>> -v::
>>> - Verbose.
>>> + Verbose. Currently shows the commit subjects next to their
>>> + SHA1.
>>
>> Whenever I see "Currently", it makes me wonder "why does it need to
>> say that? Is there a plan to change i
Jens Lehmann writes:
> But what about this:
>
> struct strbuf cut_line = STRBUF_INIT;
> strbuf_addf(&cut_line, "%c %s", comment_line_char, wt_status_cut_line);
> p = strstr(buf->buf, cut_line.buf);
> if (p && (p == buf->buf || p[-1] == '\n'))
> strbuf_setlen(
Nguyễn Thái Ngọc Duy writes:
> With the introduction of :(literal), :(glob) and :(icase), :(top) is
> no longer the only recognized magic signature.
You need to re-read the message you took hints that led to this
patch from (or, rather, the existing document around the area you
are patching, wh
Am 21.11.2013 00:04, schrieb Junio C Hamano:
> Jens Lehmann writes:
>> diff --git a/wt-status.c b/wt-status.c
>> index b4e44ba..734f94b 100644
>> --- a/wt-status.c
>> +++ b/wt-status.c
>> @@ -16,6 +16,9 @@
>> #include "column.h"
>> #include "strbuf.h"
>>
>> +static char wt_status_cut_line[] = /*
Thomas Rast writes:
> NAME
>
> -git-cherry - Find commits not merged upstream
> +git-cherry - Find commits not applied in upstream
Good.
> +Determine whether there are commits in `..` that are
> +equivalent to those in the range `..`.
>
> +The equivalence test is based on the diff, aft
On Thu, Nov 21, 2013 at 07:43:03PM +0700, Duy Nguyen wrote:
> > - if (experimental_loose_object(map)) {
>
> Perhaps keep this..
>
> > - /*
> > -* The old experimental format we no longer produce;
> > -* we can still read it.
> > -
Torsten Bögershausen writes:
>> Subject: Re: [PATCH v6 05/10] git fetch-pack: Add --diag-url
s/Add/add/ please.
> The main purpose is to trace the URL parser called by git_connect() in
> connect.c
>
> The main features of the parser can be listed as this:
> - parse out host and path for URLs wi
Commit faea9ccbadf75128 introduced "user-relative paths":
"ssh://host.xz/~junio/repo" is the same as "host.xz:~junio/repo".
Commit 356bece0a27258181 "Support [address] in URLs" introduced a regression:
When an URL like "[::1]:/~repo" is used, the replacement of "/~"
with "~" was enabled for IPv6 h
"Andrés G. Aragoneses" writes:
> From 99e387151594572dc136bf1fae45593ee710e817 Mon Sep 17 00:00:00 2001
> From: =?UTF-8?q?Andr=C3=A9s=20G=2E=20Aragoneses?=
> Date: Wed, 13 Nov 2013 16:55:08 +0100
> Subject: [PATCH] transport: Catch non positive --depth option value
>
> Instead of simply ignoring
Add more tests testing all the combinations:
-IPv4 or IPv6
-path starting with "/" or with "/~"
-with and without the ssh:// scheme
Some test fail, they need updates in connect.c
---
t/t5601-clone.sh | 102 +--
1 file changed, 100 insertions(
Jeff King writes:
> We could try to improve the heuristic to err on the side of
> normal objects in the face of corruption, but there is
> really little point. The experimental format is long-dead,
> and was never enabled by default to begin with. We can
> instead simply remove it. The only affec
Torsten Bögershausen writes:
> git_connect has grown large due to the many different protocols syntaxes
> that are supported. Move the part of the function that parses the URL to
> connect to into a separate function for readability.
>
> Signed-off-by: Johannes Sixt
> ---
I lost track, but was
Torsten Bögershausen writes:
> Add test cases using git fetch-pack --diag-url:
>
> - parse out host and path for URLs with a scheme (git:// file:// ssh://)
> - parse host names embedded by [] correctly
> - extract the port number, if present
> - seperate URLs like "file" (which are local)
> fro
Hi git list,
I am trying to diagnose a strange problem in a VM running as a 'git
over ssh server', with one repo which periodically grows very quickly.
The complete dataset packs to a single pack+index of ~650MB. Growth is
slow, these are ASCII text reports that use a template -- highly
compressi
Torsten Bögershausen writes:
> Commit faea9ccbadf75128 introduced "user-relative paths":
> "ssh://host.xz/~junio/repo" is the same as "host.xz:~junio/repo".
>
> Commit 356bece0a27258181 "Support [address] in URLs" introduced a regression:
> When an URL like "[::1]:/~repo" is used, the replacement
Torsten Bögershausen writes:
> Make the function is_local() from tramsport.c public and use it
s/ams/ans/, perhaps?
> in both transport.c and connect.c
> Use a protocol "local" for URLs for the local file system.
> ---
> connect.c| 58
> ++--
I would like to discuss a very important crude oil project with you,kindly
revert back to me if this is your valid email address for further
information.
Regards,
Lee
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More m
Torsten Bögershausen writes:
> Since commit faea9ccb URLs host:~repo or ssh://host:/~repo
> reach the home directory.
> In 356bece0 support for [] was introduced, and as a side
> effect, [host]:/~repo was the same as [host]:~repo.
> The side effect was removed in c01049ae, "connect.c: Corner case
I would like to discuss a very important crude oil project with you,kindly
revert back to me if this is your valid email address for further
information.
Regards,
Lee
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More m
Commit 8d3d28f5 added test cases for URLs which should be ssh.
Remove the function clear_ssh, use test_when_finished to clean up.
Introduce the function setup_ssh_wrapper, which could be factored
out together with expect_ssh.
Tighten one test and use "foo:bar" instead of "./foo:bar",
Helped-by:
Junio C Hamano writes:
An addendum.
> As we can see in a later paragaph:
>
> The "magic signature" consists of an ASCII symbol that is not
> alphanumeric. Currently only the slash `/` is recognized as a
> "magic signature"...
>
> the correct way to read that "a character that cannot
Since day one, function git_connect() had a limit on the command line of
the command that is invoked to make a connection. 7a33bcbe converted the
code that constructs the command to strbuf. This would have been the
right time to remove the limit, but it did not happen. Remove it now.
git_connect()
Junio C Hamano writes:
>> OPTIONS
>> ---
>> -v::
>> -Verbose.
>> +Verbose. Currently shows the commit subjects next to their
>> +SHA1.
>
> Whenever I see "Currently", it makes me wonder "why does it need to
> say that? Is there a plan to change it soon, and if so where is the
Here are the topics that have been cooking. Commits prefixed with
'-' are only in 'pu' (proposed updates) while commits prefixed with
'+' are in 'next'.
Hopefully 1.8.5-rc3 that was tagged on Wednesday will be the final
release candidate for this cycle.
You can find the changes described here in
Add test cases using git fetch-pack --diag-url:
- parse out host and path for URLs with a scheme (git:// file:// ssh://)
- parse host names embedded by [] correctly
- extract the port number, if present
- seperate URLs like "file" (which are local)
from URLs like "host:repo" which should use ssh
git_connect has grown large due to the many different protocols syntaxes
that are supported. Move the part of the function that parses the URL to
connect to into a separate function for readability.
Signed-off-by: Johannes Sixt
---
connect.c | 80 ++---
Commit 8d3d28f5 added test cases for URLs which should be ssh.
Remove the function clear_ssh, use test_when_finished to clean up.
Introduce the function setup_ssh_wrapper, which could be factored
out together with expect_ssh.
Tighten one test and use "foo:bar" instead of "./foo:bar",
Helped-by:
Jeff King writes:
> On Thu, Nov 21, 2013 at 12:30:56PM +0100, Thomas Rast wrote:
>
>> +Later, you can whether your changes have been applied by saying (still
>> +on `topic`):
>
> s/can/& see/ ?
>
>> +Note that this uses , and assumes that
>> +`core.autosetupmerge` is enabled (the default).
>
> I
On Fri, Nov 22, 2013 at 3:18 AM, Junio C Hamano wrote:
> "Andrés G. Aragoneses" writes:
>
>> From 99e387151594572dc136bf1fae45593ee710e817 Mon Sep 17 00:00:00 2001
>> From: =?UTF-8?q?Andr=C3=A9s=20G=2E=20Aragoneses?=
>> Date: Wed, 13 Nov 2013 16:55:08 +0100
>> Subject: [PATCH] transport: Catch n
thanks.
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
On Thu, Nov 21, 2013 at 5:04 PM, Joey Hess wrote:
>
> BTW, I've also seen git cat-file --batch report wrong sizes for objects,
> sometimes without crashing. This is particularly problimatic because if
> the object size is wrong, it's very hard to detect the actual end of the
> object output in the
---
Documentation/git-svn.txt | 12 ++--
git-svn.perl | 46 --
2 files changed, 38 insertions(+), 20 deletions(-)
diff --git a/Documentation/git-svn.txt b/Documentation/git-svn.txt
index 30c5ee2..0c1cd46 100644
--- a/Documentation/g
Duy Nguyen writes:
> Btw I'm thinking of extending pathspec magic syntax a bit to allow
> path completion. Right now the user has to write
>
> git log -- :-Documentation
>
> which does not play well with path completion. I'm thinking of accepting
>
> git log -- :- Documentation
Please don't. Th
On Fri, Nov 22, 2013 at 6:55 AM, Junio C Hamano wrote:
> Junio C Hamano writes:
>
> An addendum.
>
>> As we can see in a later paragaph:
>>
>> The "magic signature" consists of an ASCII symbol that is not
>> alphanumeric. Currently only the slash `/` is recognized as a
>> "magic signa
On Thu, Nov 21, 2013 at 2:52 PM, Junio C Hamano wrote:
>> - if it's receiving from many pushers, it races with itself; needs
>> some lock or back-off mechanism
>
> Surely.
>
> I think these should help:
>
> 64a99eb4 (gc: reject if another gc is running, unless --force is given,
> 2013-08-08)
On Thu, Nov 21, 2013 at 6:48 PM, Jeff King wrote:
> @@ -1514,14 +1469,6 @@ unsigned long unpack_object_header_buffer(const
> unsigned char *buf,
>
> int unpack_sha1_header(git_zstream *stream, unsigned char *map, unsigned
> long mapsize, void *buffer, unsigned long bufsiz)
> {
> - unsign
Since commit faea9ccb URLs host:~repo or ssh://host:/~repo
reach the home directory.
In 356bece0 support for [] was introduced, and as a side
effect, [host]:/~repo was the same as [host]:~repo.
The side effect was removed in c01049ae, "connect.c: Corner case for IPv6".
Re-reading the documentation
>From 99e387151594572dc136bf1fae45593ee710e817 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andr=C3=A9s=20G=2E=20Aragoneses?=
Date: Wed, 13 Nov 2013 16:55:08 +0100
Subject: [PATCH] transport: Catch non positive --depth option value
Instead of simply ignoring the value passed to --depth
option when it
On Thu, Nov 21, 2013 at 10:21 AM, Martin Langhoff
wrote:
> Do client pushes over git+ssh ever trigger a repack on the server?
man git-config
[snip]
receive.autogc
By default, git-receive-pack will run "git-gc --auto" after
receiving data from git-push and updating re
Duy Nguyen writes:
> On Thu, Nov 21, 2013 at 6:48 PM, Jeff King wrote:
>> @@ -1514,14 +1469,6 @@ unsigned long unpack_object_header_buffer(const
>> unsigned char *buf,
>>
>> int unpack_sha1_header(git_zstream *stream, unsigned char *map, unsigned
>> long mapsize, void *buffer, unsigned long b
On Thu, Nov 21, 2013 at 12:04:26PM -0400, Joey Hess wrote:
> Jeff King wrote:
> > This latter behavior is much worse for two reasons. One,
> > git reports an allocation error when the real error is
> > corruption. And two, the program dies unconditionally, so
> > you cannot even run fsck (which wo
Martin Langhoff writes:
> On Thu, Nov 21, 2013 at 10:21 AM, Martin Langhoff
> wrote:
>> Do client pushes over git+ssh ever trigger a repack on the server?
>
> man git-config
> [snip]
>
>receive.autogc
>By default, git-receive-pack will run "git-gc --auto" after
>r
Use get_host_and_port() even for ssh.
Remove the variable port git_connect(), and simplify parse_connect_url()
Use only one return point in git_connect(), doing the free() and return conn.
t5601 had 2 corner test cases which now pass.
---
connect.c | 47 +--
The main purpose is to trace the URL parser called by git_connect() in
connect.c
The main features of the parser can be listed as this:
- parse out host and path for URLs with a scheme (git:// file:// ssh://)
- parse host names embedded by [] correctly
- extract the port number, if present
- seper
The output of git format-patch can vary with user preferences. In
particular setting diff.noprefix will break the "git apply" that
is done as part of "git p4 submit".
Signed-off-by: Crestez Dan Leonard
---
git-p4.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/git-p4.py
I would like to discuss a very important crude oil project with you,kindly
revert back to me if this is your valid email address for further
information.
Regards,
Lee
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More m
Make the function is_local() from tramsport.c public and use it
in both transport.c and connect.c
Use a protocol "local" for URLs for the local file system.
---
connect.c| 58 ++--
connect.h| 1 +
t/t5601-clone.sh | 10 +-
Jeff King wrote:
> This latter behavior is much worse for two reasons. One,
> git reports an allocation error when the real error is
> corruption. And two, the program dies unconditionally, so
> you cannot even run fsck (which would otherwise ignore the
> broken object and keep going).
BTW, I've a
Crestez Dan Leonard writes:
> The output of git format-patch can vary with user preferences. In
> particular setting diff.noprefix will break the "git apply" that
> is done as part of "git p4 submit".
>
> Signed-off-by: Crestez Dan Leonard
> ---
> git-p4.py | 2 +-
> 1 file changed, 1 insertion
Commit 8d3d28f5 added test cases for URLs which should be ssh.
Remove the function clear_ssh, use test_when_finished to clean up.
Introduce the function setup_ssh_wrapper, which could be factored
out together with expect_ssh.
Tighten one test and use "foo:bar" instead of "./foo:bar",
Helped-by:
Duy Nguyen writes:
> Current version does force that.
>
> $ git log -- ':/#aa'
> fatal: Unimplemented pathspec magic '#' in ':/#aa'
>
> Not sure if there are tests for it though. I'll add an advice to do ":/:#aa".
It is good that we already do the right thing, but actually I was
not questioning
60 matches
Mail list logo