Re: [PATCH 1/5] hashmap: add enum for hashmap free_entries option

2014-06-17 Thread Junio C Hamano
Heiko Voigt writes: > If this is such a controversial change for you I will drop this patch in > the next round. I think it would make the callsite more readable without > adding much clutter but I am fine with it either way. OK, let's do that. -- To unsubscribe from this list: send the line "un

Re: Re: [PATCH 1/5] hashmap: add enum for hashmap free_entries option

2014-06-17 Thread Heiko Voigt
On Tue, Jun 17, 2014 at 10:30:35AM +0200, Karsten Blees wrote: > Am 12.06.2014 21:12, schrieb Junio C Hamano: > > Karsten Blees writes: > > > >> Am 10.06.2014 12:17, schrieb Heiko Voigt: > >>> The intention of Jonathans critique here[1] was that you do not see what > >>> this parameter does on th

Re: [PATCH 1/5] hashmap: add enum for hashmap free_entries option

2014-06-17 Thread Karsten Blees
Am 12.06.2014 21:12, schrieb Junio C Hamano: > Karsten Blees writes: > >> Am 10.06.2014 12:17, schrieb Heiko Voigt: >>> The intention of Jonathans critique here[1] was that you do not see what >>> this parameter does on the callsite. I.e.: >>> >>> hashmap_free(&map, 1); >>> >>> compared to >>

Re: [PATCH 1/5] hashmap: add enum for hashmap free_entries option

2014-06-12 Thread Junio C Hamano
Karsten Blees writes: > Am 10.06.2014 12:17, schrieb Heiko Voigt: >> The intention of Jonathans critique here[1] was that you do not see what >> this parameter does on the callsite. I.e.: >> >> hashmap_free(&map, 1); >> >> compared to >> >> hashmap_free(&map, HASHMAP_FREE_ENTRIES); >

Re: [PATCH 1/5] hashmap: add enum for hashmap free_entries option

2014-06-11 Thread Karsten Blees
Am 10.06.2014 12:17, schrieb Heiko Voigt: > On Fri, Jun 06, 2014 at 07:52:03PM +0200, Karsten Blees wrote: >> Am 05.06.2014 08:06, schrieb Heiko Voigt: >>> This allows a reader to immediately know which options can be used and >>> what this parameter is about. >>> >> [...] >>> -void hashmap_free(st

Re: [PATCH 1/5] hashmap: add enum for hashmap free_entries option

2014-06-10 Thread Heiko Voigt
On Fri, Jun 06, 2014 at 07:52:03PM +0200, Karsten Blees wrote: > Am 05.06.2014 08:06, schrieb Heiko Voigt: > > This allows a reader to immediately know which options can be used and > > what this parameter is about. > > > [...] > > -void hashmap_free(struct hashmap *map, int free_entries) > > +voi

Re: [PATCH 1/5] hashmap: add enum for hashmap free_entries option

2014-06-06 Thread Karsten Blees
Am 05.06.2014 08:06, schrieb Heiko Voigt: > This allows a reader to immediately know which options can be used and > what this parameter is about. > [...] > -void hashmap_free(struct hashmap *map, int free_entries) > +void hashmap_free(struct hashmap *map, enum hashmap_free_options > free_entries