On Thu, Jun 15, 2017 at 11:43 PM, Michael Haggerty wrote:
> I chose that name because it is a `ref_store`, with `packed_` being a
> short prefix that tells what kind of `ref_store`.
>
> The next question is, why `ref_store` as opposed to `refs_store`? To me
> it sounds more natural in English for
On 06/16/2017 07:39 AM, Stefan Beller wrote:
> On Thu, Jun 15, 2017 at 7:47 AM, Michael Haggerty
> wrote:
>> [...]
>> @@ -125,7 +125,7 @@ static void clear_packed_ref_cache(struct
>> files_ref_store *refs)
>> if (refs->packed_ref_store->cache) {
>> struct packed_ref_cache
On Thu, Jun 15, 2017 at 7:47 AM, Michael Haggerty wrote:
> Move the `packed_refs_lock` member from `files_ref_store` to
> `packed_ref_store`, and rename it to `lock` since it's now more
> obvious what it is locking.
>
> Signed-off-by: Michael Haggerty
> ---
> refs/files-backend.c | 31 ++
Move the `packed_refs_lock` member from `files_ref_store` to
`packed_ref_store`, and rename it to `lock` since it's now more
obvious what it is locking.
Signed-off-by: Michael Haggerty
---
refs/files-backend.c | 31 ---
1 file changed, 16 insertions(+), 15 deletions(-
4 matches
Mail list logo