t;filter_body()" could be used for
refactoring the part of code which parses the header to prepare the
email and send it.
In contrast to the previous version it doesn't keep the header order
and strip duplicate headers.
Signed-off-by: Nathan Payre
Signed-off-by: Matthieu Moy
Signed-of
t;filter_body()" could be used for
refactoring the part of code which parses the header to prepare the
email and send it.
Signed-off-by: Nathan Payre
Signed-off-by: Matthieu Moy
Signed-off-by: Timothee Albertin
Signed-off-by: Daniel Bensoussan
Signed-off-by: Junio C Hamano
Than
2017-12-11 22:12 GMT+01:00 Matthieu Moy :
> "PAYRE NATHAN p1508475" wrote:
>> + my %parsed_email;
>> + $parsed_email{'body'} = '';
>> + while (my $line = <$c>) {
>> + next if $line =~ m/^GIT:/;
>> + parse_header_line($line, \%parsed_email);
>> + if
t;filter_body()" could be used for
refactoring the part of code which parses the header to prepare the
email and send it.
Signed-off-by: Nathan Payre
Signed-off-by: Matthieu Moy
Signed-off-by: Timothee Albertin
Signed-off-by: Daniel Bensoussan
Signed-off-by: Junio C Hamano
Thanks-to: Æ
t;filter_body()" could be used for refactoring
the part of code which parses the header a last time to prepare the
email and send it.
Signed-off-by: Nathan Payre
Signed-off-by: Matthieu Moy
Signed-off-by: Timothee Albertin
Signed-off-by: Daniel Bensoussan
Signed-off-by: Junio C Ha
The existing code mixes parsing of email header with regular
expression and actual code. Extract the parsing code into a new
subroutine 'parse_header_line()'. This improves the code readability
and make parse_header_line reusable in other place.
Signed-off-by: Nathan Payre
Sig
Junio C Hamano : writes:
> ... throughout this patch, not limited to this section, indentation
> is strange and there seem to be many "print" that show messages that
> do not seem to be meant for end-user consumption. I can see that
> this aspires to improve the readability, but not quite yet ;-)
The existing code mixes parsing of email header with regular
expression and actual code. Extract the parsing code into a new
subroutine 'parse_header_line()'. This improves the code readability
and make parse_header_line reusable in other place.
Signed-off-by: Nathan Payre
Sig
The existing code mixes parsing of email header with regular
expression and actual code. Extract the parsing code into a new
subroutine 'parse_header_line()'. This improves the code readability
and make parse_header_line reusable in other place.
Signed-off-by: Nathan Payre
Sig
I've tested your code, and after few changes it's works perfectly!
The code looks better now.
Thanks a lot for your review.
2017-12-03 23:00 GMT+01:00 Ævar Arnfjörð Bjarmason :
>
> On Sat, Dec 02 2017, Payre Nathan jotted:
>
>> From: Nathan Payre
>>
>> The
I found a mistake in my signed-off-by, please replace
by
Excuse me.
2017-12-02 18:02 GMT+01:00 Payre Nathan :
> From: Nathan Payre
>
> The existing code mixes parsing of email header with regular
> expression and actual code. Extract the parsing code into a new
> subroutine
I Will send the modification in the next patch, I prefer to refractor
a part of the code before.
>> diff --git a/git-send-email.perl b/git-send-email.perl
>> index 2208dcc21..665c47d15 100755
>> --- a/git-send-email.perl
>> +++ b/git-send-email.perl
>> @@ -57,6 +57,7 @@ git send-email --dump-alias
Hi,
Thanks you for the this complete answer,
we take note of your comments.
We would like to reword something else in the same line
and we don't know what is the best way to do that properly.
Should we do a [PATCH v2] or revert the last commit and
commit a new one?
2017-10-05 12:13 GMT+02:00 Jun
ject", ...) will be automatically filled.
For now the code contains a syntax error then our obvious first
goal is to fix it.
Discussion of the previous team with more information:
https://public-inbox.org/git/1464031829-6107-1-git-send-email-tom.russe...@grenoble-inp.org/
2017-10-04 6:05 GMT+0
Hi all,
me and my two other partner (Daniel and Timothee) have make the choice
to contribute to gitHub for a university project supervised by Mattieu
Moy.
The principal project is to improve the git-send-email function, for
example we will try to implement the possibility to answer to a email
by k
15 matches
Mail list logo