[GSoC][PATCH 1/2] userdiff: add built-in patterns for CSS

2015-03-08 Thread Hiroyuki Sano
Add regex patterns for CSS. The word regex maches selectors, properties, and values. On the other hand, the funcname regex matches lines contains the curly brace character. Signed-off-by: Hiroyuki Sano --- t/t4018-diff-funcname.sh | 1 + t/t4034-diff-words.sh| 1 + t/t4034/css/expect

[GSoC][PATCH 2/2] attrs: add "css" to the list of userdiff bulit-in patterns

2015-03-08 Thread Hiroyuki Sano
Signed-off-by: Hiroyuki Sano --- Documentation/gitattributes.txt | 2 ++ 1 file changed, 2 insertions(+) diff --git a/Documentation/gitattributes.txt b/Documentation/gitattributes.txt index c892ffa..8904a2a 100644 --- a/Documentation/gitattributes.txt +++ b/Documentation/gitattributes.txt

Re: [PATCH v3][GSOC] fsck: use bitwise-or assignment operator to set flag

2014-03-20 Thread Hiroyuki
Junio and Eric, Thank you for the reviews and helpful advice. I should have read more past commit messages before send patch. Regards, 2014-03-21 3:20 GMT+09:00 Junio C Hamano : > Hiroyuki Sano writes: > >> fsck_tree() has two different ways to set a flag, >> which

[PATCH v3][GSOC] fsck: use bitwise-or assignment operator to set flag

2014-03-19 Thread Hiroyuki Sano
makes the code shorter and easier to read, and it is brief and to the point. Signed-off-by: Hiroyuki Sano --- fsck.c | 18 ++ 1 file changed, 6 insertions(+), 12 deletions(-) diff --git a/fsck.c b/fsck.c index b3022ad..abed62b 100644 --- a/fsck.c +++ b/fsck.c @@ -165,18 +165,12

[PATCH v2 1/3][GSOC] diff: rename read_directory() to get_path_list()

2014-03-19 Thread Hiroyuki Sano
Including "dir.h" in "diff-no-index.c", it causes a compile error, because the same name function read_directory() is declared globally in "dir.h". This change is to avoid conflicts as above. Signed-off-by: Hiroyuki Sano --- diff-no-index.c | 6 +++--- 1 fi

[PATCH v2 3/3][GSOC] fsck: replace if-statements to logical expressions

2014-03-19 Thread Hiroyuki Sano
stead of strcmp() to avoid hard coding. The is_dot_or_dotdot() is used to check if the string is either "." or "..". Include the "dir.h" header file to use is_dot_or_dotdot(). Signed-off-by: Hiroyuki Sano --- fsck.c | 19 +++ 1 file changed, 7 ins

[PATCH v2 2/3][GSOC] diff: use is_dot_or_dotdot() instead of strcmp()

2014-03-19 Thread Hiroyuki Sano
The is_dot_or_dotdot() is used to check if the string is either "." or "..". Include the "dir.h" header file to use is_dot_or_dotdot(). Signed-off-by: Hiroyuki Sano --- diff-no-index.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/diff-no-i

[PATCH 3/3][GSOC] fsck: use is_dot_or_dotdot() instead of strcmp()

2014-03-17 Thread Hiroyuki Sano
The is_dot_or_dotdot() is used to check if the string is either "." or "..". Signed-off-by: Hiroyuki Sano --- fsck.c | 11 +++ 1 file changed, 7 insertions(+), 4 deletions(-) diff --git a/fsck.c b/fsck.c index b3022ad..c9d7784 100644 --- a/fsck.c +++ b/fsck.c @@ -6

[PATCH 1/3][GSOC] diff: rename read_directory() to get_directory_list()

2014-03-17 Thread Hiroyuki Sano
Including "dir.h" in "diff-no-index.c", it causes a compile error, because the same name function read_directory() is declared globally in "dir.h". This change is to avoid conflicts as above. Signed-off-by: Hiroyuki Sano --- diff-no-index.c | 6 +++--- 1 fi

[PATCH 2/3][GSOC] diff: use is_dot_or_dotdot() instead of strcmp()

2014-03-17 Thread Hiroyuki Sano
The is_dot_or_dotdot() is used to check if the string is either "." or "..". Signed-off-by: Hiroyuki Sano --- diff-no-index.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/diff-no-index.c b/diff-no-index.c index 1ed5c9d..ccd9270 100644 --- a/diff-no-i