On Wed, 19 Sep 2018 at 22:15, Ramsay Jones wrote:
> On 19/09/18 18:49, Martin Ågren wrote:
> > On Wed, 19 Sep 2018 at 02:07, Ramsay Jones
> > wrote:
> >> +GEN_HDRS := command-list.h unicode-width.h
> >
> > Most of the things happening around here are obvious steps towards the
> > end-goal and se
On Mon, Sep 17, 2018 at 07:18:50PM -0400, Taylor Blau wrote:
> Hi brian,
>
> Thanks for CC-ing me on this.
>
> I use editorconfig every day via the configuration in my home directory
> [1], and the Vim plugin editorconfig-vim [2]. It's a great piece of
> software, and I've been using it without a
On Tue, Sep 18, 2018 at 08:00:27PM -0700, Junio C Hamano wrote:
> "brian m. carlson" writes:
>
> > To make automatically configuring one's editor easier, provide an
> > EditorConfig file. This is an INI-style configuration file that can be
> > used to specify editor settings and can be understoo
On Wed, Sep 19, 2018 at 9:15 AM Elijah Newren wrote:
>
> Summary:
> merge_file_1() -> merge_mode_and_contents()
> merge_content() -> handle_content_merge()
>
> merge_file_1() is a very unhelpful name. Rename it to
> merge_mode_and_contents() to reflect what it does.
>
> merge_content() calls
> I think "Is it a CPU archtecture?" is a red-herring, but between
It wasn't meant to be a red-herring though. Plenty of Linux
distributions have different architecture-specific package repos, and
arch is a common abbreviation for architecture. This only comes up if
you search for the full word e.
Frederick Eaton writes:
> When I read this man page I couldn't figure out what kind of input it
> was referring to, or how input was being put into columns, or where I
> should look for the syntax of the --mode option.
>
> Signed-off-by: Frederick Eaton
> ---
> Documentation/git-column.txt | 35
Frederick Eaton writes:
> Is it a CPU architecture? Is it Arch Linux? If you search for "arch
> repository", nothing relevant comes up. Let's call it GNU Arch so
> people can find it with search engines.
>
> Signed-off-by: Frederick Eaton
> ---
> Documentation/git-archimport.txt | 5 +++--
> 1
Frederick Eaton writes:
> I've never sent patches using git before so I thought it would be
> useful to make a small test.
... eh, welcome ;-)
> I read ./Documentation/SubmittingPatches and I sent these to myself
> and practiced applying them using `git am`, and I also compiled and
> checked th
The following command sequence exits with 1, and no stderr
base='remotes/origin/dev';
fork_point="$(git merge-base --fork-point "$base")";
I cannot figure out why it's exiting with 1, but there is no stdout/stderr
-alex
--
Alexander D. Mills
¡¡¡ New cell phone number: (415)730-1805 !!!
alexan
On Wed, 19 Sep 2018 at 23:04, Ævar Arnfjörð Bjarmason wrote:
> Fix a regression in my recent 7b0f229222 ("commit-graph write: add
> progress output", 2018-09-17), the newly added progress output for
> "commit-graph write" didn't check the --quiet option.
s/, t/. T/, perhaps. Maybe also s/did/does
Fix a regression in my recent 7b0f229222 ("commit-graph write: add
progress output", 2018-09-17), the newly added progress output for
"commit-graph write" didn't check the --quiet option.
Do so, and add a test asserting that this works as expected. Since the
TTY perquisite isn't available everywhe
The caption uses the term "human readable", but the DESCRIPTION did
not explain this in context.
Signed-off-by: Frederick Eaton
---
Documentation/git-describe.txt | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/Documentation/git-describe.txt b/Documentation/git-describe.tx
When I read this man page I couldn't figure out what kind of input it
was referring to, or how input was being put into columns, or where I
should look for the syntax of the --mode option.
Signed-off-by: Frederick Eaton
---
Documentation/git-column.txt | 35 +--
1
I've never sent patches using git before so I thought it would be
useful to make a small test.
I read ./Documentation/SubmittingPatches and I sent these to myself
and practiced applying them using `git am`, and I also compiled and
checked the revised manual pages to see that they format correctly.
Is it a CPU architecture? Is it Arch Linux? If you search for "arch
repository", nothing relevant comes up. Let's call it GNU Arch so
people can find it with search engines.
Signed-off-by: Frederick Eaton
---
Documentation/git-archimport.txt | 5 +++--
1 file changed, 3 insertions(+), 2 deletion
On Wed, Sep 19 2018, Jeff King wrote:
> On Wed, Sep 19, 2018 at 07:22:44PM +0200, Ævar Arnfjörð Bjarmason wrote:
>
>> > Do we have --quiet option or something that needs to completely
>> > suppress this progress thing?
>>
>> Yes. I also see my commit graph process patches sitting in "next" broke
On Wed, Sep 19, 2018 at 5:36 AM Eric Sunshine wrote:
>
> On Tue, Sep 18, 2018 at 10:11 PM Matthew DeVore wrote:
> > Yes, it's probably better to add a point about that. Here is the new
> > documentation after applying your suggestions:
> >
> > - If a piped sequence which spans multiple lines, pu
On Wed, Sep 19 2018, Jeff King wrote:
> On Wed, Sep 19, 2018 at 02:47:09PM -0300, Leonardo Bozzi wrote:
>
>> Good afternoon, I'm trying to set up a git server, but I want to use
>> ssh access to connect clients on my server, but because of a
>> limitation in my internet provider it blocks access
Junio C Hamano writes:
> SZEDER Gábor writes:
>
>>> While inspecting this code, I realized that the final test for
>>> 'commit_contains --tag' is silently dropping the '--tag' argument.
>>> It should be quoted to include both.
>>
>> Nit: while quoting the function's arguments does fix the issue,
On 19/09/18 18:49, Martin Ågren wrote:
> Hi Ramsay,
>
> On Wed, 19 Sep 2018 at 02:07, Ramsay Jones
> wrote:
>> @@ -2675,6 +2676,17 @@ $(SP_OBJ): %.sp: %.c GIT-CFLAGS FORCE
>> .PHONY: sparse $(SP_OBJ)
>> sparse: $(SP_OBJ)
>>
>> +GEN_HDRS := command-list.h unicode-width.h
>
> Most of the thi
SZEDER Gábor writes:
>> While inspecting this code, I realized that the final test for
>> 'commit_contains --tag' is silently dropping the '--tag' argument.
>> It should be quoted to include both.
>
> Nit: while quoting the function's arguments does fix the issue, it
> leaves the tests prone to t
SZEDER Gábor writes:
> it appears that this patch (and its previous versions as well) is
> responsible for triggering occasional test failures in
> 't7814-grep-recurse-submodules.sh', more frequently, about once in
> every ten runs, on macOS on Travis CI, less frequently, about once in
> a couple
Nguyễn Thái Ngọc Duy writes:
> Commit b0db704652 (pathspec: allow querying for attributes -
> 2017-03-13) adds new pathspec magic 'attr' but only with
> match_pathspec(). "git add" has some pathspec related code that still
> does not know about 'attr' and will bail out:
>
> $ git add ':(attr
On Wed, Sep 19, 2018 at 07:22:44PM +0200, Ævar Arnfjörð Bjarmason wrote:
> > Do we have --quiet option or something that needs to completely
> > suppress this progress thing?
>
> Yes. I also see my commit graph process patches sitting in "next" broke
> the "git gc --quiet" mode, and I'll need to
Ok
git clone ssh://bo...@bozzi.net:8822/opt/gitcurso
access sucess.
Adm. Leonardo Bozzi
Administrador / Analista de Sistemas
Tel.: (27) 99988-4576
CRA-ES: 13256
Em qua, 19 de set de 2018 às 14:50, Jeff King escreveu:
>
> On Wed, Sep 19, 2018 at 02:47:09PM -0300, Leonardo Bozzi wrote:
On Wed, Sep 19, 2018 at 08:34:05PM +0200, Martin Ågren wrote:
> > + /*
> > +* First see if we're already sending the base (or it's explicitly
> > in
> > +* our "excluded" list.
> > +*/
>
> Missing ')'.
Oops, yes.
> > + if (use_delta_islands) {
> > +
On Wed, Sep 19, 2018 at 5:50 AM Eric Sunshine wrote:
>
> If so, then please use test_cmp() rather than raw 'cmp' since
> test_cmp() will show the actual difference between the expected and
> actual files, which can be helpful when diagnosing a failing test.
>
All the other testcases in this file u
On Wed, 19 Sep 2018 at 05:49, Jeff King wrote:
> This is tricky to do inside a single "if" statement. And
> after the merge in f3504ea3dd (Merge branch
> 'cc/delta-islands', 2018-09-17), that "if" condition is
> already getting pretty unwieldy. So this patch moves the
> logic into a helper functio
Hi Taylor,
On Wed, 19 Sep 2018 at 19:21, Taylor Blau wrote:
> I could take or leave 2/2, since I usually write ", (see: above)", but
> I'm not sure if that's grammatically correct or not.
Well, I sure ain't no grammar expert too... This is not a patch I feel
strongly about, so I'll be happy to d
On Wed, Sep 19, 2018 at 02:47:09PM -0300, Leonardo Bozzi wrote:
> Good afternoon, I'm trying to set up a git server, but I want to use
> ssh access to connect clients on my server, but because of a
> limitation in my internet provider it blocks access from outside on
> port 22, so I changed the sa
Hi Ramsay,
On Wed, 19 Sep 2018 at 02:07, Ramsay Jones wrote:
> @@ -2675,6 +2676,17 @@ $(SP_OBJ): %.sp: %.c GIT-CFLAGS FORCE
> .PHONY: sparse $(SP_OBJ)
> sparse: $(SP_OBJ)
>
> +GEN_HDRS := command-list.h unicode-width.h
Most of the things happening around here are obvious steps towards the
end-
Good afternoon, I'm trying to set up a git server, but I want to use
ssh access to connect clients on my server, but because of a
limitation in my internet provider it blocks access from outside on
port 22, so I changed the same from ssh to 8822. But when I give the
command:
$git remote add origin
On Mon, Sep 17, 2018 at 5:34 PM Eric Sunshine wrote:
>
> On Mon, Sep 17, 2018 at 6:25 PM Matthew DeVore wrote:
> > tests: Add linter check for pipe placement style
>
> Until now, the various "lint" checks have been for genuine portability
> problems (except perhaps 'test-lint-duplicates'). This n
On Wed, Sep 19 2018, Duy Nguyen wrote:
> On Wed, Sep 19, 2018 at 4:23 PM Ævar Arnfjörð Bjarmason
> wrote:
>> Before this change the "git reflog expire" command didn't report any
>> progress.
>
> I love these progress additions you've been pushing lately :)
>
>> diff --git a/builtin/reflog.c b/b
Hi Martin,
On Wed, Sep 19, 2018 at 06:38:19PM +0200, Martin Ågren wrote:
> Rather than saying "(see: above)", drop the colon. Also drop the comma
> before this note.
>
> Signed-off-by: Martin Ågren
Thanks for both of these. I should have at least taken care of 1/2
myself, but I am appreciative o
In the "Reporting Bugs" section of git(1), we refer to the mailing list,
but we do not give any hint about where the archives might be found.
Copy the text from README.md on this to give potential reporters an
honest chance of finding out whether their bug has already been
reported.
Signed-off-by:
Rather than saying "(see: above)", drop the colon. Also drop the comma
before this note.
Signed-off-by: Martin Ågren
---
Documentation/git-config.txt | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/Documentation/git-config.txt b/Documentation/git-config.txt
index 9d8cea72
After fb0dc3bac1 (builtin/config.c: support `--type=` as preferred
alias for `--`, 2018-04-18) we have a more modern way of spelling
`--bool`.
Update all instances except those that explicitly document the
"historical options" in git-config.txt. The other old-style
type-specifiers already seem to
The command is `git commit-graph`, but the file it processes is the
"commit graph file" without a dash. We have a few references to the
"commit-graph file", though. Fix them.
Signed-off-by: Martin Ågren
---
Documentation/git-commit-graph.txt | 6 +++---
1 file changed, 3 insertions(+), 3 deletio
This document sometimes refers to the "commit graph file" as just "the
graph file". This saves a couple of words here and there at the risk of
confusion. In particular, the documentation for `git commit-graph read`
appears to suggest that there are indeed different types of graph files.
Let's just
We have a couple of bullet items which span multiple lines, and where we
have prefixed each line with a `*`. (This might be the result of a text
editor trying to help.) This results in each line being typeset as a
separate bullet item. Drop the extra `*`.
Signed-off-by: Martin Ågren
---
Document
While we're here, fix an instance of "folder" to be "directory".
Signed-off-by: Martin Ågren
---
Documentation/git-commit-graph.txt | 13 +++--
1 file changed, 7 insertions(+), 6 deletions(-)
diff --git a/Documentation/git-commit-graph.txt
b/Documentation/git-commit-graph.txt
index f42
The first patch is a bug-fix. The second applies some more
`monospace`-ing, which should also be good thing.
The last two patches are based on my understanding that `git
commit-graph` handles the "commit graph file", without a dash. If that's
correct, there might be more such cleanups to be made i
On Wed, Sep 19, 2018 at 4:23 PM Ævar Arnfjörð Bjarmason
wrote:
> Before this change the "git reflog expire" command didn't report any
> progress.
I love these progress additions you've been pushing lately :)
> diff --git a/builtin/reflog.c b/builtin/reflog.c
> index 3acef5a0ab..d3075ee75a 100644
On Wed, Sep 19, 2018 at 06:12:23PM +0200, Duy Nguyen wrote:
> On Wed, Sep 19, 2018 at 1:19 AM Jeff King wrote:
> >
> > On Tue, Sep 18, 2018 at 12:36:06PM -0700, Jacob Keller wrote:
> >
> > > > I like that, too. It's a little more costly just because it may involve
> > > > object-db writes, but I
Summary:
merge_file_1() -> merge_mode_and_contents()
merge_content() -> handle_content_merge()
merge_file_1() is a very unhelpful name. Rename it to
merge_mode_and_contents() to reflect what it does.
merge_content() calls merge_mode_and_contents() to do the main part of
its work, but most o
merge_3way() has code to mark different sides of the conflict with info
about where the content comes from. If the names of the files involved
match, it simply uses the branch name. If the names of the files do not
match, it uses branchname:filename. Unfortunately, merge_content()
previously alw
While working on a series to make file collision conflict handling
consistent, I discovered a latent bug in merge_content()...and several
opportunities for cleanup. This series fixes that bug, deletes the
merge_file_special_markers() and merge_file_one() functions, and
renames a pair of functions
merge_file_one() is a convenience function taking a bunch of oids and
modes, combining each pair into a diff_filespec, and then calling
merge_file_1(). When we already start with diff_filespec's, we can
just call merge_file_1() directly instead of splitting out the oids
and modes for the wrapper t
The function names merge_file_one() and merge_file_1() aren't
particularly intuitive function names, especially since there is no
associated merge_file() function that these are related to. The
previous commit showed that merge_file_one() was prone to be called when
merge_file_1() should be, and s
On Wed, Sep 19, 2018 at 1:19 AM Jeff King wrote:
>
> On Tue, Sep 18, 2018 at 12:36:06PM -0700, Jacob Keller wrote:
>
> > > I like that, too. It's a little more costly just because it may involve
> > > object-db writes, but I think in most cases it would be fine. I almost
> > > always "git stash" a
On Wed, Sep 19, 2018 at 7:24 AM Vasily Korytov
wrote:
>
> Hi,
>
> $ locale
> LANG=
> LC_COLLATE="C"
> LC_CTYPE="UTF-8"
> LC_MESSAGES="C"
> LC_MONETARY="C"
> LC_NUMERIC="C"
> LC_TIME="C"
> LC_ALL=
> $ uname -mrs
> Darwin 16.7.0 x86_64
> $ git --version
> git version 2.19.0
>
> In Mac’s system prefe
Matthew DeVore writes:
> Yes, it's probably better to add a point about that. Here is the new
> documentation after applying your suggestions:
>
> - If a piped sequence which spans multiple lines, put each statement
>on a separate line and put pipes on the end of each line, rather
>than
Hi,
$ locale
LANG=
LC_COLLATE="C"
LC_CTYPE="UTF-8"
LC_MESSAGES="C"
LC_MONETARY="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_ALL=
$ uname -mrs
Darwin 16.7.0 x86_64
$ git --version
git version 2.19.0
In Mac’s system preferences I have three languages: English (default), Russian,
Ukrainian.
After update to G
Before this change the "git reflog expire" command didn't report any
progress. This is the second command (after "pack-refs --all --prune")
that the "gc" command will run.
On small repositories like this command won't take long to run, my
test system it takes just under 1 second to run on git.git,
I wish to discuss a proposal with you, please contact me via email for more
details immediately.
On Tue, Sep 18, 2018 at 10:56 PM Matthew DeVore wrote:
> On Mon, Sep 17, 2018 at 6:57 PM Eric Sunshine wrote:
> > On Mon, Sep 17, 2018 at 6:25 PM Matthew DeVore wrote:
> > > + cmp - $3
> >
> > This is just wrong. The "-" argument to 'cmp' says to read from
> > standard input, but t
On Tue, Sep 18, 2018 at 10:11 PM Matthew DeVore wrote:
> Yes, it's probably better to add a point about that. Here is the new
> documentation after applying your suggestions:
>
> - If a piped sequence which spans multiple lines, put each statement
s/which//
>on a separate line and put pipes
Hi everyone,
The 43rd edition of Git Rev News is now published:
https://git.github.io/rev_news/2018/09/19/edition-43/
Thanks a lot to the contributors: Johannes Schindelin and Luca Milanesio.!
Enjoy,
Christian, Jakub, Markus and Gabriel.
59 matches
Mail list logo