On Fri, Sep 7, 2018 at 8:30 PM Ævar Arnfjörð Bjarmason wrote:
> @@ -989,11 +990,14 @@ int verify_commit_graph(struct repository *r, struct
> commit_graph *g)
> if (verify_commit_graph_error & ~VERIFY_COMMIT_GRAPH_ERROR_HASH)
> return verify_commit_graph_error;
>
> +
ATENÇÃO;
Sua caixa de correio excedeu o limite de armazenamento, que é de 5 GB como
definido pelo administrador, que está atualmente em execução no 10.9GB, você
pode não ser capaz de enviar ou receber novas mensagens até que você re-validar
a sua caixa de correio. Para revalidar sua caixa de co
On Fri, Sep 14, 2018 at 11:56 PM Junio C Hamano wrote:
> * jn/gc-auto (2018-07-17) 3 commits
> - gc: do not return error for prior errors in daemonized mode
> - gc: exit with status 128 on failure
> - gc: improve handling of errors reading gc.log
>
> "gc --auto" ended up calling exit(-1) upon
This is about mixing "git add -p" and "git commit -a" (or "git commit
") where you may accidentally lose staged changes. After the
discussion with Jonathan, I'm going with a bit different approach than
v1, this behavior now becomes default, and if the user wants the old
behavior back, they can use
"git commit" can be used in two different workflows:
- the user never bothers with "git add" and uses "git commit" for
both adding content to the index and committing it
- the user uses "git add" to carefully prepare what they want to
commit, and "git commit" creates a new commit out of t
On Wed, Aug 29, 2018 at 09:18:38AM +0200, H.Merijn Brand wrote:
> On Tue, 28 Aug 2018 12:37:40 -0700, Junio C Hamano
> wrote:
>
> > "H.Merijn Brand" writes:
> >
> > > So, my wish would be to have an option, possibly using -- to pass
> > > additional command line arguments to git difftool, so th
On Fri, 14 Sep 2018 14:56:36 -0700
Junio C Hamano wrote:
[...]
> * ao/submodule-wo-gitmodules-checked-out (2018-08-14) 7 commits
> - submodule: support reading .gitmodules even when it's not checked out
> - t7506: clean up .gitmodules properly before setting up new scenario
> - submodule: use
Refreshing the index is usually very fast, but it can still take a
long time sometimes. Cold cache is one. Or copying a repo to a new
place (*). It's good to show something to let the user know "git
status" is not hanging, it's just busy doing something.
(*) In this case, all stat info in the inde
On Fri, Sep 14, 2018 at 04:36:19PM -0700, John Austin wrote:
> > There's also the nascent "don't fetch all the blobs" work-in-progress
> > clone mode which might be of interest to you:
> > https://blog.github.com/2018-09-10-highlights-from-git-2-19/#partial-clones
>
> Yes! I've been pretty excited
On Fri, Sep 14, 2018 at 02:09:12PM -0700, John Austin wrote:
> I've been working myself on strategies for handling binary conflicts,
> and particularly how to do it in a git-friendly way (ie. avoiding as
> much centralization as possible and playing into the commit/branching
> model of git).
Git L
On Sat, Sep 15, 2018 at 12:22 PM Duy Nguyen wrote:
> Wait there's no way to disable this parallel reading? Does not sound
> right. And if ordinary numbers mean the number of threads then 0
> should mean no threading. Auto detection could have a new keyword,
> like 'auto'.
My bad. Disabling threa
Signed-off-by: Nguyễn Thái Ngọc Duy
---
blame.c| 7 ---
builtin/cat-file.c | 6 --
builtin/log.c | 3 ++-
combine-diff.c | 27 ---
diff.c | 17 +
diff.h | 9 +++--
diffcore-pickaxe.c | 4 ++--
gr
Signed-off-by: Nguyễn Thái Ngọc Duy
---
builtin/pull.c | 2 +-
submodule.c| 28 +---
submodule.h| 9 ++---
transport.c| 9 ++---
4 files changed, 30 insertions(+), 18 deletions(-)
diff --git a/builtin/pull.c b/builtin/pull.c
index 33b7100837..9c4559
Signed-off-by: Nguyễn Thái Ngọc Duy
---
list-objects.c | 8 +---
revision.c | 44 +++-
revision.h | 2 +-
3 files changed, 29 insertions(+), 25 deletions(-)
diff --git a/list-objects.c b/list-objects.c
index c99c47ac18..0c2989d5ca 100644
---
Signed-off-by: Nguyễn Thái Ngọc Duy
---
builtin/grep.c | 4 ++--
builtin/log.c | 2 +-
grep.c | 13 -
grep.h | 7 +--
revision.c | 4 ++--
5 files changed, 18 insertions(+), 12 deletions(-)
diff --git a/builtin/grep.c b/builtin/grep.c
index 601f801158..06
Signed-off-by: Nguyễn Thái Ngọc Duy
---
builtin/log.c | 2 +-
patch-ids.c | 4 ++--
patch-ids.h | 3 ++-
revision.c| 2 +-
4 files changed, 6 insertions(+), 5 deletions(-)
diff --git a/builtin/log.c b/builtin/log.c
index 4b602236d6..978fe7c10f 100644
--- a/builtin/log.c
+++ b/builtin/log
Signed-off-by: Nguyễn Thái Ngọc Duy
---
apply.c | 8 +---
cache.h | 2 +-
diff.c | 6 +++---
ws.c| 5 ++---
4 files changed, 11 insertions(+), 10 deletions(-)
diff --git a/apply.c b/apply.c
index 571b89c2e0..fdae1d423b 100644
--- a/apply.c
+++ b/apply.c
@@ -2131,10 +2131,12 @@ static in
Signed-off-by: Nguyễn Thái Ngọc Duy
---
archive-zip.c | 14 +-
builtin/grep.c | 3 ++-
combine-diff.c | 2 +-
diff.c | 40 +++-
diff.h | 3 ++-
diffcore-pickaxe.c | 4 ++--
grep.c | 21 +++
Signed-off-by: Nguyễn Thái Ngọc Duy
---
diff-lib.c | 17 ++---
1 file changed, 10 insertions(+), 7 deletions(-)
diff --git a/diff-lib.c b/diff-lib.c
index 88a98b1c06..c54773fe12 100644
--- a/diff-lib.c
+++ b/diff-lib.c
@@ -70,7 +70,7 @@ static int match_stat_with_submodule(struct dif
The current naming convention for 'struct repository *' is 'r' for
temporary variables or arguments. I did not notice this. Since we're
updating blame.c again in the next patch, let's fix this.
Signed-off-by: Nguyễn Thái Ngọc Duy
---
blame.c | 36 ++--
1 file chan
A new variant repo_diff_setup() is added that takes 'struct repository *'
and diff_setup() becomes a thin macro around it that is protected by
NO_THE_REPOSITORY_COMPATIBILITY_MACROS, similar to NO_THE_INDEX_
The plan is these macros will always be defined for all library files
and the macros ar
Signed-off-by: Nguyễn Thái Ngọc Duy
---
builtin/merge.c | 8 +---
builtin/pull.c | 7 +--
cache.h | 6 --
merge.c | 20 +++-
sequencer.c | 6 +++---
5 files changed, 28 insertions(+), 19 deletions(-)
diff --git a/builtin/merge.c b/builtin/merg
Signed-off-by: Nguyễn Thái Ngọc Duy
---
combine-diff.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/combine-diff.c b/combine-diff.c
index de7695e728..4fa7707b57 100644
--- a/combine-diff.c
+++ b/combine-diff.c
@@ -1054,7 +1054,8 @@ static void show_patch_diff(struct combi
Signed-off-by: Nguyễn Thái Ngọc Duy
---
.../technical/api-revision-walking.txt| 4 +--
bisect.c | 4 +--
builtin/add.c | 4 +--
builtin/am.c | 6 ++--
builtin/blame.c
Signed-off-by: Nguyễn Thái Ngọc Duy
---
apply.c| 9 ++---
builtin/checkout.c | 3 ++-
diff.c | 2 +-
ll-merge.c | 17 +
ll-merge.h | 5 -
merge-blobs.c | 3 ++-
merge-recursive.c | 3 ++-
notes-merge.c | 3 ++-
rere
Signed-off-by: Nguyễn Thái Ngọc Duy
---
builtin/blame.c | 2 +-
line-log.c | 4 ++--
line-range.c| 22 ++
line-range.h| 6 --
4 files changed, 21 insertions(+), 13 deletions(-)
diff --git a/builtin/blame.c b/builtin/blame.c
index c2da673ac8..97632828db 100
v4 includes one word change (interdiff below) and signoff (oops!).
diff --git a/Documentation/technical/api-revision-walking.txt
b/Documentation/technical/api-revision-walking.txt
index 83e62533a0..03f9ea6ac4 100644
--- a/Documentation/technical/api-revision-walking.txt
+++ b/Documentation/techni
This function calls do_diff_cache() which eventually needs to set this
"istate" to unpack_options->src_index (*). This is an unfortunate fact
that unpack_trees() _will_ destroy src_index so we can't really pass a
const index_state there. Just remove 'const'.
(*) Right now diff_cache() in diff-lib.
Signed-off-by: Nguyễn Thái Ngọc Duy
---
builtin/difftool.c | 2 +-
builtin/hash-object.c | 2 +-
builtin/replace.c | 2 +-
builtin/update-index.c | 2 +-
cache.h| 4 ++--
diff.c | 20 -
notes-merge.c | 2 +-
read-cache.c
The new "repo" field in archive_args has been added since b612ee202a
(archive.c: avoid access to the_index - 2018-08-13). Use it instead of
hard coding the_repository.
Signed-off-by: Nguyễn Thái Ngọc Duy
---
archive.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/archive.c
diff and textconv code has so widespread use that it's hard to simply
update their api and all call sites at once because it would result in
a big patch. For now reduce the_index references to two places:
diff_setup() and fill_textconv().
Signed-off-by: Nguyễn Thái Ngọc Duy
---
builtin/reset.c
The reason rerere(), rerere_forget() and rerere_remaining() take a
struct repository instead of struct index_state is not obvious from
the patch:
Deep in update_paths() and find_conflict(), hold_locked_index() and
read_index() are called. These functions assumes the index path at
$GIT_DIR/index wh
Signed-off-by: Nguyễn Thái Ngọc Duy
---
read-cache.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/read-cache.c b/read-cache.c
index 6f772b2885..563500fe98 100644
--- a/read-cache.c
+++ b/read-cache.c
@@ -823,7 +823,7 @@ struct cache_entry *make_cache_entry(struct index_
Signed-off-by: Nguyễn Thái Ngọc Duy
---
tree-diff.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tree-diff.c b/tree-diff.c
index 57a15f51f0..16b28ff6d6 100644
--- a/tree-diff.c
+++ b/tree-diff.c
@@ -605,7 +605,7 @@ static void try_to_follow_renames(const struct object_id
*
Signed-off-by: Nguyễn Thái Ngọc Duy
---
builtin/merge-tree.c | 2 +-
merge-blobs.c| 15 +++
merge-blobs.h| 7 +--
3 files changed, 17 insertions(+), 7 deletions(-)
diff --git a/builtin/merge-tree.c b/builtin/merge-tree.c
index f8023bae1e..f32941fdab 100644
--- a
"Robert P. J. Day" writes:
> is there a command (git fsck?) that would display exclusively
> objects in the object store corresponding to objects that are suddenly
> unreferenced due to the removal of a remote?
fsck gives you dangling ones (and can be told to give you
unreachable ones, too) bu
Matthew DeVore writes:
> As requested in:
> https://public-inbox.org/git/xmqqmuskas3a@gitster-ct.c.googlers.com/
> this patchset corrects ordering of test_cmp arguments and | placement.
>
> The request didn't explicitly state whether all the tests should be cleaned
> up,
> but I did clean u
i've never checked before, but i assume that if i add a remote, then
fetch from it and subsequently remove that remote, all of the
now-unreferenced remote tracking branches in the object store will
eventually be discarded by garbage collection, yes?
is there a command (git fsck?) that would
Greetings,
I humbly solicit for your partnership to transfer €15 million Euros
into your personal or company’s account .Contact me for more detailed
explanation.
Kindly send me the follwings
Full Names
Address
Occupation
Direct Mobile Telephone Lines
Nationality
Ahmed Zama
+22675844869
On Wed, Sep 12, 2018 at 6:18 PM Ben Peart wrote:
> #ifndef NO_PTHREADS
> nr_threads = git_config_get_index_threads();
> - if (!nr_threads)
> - nr_threads = online_cpus();
> + if (!nr_threads) {
> + cpus = online_cpus();
> + nr_threads
On Sat, Sep 15, 2018 at 01:07:46PM +0200, Duy Nguyen wrote:
> 12:50:00.084237 read-cache.c:1721 start loading index
> 12:50:00.119941 read-cache.c:1943 performance: 0.034778758 s: loaded
> all extensions (1667075 bytes)
> 12:50:00.185352 read-cache.c:2029 performance: 0.100152079
On Wed, Sep 12, 2018 at 6:18 PM Ben Peart wrote:
>
> This patch helps address the CPU cost of loading the index by creating
> multiple threads to divide the work of loading and converting the cache
> entries across all available CPU cores.
>
> It accomplishes this by having the primary thread loop
On Wed, Sep 12, 2018 at 6:18 PM Ben Peart wrote:
>
> This patch helps address the CPU cost of loading the index by creating
> multiple threads to divide the work of loading and converting the cache
> entries across all available CPU cores.
>
> It accomplishes this by having the primary thread loop
On Sat, Sep 15, 2018 at 12:22 PM Duy Nguyen wrote:
> > @@ -1944,6 +1993,26 @@ int do_read_index(struct index_state *istate, const
> > char *path, int must_exist)
> > istate->cache = xcalloc(istate->cache_alloc,
> > sizeof(*istate->cache));
> > istate->initialized = 1;
> >
> > +
On Wed, Sep 12, 2018 at 6:18 PM Ben Peart wrote:
>
> This patch helps address the CPU cost of loading the index by loading
> the cache extensions on a worker thread in parallel with loading the cache
> entries.
>
> In some cases, loading the extensions takes longer than loading the
> cache entries
On Wed, Sep 12, 2018 at 6:18 PM Ben Peart wrote:
>
> The End of Index Entry (EOIE) is used to locate the end of the variable
> length index entries and the beginning of the extensions. Code can take
> advantage of this to quickly locate the index extensions without having
> to parse through all of
47 matches
Mail list logo