The commits in state:filter.map have already been processed, so don't
filter them again. This makes incremental git filter-branch much faster.
Also add tests for --state-branch option.
Signed-off-by: Michael Barabanov
---
git-filter-branch.sh | 3 +++
t/t7003-filter-branch.sh | 15
Could you act as the beneficiary to claim 9.8M USD that my bank wants
to confiscate? I will give you 50% and Every documentation would be
put in placed.
Mr Ubaithullah from Hong Kong.
A bit of an amusing edge case.
I'm not exactly sure the correct approach to fix this but here's my
reproduction, triage, and a few potential options I see.
Note that after the username prompt, I pressed ^D
$./prefix/bin/git --version
git version 2.18.0
$ PATH=$PWD/prefix/bin:$PATH git clone
http
Hi,
Brandon Williams wrote:
> Implement ref-in-want on the client side so that when a server supports
> the "ref-in-want" feature, a client will send "want-ref" lines for each
> reference the client wants to fetch.
>
> Signed-off-by: Brandon Williams
> ---
> fetch-pack.c |
On Fri, Jun 22, 2018 at 06:34:28PM -0400, Eric Sunshine wrote:
> I wonder if it would be better and cleaner to limit the visibility of
> this change to cmd_branch(), rather than spreading it across a global
> variable, a callback function, and cmd_branch(). Perhaps, like this:
I'd prefer that, to
This seems to break the documentation build rather badly; I have a
monkey-fix queued at the tip fo the topic branch for tonight's push.
On Fri, Jun 22, 2018 at 05:24:14AM -0400, Jeff King wrote:
> Let's deprecate "-l" in hopes of eventually re-purposing it
> to "--list".
>
> Signed-off-by: Jeff King
> ---
> diff --git a/builtin/branch.c b/builtin/branch.c
> @@ -36,6 +36,7 @@ static const char * const builtin_branch_usage[] = {
> +
Hi,
Brandon Williams wrote:
> On 06/14, Stefan Beller wrote:
> > On Wed, Jun 13, 2018 at 2:39 PM Brandon Williams wrote:
>>> + for (r = refs; r; r = r->next) {
>>> + if (!strcmp(end, r->name)) {
>>> + oidcpy(&r->old_oid, &oid);
>>
On Fri, Jun 22, 2018 at 11:45:09PM +0200, Johannes Schindelin wrote:
> > This might be a candidate for another "weather balloon" patch to see if
> > anybody complains, though. The last time time we dealt with this in a
> > major way was over 7 years ago in 28bd70d811 (unbreak and eliminate
> > NO_
Hi Peff,
On Thu, 21 Jun 2018, Jeff King wrote:
> On Thu, Jun 21, 2018 at 07:53:02AM -0400, Jeff King wrote:
>
> > > @@ -1429,7 +1447,7 @@ static void show_line(struct grep_opt *opt, char
> > > *bol, char *eol,
> > >*/
> > > if (opt->columnnum && cno) {
> > > char buf[32];
> > >
Brandon Williams wrote:
> --- a/builtin/fetch.c
> +++ b/builtin/fetch.c
> @@ -967,10 +967,16 @@ static int fetch_refs(struct transport *transport,
> struct ref *ref_map)
> int ret = quickfetch(ref_map);
> if (ret)
> ret = transport_fetch_refs(transport, ref_map);
> -
Hi,
Brandon Williams wrote:
> [Subject: fetch: refactor fetch_refs into two functions]
>
> Refactor the fetch_refs function into a function that does the fetching
> of refs and another function that stores them.
>
> Signed-off-by: Brandon Williams
> ---
> builtin/fetch.c | 19 +-
On 06/22, Antonio Ospite wrote:
> On Fri, 22 Jun 2018 10:13:10 -0700
> Brandon Williams wrote:
>
> [...]
> > Thanks for working on this. I think its a good approach and the end
> > result makes it much harder for arbitrary config to sneak back in to the
> > .gitmodules file. And after this ser
Hi,
Brandon Williams wrote:
> Add an 'unpack-sideband' subcommand to the test-pkt-line helper to
> enable unpacking packet line data sent multiplexed using a sideband.
>
> Signed-off-by: Brandon Williams
> ---
> t/helper/test-pkt-line.c | 33 +
> 1 file changed,
On Fri, Jun 22, 2018 at 1:45 PM Marc Strapetz wrote:
>
> On 22.06.2018 19:36, Johannes Sixt wrote:
> > Am 22.06.2018 um 14:04 schrieb Marc Strapetz:
> >> On Windows, when creating following repository:
> >>
> >> $ git init
> >> $ echo "1" > file.txt
> >> $ git add .
> >> $ git commit -m "initial i
Hi Junio,
Le 22/06/2018 à 18:27, Junio C Hamano a écrit :
> Alban Gruin writes:
> > This rewrites (the misnamed) setup_reflog_action() from shell to C. The
> > new version is called checkout_base_commit().
>
> ;-) on the "misnamed" part. Indeed, setting up the comment for the
> reflog entry is
Hi Junio,
Le 22/06/2018 à 00:03, Junio C Hamano a écrit :
> Alban Gruin writes:
> > This adds a new function, run_command_silent_on_success(), to
> > redirect the stdout and stderr of a command to a strbuf, and then to run
> > that command. This strbuf is printed only if the command fails. It is
Jonathan Nieder wrote:
> Josh Steadmon wrote:
>> HTTP servers return 400 if you send headers before the GET request.
[...]
> Tested using
>
> openssl s_client -connect github.com:443
>
> with input
>
> GET /git/git/info/refs?service=git-upload-pack HTTP/1.0
> Host: github.com
> Git-Protoco
On 22.06.2018 19:36, Johannes Sixt wrote:
Am 22.06.2018 um 14:04 schrieb Marc Strapetz:
On Windows, when creating following repository:
$ git init
$ echo "1" > file.txt
$ git add .
$ git commit -m "initial import"
$ ren file.txt File.txt
$ git config core.ignorecase false
This is a user error
On Fri, 22 Jun 2018 10:13:10 -0700
Brandon Williams wrote:
[...]
> Thanks for working on this. I think its a good approach and the end
> result makes it much harder for arbitrary config to sneak back in to the
> .gitmodules file. And after this series it looks like you should be in
> a good pl
Josh Steadmon wrote:
> HTTP servers return 400 if you send headers before the GET request.
>
> Signed-off-by: Josh Steadmon
> ---
> Documentation/technical/protocol-v2.txt | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
Thanks. Congrats on your first patch! ;-)
Tested using
opens
HTTP servers return 400 if you send headers before the GET request.
Signed-off-by: Josh Steadmon
---
Documentation/technical/protocol-v2.txt | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/Documentation/technical/protocol-v2.txt
b/Documentation/technical/protocol-v2.txt
in
On 6/9/2018 2:13 PM, Duy Nguyen wrote:
On Thu, Jun 7, 2018 at 4:07 PM Derrick Stolee wrote:
If a 'git repack' command replaces existing packfiles, then we must
clear the existing multi-pack-index before moving the packfiles it
references.
I think there are other places where we add or remove p
On 6/9/2018 2:03 PM, Duy Nguyen wrote:
On Thu, Jun 7, 2018 at 4:06 PM Derrick Stolee wrote:
Signed-off-by: Derrick Stolee
---
packfile.c | 5 -
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/packfile.c b/packfile.c
index 638e113972..059b2aa097 100644
--- a/packfile.c
+++ b
On 6/9/2018 2:01 PM, Duy Nguyen wrote:
On Thu, Jun 7, 2018 at 4:06 PM Derrick Stolee wrote:
@@ -565,8 +632,11 @@ static void find_abbrev_len_for_pack(struct packed_git *p,
static void find_abbrev_len_packed(struct min_abbrev_data *mad)
{
+ struct midxed_git *m;
struct packed
On 6/22/2018 2:31 PM, Junio C Hamano wrote:
Derrick Stolee writes:
The index extension documentation doesn't appear to be clear about
which extensions are optional or required, but it seems the
split-index is the only "required" one and uses lowercase for its
extension id.
read-cache.c::
Derrick Stolee writes:
> The index extension documentation doesn't appear to be clear about
> which extensions are optional or required, but it seems the
> split-index is the only "required" one and uses lowercase for its
> extension id.
read-cache.c::
/* Index extensions.
*
* The
On 6/21/2018 1:38 PM, Junio C Hamano wrote:
Derrick Stolee writes:
On 6/7/2018 2:26 PM, Duy Nguyen wrote:
On Thu, Jun 7, 2018 at 4:03 PM, Derrick Stolee wrote:
@@ -74,6 +80,31 @@ struct midxed_git *load_midxed_git(const char *object_dir)
m->num_chunks = *(m->data + 6);
m
Am 22.06.2018 um 14:04 schrieb Marc Strapetz:
On Windows, when creating following repository:
$ git init
$ echo "1" > file.txt
$ git add .
$ git commit -m "initial import"
$ ren file.txt File.txt
$ git config core.ignorecase false
This is a user error. core.ignorecase is *not* an instruction a
> On 6/21/2018 7:06 PM, Jonathan Tan wrote:
> >>> diff --git a/commit.c b/commit.c
> >>> index 0030e79940..38c12b002f 100644
> >>> --- a/commit.c
> >>> +++ b/commit.c
> >>> @@ -317,7 +317,7 @@ struct tree *get_commit_tree(const struct commit
> >>> *commit)
> >>> if (commit->graph_pos == C
On 06/22, Antonio Ospite wrote:
> Hi,
>
> when I tried to reuse and extend 'config_from_gitmodules' in
> https://public-inbox.org/git/20180514105823.8378-2-...@ao2.it/ it was
> pointed out to me that special care is needed to make sure that this
> function does not get abused to bring in arbitrary
> I'm waiting for sb/object-store-lookup to be in 'next' before I re-roll
> that branch. If you're not in a rush to send this series, perhaps wait
> for the next version here.
Did you mean another branch? I'm looking at
https://github.com/gitster/git right now, and I see
sb/object-store{,-alloc,
On 06/22, Antonio Ospite wrote:
> Use one callback per configuration setting to handle the generic options
> which have to be supported for backward compatibility.
>
> This removes some duplication and some support code at the cost of
> parsing the .gitmodules file twice when calling the fetch com
On 06/22, Antonio Ospite wrote:
> Reuse config_from_gitmodules in repo_read_gitmodules to remove some
> duplication and also have a single point where the .gitmodules file is
> read.
>
> The change does not introduce any new behavior, the same gitmodules_cb
> config callback is still used which on
On 06/22, Antonio Ospite wrote:
> Add a helper function to make it clearer that retrieving 'update-clone'
> configuration from the .gitmodules file is a special case supported
> solely for backward compatibility purposes.
>
> This change removes one direct use of 'config_from_gitmodules' for
> opt
On 06/22, Antonio Ospite wrote:
> diff --git a/submodule-config.c b/submodule-config.c
> index b431555db..ef292eb7c 100644
> --- a/submodule-config.c
> +++ b/submodule-config.c
> @@ -688,3 +688,31 @@ void config_from_gitmodules(config_fn_t fn, void *data)
> free(file);
> }
> }
Reuse config_from_gitmodules in repo_read_gitmodules to remove some
duplication and also have a single point where the .gitmodules file is
read.
The change does not introduce any new behavior, the same gitmodules_cb
config callback is still used which only deals with configuration
specific to subm
Add a helper function to make it clearer that retrieving 'update-clone'
configuration from the .gitmodules file is a special case supported
solely for backward compatibility purposes.
This change removes one direct use of 'config_from_gitmodules' for
options not strictly related to submodules: "su
Hi,
when I tried to reuse and extend 'config_from_gitmodules' in
https://public-inbox.org/git/20180514105823.8378-2-...@ao2.it/ it was
pointed out to me that special care is needed to make sure that this
function does not get abused to bring in arbitrary configuration stored
in the .gitmodules fil
Alban Gruin writes:
> This rewrites (the misnamed) setup_reflog_action() from shell to C. The
> new version is called checkout_base_commit().
;-) on the "misnamed" part. Indeed, setting up the comment for the
reflog entry is secondary to what this function wants to do, which
is to check out the
Add a helper function to make it clearer that retrieving 'fetch'
configuration from the .gitmodules file is a special case supported
solely for backward compatibility purposes.
This change removes one direct use of 'config_from_gitmodules' in code
not strictly related to submodules, in the effort
Generlize config_from_gitmodules to accept a repository as an argument.
This is in preparation to reuse the function in repo_read_gitmodules in
order to have a single point where the '.gitmodules' file is accessed.
Signed-off-by: Antonio Ospite
---
submodule-config.c | 10 +-
1 file cha
Use one callback per configuration setting to handle the generic options
which have to be supported for backward compatibility.
This removes some duplication and some support code at the cost of
parsing the .gitmodules file twice when calling the fetch command.
Signed-off-by: Antonio Ospite
---
The .gitmodules file is not meant as a place to store arbitrary
configuration to distribute with the repository.
Move config_from_gitmodules() out of config.c and into
submodule-config.c to make it even clearer that it is not a mechanism to
retrieve arbitrary configuration from the .gitmodules fil
Now that 'config_from_gitmodules' is not used in the open, it can be
marked as private.
Hopefully this will prevent its usage for retrieving arbitrary
configuration form the '.gitmodules' file.
Signed-off-by: Antonio Ospite
---
submodule-config.c | 8
submodule-config.h | 12 +
To support git-grep(1)'s new option, '--column', document and teach
grep.c how to interpret relevant configuration options, similar to those
associated with '--line-number'.
Signed-off-by: Taylor Blau
---
Documentation/config.txt | 5 +
Documentation/git-grep.txt | 3 +++
grep.c
Take advantage of 'git-grep(1)''s new option, '--column' in order to
teach Peff's 'git-jump' script how to jump to the correct column for any
given match.
'git-grep(1)''s output is in the correct format for Vim's jump list, so
no additional cleanup is necessary.
Signed-off-by: Taylor Blau
---
c
To prepare for 'git grep' learning '--column', teach grep.c's
show_line() how to show the column of the first match on non-context
lines.
Signed-off-by: Taylor Blau
---
grep.c | 33 -
1 file changed, 28 insertions(+), 5 deletions(-)
diff --git a/grep.c b/grep.c
i
Teach 'git-grep(1)' a new option, '--column', to show the column
number of the first match on a non-context line. This makes it possible
to teach 'contrib/git-jump/git-jump' how to seek to the first matching
position of a grep match in your editor, and allows similar additional
scripting capabiliti
To support showing the matched column when calling 'git-grep(1)', teach
'grep_opt' the normal set of options to configure the default behavior
and colorization of this feature.
Now that we have opt->columnnum, use it to disable short-circuiting over
ORs and ANDs so that col and icol are always fil
Hi,
Attached is my third--anticipate the final--re-roll of my series to
teach 'git grep --column'.
Since the last time, only a couple of things have changed at Peff's
suggestions in [1]. The changes are summarized here, and an inter-diff
is available below:
- Change "%zu" to PRIuMAX (and an ap
lineNumber has casing that is inconsistent with surrounding options,
like color.grep.matchContext, and color.grep.matchSelected. Re-case this
documentation in order to be consistent with the text around it, and to
ensure that new entries are consistent, too.
Signed-off-by: Taylor Blau
---
Docume
When calling match_line(), callers presently cannot determine the
relative offset of the match because match_line() discards the
'regmatch_t' that contains this information.
Instead, teach match_line() to take in two 'ssize_t's. Fill the first
with the offset of the match produced by the given exp
Dear Sir/Madam,
Greetings from United Arab Emirate(U.A.E)Dubai,i am banker with a confidential
project which i need to solicite your cooperation.
Please reply to enable me send you the complete details about this project.
Best Regards,
Mr.Thomas Pereira
This will enable users to implement bisecting on first parents
which can be useful for when the commits from a feature branch
that we want to merge are not always tested.
Signed-off-by: Tiago Botelho
---
This patch resolves every issue with the unit tests.
The bug detected by Junio regarding d
On Windows, when creating following repository:
$ git init
$ echo "1" > file.txt
$ git add .
$ git commit -m "initial import"
$ ren file.txt File.txt
$ git config core.ignorecase false
Status results are:
$ git status --porcelain
?? File.txt
As on Unix, I would expect to see:
$ git status --p
Dear Git users,
It is my pleasure to announce that Git for Windows 2.18.0 is available from:
https://gitforwindows.org/
Changes since Git for Windows v2.17.1(2) (May 29th 2018)
New Features
* Comes with Git v2.18.0.
* Comes with Git Credential Manager v1.16.2.
Bug Fixes
* The d
The other "mode" options of git-branch have short-option
aliases that are easy to type (e.g., "-d" and "-m"). Let's
give "--list" the same treatment.
This also makes it consistent with the similar "git tag -l"
option.
We didn't do this originally because "--create-reflog" was
squatting on the "-l
The "-l" option is short for "--create-reflog". This has
caused much confusion over the years. Most people expect it
to work as "--list", because that would match the other
"mode" options like -d/--delete and -m/--move, as well as
the similar -l/--list option of git-tag.
Adding to the confusion, u
This test checks that the "-l" option creates a reflog. But
in fact we'd create one even without it, since the default
in a non-bare repository is to do so. Let's unset the config
so we can be sure our "-l" option is kicking in.
Note that we can't do this with test_config, since that
would leave t
In preparation for deprecating "-l", let's make sure we're
using the recommended option ourselves.
This patch just mechanically converts "branch -l" to "branch
--create-reflog". Note that with the exception of the
actual "--create-reflog" test, we could actually remove "-l"
entirely from most of
This series replaces the contents of jk/branch-l-0-deprecation,
jk/branch-l-1-removal, and jk/branch-l-2-reincarnation.
It implements the idea discussed in the subthread in:
https://public-inbox.org/git/xmqqzi0hety4@gitster-ct.c.googlers.com/
Namely that "branch -l" would warn about deprec
Junio C Hamano writes:
> Sergey Organov writes:
>
>> When cherry-picking multiple commits, it's impossible to have both
>> merge- and non-merge commits on the same command-line. Not specifying
>> '-m 1' results in cherry-pick refusing to handle merge commits, while
>> specifying '-m 1' fails on
> @@ -487,6 +510,52 @@ recreates the topic branch with fresh commits so it can
> be remerged
> successfully without needing to "revert the reversion" (see the
> link:howto/revert-a-faulty-merge.html[revert-a-faulty-merge How-To] for
> details).
>
> +INCOMPATIBLE OPTIONS
> +-
> When an error occurs in updating the working tree of a submodule in
> submodule_move_head, tell the user which submodule the error occurred in.
>
> The call to read-tree contains a super-prefix, such that the read-tree
> will correctly report any path related issues, but some error messages
>
Hello Dear Friend I have a business proposal for you which involves a
huge amount of money that run into millions of US dollars that i want
to transfer to your country for safe keeping and investment this is
not a spam, its a real business that will benefit both of us. Please
try as much as possibl
On Fri, Jun 22, 2018 at 2:50 AM Ville Skyttä wrote:
> Signed-off-by: Ville Skyttä
> ---
> diff --git a/Documentation/config.txt b/Documentation/config.txt
> @@ -354,7 +354,7 @@ advice.*::
> ignoredHook::
> - Advice shown if an hook is ignored because the hook is not
> +
On Thu, Jun 21, 2018 at 04:45:49PM -0500, Taylor Blau wrote:
> > but not this:
> >
> > $ ./git grep --column -v --not -e scalable --and --not -e fast --
> > README.md
> > README.md:13:Git - fast, scalable, distributed revision control system
> > README.md:16:Git is a fast, scalable, distrib
68 matches
Mail list logo