Karthik Nayak writes:
> On 06/01/2015 02:16 AM, Matthieu Moy wrote:
>> Karthik Nayak writes:
>>
>> > That is kind of a problem, If I need to swap those commits also, I'd
>> > have to add the part where ref-filter is added to the Makefile with
>> > the code movement from for-each-ref to ref-filte
Christian Couder writes:
> sort_refs() -> ref_array_sort()
> struct ref_sort -> struct ref_sort_criteria
> default_sort() -> ref_default_sort_criteria()
> opt_parse_sort() -> opt_parse_ref_sort_criteria()
BTW, having such summary in the log message would help review: we could
think and discuss t
Signed-off-by: Brett Randall
---
Documentation/git-svn.txt | 3 +++
1 file changed, 3 insertions(+)
diff --git a/Documentation/git-svn.txt b/Documentation/git-svn.txt
index 11d1e2f..0c0f60b 100644
--- a/Documentation/git-svn.txt
+++ b/Documentation/git-svn.txt
@@ -174,6 +174,9 @@ Skip "branches"
On Sun, May 31, 2015 at 6:29 PM, Eric Sunshine wrote:
> Replace unnecessarily complex regular expression for recognizing comment
> and blanks lines in sendmail aliases with idiomatic expressions which
s/blanks/blank/
> can be easily understood at a glance.
>
> Signed-off-by: Eric Sunshine
> ---
On Sun, May 31, 2015 at 10:36:52AM +0100, John Lee wrote:
> On Sat, 30 May 2015, David Aguilar wrote:
>
> >On Tue, May 26, 2015 at 09:50:49PM +0100, John Lee wrote:
> >>Hi
> >>
> >>Does anybody have code to stage commits using a the visual
> >>diff/merge tools supported by git-difftool? Is there
On Mon, Jun 01, 2015 at 09:17:59AM +0900, Greg KH wrote:
> Hi all,
>
> I received the patch attached below as part of a submission against the
> Linux kernel tree. The patch seems to have been hand-edited, and is not
> correct, and patch verifies this as being a problem:
>
> $ patch -p1 --dry-ru
format-patch would segfault if provided a tag as one of the range
endpoints in conjunction with --ignore-if-in-upstream, as it assumed the
object was a commit and attempted to cast it to struct commit.
Dereference the tag as soon as possible to prevent this, but not until
after copying the necessar
Hi all,
I received the patch attached below as part of a submission against the
Linux kernel tree. The patch seems to have been hand-edited, and is not
correct, and patch verifies this as being a problem:
$ patch -p1 --dry-run < bad_patch.mbox
checking file drivers/staging/rtl8192u/ieee80211/ie
On Mon, Jun 1, 2015 at 1:53 AM, Christian Couder
wrote:
> On Mon, Jun 1, 2015 at 1:14 AM, Christian Couder
> wrote:
>> On Sun, May 31, 2015 at 10:45 PM, Bruce Korb wrote:
>>> Oh, you can also clone the gnu-pw-mgr and likely get the same result:
>>
>> Yeah, after cloning from http://git.savannah.
On Mon, Jun 1, 2015 at 1:14 AM, Christian Couder
wrote:
> On Sun, May 31, 2015 at 10:45 PM, Bruce Korb wrote:
>> Oh, you can also clone the gnu-pw-mgr and likely get the same result:
>
> Yeah, after cloning from http://git.savannah.gnu.org/r/gnu-pw-mgr.git
> I get the following backtrace:
>
> Pro
When --patch or pathspecs are passed to git checkout, the working tree
will not be switching branch, so there's no need to check if the branch
that we are running checkout on is already checked out.
Signed-off-by: Spencer Baugh
---
builtin/checkout.c | 1 +
1 file changed, 1 insertion(+)
diff -
On Sun, May 31, 2015 at 10:45 PM, Bruce Korb wrote:
> Oh, you can also clone the gnu-pw-mgr and likely get the same result:
Yeah, after cloning from http://git.savannah.gnu.org/r/gnu-pw-mgr.git
I get the following backtrace:
Program received signal SIGSEGV, Segmentation fault.
0x004b26b1
On Sun, May 31, 2015 at 10:50 PM, Karthik Nayak wrote:
> On 06/01/2015 02:16 AM, Matthieu Moy wrote:
>>
>> You can have a preparatory patch that adds ref-filter.c containing just
>> "#include ref-filter.h" and ref-filter.h with proper content. After this
>> preparatory patch, you're in a rather si
Signed-off-by: Eric Sunshine
---
git-send-email.perl | 17 +
1 file changed, 5 insertions(+), 12 deletions(-)
diff --git a/git-send-email.perl b/git-send-email.perl
index 0b18682..1380e6e 100755
--- a/git-send-email.perl
+++ b/git-send-email.perl
@@ -517,22 +517,15 @@ my %parse_a
The sendmail aliases parser inlined into %parse_alias is already
uncomfortably large and is expected to grow as additional functionality
is implemented, so extract it to improve manageability.
Signed-off-by: Eric Sunshine
---
git-send-email.perl | 38 --
1 fil
A line beginning with whitespace is folded into the preceding line.
A line ending with '\' consumes the following line.
While here, also test an empty sendmail aliases file.
Signed-off-by: Eric Sunshine
---
t/t9001-send-email.sh | 34 ++
1 file changed, 34 insert
Several new tests of sendmail aliases parsing will be added in a
subsequent patch, so factor out functionality common to all of them
into a new helper function.
Signed-off-by: Eric Sunshine
---
t/t9001-send-email.sh | 47 +--
1 file changed, 29 inserti
Replace unnecessarily complex regular expression for recognizing comment
and blanks lines in sendmail aliases with idiomatic expressions which
can be easily understood at a glance.
Signed-off-by: Eric Sunshine
---
git-send-email.perl | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --
Logical lines in sendmail aliases files can be spread over multiple
physical lines[1]. A line beginning with whitespace is folded into the
preceding line. A line ending with '\' consumes the following line.
[1]: https://www.freebsd.org/cgi/man.cgi?query=aliases&sektion=5
Signed-off-by: Eric Sunsh
Signed-off-by: Eric Sunshine
---
git-send-email.perl | 5 -
1 file changed, 5 deletions(-)
diff --git a/git-send-email.perl b/git-send-email.perl
index 819f87e..0b18682 100755
--- a/git-send-email.perl
+++ b/git-send-email.perl
@@ -517,26 +517,21 @@ my %parse_alias = (
This series adds line continuation support for sendmail aliases.
It extends basic sendmail aliases functionality implemented by
ah/send-email-sendmail-alias (currently d1205b07 in 'pu')
Eric Sunshine (9):
send-email: further document missing sendmail aliases functionality
send-email: visually
Sendmail aliases[1] supports expansion to a file ("/path/name") or
pipe ("|command"), as well as file inclusion (":include: /path/name"),
however, our implementation does not support such functionality.
[1]: https://www.freebsd.org/cgi/man.cgi?query=aliases&sektion=5
Signed-off-by: Eric Sunshine
Although emitted to stderr, warnings from the sendmail aliases parser
are not visually distinguished as such, and thus can easily be
overlooked in the normal noisy send-email output.
Signed-off-by: Eric Sunshine
---
This prepends lowercase "warning:" rather than uppercase since lowercase
is used
On 06/01/2015 02:16 AM, Matthieu Moy wrote:
Karthik Nayak writes:
> That is kind of a problem, If I need to swap those commits also, I'd
> have to add the part where ref-filter is added to the Makefile with
> the code movement from for-each-ref to ref-filter. This again will not
> just be Code
Karthik Nayak writes:
> That is kind of a problem, If I need to swap those commits also, I'd
> have to add the part where ref-filter is added to the Makefile with
> the code movement from for-each-ref to ref-filter. This again will not
> just be Code movement.
You can have a preparatory patch th
Oh, you can also clone the gnu-pw-mgr and likely get the same result:
$ cat .git/config
[core]
repositoryformatversion = 0
filemode = true
bare = false
logallrefupdates = true
[remote "origin"]
fetch = +refs/heads/*:refs/remotes/origin/*
url = ssh://
bt won't help much:
Program received signal SIGSEGV, Segmentation fault.
0x0047e62f in ?? ()
(gdb) bt
#0 0x0047e62f in ?? ()
#1 0x0047e6ba in ?? ()
#2 0x0043cb9a in ?? ()
#3 0x0043e9cc in ?? ()
#4 0x0040647d in ?? ()
#5 0x00405863 in ??
Junio C Hamano writes:
> Karthik Nayak writes:
>
>> /*
>> + * Given a refname, return 1 if the refname matches with one of the patterns
>> + * while the pattern is a pathname like 'refs/tags' or 'refs/heads/master'
>> + * and so on, else return 0. Supports use of wild characters.
>> + */
>> +st
On Sun, May 31, 2015 at 9:13 PM, Bruce Korb wrote:
> $ git format-patch -o patches --ignore-if-in-upstream
> 14949fa8f39d29e44b43f4332ffaf35f11546502..2de9eef391259dfc8748dbaf76a5d55427f37b0d
> Segmentation fault
> /u/gnu/proj/gnu-pw-mgr
> $ git format-patch -o patches
> 14949fa8f39d29e44b43f4332f
On 05/31/2015 11:18 PM, Junio C Hamano wrote:
Karthik Nayak writes:
/*
- * A call-back given to for_each_ref(). Filter refs and keep them for
+ * A call-back given to for_each_ref(). Filter refs and keep them for
* later object processing.
*/
-static int grab_single_ref(const char *re
Complement existing --show-email option with fallback
configuration variable, with tests.
Signed-off-by: Quentin Neill
---
Documentation/git-blame.txt | 2 ++
builtin/blame.c | 10 +++-
t/t8002-blame.sh| 62 +
3 files chang
On Sun, May 31, 2015 at 1:13 PM, Junio C Hamano wrote:
> Quentin Neill writes:
>
>> From: Quentin Neill
>>
>> Complement existing --show-email option with fallback
>> configuration variable, with tests.
>> ---
>
> The patch itself looks very reasonable. Thanks for getting back to
> us ;-)
>
> A
$ git format-patch -o patches --ignore-if-in-upstream
14949fa8f39d29e44b43f4332ffaf35f11546502..2de9eef391259dfc8748dbaf76a5d55427f37b0d
Segmentation fault
/u/gnu/proj/gnu-pw-mgr
$ git format-patch -o patches
14949fa8f39d29e44b43f4332ffaf35f11546502..2de9eef391259dfc8748dbaf76a5d55427f37b0d
patc
Make strbuf_read not try to do read_in_full's job too. If xread returns
less than was requested it can be either eof or an interrupted read. If
read_in_full returns less than was requested, it's eof. Use read_in_full
to detect eof and not iterate when eof has been seen.
Signed-off-by: Jim Hill
These patches address
http://thread.gmane.org/gmane.comp.version-control.git/269050/focus=269415
linked from the git blame page, avoiding adding duplicates to info/alternates
and removing hold_lock_file_for_append which is too heavyweight for logging and
too limited for anything else.
There's an a
No uses of hold_lock_file_for_append remain, so remove it.
hold_lock_file_for_append copies its target file internally. This makes
it too heavyweight for logging and too limited for anything else. It
shouldn't be used.
Signed-off-by: Jim Hill
---
lockfile.c | 38 ---
Check for an existing match before appending a path to the alternates
file. Beyond making git look smart to anyone checking the alternates
file, this removes the last use of hold_lock_file_for_append.
Signed-off-by: Jim Hill
---
sha1_file.c| 29 +
t/t
Quentin Neill writes:
> From: Quentin Neill
>
> Complement existing --show-email option with fallback
> configuration variable, with tests.
> ---
The patch itself looks very reasonable. Thanks for getting back to
us ;-)
A few minor nits:
- Your in-body "From:" is redundant and unnecessar
Christian Couder writes:
> On Sat, May 30, 2015 at 7:53 PM, Karthik Nayak wrote:
>>
>> -static void sort_refs(struct ref_sort *sort, struct ref_array *array)
>> +void sort_ref_array(struct ref_sort *sort, struct ref_array *array)
>
> It is probably better to call the above function ref_array_sor
Karthik Nayak writes:
> /*
> - * A call-back given to for_each_ref(). Filter refs and keep them for
> + * A call-back given to for_each_ref(). Filter refs and keep them for
> * later object processing.
> */
> -static int grab_single_ref(const char *refname, const unsigned char *sha1,
> int
On 05/31/2015 11:07 PM, Junio C Hamano wrote:
Karthik Nayak writes:
Rename 'refinfo' to 'ref_array_item' as a preparatory step for introduction of
new structures in the forthcoming patch.
Re-order the fields in 'ref_array_item' so that refname can be
eventually converted to a FLEX_ARRAY.
N
On 05/31/2015 11:04 PM, Junio C Hamano wrote:
Karthik Nayak writes:
/*
+ * Given a refname, return 1 if the refname matches with one of the patterns
+ * while the pattern is a pathname like 'refs/tags' or 'refs/heads/master'
+ * and so on, else return 0. Supports use of wild characters.
+ */
Karthik Nayak writes:
> Rename 'refinfo' to 'ref_array_item' as a preparatory step for introduction
> of new structures in the forthcoming patch.
>
> Re-order the fields in 'ref_array_item' so that refname can be
> eventually converted to a FLEX_ARRAY.
Not a big enough deal to require a reroll,
Karthik Nayak writes:
> /*
> + * Given a refname, return 1 if the refname matches with one of the patterns
> + * while the pattern is a pathname like 'refs/tags' or 'refs/heads/master'
> + * and so on, else return 0. Supports use of wild characters.
> + */
> +static int match_name_as_path(const
On Wed, May 27, 2015 at 9:33 AM, Paul Tan wrote:
> Since 15ced75 (git-am foreign patch support: autodetect some patch
> formats, 2009-05-27), git-am.sh is able to autodetect mbox, stgit and
> mercurial patches through heuristics.
>
> Re-implement support for autodetecting mbox/maildir files.
A fe
On 05/31/2015 07:33 PM, Christian Couder wrote:
On Sun, May 31, 2015 at 11:17 AM, Karthik Nayak wrote:
> On 05/31/2015 01:41 PM, Christian Couder wrote:
>>
>> On Sun, May 31, 2015 at 10:04 AM, Christian Couder
>> wrote:
>>>
>>> On Sat, May 30, 2015 at 7:53 PM, Karthik Nayak
>>> wrote:
>>>
On Sun, May 31, 2015 at 11:17 AM, Karthik Nayak wrote:
> On 05/31/2015 01:41 PM, Christian Couder wrote:
>>
>> On Sun, May 31, 2015 at 10:04 AM, Christian Couder
>> wrote:
>>>
>>> On Sat, May 30, 2015 at 7:53 PM, Karthik Nayak
>>> wrote:
-static void sort_refs(struct ref_sort *sor
On Sat, 30 May 2015, David Aguilar wrote:
On Tue, May 26, 2015 at 09:50:49PM +0100, John Lee wrote:
Hi
Does anybody have code to stage commits using a the visual
diff/merge tools supported by git-difftool? Is there support in git
...
I'm a g/vim user, so git-cola is finely tuned for keyboar
Hi,
A draft of Git Rev News edition 4 is available here:
https://github.com/git/git.github.io/blob/master/rev_news/drafts/edition-4.md
Everyone is welcome to contribute in any section, like Junio and
Matthieu already did, either by editing the
above page on GitHub and sending a pull request, or
On 05/31/2015 01:41 PM, Christian Couder wrote:
On Sun, May 31, 2015 at 10:04 AM, Christian Couder
wrote:
On Sat, May 30, 2015 at 7:53 PM, Karthik Nayak wrote:
-static void sort_refs(struct ref_sort *sort, struct ref_array *array)
+void sort_ref_array(struct ref_sort *sort, struct ref_array
On 05/31/2015 01:50 PM, Christian Couder wrote:
On Sat, May 30, 2015 at 7:53 PM, Karthik Nayak wrote:
-struct ref_sort {
- struct ref_sort *next;
- int atom; /* index into used_atom array */
Where is this used_atom array?
I searched but couldn't find it in the same file.
-
On 05/31/2015 01:59 PM, Eric Sunshine wrote:
On Sun, May 31, 2015 at 4:19 AM, Karthik Nayak wrote:
> On 05/31/2015 09:13 AM, Eric Sunshine wrote:
>> On Sat, May 30, 2015 at 1:53 PM, Karthik Nayak
>> wrote:
>>>
>>> Create 'ref-filter.h', also add ref-filter to the Makefile.
>>> This completes mo
On Sun, May 31, 2015 at 4:19 AM, Karthik Nayak wrote:
> On 05/31/2015 09:13 AM, Eric Sunshine wrote:
>> On Sat, May 30, 2015 at 1:53 PM, Karthik Nayak
>> wrote:
>>>
>>> Create 'ref-filter.h', also add ref-filter to the Makefile.
>>> This completes movement of creation of 'ref-filter' from
>>> 'fo
On Sat, May 30, 2015 at 7:53 PM, Karthik Nayak wrote:
>
> -struct ref_sort {
> - struct ref_sort *next;
> - int atom; /* index into used_atom array */
Where is this used_atom array?
I searched but couldn't find it in the same file.
> - unsigned reverse : 1;
> -};
--
To unsubscr
As this is clearing the array only, it would be better to have it in a
ref_array_clear() function.
There are already argv_array_clear() and sha1_array_clear() by the way.
And maybe if many such ref_array functions are created and start being
used elsewhere we can easily move everything into new r
On 05/31/2015 09:13 AM, Eric Sunshine wrote:
On Sat, May 30, 2015 at 1:53 PM, Karthik Nayak wrote:
Create 'ref-filter.h', also add ref-filter to the Makefile.
This completes movement of creation of 'ref-filter' from
'for-each-ref'.
It's important that the project can be built successfully and
Hi Johannes,
On Tue, May 19, 2015 at 9:04 PM, Johannes Schindelin
wrote:
> On 2015-05-18 17:06, Paul Tan wrote:
>> +/**
>> + * Given a refspec, returns the merge branch. Returns NULL if the refspec
>> src
>> + * does not refer to a branch.
>> + *
>> + * FIXME: It should return the tracking branc
On 05/31/2015 08:51 AM, Eric Sunshine wrote:
On Sat, May 30, 2015 at 1:53 PM, Karthik Nayak wrote:
Rename some of the functions and make them publically available.
s/publically/publicly/
This is a preparatory step for moving code from 'for-each-ref'
to 'ref-filter' to make meaningful, targe
On 05/31/2015 08:44 AM, Eric Sunshine wrote:
On Sat, May 30, 2015 at 1:53 PM, Karthik Nayak wrote:
Intoduce 'ref_filter_cbdata' which will hold 'ref_filter'
s/Intoduce/Introduce/
(Conditions to filter the refs on) and 'ref_array' (The array
s/Conditions/conditions/
s/The/the/
of ref_arr
On Sun, May 31, 2015 at 10:04 AM, Christian Couder
wrote:
> On Sat, May 30, 2015 at 7:53 PM, Karthik Nayak wrote:
>>
>> -static void sort_refs(struct ref_sort *sort, struct ref_array *array)
>> +void sort_ref_array(struct ref_sort *sort, struct ref_array *array)
>
> It is probably better to call
Why did this comment get removed? Isn't it still meaningful to the
overall logic of this function?
Wasn't intentional, will put that back.
Sneaking in whitespace change?
Noted. thanks
--
Regards,
Karthik
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a
On Sat, May 30, 2015 at 7:53 PM, Karthik Nayak wrote:
>
> -static void sort_refs(struct ref_sort *sort, struct ref_array *array)
> +void sort_ref_array(struct ref_sort *sort, struct ref_array *array)
It is probably better to call the above function ref_array_sort()...
[...]
> -static struct ref
On Sat, May 30, 2015 at 7:53 PM, Karthik Nayak wrote:
> Introduce and implement 'ref_filter_clear_data()' which will free
> all allocated memory for 'ref_filter_cbdata' and its underlying array
> of 'ref_array_item'.
>
> Mentored-by: Christian Couder
> Mentored-by: Matthieu Moy
> Signed-off-by:
63 matches
Mail list logo