[PATCH 0/5] fc/transport-helper-sync-error-fix rebased

2014-04-18 Thread Junio C Hamano
As I have said in the recent What's cooking reports, the original posted here were based on older codebase and needed to be rebased, but it had some conflicts and I wanted to see the result double checked by the original author before we can merge it to 'next', cooked there and hopefully merged to

Re: [ANNOUNCE] WinGit - native x86/x64 Git for Windows

2014-04-18 Thread Heiko Voigt
Hi Marat, On Thu, Apr 03, 2014 at 05:18:50PM +0400, ma...@slonopotamus.org wrote: > I'm proud to announce WinGit: > an attempt to bring Git powers to 64-bit Windows. So the reason for this new package is that you need 64bit binaries? > Relationship with msysgit > = > > U

Re: [PATCH 5/5] completion: fix completion of certain aliases

2014-04-18 Thread Felipe Contreras
Junio C Hamano wrote: > Gábor Szeder writes: > > > words[] is just fine, we never modify it after it is filled by > > _get_comp_words_by_ref() at the very beginning. > > Hmph. I would have understood if the latter were "we never look at > it (to decide what to do)". "we never modify it" does n

Re: [ANNOUNCE] Git v2.0.0-rc0

2014-04-18 Thread Johan Herland
On Fri, Apr 18, 2014 at 9:37 PM, Junio C Hamano wrote: > An early preview release Git v2.0.0-rc0 is now available for > testing at the usual places. This is supposed to have _all_ the v2.0 topics, correct? I'm unable to find the commit that actually _changes_ the default prefix for "git svn" (as

Re: Refactoring hardcoded SHA-1 constants

2014-04-18 Thread Duy Nguyen
On Sat, Apr 19, 2014 at 8:06 AM, Junio C Hamano wrote: > Duy Nguyen writes: > >> On Sat, Apr 19, 2014 at 7:06 AM, Michael Haggerty >> wrote: >>> Let the brainstorming (and bikeshedding) begin! >>> >>> 1. GIT_OID_RAWSZ / GIT_OID_HEXSZ >>> >>> 2. OID_RAWSZ / OID_HEXSZ >>> >>> 3. OID_BINARY_LEN /

Re: [PATCH v9 0/6] transport-helper: fixes

2014-04-18 Thread Junio C Hamano
Felipe Contreras writes: > Junio C Hamano wrote: >> Felipe Contreras writes: >> >> > These patches add support for remote helpers --force, --dry-run, and >> > reporting >> > forced update. >> > >> > Changes since v8: >> > >> > --- a/transport-helper.c >> > +++ b/transport-helper.c >> > @@ -734

Re: Refactoring hardcoded SHA-1 constants

2014-04-18 Thread Junio C Hamano
Duy Nguyen writes: > On Sat, Apr 19, 2014 at 7:06 AM, Michael Haggerty > wrote: >> Let the brainstorming (and bikeshedding) begin! >> >> 1. GIT_OID_RAWSZ / GIT_OID_HEXSZ >> >> 2. OID_RAWSZ / OID_HEXSZ >> >> 3. OID_BINARY_LEN / OID_ASCII_LEN >> >> 4. BINARY_OID_LEN / ASCII_OID_LEN > > 5. sizeof(

Re: Project idea: strbuf allocation modes

2014-04-18 Thread Junio C Hamano
Michael Haggerty writes: > On 04/18/2014 07:21 PM, Junio C Hamano wrote: >> Michael Haggerty writes: >> >>> The Idea >>> >>> >>> I would like to see strbuf enhanced to allow it to use memory that it >>> doesn't own (for example, stack-allocated memory), while (optionally) >>> allowing

Re: Refactoring hardcoded SHA-1 constants

2014-04-18 Thread Duy Nguyen
On Sat, Apr 19, 2014 at 7:06 AM, Michael Haggerty wrote: > Let the brainstorming (and bikeshedding) begin! > > 1. GIT_OID_RAWSZ / GIT_OID_HEXSZ > > 2. OID_RAWSZ / OID_HEXSZ > > 3. OID_BINARY_LEN / OID_ASCII_LEN > > 4. BINARY_OID_LEN / ASCII_OID_LEN 5. sizeof(oid) / ASCII_OID_LEN -- Duy -- To uns

Re: [PATCH] blame: add correct paddings in time_buf for align

2014-04-18 Thread Duy Nguyen
On Sat, Apr 19, 2014 at 12:08 AM, Junio C Hamano wrote: > Duy Nguyen writes: > >> On Fri, Apr 18, 2014 at 3:44 PM, Jiang Xin wrote: >>> When show blame information with relative time, the UTF-8 characters in >>> `time_str` will break the alignment of columns after the date field. >>> This is bec

Re: Refactoring hardcoded SHA-1 constants

2014-04-18 Thread Michael Haggerty
> brian m. carlson wrote: >> I'd like to introduce a set of preprocessor constants that we'd use >> instead of hard-coded 20s and 40s everywhere. I agree that it would help code clarity to have symbolic constants for these numbers. On 04/19/2014 12:40 AM, Jonathan Nieder wrote: > Lukewarm on that

Re: [PATCH v9 0/6] transport-helper: fixes

2014-04-18 Thread Felipe Contreras
Junio C Hamano wrote: > Felipe Contreras writes: > > > These patches add support for remote helpers --force, --dry-run, and > > reporting > > forced update. > > > > Changes since v8: > > > > --- a/transport-helper.c > > +++ b/transport-helper.c > > @@ -734,7 +734,7 @@ static int push_update_ref_

Re: [PATCH v2 6/9] branch: display publish branch

2014-04-18 Thread Felipe Contreras
Jeff King wrote: > On Sat, Apr 12, 2014 at 10:05:15AM -0500, Felipe Contreras wrote: > > > As you can see; some branches are published, others are not. The ones that > > are > > not published don't have a @{publish}, and `git branch -v` doesn't show > > them. > > Why is that hard to understand?

Re: [PATCH] tag: add -i and --introduced modifier for --contains

2014-04-18 Thread Junio C Hamano
"Luis R. Rodriguez" writes: > I think ultimately this reveals that given that tags *can* be > arbitrary and subjective,... Yes; see the part at the bottom. >> Commit A can be described in terms of both v3.4 and v9.0, > > And in the real example case, why *would* c5905afb' be be described in > t

Re: [PATCH] tag: add -i and --introduced modifier for --contains

2014-04-18 Thread Luis R. Rodriguez
On Thu, Apr 17, 2014 at 10:04 AM, Junio C Hamano wrote: > "Luis R. Rodriguez" writes: > >>> And between v3.4 and v3.5-rc1, the latter is a closer anchor point >>> for that commit (v3.5-rc1 only needs about 200 hops to reach the >>> commit, while from v3.4 you would need close to 500 hops), >> >>

Re: Refactoring hardcoded SHA-1 constants

2014-04-18 Thread Jonathan Nieder
Hi, brian m. carlson wrote: > I'd like to introduce a set of preprocessor constants that we'd use > instead of hard-coded 20s and 40s everywhere. Lukewarm on that. It's hard to do consistently and unless they're named well it can be harder to know what something like BINARY_OBJECT_NAME_LENGTH m

Refactoring hardcoded SHA-1 constants

2014-04-18 Thread brian m. carlson
SHA-1 is clearly on its way out. I know that there has been discussion in the past about moving to different algorithms. I'm not interested in having that discussion now. I'd like to introduce a set of preprocessor constants that we'd use instead of hard-coded 20s and 40s everywhere. That way,

Re: user.signingkey without gpg? (using s/mime or ssh?)

2014-04-18 Thread brian m. carlson
On Fri, Apr 18, 2014 at 10:04:50PM +0200, Thomas Schittli wrote: > We already have trusted Certificates from a CA. Can we use them > instead of an additional PGP key? Git wants a key that can be used by GnuPG, and X.509 certificates can't be. It invokes the gpg binary that's in your path, so X.50

Re: Project idea: strbuf allocation modes

2014-04-18 Thread Michael Haggerty
On 04/18/2014 07:21 PM, Junio C Hamano wrote: > Michael Haggerty writes: > >> The Idea >> >> >> I would like to see strbuf enhanced to allow it to use memory that it >> doesn't own (for example, stack-allocated memory), while (optionally) >> allowing it to switch over to using allocated

user.signingkey without gpg? (using s/mime or ssh?)

2014-04-18 Thread Thomas Schittli
Dear Git Community   I've spent almost a day to find an answer to this question:   We already have trusted Certificates from a CA. Can we use them instead of an additional PGP key? We already have: - s/mime certificate - web server ssl/tls certificate - XMPP Jabber ssl/tls certificate - Object Co

[ANNOUNCE] Git v2.0.0-rc0

2014-04-18 Thread Junio C Hamano
An early preview release Git v2.0.0-rc0 is now available for testing at the usual places. A major version bump between v1.x.x series and the upcoming v2.0.0 means there are a handful of backward incompatible UI improvements, but for most people, all the tricky preparation for the transition would

What's cooking in git.git (Apr 2014, #06; Fri, 18)

2014-04-18 Thread Junio C Hamano
Here are the topics that have been cooking. Commits prefixed with '-' are only in 'pu' (proposed updates) while commits prefixed with '+' are in 'next'. The tip of the 'master' branch is at v2.0.0-rc0, an early preview release. There are a handful of topics still in 'next' (and a few that are no

Re: [PATCH 2/3] i18n: Only extract comments marked by special tag

2014-04-18 Thread Junio C Hamano
Junio C Hamano writes: > Documentation/CodingGuidelines may want to have a sentence of two to > explain this, though. After re-reading what I sent out, I realized that the way I singled out multi-line comments was misleading. Here is an updated version. -- >8 -- Subject: [PATCH] i18n: mention

Re: Store refreshed stat info in a separate file?

2014-04-18 Thread Junio C Hamano
Duy Nguyen writes: > The major cost of writing an index is the SHA-1 hashing. The bigger > the written part is, the higher cost we pay. So what if we write > stat-only data to a separate file? Think of it as an index extension, > only it stays outside the index. On webkit with 182k files, the sta

Re: Project idea: strbuf allocation modes

2014-04-18 Thread Junio C Hamano
Michael Haggerty writes: > The Idea > > > I would like to see strbuf enhanced to allow it to use memory that it > doesn't own (for example, stack-allocated memory), while (optionally) > allowing it to switch over to using allocated memory if the string grows > past the size of the pre-al

Re: [PATCH] blame: add correct paddings in time_buf for align

2014-04-18 Thread Junio C Hamano
Duy Nguyen writes: > On Fri, Apr 18, 2014 at 3:44 PM, Jiang Xin wrote: >> When show blame information with relative time, the UTF-8 characters in >> `time_str` will break the alignment of columns after the date field. >> This is because the `time_buf` padding with spaces should have a >> constan

Re: [PATCH 2/3] i18n: Only extract comments marked by special tag

2014-04-18 Thread Junio C Hamano
Jiang Xin writes: >> I am not very happy with this change, as it would force us to >> special case "Translators" comment to follow a non-standard >> multi-line comment formatting convention. Is there a way to tell >> xgettext to accept both of these forms? >> >> /* TRANSLATORS: this is a

Re: [PATCH] tag: add -i and --introduced modifier for --contains

2014-04-18 Thread Junio C Hamano
Jeff King writes: > ---A---B---C-D---E---F (maint, v3.4) > \ \ / > \ ---G-H---I (master, v4.0) >\ / / > --J--- > > The fix is J, and it got merged up to maint at D, and to master at H. > v4.0 does not contain v3.4. What's the best descripti

Re: [PATCH] blame: add correct paddings in time_buf for align

2014-04-18 Thread Duy Nguyen
On Fri, Apr 18, 2014 at 3:44 PM, Jiang Xin wrote: > When show blame information with relative time, the UTF-8 characters in > `time_str` will break the alignment of columns after the date field. > This is because the `time_buf` padding with spaces should have a > constant display width, not a fixe

Store refreshed stat info in a separate file?

2014-04-18 Thread Duy Nguyen
With git status, writing refreshed index takes 252ms per total 1s, 361s/1.4s, 86ms/360ms on gentoo-x86, webkit and linux-2.6 respectively (*). It's takes a significant amount of time from "git status". And this happens whenever you touch a single tracked file, then do "git status". We tried to solv

Project idea: strbuf allocation modes

2014-04-18 Thread Michael Haggerty
I like that strbuf is getting used more than it used to, and I think that is a good general trend to help git rid of and/or avoid buffer overflows and arbitrary limits on strings. It is unfortunate that it is currently impossible to use a strbuf without doing a memory allocation. So code like

Re: Re: [RFC/PATCH 2/4] Submodules: Add the lib-submodule-update.sh test library

2014-04-18 Thread Heiko Voigt
On Thu, Apr 17, 2014 at 11:30:04PM +0200, Jens Lehmann wrote: > - Heiko's "config cache for submodules" patch > > Needed for my recursive checkout series to populate new submodules. Which will be followed by my recursive fetch series, which is also the last part of what started with this: http

Re: [git] [RFC/PATCH 2/4] Submodules: Add the lib-submodule-update.sh test library

2014-04-18 Thread Jens Lehmann
Am 17.04.2014 23:55, schrieb W. Trevor King: > On Thu, Apr 17, 2014 at 11:08:06PM +0200, Jens Lehmann wrote: >> Am 17.04.2014 18:41, schrieb W. Trevor King: >>> On Tue, Mar 25, 2014 at 06:05:05PM +0100, Jens Lehmann wrote: *) When a submodule is replaced with a tracked file of the same name >>

Re: [PATCH v2.1] commit: add --ignore-submodules[=] parameter

2014-04-18 Thread Jens Lehmann
Am 13.04.2014 01:41, schrieb Ronald Weiss: > On 8. 4. 2014 20:26, Jens Lehmann wrote: >> Am 07.04.2014 23:46, schrieb Ronald Weiss: >>> Then, on top of that, I'll prepare patches for add to honor ignore >>> from .gitmodules, and -f implying --ignore-submodules. That might need >>> more discussion,

Re: [PATCH v4 2/2] commit: add --ignore-submodules[=] parameter

2014-04-18 Thread Jens Lehmann
Am 13.04.2014 00:49, schrieb Ronald Weiss: > Allow ignoring submodules (or not) by command line switch, like diff > and status do. > > Git commit honors the 'ignore' setting from .gitmodules or .git/config, > but didn't allow to override it from command line. > > This patch depends on Jens Lehman

Re: [PATCH v4 1/2] add: add --ignore-submodules[=] parameter

2014-04-18 Thread Jens Lehmann
Am 13.04.2014 00:45, schrieb Ronald Weiss: > Allow ignoring submodules (or not) by command line switch, like diff > and status do. > > Git add currently doesn't honor ignore from .gitmodules or .git/config, > which is related functionality, however I'd like to change that in > another patch, comin

[PATCH] blame: add correct paddings in time_buf for align

2014-04-18 Thread Jiang Xin
When show blame information with relative time, the UTF-8 characters in `time_str` will break the alignment of columns after the date field. This is because the `time_buf` padding with spaces should have a constant display width, not a fixed strlen size. So we should call utf8_strwidth() instead o