Re: [PATCH 1/3] for-each-ref: introduce %C(...) for color

2013-11-06 Thread Ramkumar Ramachandra
Junio C Hamano wrote: > ... users of for-each-ref format will be _more_ familiar with > formats used by for-each-ref, and it would make a lot more sense to > keep the syntactic resemblance between existing features to show > magic things in for-each-ref and the new feature to show color > (which is

Re: [PATCH v5 06/10] fast-export: add new --refspec option

2013-11-06 Thread Felipe Contreras
On Wed, Nov 6, 2013 at 3:00 PM, Junio C Hamano wrote: > Felipe Contreras writes: > >> On Thu, Oct 31, 2013 at 12:26 PM, Junio C Hamano wrote: >>> Felipe Contreras writes: >>> +test_expect_success 'use refspec' ' + git fast-export --refspec refs/heads/master:refs/heads/foobar maste

Re: [PATCH v3 2/2] Rename suffixcmp() to has_suffix() and invert its result

2013-11-06 Thread Junio C Hamano
Jonathan Nieder writes: >> The old name followed the pattern anything-cmp(), which suggests >> a general comparison function suitable for e.g. sorting objects. >> But this was not the case for suffixcmp(). > > It's not clear to me that prefixcmp() is usable for sorting objects, > either. Shouldn

What's cooking in git.git (Nov 2013, #02; Wed, 6)

2013-11-06 Thread Junio C Hamano
Here are the topics that have been cooking. Commits prefixed with '-' are only in 'pu' (proposed updates) while commits prefixed with '+' are in 'next'. The first release candidate 1.8.5-rc1 has been tagged. As promised/requested, the final steps for 2.0 are in 'next'; they, together with a hand

[ANNOUNCE] Git v1.8.5-rc1

2013-11-06 Thread Junio C Hamano
A release candidate Git v1.8.5-rc1 is now available for testing at the usual places. The release tarballs are found at: http://code.google.com/p/git-core/downloads/list and their SHA-1 checksums are: 005ed6e0e91043d1d9da9a47f0235fdac240269a git-1.8.5.rc1.tar.gz 542586fc562acb88aec807cd27ae

Re: [PATCH v3 2/2] Rename suffixcmp() to has_suffix() and invert its result

2013-11-06 Thread Max Horn
> Am 07.11.2013 um 00:28 schrieb Jonathan Nieder : > > Max Horn wrote: > >> Well, unlike suffixcmp, it is transitive, so it could be used for sorting. > > It is not antisymmetric. > >prefixcmp("foo", "foobar") < 0 >prefixcmp("foobar", "foo") == 0 Right! I wasn't thinkinh :-( > > I c

Re: [PATCH 0/2] thin-pack capability for send-pack/receive-pack

2013-11-06 Thread Shawn Pearce
On Wed, Nov 6, 2013 at 2:54 PM, Jeff King wrote: > If we instead introduced "no-thin", it is more like: > > 1. Receive-pack starts advertising "no-thin" (as dictated by > circumstances, as Carlos describes). > > 2. Send-pack which does not understand no-thin will ignore it and send >

Re: [PATCH v3] push: Enhance unspecified push default warning

2013-11-06 Thread Jonathan Nieder
Matthieu Moy wrote: > Junio C Hamano writes: >> Specifically: >> + "When push.default is set to 'matching', git will push all local branches\n" + "to the remote branches with the same (matching) name. >> >> invites those who do not read documentation to mistake it with using >

Re: [PATCH 0/2] thin-pack capability for send-pack/receive-pack

2013-11-06 Thread Shawn Pearce
On Wed, Nov 6, 2013 at 1:41 PM, Carlos Martín Nieto wrote: > On Wed, 2013-11-06 at 12:32 -0800, Junio C Hamano wrote: >> I'll queue these for now, but I doubt the wisdom of this series, >> given that the ship has already sailed long time ago. >> >> Currently, no third-party implementation of a rec

прекраснейший тренинг для глаз

2013-11-06 Thread leto-25
мыслите являться Зрячим? мыслите являться Зрячим? Зрячим являться бессменно прекрасно. http://goo.gl/sGzLoe -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html

Re: [PATCH v3 2/2] Rename suffixcmp() to has_suffix() and invert its result

2013-11-06 Thread Jonathan Nieder
Max Horn wrote: > Well, unlike suffixcmp, it is transitive, so it could be used for sorting. It is not antisymmetric. prefixcmp("foo", "foobar") < 0 prefixcmp("foobar", "foo") == 0 I can see how it's possible to care about the sign of the return value, but it's equally possible

Re: [PATCH v3 2/2] Rename suffixcmp() to has_suffix() and invert its result

2013-11-06 Thread Max Horn
On 06.11.2013, at 23:17, Jonathan Nieder wrote: > Hi, > > Christian Couder wrote: > >> Now has_suffix() returns 1 when the suffix is present and 0 otherwise. > > Ok. My only worry is that the function is less discoverable since > its name is so different from prefixcmp(), which might cause s

Re: [PATCH v3] push: Enhance unspecified push default warning

2013-11-06 Thread Junio C Hamano
Junio C Hamano writes: > Also applying this will have an unpleasant fallout to merging the > endgame patch b2ed944a (push: switch default from "matching" to > "simple", 2013-01-04). The added text needs to be corrected with an > evil merge. > > I'd prefer to having worry about such a fallout onl

Re: [PATCH 0/2] thin-pack capability for send-pack/receive-pack

2013-11-06 Thread Jeff King
On Wed, Nov 06, 2013 at 02:25:50PM -0800, Junio C Hamano wrote: > > Support in the code isn't always enough. The particular case that > > brought this on is one where the index-pack implementation can deal with > > thin packs just fine. > > > > This particular service takes the pack which the clie

Re: [PATCH v5 06/10] fast-export: add new --refspec option

2013-11-06 Thread Junio C Hamano
Junio C Hamano writes: > Jeff King writes: > >> I think that is much nicer for the simple cases, but how do we handle >> more complex rev expressions? One can say: >> >> git fast-export master ^origin >> >> or even: >> >> git fast-export origin..master >> >> The "^origin" is not a refspec, a

Re: [PATCH v5 06/10] fast-export: add new --refspec option

2013-11-06 Thread Junio C Hamano
Jeff King writes: > I think that is much nicer for the simple cases, but how do we handle > more complex rev expressions? One can say: > > git fast-export master ^origin > > or even: > > git fast-export origin..master > > The "^origin" is not a refspec, and finding the refspec in the > dot-ex

Re: [PATCH 0/2] thin-pack capability for send-pack/receive-pack

2013-11-06 Thread Junio C Hamano
Carlos Martín Nieto writes: > On Wed, 2013-11-06 at 12:32 -0800, Junio C Hamano wrote: >> I'll queue these for now, but I doubt the wisdom of this series, >> given that the ship has already sailed long time ago. >> >> Currently, no third-party implementation of a receiving end can >> accept thin

Re: [PATCH v3 2/2] Rename suffixcmp() to has_suffix() and invert its result

2013-11-06 Thread Jonathan Nieder
Hi, Christian Couder wrote: > Now has_suffix() returns 1 when the suffix is present and 0 otherwise. Ok. My only worry is that the function is less discoverable since its name is so different from prefixcmp(), which might cause someone to invent yet another postfixcmp. > The old name followed

Re: [PATCH v5 06/10] fast-export: add new --refspec option

2013-11-06 Thread Jeff King
On Wed, Nov 06, 2013 at 01:00:42PM -0800, Junio C Hamano wrote: > I didn't think things through, but at the external UI level, I see a > possibility of a nicer way to express the above. > > In our "push" refspec (and export is about pushing what we have), a > colonless refspec A is a short-hand f

Re: [PATCH v3] push: Enhance unspecified push default warning

2013-11-06 Thread Matthieu Moy
Junio C Hamano writes: > That is true, but does it justify giving a misleading information in > the advice message? Clearly, yes. Trying to be exhaustive here is not a good idea, we'd end up rewritting the man page, and then users won't read the message because it's too long. > Specifically: >

Re: [PATCH 0/2] thin-pack capability for send-pack/receive-pack

2013-11-06 Thread Carlos Martín Nieto
On Wed, 2013-11-06 at 12:32 -0800, Junio C Hamano wrote: > I'll queue these for now, but I doubt the wisdom of this series, > given that the ship has already sailed long time ago. > > Currently, no third-party implementation of a receiving end can > accept thin push, because "thin push" is not a c

(broken ?) output of "git diff --color-word"

2013-11-06 Thread Toralf Förster
I just commented out few lines, "git diff" is fine : @@ -144,10 +145,10 @@ StartUML || exit 2 SHARES="" if [[ $VICTIMS -eq 1 ]]; then -# SHARES="/tmp" -# SHARES="$SHARES /mnt/hostfs" -# SHARES="$SHARES /mnt/nfsv2" -# SHARES="$SHARES /mnt/nfsv3" + SHARES="/tmp" +

Re: [PATCH v5 06/10] fast-export: add new --refspec option

2013-11-06 Thread Junio C Hamano
Felipe Contreras writes: > On Thu, Oct 31, 2013 at 12:26 PM, Junio C Hamano wrote: >> Felipe Contreras writes: >> >>> +test_expect_success 'use refspec' ' >>> + git fast-export --refspec refs/heads/master:refs/heads/foobar master >>> | \ >>> + grep "^commit " | sort | uniq > ac

Re: [RFC/PATCH] Add interpret-trailers builtin

2013-11-06 Thread Junio C Hamano
Christian Couder writes: > From: Junio C Hamano > >> Christian Couder writes: >> >>> To append a s-o-b only if there is no s-o-b already, one would need to use: >>> >>> [trailer "signoff"] >>> key = "Signed-off-by:" >>> if_exist = dont_append >>> if_missing = append

Re: [PATCH 0/2] thin-pack capability for send-pack/receive-pack

2013-11-06 Thread Junio C Hamano
Carlos Martín Nieto writes: > Hi all, > > This comes as a result of the discussion starting at [0] about > git-push assuming that a server will always support thin packs. Most > out there in fact do, but this isn't necessarily the case. > > Some implementations may not have support for it yet, or

Re: [RFC/PATCH] Add interpret-trailers builtin

2013-11-06 Thread Christian Couder
From: Junio C Hamano > Christian Couder writes: > >> To append a s-o-b only if there is no s-o-b already, one would need to use: >> >> [trailer "signoff"] >> key = "Signed-off-by:" >> if_exist = dont_append >> if_missing = append >> command = echo "$GIT_COMMI

Re: [PATCH v3] push: Enhance unspecified push default warning

2013-11-06 Thread Junio C Hamano
Junio C Hamano writes: > Matthieu Moy writes: > >> I don't remember all the discussions on the patch which introduced >> the warning, but I don't think it's relevant to digg them before applying >> the patch: > > If we apply the patch then it is too late to dig them ;-) > >> * The assumption wa

Re: [PATCH] git-cat-file: fix output when format string contains no variables

2013-11-06 Thread Sven Brauch
On Wednesday 06 November 2013 10:00:57 Junio C Hamano wrote: > Thanks; first some procedural issues: Thanks, I will take care of the mentioned points for future submissions. > I think the real problem is that sha1_loose_object_info() is called > by sha1_object_info_extended(), when it does not fin

[PATCH] Add the commit.gpgsign option to sign all commits

2013-11-06 Thread Nicolas Vigier
If you want to GPG sign all your commits, you have to add the -S option all the time. The commit.gpgsign config option allows to sign all commits automatically. Signed-off-by: Nicolas Vigier --- The option description now suggests using an agent. Documentation/config.txt | 7 +++ builtin/co

Re: [PATCH v3] push: Enhance unspecified push default warning

2013-11-06 Thread Junio C Hamano
Matthieu Moy writes: > I don't remember all the discussions on the patch which introduced > the warning, but I don't think it's relevant to digg them before applying the > patch: If we apply the patch then it is too late to dig them ;-) > * The assumption was that users would read the docs, bu

Re: [PATCH] git-cat-file: fix output when format string contains no variables

2013-11-06 Thread Jeff King
On Wed, Nov 06, 2013 at 10:00:57AM -0800, Junio C Hamano wrote: > I think the real problem is that sha1_loose_object_info() is called > by sha1_object_info_extended(), when it does not find a cached or a > packed object, and the callee assumes that it is asked to fill in > only the requested piece

Re: [PATCH] git-cat-file: fix output when format string contains no variables

2013-11-06 Thread Junio C Hamano
Sven Brauch writes: > From 2e7b5aed771faeff654a447346bb0b57570d9569 Mon Sep 17 00:00:00 2001 > From: Sven Brauch > Date: Tue, 5 Nov 2013 20:06:21 +0100 > Subject: [PATCH] git-cat-file: fix output when format string contains no > variables Thanks; first some procedural issues: - Omit the firs

Re: rcs

2013-11-06 Thread Junio C Hamano
Jakub Narębski writes: > Finnerty, James M Mr CTR USA USASOC-SOAR wrote >> Jeff King [mailto:p...@peff.net]wrote: >>> On Tue, Oct 29, 2013 at 11:35:21AM -0500, Finnerty, James M Mr CTR USA >>> USASOC-SOAR wrote: >>> Hi. I'm going to attempt to import a git database into Razor which is

Re: [RFC/PATCH] Add interpret-trailers builtin

2013-11-06 Thread Junio C Hamano
Christian Couder writes: > To append a s-o-b only if there is no s-o-b already, one would need to use: > > [trailer "signoff"] > key = "Signed-off-by:" > if_exist = dont_append > if_missing = append > command = echo "$GIT_COMMITTER_NAME <$GIT_COMMITTER_EMAIL>"'

RE: git svn clone with funky tags layout

2013-11-06 Thread Jim Garrison
> -Original Message- > From: Michael J Gruber [mailto:g...@drmicha.warpmail.net] > Sent: Wednesday, November 06, 2013 6:03 AM > To: Jim Garrison; git@vger.kernel.org > Subject: Re: git svn clone with funky tags layout > > Jim Garrison venit, vidit, dixit 05.11.2013 18:16: > > I'm doing a o

Re: htonll, ntohll

2013-11-06 Thread Torsten Bögershausen
On 2013-11-05 01.00, Ramsay Jones wrote: > On 31/10/13 13:24, Torsten Bögershausen wrote: >> On 2013-10-30 22.07, Ramsay Jones wrote: > [ ... ] >>> Yep, this was the first thing I did as well! ;-) (*late* last night) >>> >>> I haven't had time today to look into fixing up the msvc build >>> (or a c

Re: [PATCH 2/2] git_connect: factor out discovery of the protocol and its parts

2013-11-06 Thread Torsten Bögershausen
On 2013-11-05 22.22, Johannes Sixt wrote: > Am 05.11.2013 21:45, schrieb Torsten Bögershausen: >> On 2013-11-05 20.39, Johannes Sixt wrote: >> Thanks for picking this up, please see some minor nits inline, >> and git_connect() is at the end >> >>> -struct child_process *git_connect(int fd[2], const

[PATCH 0/2] thin-pack capability for send-pack/receive-pack

2013-11-06 Thread Carlos Martín Nieto
Hi all, This comes as a result of the discussion starting at [0] about git-push assuming that a server will always support thin packs. Most out there in fact do, but this isn't necessarily the case. Some implementations may not have support for it yet, or the server might be running in an environ

[PATCH 2/2] send-pack: only send a thin pack if the server supports it

2013-11-06 Thread Carlos Martín Nieto
In combination a the previous patch making receive-pack advertise the thin-pack capability, this allows git to push to a server in a constrained environment which is not able to fix thin packs while taking advantage of the feature for servers which can. Signed-off-by: Carlos Martín Nieto --- sen

[PATCH 1/2] receive-pack: advertise thin-pack

2013-11-06 Thread Carlos Martín Nieto
upload-pack has long advertised thin-pack, letting the clients request these smaller packs. The client however unconditionally assumes that a server is able to fix thin packs and there is no way of telling the client that this is in fact not the case. Make receive-pack advertise 'thin-pack' in ant

Re: git svn clone with funky tags layout

2013-11-06 Thread Michael J Gruber
Jim Garrison venit, vidit, dixit 05.11.2013 18:16: > I'm doing a one-time migration of an svn project. For historical reasons our > repo layout is weird: > > trunk/reporting/reporting_app > > tags/something_else > > tags/reporting_app-2.3.45 > tags/reporting_app-2.4.46

Re: [PATCH] Catch more exceptions in compat_log_entry()

2013-11-06 Thread Catalin Marinas
On 22 October 2013 15:31, Pavel Roskin wrote: > Catch exceptions in default_repo(). Catch git.RepositoryException. > This suppresses stack trace in "stg pull" on detached head and outside > the repository. > > Signed-off-by: Pavel Roskin Thanks. Applied. Catalin -- To unsubscribe from this lis

Re: [RFC/PATCH] Add interpret-trailers builtin

2013-11-06 Thread Christian Couder
On Wed, Nov 6, 2013 at 7:43 AM, Christian Couder wrote: > Of course in the latter case, a command should probably be specified > to tell which value should be used with the key. > > For example: > > [trailer "signoff"] > key = "Signed-off-by:" > if_missing = append > com