Junio C Hamano writes:
> diff --git a/attr.c b/attr.c
> index a668a63..46bde57 100644
> --- a/attr.c
> +++ b/attr.c
> @@ -387,7 +387,7 @@ static struct attr_stack *read_attr_from_index(const char
> *path, int macro_ok)
> char *buf, *sp;
> int lineno = 0;
>
> - buf = read_blob_d
Ramkumar Ramachandra writes:
> I agree with you largely, but I would still argue that choosing a
> destination based on the current branch is a historical mistake made
> by "matching".
"matching" is not necessarily a good default for everybody, and we
are fixing that historical mistake in Git 2.
Thanks. I'll queue with the following API fix-up on this, with
obvious adjustments necessary for the later ones.
* read_blob_data_from_index() is descriptive enough. If you read a
blob from the index, you would ask for it with a path; there is
no other sensible key to do so.
* A function
Felipe Contreras writes:
> On Sat, Apr 13, 2013 at 1:00 AM, Jeff King wrote:
>> On Sat, Apr 13, 2013 at 12:42:29AM -0500, Felipe Contreras wrote:
>>
>>> To me, the reality is obvious: my patch didn't require such a big
>>> commit message, the short version was fine, the only reason Jeff King
>>>
Felipe Contreras writes:
> Why wasn't this patch merged to 'pu'? To my knowledge nobody raised
> any real concerns.
There are many reasons not to queue _everything_ ever posted to the
list on 'pu', and they are almost always not a deliberate rejection.
The maintainer may have thought he is not
Instead of using a single "slab" and keep reallocating it as we find
that we need to deal with commits with larger values of commit->index,
make a "slab" an array of many "slab_piece"s. Each access may need
two levels of indirections, but we only need to reallocate the first
level array of pointers
Introduce a header file to define a macro that can define the struct
type, initializer, accessor and cleanup functions to manage a commit
slab. Update the "indegree" topological sort facility using it.
To associate 32 flag bits with each commit,
you can write:
define_commit_slab(flag32,
The first one is Jeff's "here is what I have now" technology
demonstration.
The second attempts to iron out one kink in it, and then the third
one introduces a macro to allow other code to replicate exactly the
same code structure to support their uses.
Jeff King (1):
commit: allow associating
From: Jeff King
The "indegree" field in the commit object is only used while sorting
a list of commits in topological order, and wasting memory otherwise.
We would prefer to shrink the size of individual commit objects,
which we may have to hold thousands of in-core. We could eject
"indegree" fi
It's hard to see them among so much output otherwise.
Signed-off-by: Felipe Contreras
---
builtin/branch.c | 27 ---
1 file changed, 20 insertions(+), 7 deletions(-)
diff --git a/builtin/branch.c b/builtin/branch.c
index 00d17d2..a1cdc29 100644
--- a/builtin/branch.c
+++
Junio C Hamano wrote:
> I think you can shrink and enhance the above repertoire at the same
> time by separating "do I want to have stash and stash pop around"
> bit into an orthogonal axis. The other orthogonal axes are "Under
> what condition do I integrate the work from the upstream?" (e.g.
> "
l...@diamand.org wrote on Thu, 11 Apr 2013 21:19 +0100:
> Just a thought, but check the files that are failing to see if they've
> got RCS keywords in them ($Id$, $File$, $Date$, etc). These cause all
> sorts of nasty problems.
>
> That's assuming it's definitely not a CRLF line ending problem on
test_commit() is a well-defined function in test-lib-functions.sh that
allows you to create commits with a terse syntax. Prefer using it
over creating commits by hand.
Signed-off-by: Ramkumar Ramachandra
---
t/t5521-pull-options.sh | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff
Currently, executing a 'git pull' on a dirty worktree gives the
following annoying message:
# User doesn't notice dirty worktree
$ git pull
... # fetch operation
error: Your local changes to the following files would be overwritten by
merge:
quux
Please, commit your
14e5d40c (pull: Fix parsing of -X, 2010-01-17) added the lines
containing "git-push" and "git-merge", even though the prevelant style
at the time was to use the unhyphenated "git " form. Fix
this.
Signed-off-by: Ramkumar Ramachandra
---
git-pull.sh | 4 ++--
1 file changed, 2 insertions(+), 2 d
I've been using this patch for some time now, and have to say that
'git pull' is much more useable now. The feature is turned off by
default so that it doesn't break any existing tests.
[1/3] and [2/3] are simple "while we're there" patches, that are
unchanged from the last round.
[3/3] is actua
Jakub Narębski wrote:
> Unfortunately it turns out such simple solution doesn't really work.
>
> First, for some reason Firefox 20.0 refuses to follow file:/// link,
> even though it shows correctly worktree if copy'n'pasted as URL in new
> window / new tab.
I can confirm this behavior with chro
This configuration variable comes into effect when 'git clone' is
invoked inside an existing git repository's worktree. When set,
instead of cloning the given repository as-is, it relocates the gitdir
of the repository to the path specified by this variable. This
setting is especially useful when
When bisect successfully finds a single revision, the first bad commit
should be shown to human readers of 'git bisect log'.
This resolves the apparent disconnect between the bisection result and
the log when a bug reporter says "I know that the first bad commit is
$rev, as you can see from $(git
Please do not top-post.
On 11.04.2013, Trenton D. Adams wrote:
> #1 would actually work. Though long term it would be cool to view it
> with all the most recent commit information, kind of like github does.
> You know, showing "updated 4 days ago".
>
> On Wed, Apr 10, 2013 at 11:03 AM, Jakub N
Signed-off-by: Jiang Xin
Reviewed-by: Nguyễn Thái Ngọc Duy
---
Not mark "BUG: impossible combination of %d and %p", which would
never happen.
branch.c | 38 +++---
1 file changed, 19 insertions(+), 19 deletions(-)
diff --git a/branch.c b/branch.c
index 6ae6a..4d
This allows for optionally getting the size of the returned data and
will be used in a follow-up patch.
Signed-off-by: Lukas Fleischer
---
attr.c | 2 +-
cache.h | 2 +-
read-cache.c | 5 -
3 files changed, 6 insertions(+), 3 deletions(-)
diff --git a/attr.c b/attr.c
index 08347b
has_cr_in_index() is an almost 1:1 copy of
read_blob_data_from_index_path() with some additions. Invoke
read_blob_data_from_index_path() instead of using copy-pasted code.
Signed-off-by: Lukas Fleischer
---
convert.c | 27 ++-
1 file changed, 2 insertions(+), 25 deletions
* Make the read_index_data() function public, rename it to
read_blob_data_from_index_path() and move it from attr.c to
read-cache.c.
* Add a use_index parameter to specify a custom index_state since we are
no longer enable to access the static use_index variable from attr.c.
This allows for
Hello,
I have tried to remove and recreate my git folder and remove some files
to get more logs. Here they are:
packet: push<
capabilities^{}\0 report-status delete-refs side-band-64k quiet ofs-delta
packet: push<
packet:
*ECS 2013*
The 2013 International Conference on Electronics and Communication Systems
July 16-19, 2013, Rhodes (Rodos) Island, Greece
http://www.europment.org/conf2013/ecs.htm
PUBLICATIONS:
Extended Versions of Selected papers (about 40%) will be published in Journal
W dniu 13.04.2013 05:33, Jeff King pisze:
> When setting up a "half-auth" repository in which reads can
> be done anonymously but writes require authentication, it is
> best if the server can require authentication for both the
> ref advertisement and the actual receive-pack POSTs. [...]
Thanks f
On Fri, Apr 12, 2013 at 03:40:12PM -0400, Jeff King wrote:
> On Fri, Apr 12, 2013 at 07:26:11PM +0200, Lukas Fleischer wrote:
>
> > This allows for reusing the function in convert.c later.
> >
> > Also, move it from attr.c to read-cache.c and add a use_index parameter
> > to specify a custom inde
28 matches
Mail list logo