Hi folks,
some while ago I've already talked a bit about the OSS-QM project
and it's source code repositories, which include upstreams together
with downstream's (distros, etc) changes.
Here's a paper describing it more in datail, from automated upstream
imports down to also importing downstrea
Hi folks,
The fox eclass accumulated a lot of cruft over the years. Specifically,
it includes quite a bit of code to support versions loong gone from our
tree. The only officially supported versions now are 1.6 and 1.7.
Thus, I've edited it a bit. Main points are EAPI2 phase support and a
lot of
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1
Dne 16.9.2010 15:31, Matti Bickel napsal(a):
> Posting this for review as the diff is rather largish and I'm known to
> have the usual typo in it ;)
Your mail lacks the attachment :)
Tom
-BEGIN PGP SIGNATURE-
Version: GnuPG v2.0.16 (GNU/Linux)
On 09/16/2010 03:31 PM, Matti Bickel wrote:
--
Now complete with attachments :)
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/eclass/fox.eclass,v 1.8 2008/10/12 12:31:36
mabi Exp $
# fox eclass
#
# Thi
On Thu, 16 Sep 2010 16:24:18 +0200, Matti Bickel
wrote:
> On 09/16/2010 03:31 PM, Matti Bickel wrote:
> --
> Now complete with attachments :)
Hey Matti, few quick things.
* Can you add eclass-manpages documentation?
* econf doesn't need to "|| die"
* What is the mysterious FOXCONF variable in ec
On Thu, 16 Sep 2010 09:47:57 +0200
Enrico Weigelt wrote:
>
> Hi folks,
More spam?
jer
On Thu, 16 Sep 2010 09:41:30 -0500
Jeremy Olexa wrote:
> * econf doesn't need to "|| die"
Is that a novelty change? Most of the tree still does econf || die ...
jer
On 09/16/2010 04:41 PM, Jeremy Olexa wrote:
> Hey Matti, few quick things.
Thanks, all done. FOXCONF is now documented (though not set by default).
Updated diff and eclass attached.
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header
On Thu, 16 Sep 2010 17:44:00 +0200, Jeroen Roovers
wrote:
> On Thu, 16 Sep 2010 09:41:30 -0500
> Jeremy Olexa wrote:
>
>> * econf doesn't need to "|| die"
>
> Is that a novelty change? Most of the tree still does econf || die ...
It is just extra (not needed) code. econf() has died by itself s
В Чтв, 16/09/2010 в 17:44 +0200, Jeroen Roovers пишет:
> On Thu, 16 Sep 2010 09:41:30 -0500
> Jeremy Olexa wrote:
>
> > * econf doesn't need to "|| die"
>
> Is that a novelty change? Most of the tree still does econf || die ...
econf is function that dies on its own.
But still there is one cas
В Чтв, 16/09/2010 в 16:24 +0200, Matti Bickel пишет:
> +FOXVER=`get_version_component_range 1-2 ${FOX_PV}`
It's better to prefer $() style over ``:
http://mywiki.wooledge.org/BashFAQ/082
> if [ "${PN}" != fox ] ; then
> FOX_COMPONENT="${FOX_COMPONENT:-${PN}}"
> fi
>
> -if [ "${FOXVER}
On 09/16/2010 08:32 PM, Peter Volkov wrote:
> В Чтв, 16/09/2010 в 16:24 +0200, Matti Bickel пишет:
>> +FOXVER=`get_version_component_range 1-2 ${FOX_PV}`
>
> It's better to prefer $() style over ``:
> http://mywiki.wooledge.org/BashFAQ/082
Hmm, I prefer Backticks personally, as I like to conserve
On Thursday, September 16, 2010 14:51:39 Matti Bickel wrote:
> +#1.6: 'x11-libs/fox:1.6'
> +# 1.7: '~x11-libs/fox-${PV}'
first line is using a tab while second is spaces. both should be tabs.
> FOX_PV="${FOX_PV:-${PV}}"
while you're here, i'd change to:
: ${FOX_PV:=${PV}}
> for
В Чтв, 16/09/2010 в 15:29 -0400, Mike Frysinger пишет:
>
> > FOX_PV="${FOX_PV:-${PV}}"
>
> while you're here, i'd change to:
> : ${FOX_PV:=${PV}}
Why? This looks less readable...
--
Peter.
On 09/16/2010 09:29 PM, Mike Frysinger wrote:
>> +if [[ -f ${D}/usr/bin/fox-config ]] ; then
>> +mv "${D}/usr/bin/fox-config" "${D}/usr/bin/fox-${FOXVER}-config"
>> fi
>
> seems like you would want || die here
Why? I can't imagine how that could fail.
signature.asc
Descri
Am 16.09.2010 03:46, schrieb Ryan Hill:
> On Wed, 15 Sep 2010 19:02:00 +0200
> Thomas Sachau wrote:
>
>> From discussion on IRC, it seems, like there are different options, so i
>> would like to clarify this
>> policy:
>>
>> The test USE flag is (i am only talking about portage now, since i am m
Am 16.09.2010 04:01, schrieb Samuli Suominen:
> On 09/15/2010 08:02 PM, Thomas Sachau wrote:
>> From discussion on IRC, it seems, like there are different options, so i
>> would like to clarify this
>> policy:
>>
>> The test USE flag is (i am only talking about portage now, since i am most
>> fam
Hello
I have seen some package metadatas still referring to wormo as their
maintainer:
$ grep -r wormo */*/metada*
app-admin/ulogd/metadata.xml: wo...@gentoo.org
app-arch/pdv/metadata.xml: wo...@gentoo.org
www-client/lynx/metadata.xml: wo...@gentoo.org
But, reading http://bu
On Thu, 16 Sep 2010 23:12:10 +0200, Pacho Ramos
wrote:
> Hello
>
> I have seen some package metadatas still referring to wormo as their
> maintainer:
> $ grep -r wormo */*/metada*
> app-admin/ulogd/metadata.xml: wo...@gentoo.org
> app-arch/pdv/metadata.xml: wo...@gentoo.org
> www-client/
Il giorno gio, 16/09/2010 alle 21.47 +, Arfrever Frehtes Taifersar
Arahesis (arfrever) ha scritto:
> - -zope-dublincore-3.6.3.ebuild:
> - Delete.
> + -zope-dublincore-3.6.3.ebuild, +zope-dublincore-3.8.0.ebuild:
> + Version bump.
If you remove the "Delete" from the ChangeLog with the foll
On Thursday, September 16, 2010 16:24:14 Matti Bickel wrote:
> On 09/16/2010 09:29 PM, Mike Frysinger wrote:
> >> + if [[ -f ${D}/usr/bin/fox-config ]] ; then
> >> + mv "${D}/usr/bin/fox-config" "${D}/usr/bin/fox-${FOXVER}-config"
> >>
> >>fi
> >
> > seems like you would want || die
On Thursday, September 16, 2010 15:41:27 Peter Volkov wrote:
> В Чтв, 16/09/2010 в 15:29 -0400, Mike Frysinger пишет:
> > > FOX_PV="${FOX_PV:-${PV}}"
> >
> > while you're here, i'd change to:
> > : ${FOX_PV:=${PV}}
>
> Why? This looks less readable...
only because your eyes arent tuned to it
-mi
2010-09-16 23:50:44 Diego Elio Pettenò napisał(a):
> Il giorno gio, 16/09/2010 alle 21.47 +, Arfrever Frehtes Taifersar
> Arahesis (arfrever) ha scritto:
> > - -zope-dublincore-3.6.3.ebuild:
> > - Delete.
> > + -zope-dublincore-3.6.3.ebuild, +zope-dublincore-3.8.0.ebuild:
> > + Version bump
On Thu, 16 Sep 2010 22:42:02 +0200
Thomas Sachau wrote:
> Controling the test USE flag alone without the test FEATURE is useless, since
> it wont run the
> src_test phase.
...then don't do that? :P
> And being able to disable the test USE flag with FEATURES=test will result in
> missing deps o
On Thu, 16 Sep 2010 18:34:17 -0400
Mike Frysinger wrote:
> On Thursday, September 16, 2010 15:41:27 Peter Volkov wrote:
> > В Чтв, 16/09/2010 в 15:29 -0400, Mike Frysinger пишет:
> > > > FOX_PV="${FOX_PV:-${PV}}"
> > >
> > > while you're here, i'd change to:
> > > : ${FOX_PV:=${PV}}
> >
> > Why
On Thursday, September 16, 2010 23:51:21 Ryan Hill wrote:
> On Thu, 16 Sep 2010 18:34:17 -0400 Mike Frysinger wrote:
> > On Thursday, September 16, 2010 15:41:27 Peter Volkov wrote:
> > > В Чтв, 16/09/2010 в 15:29 -0400, Mike Frysinger пишет:
> > > > > FOX_PV="${FOX_PV:-${PV}}"
> > > >
> > > > whi
В Чтв, 16/09/2010 в 18:34 -0400, Mike Frysinger пишет:
> On Thursday, September 16, 2010 15:41:27 Peter Volkov wrote:
> > В Чтв, 16/09/2010 в 15:29 -0400, Mike Frysinger пишет:
> > > > FOX_PV="${FOX_PV:-${PV}}"
> > >
> > > while you're here, i'd change to:
> > > : ${FOX_PV:=${PV}}
> >
> > Why? Th
On Friday, September 17, 2010 01:06:19 Peter Volkov wrote:
> В Чтв, 16/09/2010 в 18:34 -0400, Mike Frysinger пишет:
> > On Thursday, September 16, 2010 15:41:27 Peter Volkov wrote:
> > > В Чтв, 16/09/2010 в 15:29 -0400, Mike Frysinger пишет:
> > > > > FOX_PV="${FOX_PV:-${PV}}"
> > > >
> > > > whil
28 matches
Mail list logo