Hello!
index 000..5375b61
--- /dev/null
+++ b/gcc/testsuite/gcc.target/i386/pr53623.c
@@ -0,0 +1,25 @@
+/* { dg-do compile { target { x86_64-*-* } } } */
+/* { dg-options "-O2 -fdump-rtl-ree" } */
Please use:
/* { dg-do compile { target { ! ia32 } } } */
Uros.
On Thu, Dec 19, 2013 at 09:57:36PM -0700, Jeff Law wrote:
> * ree.c (combine_set_extension): Handle case where source
> and destination registers in an extension insn are different.
> (combine_reaching_defs): Allow source and destination
> registers in extension to be differ
On Thu, Dec 19, 2013 at 10:22:38PM -0700, Jeff Law wrote:
> >+ *gsi = create_cond_insert_point (gsi, /*before_p=*/true,
> >+ /*then_more_likely_p=*/false,
> >+ /*create_then_fallthru_edge=*/true,
> >+ &then_b
OK to commit?
Thanks,
Bingfeng
-Original Message-
From: gcc-patches-ow...@gcc.gnu.org [mailto:gcc-patches-ow...@gcc.gnu.org] On
Behalf Of Bingfeng Mei
Sent: 18 December 2013 16:25
To: Jakub Jelinek
Cc: Richard Biener; gcc-patches@gcc.gnu.org
Subject: RE: [PATCH] Vectorization for store w
On 11/26/2013 07:45 AM, Chung-Lin Tang wrote:
> +(define_insn "movhi_internal"
> + [(set (match_operand:HI 0 "nonimmediate_operand" "=m, r,r, r,r")
> +(match_operand:HI 1 "general_operand" "rM,m,rM,I,J"))]
Didn't you say you'd removed the J alternative?
> +error ("only registe
> Hello,
>there's updated version of the patch.
>
> Tested on x86_64 with enable bootstrap.
>
> Martin
This caused pr59541.
TIA
Dominique
On Thu, Oct 31, 2013 at 09:39:11AM +0100, Jakub Jelinek wrote:
> On Thu, Oct 31, 2013 at 09:34:41AM +0100, Bernhard Reutner-Fischer wrote:
> > The cleanup routine would currently run 7 regexes on the incoming
> > compiler-flags which is supposedly pretty fast.
> > But yes, we could as well key off
> Date: Fri, 20 Dec 2013 07:57:02 +1030
> From: amo...@gmail.com
> To: bernd.edlin...@hotmail.de
> CC: gcc-patches@gcc.gnu.org; ja...@redhat.com; d...@redhat.com;
> ebotca...@adacore.com
> Subject: Re: Two build != host fixes
>
> On Thu, Dec 19, 2013 at 11:
Ultimately, mklog ought to write the ChangeLog itself.
We get rid of that headache, at least.
How about this then? Updated mklog now adds 'New file'/'New
test'/'Remove' when necessary.
I did some tests with unified/context-diffed SVN and git and it worked
as expected. I can do more testing i
On 8 November 2013 17:28, Bruce Korb wrote:
> Sure. Looks good to me. Thanks
pushed as r206146
thanks,
>
> On Fri, Nov 8, 2013 at 2:57 AM, Bernhard Reutner-Fischer
> wrote:
>> On 4 April 2013 22:20, Bruce Korb wrote:
>>> Except as noted below, fine by me.
>>>
>>> On 04/04/13 12:56, Bernhard R
On 13 November 2013 18:56, Jonathan Wakely wrote:
> On 13 November 2013 09:22, Bernhard Reutner-Fischer wrote:
>> On 11 November 2013 12:30, Jonathan Wakely wrote:
>>> How does __UCLIBC_SUSV4_LEGACY__ get defined? We'd have a problem if
>>> users defined that at configure time but not later when
Hi Martin,
Thanks for working on this!
--- However you have introduced some problems including a bootstrap fail on
darwin.
On 16 Dec 2013, at 10:13, Jan Hubicka wrote:
>> Hello,
>> there's updated version of the patch.
>>
>> Tested on x86_64 with enable bootstrap.
>>
>> Martin
>>
>> On 16
Ian Lance Taylor wrote:
> On Wed, Nov 13, 2013 at 7:30 AM, Gary Benson wrote:
> > Richard Biener wrote:
> > > On Tue, Nov 12, 2013 at 8:55 PM, Ian Lance Taylor wrote:
> > > > On Tue, Nov 12, 2013 at 11:24 AM, Uros Bizjak wrote:
> > > > >
> > > > > This was uncovered by x86 lto-profiledbootstrap.
Hi!
The bug in this PR has been introduced by my r204516 change and fixed
by r205884 (PR59417) fix.
I've committed the testcase as obvious so that we can close the PR.
2013-12-20 Jakub Jelinek
PR tree-optimization/59413
* gcc.c-torture/execute/pr59413.c: New test.
--- gcc/te
On Fri, Dec 20, 2013 at 12:18 AM, Trevor Saunders
wrote:
> As discussed in http://gcc.gnu.org/ml/gcc-patches/2013-11/msg02808.html
>
> bootstrap + same regression tests as previous rev, ok?
Ok.
Thanks,
Richard.
> 2013-12-19 Trevor saunders
>
> gcc/
> * vec.h (stack_vec): Convert to a
Hi, all,
There is a problem in nds32.h to determine available register number
for passing BLKmode argument. The original checking only refers to
NDS32_NEED_N_REGS_FOR_ARG macro but that is not sufficient to make
decision of using odd or even register number. It is supposed to
further check the t
On Fri, Dec 20, 2013 at 11:09 AM, Bingfeng Mei wrote:
> OK to commit?
Ok.
Thanks,
Richard.
> Thanks,
> Bingfeng
> -Original Message-
> From: gcc-patches-ow...@gcc.gnu.org [mailto:gcc-patches-ow...@gcc.gnu.org] On
> Behalf Of Bingfeng Mei
> Sent: 18 December 2013 16:25
> To: Jakub Jelin
On 19/12/13 17:40, Charles Baylis wrote:
> On 19 December 2013 16:13, Richard Earnshaw wrote:
>>
>> OK with that change.
>
> Thanks.
>
> The bugzilla entry is targeted at 4.8, but it is a latent problem
> which affects 4.7 too.
>
> Is it ok for 4.8, and should it be considered for 4.7?
>
Yes,
On 19/12/13 17:58, Kyrill Tkachov wrote:
On 18/12/13 15:32, Ramana Radhakrishnan wrote:
On Tue, Dec 3, 2013 at 1:46 PM, Kyrill Tkachov wrote:
Ping?
http://gcc.gnu.org/ml/gcc-patches/2013-11/msg02351.html
Thanks,
Kyrill
Ok if no objections in 24 hours.
Thanks Ramana, I've committed it as r20
On Tue, Dec 17, 2013 at 7:48 AM, Teresa Johnson wrote:
> On Mon, Dec 16, 2013 at 2:48 PM, Xinliang David Li wrote:
>> Ok -- gcov_write_counter and gcov_write_tag_length are qualified as
>> low level primitives for basic gcov format and probably should be kept
>> in gcov-io.c.
>>
>> gcov_rewrite i
We ICEd on invalid testcases with auto, because lookup_conversions
got template_type_parm as a parameter and the TYPE_BINFO didn't like
it. Fixed by checking for RECORD_OR_UNION_TYPE_P first.
Regtested/bootstrapped on x86_64-linux, ok for trunk?
2013-12-20 Marek Polacek
PR c++/59111
On Fri, Dec 20, 2013 at 5:00 AM, Gary Benson wrote:
>
> --- a/libiberty/ChangeLog
> +++ b/libiberty/ChangeLog
> @@ -1,3 +1,20 @@
> +2013-12-20 Gary Benson
> +
> + * cp-demangle.c (struct d_print_info): New fields
> + next_saved_scope, copy_templates, next_copy_template and
> +
On 12/17/2013 12:42 PM, Michael V. Zolotukhin wrote:
> Hi everybody,
>
> Here is a patch 3/3: Add invocation of target compiler.
> + /* Run objcopy on TARGET_IMAGE_FILE_NAME. */
> + buf1 = (char*) xmalloc (strlen (".data=.")
> + + strlen (OFFLOAD_IMAGE_SECTION_NAME) + 1);
On 20/12/2013, 07:08 , Yury Gribov wrote:
Ultimately, mklog ought to write the ChangeLog itself.
We get rid of that headache, at least.
How about this then? Updated mklog now adds 'New file'/'New
test'/'Remove' when necessary.
I did some tests with unified/context-diffed SVN and git and it w
Hi!
Honza recently changed the i?86 backend, so that it often doesn't
do -maccumulate-outgoing-args by default on x86_64.
Unfortunately, on some of the here included testcases this regressed
quite a bit the generated code. As AVX vectors are used, the dynamic
realignment code needs to assume e.g.
On Fri, Dec 20, 2013 at 8:06 AM, Jakub Jelinek wrote:
> Hi!
>
> Honza recently changed the i?86 backend, so that it often doesn't
> do -maccumulate-outgoing-args by default on x86_64.
> Unfortunately, on some of the here included testcases this regressed
> quite a bit the generated code. As AVX v
On 12/20/13 01:17, Uros Bizjak wrote:
Hello!
index 000..5375b61
--- /dev/null
+++ b/gcc/testsuite/gcc.target/i386/pr53623.c
@@ -0,0 +1,25 @@
+/* { dg-do compile { target { x86_64-*-* } } } */
+/* { dg-options "-O2 -fdump-rtl-ree" } */
Please use:
/* { dg-do compile { target { ! ia32 } } }
On 12/20/13 01:24, Jakub Jelinek wrote:
Thanks for working on this, the only thing I'd worry about are
HARD_REGNO_NREGS > 1 registers if the two hard regs might overlap.
The reg_set_between_p and reg_used_between_p calls when you dig down
into them eventually use reg_overlap_mentioned_p which s
Hi!
I've backported this fix from the trunk to 4.8 branch and for the trunk
committed the new testcase.
2013-12-20 Jakub Jelinek
PR c++/59255
Backported from mainline
2013-08-19 Dehao Chen
* value-prof.c (gimple_ic): Fix the bug of adding EH edge.
On Fri, Dec 20, 2013 at 09:26:10AM -0700, Jeff Law wrote:
> >Thanks for working on this, the only thing I'd worry about are
> >HARD_REGNO_NREGS > 1 registers if the two hard regs might overlap.
> The reg_set_between_p and reg_used_between_p calls when you dig down
> into them eventually use reg_ove
> This patch seems to make rather too many assumptions about host and
> target compilers. Certainly code like this can't go into
> target-independent code like lto-wrapper.
That's true. The point of this patch was to show what is needed to support
x86->MIC OpenMP offloading, as we currently see it
> > Perhaps we should add sandybridge, ivybridge and haswell aliases for
> > corei7-avx, core-avx-i, core-avx2? I mean, it is a nightmare to remember
> > which one has the i7 in and which doesn't even for me.
>
> Yes please, I think this is a good idea.
I've added aliases for haswell, sandybridg
On Fri, Dec 20, 2013 at 8:47 AM, Ilya Tocar wrote:
>> > Perhaps we should add sandybridge, ivybridge and haswell aliases for
>> > corei7-avx, core-avx-i, core-avx2? I mean, it is a nightmare to remember
>> > which one has the i7 in and which doesn't even for me.
>>
>> Yes please, I think this is
On 12/20/13 09:45, Jakub Jelinek wrote:
On Fri, Dec 20, 2013 at 09:26:10AM -0700, Jeff Law wrote:
Thanks for working on this, the only thing I'd worry about are
HARD_REGNO_NREGS > 1 registers if the two hard regs might overlap.
The reg_set_between_p and reg_used_between_p calls when you dig dow
Hi Jakub,
Could you please take a look at this patch for libgomp?
It adds new function GOMP_register_lib, that should be called from every
exec/lib with target regions (that was done in patch [1]). This function
maintains the array of pointers to the target shared library descriptors.
Also this
On 12/13/2013 10:32 AM, Jan Hubicka wrote:
On 12/13/2013 05:58 AM, Jan Hubicka wrote:
Moreover when we turn comdat_local to false, we need to recompute also
function it is inlined into.
I don't see why. If function A calls function B, which calls
comdat-local function C, A can be inlined, so
On Fri, Dec 20, 2013 at 10:17:10AM -0700, Jeff Law wrote:
> ISTM if we're presented with something like that (and I don't think
> there's anything in RA which explicitly disallows such code), then
> what we have to evaluate is whether or not the transformation
> preserves the semantics.
>
> So, in
On 12/20/13 10:25, Jakub Jelinek wrote:
So it probably should be checked
in combine_reaching_defs instead where you have already both the registers
in the right modes available and can call reg_overlap_mentioned_p on them
directly. One argument would be SET_DEST (def_insn) and one SET_DEST
(ca
So here's an alternate approach to fixing 59285. I still think
attacking this in rtl_merge_blocks is better, but with nobody else
chiming in to break the deadlock Steven and myself are in, I'll go with
Steven's preferred solution (fix the callers in ifcvt.c).
If we were to return to a "fix
Hi all,
This patch will add armv7ve support to gcc. Armv7ve is basically a
armv7-a architecture profile with Virtualization Extensions. Additional
test cases are also added.
With this patch and to keep backward compatibility with old assembler,
the following asm header will be generated when
On 12/20/13 10:25, Jakub Jelinek wrote:
Yes. So my suggestion actually was not correct for that:
&& !reg_overlap_mentioned_p (dest, XEXP (src, 0))
because the first extension above has r1:SI and r2:DI which don't
overlap, only r1:DI and r2:DI overlap. So it probably should be checked
in comb
On Fri, Dec 20, 2013 at 01:44:06PM -0700, Jeff Law wrote:
> @@ -342,7 +354,8 @@ combine_set_extension (ext_cand *cand, rtx curr_insn, rtx
> *orig_set)
>if (dump_file)
> {
>fprintf (dump_file,
> -"Tentatively merged extension with definition:\n");
> +
We have committed several backports from trunk to linaro/gcc-4_8-branch:
r203799 as r205740 (fix testcases for ARM hardfloat targets)
r203327 as r205742 (Enhance phiopt to handle BIT_AND_EXPR)
r204737 as r205743 (Make AArch64 frame grow downwards)
r202872 as r205744 ([ARM][testsuite] Add effective
Hi,
the below patch adds support for powerpc64 FreeBSD for the boehm-gc.
The diff is already available in boehm-gc trunk.
Ok for gcc trunk?
Thanks,
Andreas
2013-12-20 Andreas Tobler
* include/private/gcconfig.h: Add FreeBSD powerpc64 defines.
Index: include/private/gcconfig.h
=
Here are the results using our internal benchmarks which are a mixed a
multi-threaded and single-threaded programs.
This was collected about a month ago but I did not got time to send
due to an unexpected trip.
cmpxchg gives the worst performance due to the memory barriers it incurs.
I'll send a p
On Fri, Dec 20, 2013 at 8:55 AM, H.J. Lu wrote:
> On Fri, Dec 20, 2013 at 8:47 AM, Ilya Tocar wrote:
>>> > Perhaps we should add sandybridge, ivybridge and haswell aliases for
>>> > corei7-avx, core-avx-i, core-avx2? I mean, it is a nightmare to remember
>>> > which one has the i7 in and which d
On Fri, Dec 20, 2013 at 2:09 AM, Bingfeng Mei wrote:
> OK to commit?
>
> Thanks,
> Bingfeng
> -Original Message-
> From: gcc-patches-ow...@gcc.gnu.org [mailto:gcc-patches-ow...@gcc.gnu.org] On
> Behalf Of Bingfeng Mei
> Sent: 18 December 2013 16:25
> To: Jakub Jelinek
> Cc: Richard Biener
On 12/20/2013 09:29 AM, Marek Polacek wrote:
We ICEd on invalid testcases with auto, because lookup_conversions
got template_type_parm as a parameter and the TYPE_BINFO didn't like
it. Fixed by checking for RECORD_OR_UNION_TYPE_P first.
Use CLASS_TYPE_P instead. OK with that change.
Jason
Committed documentation as r206161. Sorry about the delay.
Thanks,
Sharad
On Thu, Nov 28, 2013 at 10:03 AM, Martin Jambor wrote:
> Hi,
>
> On Tue, Aug 06, 2013 at 10:18:05AM -0700, Sharad Singhai wrote:
>> On Tue, Aug 6, 2013 at 10:10 AM, Martin Jambor wrote:
>> > On Tue, Aug 06, 2013 at 09:22:
49 matches
Mail list logo