On Wed, Jul 17, 2013 at 6:18 PM, David Malcolm wrote:
> gcc/
>
> Explicitly number the instances of passes within passes.def.
>
> This is needed by a subsequent patch so that we can create
> fields within the pipeline class for each pass instance (to help
> locate p
On Wed, Jul 17, 2013 at 6:18 PM, David Malcolm wrote:
> The following patch series moves the logic for creating the
> pipeline of optimization passes out from passes.c and into a new
> passes.def file (patches 1 and 2).
>
> It then explicitly numbers those passes that have multiple instances, by
>
Hello!
> The PR is logged against Darwin, and (as Jakub points out in the PR
> thread) indeed Darwin is missing a nonlocal_goto_receiver to restore
> the PIC reg in code that uses it (most of the patch).
>
> However, there is a second issue, and (if I've understood things
> correctly) this affects
Hi Uros,
(working on a re-vamp with an expander for the nonlocal goto MD).
On 18 Jul 2013, at 08:26, Uros Bizjak wrote:
> Under assumpiton that foo and bar doesn't share the same GOT, you will
> see that g42 after the label is accessed with "clobbered" %ebx.
My understanding is that foo and ba
Zoran Jovanovic wrote:
>Hello,
>This patch adds new optimization pass that combines several adjacent
>bit field accesses that copy values from one memory location to another
>into single bit field access.
>
>Example:
>
>Original code:
> D.1351;
> D.1350;
> D.1349;
> D.1349_2 = p1_1(D)->f1;
On Wed, Jul 17, 2013 at 7:06 PM, Jonathan Wakely wrote:
> The changelog has a typo, _M__search_from_first has two underscores.
>
> The testcase dg-options should use -std=gnu++11 not -std=c++0x. Is
> the testcase based on an existing file? If not the copyright year
> should just be 2013.
These w
Hi Uros,
On 18 Jul 2013, at 07:31, Uros Bizjak wrote:
> This should be implemented as an expander. You also won't need
> UNSPEC_NLGR that way.
Now I reload the state from this PR, I recall why this did not work.
in the case:
foo ()
{
do stuff that doesn't use the pic reg
call nested functi
Ping~
Thanks,
Yufeng
On 07/02/13 19:53, Yufeng Zhang wrote:
Hi Andrew,
Please find the updated patch in the attachment that addresses your
comments.
It now builds both ilp32 and lp64 multilibs by default, with the
--with-multilib-list support remaining to provide options to turn off
one of th
Ping~
Thanks,
Yufeng
On 06/26/13 23:35, Yufeng Zhang wrote:
This patch updates the AArch64 backend to support the small absolute and
small PIC addressing models for ILP32; it also updates a number of other
backend macros and hooks in order to support ILP32.
OK for the trunk?
Thanks,
Yufeng
Ping^3~
Thanks,
Yufeng
On 07/08/13 11:11, Yufeng Zhang wrote:
Ping^2~
Thanks,
Yufeng
On 07/02/13 23:44, Yufeng Zhang wrote:
Ping~
Can I get an OK please if there is no objection?
Regards,
Yufeng
On 06/26/13 23:39, Yufeng Zhang wrote:
This patch updates assign_parm_find_data_types to ass
Ping~
Thanks,
Yufeng
On 06/26/13 23:41, Yufeng Zhang wrote:
The attached patch fixes a few gcc test cases.
Thanks,
Yufeng
gcc/testsuite/
* gcc.dg/20020219-1.c: Skip the test on aarch64*-*-* in ilp32.
* gcc.target/aarch64/aapcs64/test_18.c (struct y): Change the field
Ping~
Thanks,
Yufeng
On 06/26/13 23:42, Yufeng Zhang wrote:
This patch defines _ILP32 and __ILP32__ for the AArch64 port when the
ILP32 ABI is in use.
This helps libraries, e.g. libgloss and glibc, recognize which model is
being compiled.
OK for the trunk?
Thanks,
Yufeng
gcc/
* con
Ping~
Thanks,
Yufeng
On 06/27/13 17:00, Yufeng Zhang wrote:
This patch fixes the bug that pointer-typed argument passed on stack is
not padded properly in ILP32.
OK for the trunk?
Thanks,
Yufeng
gcc/
* config/aarch64/aarch64.c (aarch64_pad_arg_upward): In big-endian,
p
Currently, the fixed-point rounding does not work correctly in the overflow
case. This is because of misreading section 2.1.7.2 of TR 18037.
Rounding builtins expand to saturated addition and AND so that the instruction
sequence is
add value1
if not overflow goto 0
load max value
0:
and value2
On Thu, 2013-07-18 at 00:08 -0700, Andrew Pinski wrote:
> On Wed, Jul 17, 2013 at 6:18 PM, David Malcolm wrote:
> > gcc/
> >
> > Explicitly number the instances of passes within passes.def.
> >
> > This is needed by a subsequent patch so that we can create
> > fields within
On Thu, Jul 18, 2013 at 12:12 PM, Iain Sandoe wrote:
>> This should be implemented as an expander. You also won't need
>> UNSPEC_NLGR that way.
>
> Now I reload the state from this PR, I recall why this did not work.
>
> in the case:
>
> foo ()
> {
>
> do stuff that doesn't use the pic reg
>
>
Hi,
Please find the patch to add assembler option "-mcu" for generating assembler
error messages when target not supporting hardware FPU were seeing FPU code,
namely RX100 and RX200.
KPIT has recently submitted a patch to add warnings of RX variants that do not
have hardware FPU support,
http://w
Hi,
running the cilk-plus.exp tests I get ~200 FAILs because the tests are not
written for 16-bit int or size_t platforms.
As a quick tentative fix, the cilk-plus tests are skipped on such platforms.
Common problems are:
- internal compiler error: in build_int_cst_wide, at tree.c:1214
- warnin
Ian Lance Taylor writes:
> I have committed a large patch to update libgo to the library that was
> part of the Go 1.1.1 release. As usual, I'm not including the entire
> patch in this e-mail message, because it is too large. I'm only
> including the changes to the files that are partially gccg
> "Phil" == Phil Muldoon writes:
Phil> 2013-07-03 Phil Muldoon
Phil> PR gcc/53477
Phil> http://sourceware.org/bugzilla/show_bug.cgi?id=15195
Phil> * python/libstdcxx/v6/printers.py (Printer.__call__): If a value
Phil> is a reference, fetch referenced value.
Phil> (RxPrinter.invok
On Thu, Jul 18, 2013 at 4:33 AM, David Malcolm wrote:
> On Thu, 2013-07-18 at 00:08 -0700, Andrew Pinski wrote:
>> On Wed, Jul 17, 2013 at 6:18 PM, David Malcolm wrote:
>> > gcc/
>> >
>> > Explicitly number the instances of passes within passes.def.
>> >
>> > This is needed by a s
The following patch fixes a testsuite failure due to the fact that
-mcpu=power8 was turning on the new flags such as power8-vector, which
would then result in the VSX flag being turned back on after it was
previously turned off due to a conflicting option such as -msoft-float.
Bootstrap/regtes
> "David" == David Malcolm writes:
David> If so, what tools are blessed for usage at build time? (I'd prefer
David> Python, but I don't think that's a build-time dep yet).
http://www.gnu.org/prep/standards/html_node/Utilities-in-Makefiles.html#Utilities-in-Makefiles
Tom
pass_ipa_lto_wpa_fixup was removed in r158622:
2010-04-21 Jan Hubicka
[...snip...]
* passes.c (init_optimization_passes): Remove pass_ipa_lto_wpa_fixup.
but that commit left the declaration still present in tree-pass.h
This patch removes the redundant decl.
Successfully boots
On 07/17/2013 10:41 AM, pcha...@cs.wisc.edu wrote:
Hi,
The problem appears in revision 200945 in version 4.9. I attached
a one-line patch that fixes it. I also reported this problem at
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=57810 .
In method "validate_const_int()" in "gcc/read-rtl.c", th
On 07/17/2013 10:38 AM, pcha...@cs.wisc.edu wrote:
Hi,
The problem appears in revision 200945 in version 4.9. I attached
a one-line patch that fixes it. I also reported this problem at
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=57805.
In method "write_roots()" in gcc/gengtype.c, the loop on
On 07/18/2013 10:03 AM, David Malcolm wrote:
pass_ipa_lto_wpa_fixup was removed in r158622:
2010-04-21 Jan Hubicka
[...snip...]
* passes.c (init_optimization_passes): Remove pass_ipa_lto_wpa_fixup.
but that commit left the declaration still present in tree-pass.h
This patch
On 07/17/2013 07:18 PM, David Malcolm wrote:
gcc/
* passes.c (init_optimization_passes): Introduce macros for
constructing the tree of passes (INSERT_PASSES_AFTER,
PUSH_INSERT_PASSES_WITHIN, POP_INSERT_PASSES,
TERMINATE_PASS_LIST).
---
gcc/passes.c | 108
On 07/17/2013 07:18 PM, David Malcolm wrote:
gcc/
* passes.def: New.
* passes.c (init_optimization_passes): Move the construction of
the pass hierarchy into a new passes.def file.
* Makefile.in (passes.o): Add dependency on passes.def.
OK for the trunk.
I'm ass
On 07/17/2013 07:18 PM, David Malcolm wrote:
gcc/
Explicitly number the instances of passes within passes.def.
This is needed by a subsequent patch so that we can create
fields within the pipeline class for each pass instance (to help
locate pass instances when d
On Wed, Jul 17, 2013 at 09:18:21PM -0400, David Malcolm wrote:
> --- /dev/null
> +++ b/gcc/passes.def
> @@ -0,0 +1,405 @@
> +/* Description of pass structure
> + Copyright (C) 2013 Free Software Foundation, Inc.
Shouldn't this be 1987-2013 instead? I mean, it isn't really a new file,
the conten
On 07/17/2013 07:18 PM, David Malcolm wrote:
contrib/
* check_passes.py: New.
OK for the trunk.
jeff
Hmm, that logic is difficult to follow. It needs comments at least
explaining last_seen_* and why the loop in the suffix handling keeps
going after we change the phase to RAW_STR.
Maybe instead of tracking last_seen_* BUFF_APPEND could copy into a
short local char array as well as the string
On 03/18/13 05:48, David Holsgrove wrote:
Changelog
2013-03-18 David Holsgrove
* gcc/config/microblaze/microblaze.c (microblaze_expand_prologue):
Add check for flag_stack_usage to handle -fstack-usage support
Signed-off-by: David Holsgrove
Applied revision 201035.
--
Michael Eager
On 07/12/2013 04:13 PM, Cong Hou wrote:
GCC bootstrap failed with loop vectorizer turned on by default at O2.
The symptom is that the comparison between stage2&3 compilers fails.
The root cause is a bug in the file "tree-vect-data-refs.c", where a
qsort() function call is used to sort a group of
The difference is that the relative order of DECL_UIDs do not change
whether debug info is on or not, but there is no such guarantee when
hashing is involved.
David
On Thu, Jul 18, 2013 at 9:45 AM, Jeff Law wrote:
> On 07/12/2013 04:13 PM, Cong Hou wrote:
>>
>> GCC bootstrap failed with loop vec
On Thu, 2013-07-18 at 10:11 -0600, Jeff Law wrote:
> On 07/18/2013 10:03 AM, David Malcolm wrote:
> > pass_ipa_lto_wpa_fixup was removed in r158622:
> >
> > 2010-04-21 Jan Hubicka
> > [...snip...]
> > * passes.c (init_optimization_passes): Remove pass_ipa_lto_wpa_fixup.
> >
> > but
On 07/18/2013 10:53 AM, David Malcolm wrote:
On Thu, 2013-07-18 at 10:11 -0600, Jeff Law wrote:
In the example ("Commit the changes to the central repository") you
appear to have trimmed the top line containing date and name from the
ChangeLog entry, and I've (mostly) emulated that in my commits
On 07/15/2013 02:26 PM, Wei Mi wrote:
> Hi,
>
> http://gcc.gnu.org/bugzilla/show_bug.cgi?id=57878
>
> The bug occurs because tfreq is given higher priority than bigger mode
> in reload_pseudo_compare_func. When there are multiple reload pseudos
> in the same insn, and the pseudo with bigger mode ha
On Thu, Jul 18, 2013 at 10:45:19AM -0600, Jeff Law wrote:
> If I understand you correctly, you're claiming that the DECL_UID can
> vary based on whether or not we're emitting debug info. This can be
> seen in iterative_hash_expr:
Yes, for e.g. SSA_NAME_VERSION, we require that it is the same in b
> * dwarf2out.c (field_type): static removed from declaration.
> (simple_type_size_in_bits): static removed from declaration.
> (field_byte_offset): static removed from declaration.
> (field_type): static inline removed from declaration.
If you're going to use these declarations from
tree-
On Jul 18, 2013, at 6:48 AM, Georg-Johann Lay wrote:
> running the cilk-plus.exp tests I get ~200 FAILs because the tests are not
> written for 16-bit int or size_t platforms.
>
> As a quick tentative fix, the cilk-plus tests are skipped on such platforms.
I think this patch is fine. Until such
On Thu, 2013-07-18 at 10:18 -0600, Jeff Law wrote:
> On 07/17/2013 07:18 PM, David Malcolm wrote:
> > gcc/
> > * passes.c (init_optimization_passes): Introduce macros for
> > constructing the tree of passes (INSERT_PASSES_AFTER,
> > PUSH_INSERT_PASSES_WITHIN, POP_INSERT_PASSES,
> >
On Thu, Jul 18, 2013 at 10:58 AM, Pat Haugen
wrote:
> The following patch fixes a testsuite failure due to the fact that
> -mcpu=power8 was turning on the new flags such as power8-vector, which would
> then result in the VSX flag being turned back on after it was previously
> turned off due to a c
> -Original Message-
> From: Mike Stump [mailto:mikest...@comcast.net]
> Sent: Thursday, July 18, 2013 2:14 PM
> To: Georg-Johann Lay
> Cc: gcc-patches@gcc.gnu.org; Iyer, Balaji V
> Subject: Re: [patch,cilk-plus,testsuite] Skip int16 and size16 targets (too
> much
> FAILs)
>
> On Jul 18
On Thu, 2013-07-18 at 10:21 -0600, Jeff Law wrote:
> On 07/17/2013 07:18 PM, David Malcolm wrote:
> > gcc/
> > * passes.def: New.
> >
> > * passes.c (init_optimization_passes): Move the construction of
> > the pass hierarchy into a new passes.def file.
> >
> > * Makefile.in (passes.
Committed the following as obvious.
2013-07-18 Pat Haugen
* gcc.target/powerpc/pr57744.c: Fix typo.
Index: gcc/testsuite/gcc.target/powerpc/pr57744.c
===
--- gcc/testsuite/gcc.target/powerpc/pr57744.c(revision 2009
On Wed, 17 Jul 2013, Zoran Jovanovic wrote:
> Hello,
> This patch adds new optimization pass that combines several adjacent bit
> field accesses that copy values from one memory location to another into
> single bit field access.
>
> Example:
>
> Original code:
> D.1351;
> D.1350;
> D.13
On 07/05/2013 10:04 AM, Marek Polacek wrote:
+/* This type represents an entry in the hash table. */
Please describe the hash table more up here. What are you tracking?
+ hashval_t h = iterative_hash_object (data->type, 0);
+ h = iterative_hash_object (data->decl, h);
If you hash the de
On Tue, Jul 16, 2013 at 08:04:14AM +0200, Bernhard Reutner-Fischer wrote:
> +# ubsan_finish -- called at the start of each subdir of tests
>
> s/the start/the end/
You're attentive, will fix. Thanks,
Marek
On Wed, 17 Jul 2013, Richard Sandiford wrote:
> "Maciej W. Rozycki" writes:
> >> The patch mostly looks good apart from that, but please use a single
> >> enum for the 2008/legacy thing, both in mips.h and mips.opt.
> >
> > Also mips.c and mips.md (and last but not least mips-opts.h). Done.
>
On 19 July 2013 02:42, Michael Eager wrote:
> On 03/18/13 05:48, David Holsgrove wrote:
>>
>> Changelog
>>
>> 2013-03-18 David Holsgrove
>>
>> * gcc/config/microblaze/microblaze.c (microblaze_expand_prologue):
>> Add check for flag_stack_usage to handle -fstack-usage support
>>
>> Signed-o
On 07/18/13 16:25, David Holsgrove wrote:
On 19 July 2013 02:42, Michael Eager wrote:
On 03/18/13 05:48, David Holsgrove wrote:
Changelog
2013-03-18 David Holsgrove
* gcc/config/microblaze/microblaze.c (microblaze_expand_prologue):
Add check for flag_stack_usage to handle -fstack-
On Mon, 8 Jul 2013 20:20:01 -0600
Ryan Hill wrote:
Ping.
> On Mon, 1 Jul 2013 14:56:01 -0600
> Ryan Hill wrote:
>
> Ping.
> http://gcc.gnu.org/ml/gcc-patches/2013-07/msg00033.html
>
>
> > libitm is currently unconditionally built with -Werror. This patch adds
> > --enable-werror to control
On Mon, 8 Jul 2013 20:19:24 -0600
Ryan Hill wrote:
Ping.
> On Mon, 1 Jul 2013 14:55:35 -0600
> Ryan Hill wrote:
>
> Ping.
> http://gcc.gnu.org/ml/gcc-patches/2013-07/msg00032.html
>
> > libatomic is currently unconditionally built with -Werror. This patch adds
> > --enable-werror to control
On Wed, 21 Nov 2012 13:15:34 +
Marcus Shawcroft wrote:
> Thanks for looking at this Laurynas.
>
> I've committed the attached to trunk.
>
>
> /Marcus
>
> 2012-11-21 Marcus Shawcroft
>
> * Makefile.in (gengtype-lex.o): Add dependency on $(BCONFIG_H).
This also affects 4.7. Ca
56 matches
Mail list logo