Dear Tobias,
I think that this is sufficiently "obvious" that you could have taken
silence to be approval :-)
Of course it's OK for trunk.
Cheers
Paul
On Fri, Oct 14, 2011 at 11:15 PM, Tobias Burnus wrote:
> *ping*
>
> http://gcc.gnu.org/ml/fortran/2011-10/msg00073.html
>
> On 12.10.2011 15:5
Kirill Yukhin writes:
> --- /dev/null
> +++ b/gcc/testsuite/gcc.target/i386/fma_double_1.c
> @@ -0,0 +1,19 @@
> +/* { dg-do compile } */
> +/* { dg-prune-output ".*warning: 'sseregparm' attribute ignored.*" } */
That prunes too much. gcc-dg-prune brackets the regexp so that it only
matches with
On Sat, Oct 15, 2011 at 10:14 AM, Andreas Schwab wrote:
>> --- /dev/null
>> +++ b/gcc/testsuite/gcc.target/i386/fma_double_1.c
>> @@ -0,0 +1,19 @@
>> +/* { dg-do compile } */
>> +/* { dg-prune-output ".*warning: 'sseregparm' attribute ignored.*" } */
>
> That prunes too much. gcc-dg-prune bracke
Hello world,
here is a fix for PR 50690, pretty self-explanatory. Regression-tested.
OK for trunk?
Thomas
2011-10-15 Thomas Koenig
PR fortran/50690
* frontend-passes.c (omp_level): New variable.
(create_var): If we are within an OMP block, put
the
This patch disables the machinery associated with allocating objects on a user
defined storage pool in build-in-place functions ZFP does not support pools.
Tested on x86_64-pc-linux-gnu, committed on trunk
2011-10-15 Bob Duff
* exp_ch6.adb (Add_Unconstrained_Actuals_To_Build_In_Place_
The type Queue has a (default) discriminant to specify the (ceiling)
priority. That discriminant value is now used as the value of the Priority
aspect of the protected type.
Tested on x86_64-pc-linux-gnu, committed on trunk
2011-10-15 Matthew Heaney
* a-cusyqu.ads, a-cbsyqu.ads, a-cup
On behalf of Tilera Corporation, I'd like to contribute gcc ports to two of its
families of architectures, the TILEPro architecture and the TILE-Gx
architecture. TILEPro is a VLIW architecture with 32-bit registers, 32-bit
address space, and 64-bit instructions. TILE-Gx is a VLIW architecture wit
Here are the toplevel changes.
* MAINTAINERS (tilegx port): Add self.
(tilepro port): Add self.
diff -r -u -p -N /home/packages/gcc-4.7.0-179959/MAINTAINERS ./MAINTAINERS
--- /home/packages/gcc-4.7.0-179959/MAINTAINERS 2011-10-14 01:12:54.0
-0400
+++ ./MAINTAINERS 2
Here are the contrib changes.
* config-list.mk (tilegx-linux-gnu): Add.
(tilepro-linux-gnu): Add.
diff -r -u -p -N /home/packages/gcc-4.7.0-179959/contrib/config-list.mk
./contrib/config-list.mk
--- /home/packages/gcc-4.7.0-179959/contrib/config-list.mk 2011-10-14
01:08:51.
Here is the libcpp port.
* configure.ac: Require 64-bit hwint for tilegx and tilepro.
* configure: Regenerate.
diff -r -u -p -N /home/packages/gcc-4.7.0-179959/libcpp/configure
./libcpp/configure
--- /home/packages/gcc-4.7.0-179959/libcpp/configure2011-10-14
01:12:52.
Here is the libgcc port.
* config.host: Handle tilegx and tilepro.
* config/tilegx/t-tilegx: New file.
* config/tilepro/atomic.c: New file.
* config/tilepro/milieu.h: New file.
* config/tilepro/softdivide.c: New file.
* config/tilepro/softfloat.c: Ne
Here is the libgomp port.
* configure.tgt: Handle tilegx and tilepro.
* config/linux/tile/futex.h: New file.
diff -r -u -p -N
/home/packages/gcc-4.7.0-179959/libgomp/config/linux/tile/futex.h
./libgomp/config/linux/tile/futex.h
--- /home/packages/gcc-4.7.0-179959/libgomp/config/
Here are the wwwdocs changes, with the news date TBD.
Index: backends.html
===
RCS file: /cvs/gcc/wwwdocs/htdocs/backends.html,v
retrieving revision 1.41
diff -u -p -r1.41 backends.html
--- backends.html 15 Jul 2011 09:48:14 -00
On Sat, Oct 15, 2011 at 10:32 AM, Uros Bizjak wrote:
>>> --- /dev/null
>>> +++ b/gcc/testsuite/gcc.target/i386/fma_double_1.c
>>> @@ -0,0 +1,19 @@
>>> +/* { dg-do compile } */
>>> +/* { dg-prune-output ".*warning: 'sseregparm' attribute ignored.*" } */
>>
>> That prunes too much. gcc-dg-prune br
On Sat, Oct 15, 2011 at 11:02:12AM +0200, Thomas Koenig wrote:
> Hello world,
>
> here is a fix for PR 50690, pretty self-explanatory. Regression-tested.
> OK for trunk?
This looks wrong. Threadprivate variables aren't completely cheap,
much better would be an automatic variable instead.
As For
Am 15.10.2011 13:36, schrieb Jakub Jelinek:
This looks wrong. Threadprivate variables aren't completely cheap,
much better would be an automatic variable instead.
As Fortran FE IL doesn't have block local variables, I guess you want
to create the var at function scope and add a private(that_tem
> Forgot to mention: Will backport to 4.6 during the weekend (hopefully
> in time for 4.6.2).
Just did so (r180037).
Cheers,
Janus
> 2011/10/14 Janus Weil :
>> Hi all,
>>
>> I just committed a one-line fix for this regression (approved by
>> Tobias in a private mail):
>>
>> http://gcc.gnu.org
> PR middle-end/50496
> * cfgrtl.c (try_redirect_by_replacing_jump): Treat EXIT_BLOCK_PTR case
> separately before call to redirect_jump(). Add assertion.
> (patch_jump_insn): Same.
This will definitely disable redirections to the exit block. Now...
> diff --git a/gcc/cfg
> About the 1st question. Before gcc4.7, the only class (allocno class)
> used for coloring can be a cover class. So it was not possible to use
> GENERAL_OR_EXTRA_FP_REGS in gcc4.6 and older versions. Starting gcc4.7,
> class used for coloring can be any class which is more profitable than
> mem
Hi Jakub,
I guess you want
to create the var at function scope and add a private(that_temporary)
clause to the nearest enclosing OpenMP directive.
Here is a patch which implements this. Regression-tested, no new
failures. OK for trunk?
Thomas
2011-10-15 Thomas Koenig
PR
Am 15.10.2011 14:04, schrieb Thomas Koenig:
Am 15.10.2011 13:36, schrieb Jakub Jelinek:
This looks wrong. Threadprivate variables aren't completely cheap,
much better would be an automatic variable instead.
As Fortran FE IL doesn't have block local variables, I guess you want
to create the var
All comments here refer to the first instance of an issue; many issues are
shared between the two ports but are only mentioned once here.
On Sat, 15 Oct 2011, Walter Lee wrote:
> +#undef SYSROOT_SUFFIX_SPEC
> +#define SYSROOT_SUFFIX_SPEC "%{mbme:/usr/lib/bme;mnewlib:/usr/lib/newlib}"
> +
> +#und
Pedro Alves schrieb:
On Friday 14 October 2011 18:19:00, Georg-Johann Lay wrote:
Paolo Bonzini schrieb:
On 10/14/2011 06:23 PM, Georg-Johann Lay wrote:
+@item -mjump-to-noreturn
+@opindex mjump-to-noreturn
+Use a jump instruction instead of a call instruction when calling a
+no-return funct
On Sat, 15 Oct 2011, Walter Lee wrote:
> +FPBIT_FUNCS := $(filter-out \
> + _addsub_sf _mul_sf _div_sf _negate_sf \
> + _eq_sf _ne_sf _le_sf _lt_sf _ge_sf _gt_sf \
> + _sf_to_di _sf_to_si _sf_to_udi _sf_do_usi \
> + _di_to_sf _si_to_sf _udi_to_sf _usi_to_sf, \
> + $(FPBIT_FUNCS))
> +
> +DPBIT
On Sat, Oct 15, 2011 at 06:36:55PM +0200, Tobias Burnus wrote:
> I think that's the wrong solution to the problem: I think it makes
> more sense to fix the handling for OMP workshare to handle BLOCK
> correctly rather than to move the variable to the function scope and
> then to fiddle with the pri
On Sat, Oct 15, 2011 at 07:19:43PM +0200, Jakub Jelinek wrote:
> On Sat, Oct 15, 2011 at 06:36:55PM +0200, Tobias Burnus wrote:
> > I think that's the wrong solution to the problem: I think it makes
> > more sense to fix the handling for OMP workshare to handle BLOCK
> > correctly rather than to mo
On 10/14/2011 06:57 PM, Paolo Carlini wrote:
- return false;
+ return complete_type_or_else (type, NULL_TREE);
I think I'd do
complete_type_or_else (strip_array_types (type), NULL_TREE)
so that the error doesn't complain about unspecified bounds, which would
be misleading.
Jason
On 10/15/2011 08:33 PM, Jason Merrill wrote:
On 10/14/2011 06:57 PM, Paolo Carlini wrote:
- return false;
+ return complete_type_or_else (type, NULL_TREE);
I think I'd do
complete_type_or_else (strip_array_types (type), NULL_TREE)
so that the error doesn't complain about unspecified boun
OK.
Jason
Tested on x86_64-linux, --with-cpu=corei7 and ppc64-linux, --with-cpu=G5.
Committed.
r~
* tree-vect-slp.c: Include langhooks.h.
(vect_create_mask_and_perm): Emit VEC_PERM_EXPR, not a builtin.
(vect_transform_slp_perm_load): Use can_vec_perm_expr_p. Simplify
mask
On 10/12/2011 04:58 PM, 3dw...@verizon.net wrote:
+ const char *text = (const char *)tok->val.str.text;
+ char delim;
+ unsigned int i;
+ for (i = 0; i < len; ++i)
+if (text[i] == '\'' || text[i] == '"')
+ break;
This seems like it will get confused by embedded ' or \" in the strin
On 10/12/2011 04:58 PM, 3dw...@verizon.net wrote:
+ tree const_char_ptr_type_node
+ = build_pointer_type (build_type_variant (char_type_node, 1, 0));
You can just use const_string_type_node here.
Jason
This patch fixes the checking of constant SHIFT values against
the bitsize of the argument to be shifted. I've been running
this patch on amd64-*-freebsd for sevearl days without a
problem (ie., multiple 'gmake check-gfortran' invocations).
OK for trunk?
2011-10-15 Steven G. Kargl
*
This patch fixes a bug in which the widening multiply-and-accumulate
optimization failed to take the intermediate types into account.
The effect of this is that the compiler would do what the programmer
expected to happen, rather than what the C standard requires to happen
(in many cases), so
resolve_ref() calls resolve_substring() but failed to check
its return value. This patch does the check.
2011-10-15 Steven G. Kargl
* resolve.c (resolve_ref): Check return value of resolve_substring().
2011-10-15 Steven G. Kargl
* gfortran.dg/substring_integer_index.f90
From: Andi Kleen
Some external tools special case __gnu_lto* symbols, and the new __gnu_slim_lto
was the only LTO symbol not matching this pattern. Since I don't think
there are any users rename it to __gnu_lto_slim
Passes bootstrap and test suite on x86_64-linux. Ok?
Cc: hubi...@ucw.cz
gcc/:
36 matches
Mail list logo