Re: [PATCH 1/4] introduce struct strlen_data_t into gimple-fold

2018-12-14 Thread Martin Sebor
On 12/14/18 2:23 PM, Jeff Law wrote: On 12/10/18 2:00 PM, Martin Sebor wrote: Jeff, is there something you are expecting me to change in response to this or have you just not gotten around to reviewing the rest? Your last comment led me to believe you had another iteration on the first patch to

Re: [PATCH 1/4] introduce struct strlen_data_t into gimple-fold

2018-12-14 Thread Jeff Law
On 12/10/18 2:00 PM, Martin Sebor wrote: > Jeff, is there something you are expecting me to change in > response to this or have you just not gotten around to reviewing > the rest? Your last comment led me to believe you had another iteration on the first patch to do before we moved forward. > >

Re: [PATCH 1/4] introduce struct strlen_data_t into gimple-fold

2018-12-10 Thread Martin Sebor
Jeff, is there something you are expecting me to change in response to this or have you just not gotten around to reviewing the rest? Martin On 11/28/18 9:26 PM, Jeff Law wrote: On 11/25/18 5:05 PM, Martin Sebor wrote: If so, then I think we need to look for a better name than MAXSIZE and MA

Re: [PATCH 1/4] introduce struct strlen_data_t into gimple-fold

2018-11-28 Thread Jeff Law
On 11/25/18 5:05 PM, Martin Sebor wrote: > >> If so, then I think we need >> to look for a better name than MAXSIZE and MAXLEN. > > I find these names quite fitting and I'm not sure what might work > better.  I renamed MAXSIZE to MAXBOUND but nothing comes to mind > as a replacement for MAXLEN. 

Re: [PATCH 1/4] introduce struct strlen_data_t into gimple-fold

2018-11-25 Thread Martin Sebor
On 10/10/18 1:39 PM, Jeff Law wrote: On 10/2/18 10:37 AM, Martin Sebor wrote: [1/4] - Introduce struct strlen_data_t into gimple-fold This patch introduces a new data structure to reduce the number of arguments and overloads of the get_range_strlen API.  One of the goals of this change is to ma

Re: [PATCH 1/4] introduce struct strlen_data_t into gimple-fold

2018-10-10 Thread Jeff Law
On 10/2/18 10:37 AM, Martin Sebor wrote: > [1/4] - Introduce struct strlen_data_t into gimple-fold > > This patch introduces a new data structure to reduce the number > of arguments and overloads of the get_range_strlen API.  One of > the goals of this change is to make the API safer to use for >

Re: [PATCH 1/4] introduce struct strlen_data_t into gimple-fold

2018-10-03 Thread Bernd Edlinger
Hi, > --- a/gcc/calls.c > +++ b/gcc/calls.c > @@ -1557,7 +1557,10 @@ maybe_warn_nonstring_arg (tree fndecl, tree exp) >tree bound = NULL_TREE; > >/* The range of lengths of a string argument to one of the comparison > - functions. If the length is less than the bound it is used inst

[PATCH 1/4] introduce struct strlen_data_t into gimple-fold

2018-10-02 Thread Martin Sebor
[1/4] - Introduce struct strlen_data_t into gimple-fold This patch introduces a new data structure to reduce the number of arguments and overloads of the get_range_strlen API. One of the goals of this change is to make the API safer to use for optimization (which looks for "permissive" results t