From: yfeldblum
The stdout stream is reserved for output intentionally produced by the
application. Assertion failures and other forms of logging must be
emitted to stderr, not to stdout.
It is common for testing and monitoring infrastructure to scan stderr
for errors, such as for assertion fail
and the std::binary_search?
Thanks,
Jay Pokarna
On Wed, May 31, 2017 at 3:50 AM, Mike Stump wrote:
> On May 29, 2017, at 1:05 AM, jay pokarna wrote:
>>
>> Could you give me the contact of the standard committee?
>
> https://isocpp.org/std/the-committee
>
--
Regards,
Respected Sir,
Could you give me the contact of the standard
committee which handles changes to the c++ standard.
Regards,
Jay Pokarna
On Mon, May 29, 2017 at 2:17 PM, Tim Shen wrote:
> On Mon, May 29, 2017 at 1:05 AM, jay pokarna wrote:
>>>> The techni
?
Regards,
Jay Pokarna
On Mon, May 29, 2017 at 1:13 PM, Tim Song wrote:
> I'm not sure if you forgot to CC the lists or intended to direct the
> email to me alone.
>
> On Mon, May 29, 2017 at 2:41 AM, jay pokarna wrote:
>> I know that cpp wants to generalise its methods so t
Hey,
I am Jay.
I have written code for an optimised version of the binary_search
algorithm of the algorithm header file of the standard template
library.
I have implemented it for the integer data type, but it can be
implemented for any other data type without any changes in the
algorithm as
On 24 November 2015 at 11:34, Marek Polacek wrote:
> On Tue, Nov 24, 2015 at 11:24:38AM +0000, Jay Foad wrote:
>> r230331 also seems to be causing this on x86_64-pc-linux-gnu:
>>
>> $ cat x.c
>> #define P(b) b&&4
>> int a[]=0;
>> int f() { X||P(
$ cat x.c
#define P(b) b&&4
int a[]=0;
int f() { X||P(d); }
$ ~/gcc/build/gcc/cc1 -quiet -Wall x.c
[...]
x.c:3:1: internal compiler error: in contains_point, at
diagnostic-show-locus.c:335
int f() { X||P(d); }
^~~
0x1268fc9 contains_point
/home/jay/svn/gcc/trunk/gcc/diagnostic-show-locu
On 8 May 2015 at 16:23, Richard Henderson wrote:
> Yes, the i386 backend has not implemented conditional sibcalls.
See: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=60159
Jay.
On 3 December 2014 at 14:36, Martin Jambor wrote:
> On Wed, Dec 03, 2014 at 10:53:54AM +0000, Jay Foad wrote:
>> > Index: src/gcc/ipa-prop.h
>> > ===
>> > --- src.orig/gcc/ipa-prop.h
>> > +++ sr
> Index: src/gcc/ipa-cp.c
> ===
> --- src.orig/gcc/ipa-cp.c
> +++ src/gcc/ipa-cp.c
> @@ -262,6 +262,9 @@ public:
>ipcp_lattice ctxlat;
>/* Lattices describing aggregate parts. */
>ipcp_agg_lattice *aggs;
> + /* Alignment
recall not replaceable is more important.
- Jay
On Nov 6, 2014, at 11:38 PM, Richard Henderson wrote:
> On 11/06/2014 06:45 PM, Ian Taylor wrote:
>> On Thu, Nov 6, 2014 at 5:04 AM, Richard Henderson wrote:
>>>
>>> That said, this *may* not actually be a problem
rly on sparc64, passing them as parameters.
Is that what is being used here?
Maybe best to add some members to achieve equivalent size/alignment?
- Jay
> + __builtins_arm_ldfpscr.
s/__builtins/__builtin/g
Did you mean "and __builtin_arm_get_fpscr"?
> +#define FP_BUILTIN(L, U) \
> + {0, CODE_FOR_##L, "__builtin_arm_"#L, ARM_BUILTIN_##U, \
> + UNKNOWN, 0},
> +
> + FP_BUILTIN (set_fpscr, GET_FPSCR)
> + FP_BUILTIN (get_fpscr, SET_FPSCR)
> +#undef FP_BUILTIN
This looks like a typo: you have mapped set->GET and get->SET.
Jay.
Isn't mixing and matching and mismatching somewhat inevitable? Libffi & gcc
don't always come along with each other? One must never change the ABI?
- Jay
On Sep 11, 2013, at 5:55 AM, Bill Schmidt wrote:
> On Wed, 2013-09-11 at 21:08 +0930, Alan Modra wrote:
>> On Wed
st_of_handle_lower_subreg2): Call decompose_multiword_subregs
> with DECOMPOSE_COPIES true.
This patch seems to have caused a slight regression in ARM register allocation:
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58166
Jay.
#define ioctl(fd, func, arg) ioctl(fd, func, (int)arg)
"(int)(arg)", surely.
Jay.
17,424
> so all nodes have these fields.
>
> See the accessor macros, defined below, for documentation of the
> !fields, and the table below which connects the fileds and the
> !accessor macros. */
Typo "fileds".
Jay.
"section"
of code make its own typedefs thereof.
Establish a naming convention perhaps such that when I see foo_t, I know at a
glance that is "just some integer type".
Maybe by always putting "size" or "count" in the name?
But some things are pervasive -- host/target address sizes/offsets.
I need to go read the document..
- Jay
cc-4.x via K&R cc via gcc 3.x
(3.3?). Obviously it is more time and work,
but it does work, and frees mainline gcc from caring.)
Heck, one could even automate this like how there is a multi-pass bootstrap,
adding earlier stages
that go via e.g. gcc 3.3. The earlier compiler stages could be stripped down,
e.g. no optimizer, no debug info output, no LTO.
- Jay
Oops, agreed, shift missing. Also, I've been bitten, unable to find stuff
(grep) due to token pasting, so I am a little slower to use it.
But I understand it is useful in general for reuse.
- Jay
> Subject: Re: constant that doesn't fit
Thank you. I like it. May I have another?
book2:gcc jay$ grep -i epoch vms*
vmsdbgout.c:/* Difference in seconds between the VMS Epoch and the Unix Epoch */
vmsdbgout.c:static const long long vms_epoch_offset = 3506716800ll;
vmsdbgout.c:#define VMS_EPOCH_OFFSET 350671680
vmsdbgout.c
re, but that takes us back to the original gdb issue: it does not
> understand statement expressions.
What's wrong with:
(check_in_cxx(t), t)
?
Jay.
t;align = 1 << 32; // or some suitably large power of two
pi->misalign = val->value;
Jay.
that M=1, N=0 is always a valid conservative thing to return.
If there is a difference, the comment should explain what it means.
Thanks,
Jay.
On 9 August 2011 13:23, Richard Guenther wrote:
> 2011-08-08 Richard Guenther
>
> * tree-vrp.c (zero_nonzero_bits_from_vr): Also return precise
> information for with only negative values.
"for *ranges* with" ?
Jay.
On 7 July 2011 09:09, Richard Sandiford wrote:
> gcc/
> * reload1.c (choose_reload_regs): Use mode sizes to check whether
> an old relaod register completely defines the required value.
s/relaod/reload/
Jay.
> BIT_FIELD_EXPR is equivalent to computing
> a & ~((1 << C1 - 1) << C2) | ((b << C2) & (1 << C1 = 1)),
a & ~(((1 << C1) - 1) << C2) | ((b & ((1 << C1) - 1)) << C2)
?
Jay.
thus
> inserting b of width C1 at the bitfi
On 11 April 2011 15:25, Richard Guenther wrote:
> ! set_min_and_max_values_for_integral_type (t, precision,
> ! /*is_unsinged=*/true);
s/ng/gn/
Jay.
28 matches
Mail list logo