Re: [PATCH] gm2: add missing debug output guard

2024-08-10 Thread Wilken Gottwalt
On Sat, 10 Aug 2024 13:43:33 +0200 (CEST) Gerald Pfeifer wrote: > On Tue, 23 Jul 2024, Gaius Mulley wrote: > >> gcc/gm2: > >>* gm2-libs-iso/MemStream.mod: Guard debug output. > > many thanks! > > I noticed this has not been pushed yet and believe Wilken does not have > write/push access - s

Re: [PATCH v3] diagnostics: Follow DECL_ORIGIN in lhd_print_error_function [PR102061]

2024-08-10 Thread Peter0x44
so duplicating an inline for example in the case we split a function and then inline both parts or in the case we inline a IPA-CP forwarder and the specific clone. It's not obvious what we should do here since of course for a recursive function we can have a function inlined two times in a row

[PATCH v4] diagnostics: Follow DECL_ORIGIN in lhd_print_error_function [PR102061]

2024-08-10 Thread Peter Damianov
Currently, if a warning references a cloned function, the name of the cloned function will be emitted in the "In function 'xyz'" part of the diagnostic, which users aren't supposed to see. This patch follows the DECL_ORIGIN link to get the name of the original function, so the internal compiler det

RE: [PATCH v1] RISC-V: Make sure high bits of usadd operands is clean for HI/QI [PR116278]

2024-08-10 Thread Li, Pan2
> Isn't this just zero extension from a narrower mode to a wider mode? > Why not just use zero_extend? That will take advantage of existing > expansion code to select an efficient extension approach at initial RTL > generation rather than waiting for combine to clean things up. Thanks Jeff, le

RE: [PATCH v1] RISC-V: Bugfix incorrect operand for vwsll auto-vect

2024-08-10 Thread Li, Pan2
> I think my original (failed) idea was this pattern to be an > intermediate/bridge > pattern that never splits. Yes, this pattern should not be hit by design, and any changes to the layout of pattern may result in some vwsll autovec failure. > Once we need to "split" maybe the regular shift i

[pushed] wwwdocs: news: Remove obsolete G95 link

2024-08-10 Thread Gerald Pfeifer
Neither that link nor another one the page it points to (which is in Japanese now) has remotely current status (nor dates including years). --- htdocs/news.html | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/htdocs/news.html b/htdocs/news.html index a8850dd4..c8271e0a 10064

[PATCH v7 2/3] Merge definitions of array_type_nelts_top()

2024-08-10 Thread Alejandro Colomar
There were two identical definitions, and none of them are available where they are needed for implementing __lengthof__. Merge them, and provide the single definition in gcc/tree.{h,cc}, where it's available for __lengthof__, which will be added in the following commit. gcc/ChangeLog: *

[PATCH v7 3/3] c: Add __lengthof__ operator

2024-08-10 Thread Alejandro Colomar
This operator is similar to sizeof but can only be applied to an array, and returns its length (number of elements). FUTURE DIRECTIONS: - We should make it work with array parameters to functions, and somehow magically return the length designator of the array, regardless of it being reall

[PATCH v7 1/3] gcc/: Rename array_type_nelts() => array_type_nelts_minus_one()

2024-08-10 Thread Alejandro Colomar
The old name was misleading. While at it, also rename some temporary variables that are used with this function, for consistency. Link: https://inbox.sourceware.org/gcc-patches/9fffd80-dca-2c7e-14b-6c9b509a7...@redhat.com/T/#m2f661c67c8f7b2c405c8c7fc3152dd85dc729120 Cc: Gabriel Ravier Cc: Marti

[PATCH v7 0/3] c: Add __lengthof__ operator

2024-08-10 Thread Alejandro Colomar
Hi! v7: - Tests: - Fix 2 tests (whitespace fix). - Fix typo in comment. Alejandro Colomar (3): gcc/: Rename array_type_nelts() => array_type_nelts_minus_one() Merge definitions of array_type_nelts_top() c: Add __lengthof__ operator gcc/c-family/c-common.cc| 26

Re: [PATCH] doc: Editorial changes in -fprofile-partial-training

2024-08-10 Thread Sandra Loosemore
On 8/10/24 13:24, Gerald Pfeifer wrote: +With @code{-fprofile-use} all portions of programs not executed during +training runs are optimized aggressively for size rather than speed. +In some cases it is not practical to train all possible hot paths in +the program. (For example, a program may co

[wwwdocs] Re: [COMMITTED] gcc-14: Add Ada changes

2024-08-10 Thread Gerald Pfeifer
On Fri, 26 Apr 2024, Marc Poulhiès wrote: > Co-authored-by: Fernando Oleo Blanco > Co-authored-by: Piotr Trojanek > Signed-off-by: Marc Poulhiès > --- > htdocs/gcc-14/changes.html | 67 +- This is really great how thoroughly you documented all these changes -

[pushed] wwwdocs: gcc-14: Use runtime instead of run-time

2024-08-10 Thread Gerald Pfeifer
Per codingconventions.html as a noun we use "runtime" as opposed to "run-time". Pushed. Gerald --- htdocs/gcc-14/changes.html | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/htdocs/gcc-14/changes.html b/htdocs/gcc-14/changes.html index 62a279b1..aa1d97a8 100644 --- a/htdocs

[pushed] wwwdocs: readings: Update MicroBlaze blaze

2024-08-10 Thread Gerald Pfeifer
Pushed. Gerald This is now under amd.com instead of xilinx.com. --- htdocs/readings.html | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/htdocs/readings.html b/htdocs/readings.html index f0d44d6f..1f1dbae3 100644 --- a/htdocs/readings.html +++ b/htdocs/readings.html @@ -1

[PATCH] doc: Editorial changes in -fprofile-partial-training

2024-08-10 Thread Gerald Pfeifer
I became aware of a typo in this paragraph and then realized there is more room for editorial changes (grammar, consistency, and being more clear). *Not* pushed. Honza, Sandra, what do you think? Gerald gcc: * doc/invoke.texi (Optimize Options) <-fprofile-partial-training>: Ed

Re: Ping^6: [PATCH 0/2] Fix two test failures with --enable-default-pie [PR70150]

2024-08-10 Thread Xi Ruoyao
On Wed, 2024-07-31 at 21:58 +, Joseph Myers wrote: > On Mon, 22 Jul 2024, Xi Ruoyao wrote: > > > On Mon, 2024-05-06 at 12:45 +0800, Xi Ruoyao wrote: > > > In GCC 14.1-rc1, there are two new (comparing to GCC 13) failures if > > > the build is configured --enable-default-pie.  Let's fix them. >

Re: [PATCH v1] RISC-V: Make sure high bits of usadd operands is clean for HI/QI [PR116278]

2024-08-10 Thread Jeff Law
On 8/8/24 9:12 PM, pan2...@intel.com wrote: From: Pan Li For QI/HImode of .SAT_ADD, the operands may be sign-extended and the high bits of Xmode may be all 1 which is not expected. For example as below code. signed char b[1]; unsigned short c; signed char *d = b; int main() { b[0] = -4

Re: [PATCH] Avoid cfg corruption when using sjlj exceptions where loops are present in the assign_params emitted code.

2024-08-10 Thread Jeff Law
On 8/9/24 1:14 AM, Joern Wolfgang Rennecke wrote: bootstrapped on x86_64-pc-linux-gnu. anti-cfg-corrupt.txt Avoid cfg corruption when using sjlj exceptions where loops are present in the assign_params emitted code. 2024-08-06 Joern Rennecke gcc/ * except.cc (sjlj_emit_function_en

Re: [PATCH v1] RISC-V: Bugfix incorrect operand for vwsll auto-vect

2024-08-10 Thread Robin Dapp
A bit of bikeshedding: While it's obviously a bug, I'm not really sure it's useful to truncate before emitting the widening shift. Do we save an instruction vs. the regular non-widening shift by doing so? I think my original (failed) idea was this pattern to be an intermediate/bridge pattern tha

Re: [PATCH, RFC] 16-bit testsuite fixes - code-size dependent

2024-08-10 Thread Jeff Law
On 8/8/24 10:28 PM, Joern Wolfgang Rennecke wrote: I'm not quite that sure about the general applicability of these, as these depend somewhat on code size. Although there might be something we can prove about a minimum frame size for one test or the other at -O0. I also tried to add /* { dg

Re: [PATCH] 16 bit testsuite fixes - hard failures

2024-08-10 Thread Jeff Law
On 8/8/24 10:09 PM, Joern Wolfgang Rennecke wrote: This fixes problems with tests that exceed a data type or the maximum stack frame size on 16 bit targets. Note: GCC has a limitation that a stack frame cannot exceed half the address space. For two tests the decision to modify or skip them s

??????[PATCH v1] RISC-V: Bugfix incorrect operand for vwsll auto-vect

2024-08-10 Thread ??????
lgtm. thanks --Reply to Message-- On Sat, Aug 10, 2024 20:36 PM pan2.li

[PATCH v1] RISC-V: Bugfix incorrect operand for vwsll auto-vect

2024-08-10 Thread pan2 . li
From: Pan Li This patch would like to fix one ICE when rv64gcv_zvbb for vwsll. Consider below example. void vwsll_vv_test (short *restrict dst, char *restrict a, int *restrict b, int n) { for (int i = 0; i < n; i++) dst[i] = a[i] << b[i]; } It will hit the vwsll patter

C++/ME patch ping

2024-08-10 Thread Arsen Arsenović
Hi! A gentle ping on these two patches pertaining to C++-related middle-end diagnostics: - https://inbox.sourceware.org/20240807131613.526335-1-ar...@aarsen.me/ - https://inbox.sourceware.org/20240802211503.3992610-2-ar...@aarsen.me/ TIA, have a lovely day :-) (PS: apologies if I'm pinging the

Re: [PATCH] gm2: add missing debug output guard

2024-08-10 Thread Gerald Pfeifer
On Tue, 23 Jul 2024, Gaius Mulley wrote: >> gcc/gm2: >> * gm2-libs-iso/MemStream.mod: Guard debug output. > many thanks! I noticed this has not been pushed yet and believe Wilken does not have write/push access - so just pushed this on his behalf. Wilken, it may be good to note this as part

Re: [PATCH] aarch64: Emit ADD X, Y, Y instead of SHL X, Y, #1 for Advanced SIMD

2024-08-10 Thread Richard Sandiford
Kyrylo Tkachov writes: > Hi all, > > On many cores, including Neoverse V2 the throughput of vector ADD > instructions is higher than vector shifts like SHL. We can lean on that > to emit code like: > add v0.4s, v0.4s, v0.4s > instead of: > shl v0.4s, v0.4s, 1 > > LLVM already does thi

Re: [PATCH] [x86] Mention _Float16 and __bf16 changes in GCC14.

2024-08-10 Thread Gerald Pfeifer
On Wed, 31 Jul 2024, liuhongt wrote: > + The _Float16 and __bf16 type are supported > +independent of SSE2. W/o SSE2, these types are storage-only, compiler > will > +issue an error when they're used in conversion, unary operation, > +binary operation, parameter passing or value retu

Re: [PATCH] Add a bootstrap-native build config

2024-08-10 Thread Gerald Pfeifer
On Tue, 30 Jul 2024, Andi Kleen wrote: > config/ChangeLog: > > * bootstrap-native.mk: New file. > > gcc/ChangeLog: > > * doc/install.texi: Document bootstrap-native. This makes sense to me, and the documentation is fine (with "latter" instead of "later"); I cannot approve the code

[committed] testsuite: Fix up sse3-addsubps.c

2024-08-10 Thread Jakub Jelinek
On Thu, Aug 08, 2024 at 10:01:14PM +0200, Alejandro Colomar wrote: > Here are the suspects: > > ./gcc/testsuite/gcc.target/powerpc/sse3-addsubps.c:80: > for (i = 0; i < sizeof (vals) / sizeof (vals); i += 8) This is an obvious typo as can be seen in what the test does, what similar tests

[patch,avr,applied] ad PR113934: Add option -mlra to switch to LRA.

2024-08-10 Thread Georg-Johann Lay
Applied this patch that makes it easier for the LRA maintainers to reproduce LRA bugs that pop up for avr. Johann -- AVR: ad target/113934 - Add option -mlra to enable LRA. PR target/113934 gcc/ * config/avr/avr.opt (-mlra): New target option. * config/avr/avr.cc (avr_u

Re: [PATCH v3 02/12] OpenMP: middle-end support for metadirectives

2024-08-10 Thread Jakub Jelinek
On Sat, Aug 10, 2024 at 09:18:24AM +0200, Jakub Jelinek wrote: > On Fri, Aug 09, 2024 at 07:12:48PM +0200, Jakub Jelinek wrote: > > > --- a/gcc/gimple.def > > > +++ b/gcc/gimple.def > > > @@ -398,6 +398,13 @@ DEFGSCODE(GIMPLE_OMP_TEAMS, "gimple_omp_teams", > > > GSS_OMP_PARALLEL_LAYOUT) > > >

Re: [PATCH v3 02/12] OpenMP: middle-end support for metadirectives

2024-08-10 Thread Jakub Jelinek
On Fri, Aug 09, 2024 at 07:12:48PM +0200, Jakub Jelinek wrote: > > --- a/gcc/gimple.def > > +++ b/gcc/gimple.def > > @@ -398,6 +398,13 @@ DEFGSCODE(GIMPLE_OMP_TEAMS, "gimple_omp_teams", > > GSS_OMP_PARALLEL_LAYOUT) > > CLAUSES is an OMP_CLAUSE chain holding the associated clauses. */ > > DEF