This issue is noticed when support strided load/store auto-vectorization.
Commit it as it is obvious.
gcc/ChangeLog:
* config/riscv/vector.md: Fix bug.
---
gcc/config/riscv/vector.md | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/gcc/config/riscv/vector.md b/gcc/con
Hi Folks
> On 4 Nov 2023, at 17:02, Simon Wright wrote:
>
> On 3 Nov 2023, at 08:39, Arnaud Charlet wrote:
>> So without changing fundamentally the model, you can't decide dynamically
>> for the whole
>> system. Making the choice based on the current directory is pretty random,
>> since the
Hello Richard:
Below are the performance numbers on CPU 2017 benchmarks with and without
register pressure
changes for code sinking.
INT Benchmarks:
With register pressure code sinking changes:
Estimated Estimated
Base Base
On Sat, 2023-11-04 at 16:23 +, Sergei Trofimovich wrote:
> From: Sergei Trofimovich
>
> Without the change `./configure --enable-checking=release` bootstrap
> fails as:
>
> gcc/gcc-urlifier.cc:100:1: error:
> 'get_url_suffix_for_quoted_text()'
> defined but not used [-Werror=unus
On 3 Nov 2023, at 08:39, Arnaud Charlet wrote:
> In addition to the non portable issues already mentioned, this change isn't
> OK also
> for other reasons.
>
> Basically this function is global and decides once for all on the case
> sensitivity, while
> the case sensitiviy is on a per filsyste
From: Sergei Trofimovich
Without the change `./configure --enable-checking=release` bootstrap
fails as:
gcc/gcc-urlifier.cc:100:1: error: 'get_url_suffix_for_quoted_text()'
defined but not used [-Werror=unused-function]
This happens because the helper is used only in `ASSERT` macros
On Sat, 28 Oct 2023 at 14:15, Feng Jisen wrote:
>
> This patch remove a redundant partial specialization in class _Nth_type.
Thanks for the patch, I've pushed it to trunk now.
>
> For the original metafunction _Nth_type code,
> # 0
> template
> struct _Nth_type<0, _Tp0, _Rest...>
> {
Tested x86_64-linux. Pushed to trunk.
Probably worth backporting after some time on trunk.
-- >8 --
Use strerror_r instead of strerror when available, due to the latter not
being thread-safe. This is complicated by Glibc providing a GNU-specific
strerror_r which is not compatible with POSIX stre
Pushed to trunk.
-- >8 --
The name "_N" is listed as a reserved name on Solaris, so we shouldn't
use it as an example of our naming conventions.
libstdc++-v3/ChangeLog:
* doc/xml/manual/appendix_contributing.xml: Replace example that
uses a BADNAME.
* doc/html/manual/sou
Hi!
This patch adds omp::decl support which has been added recently for
C++ also to C.
Bootstrapped/regtested on x86_64-linux and i686-linux, committed to
trunk.
2023-11-04 Jakub Jelinek
* c-parser.h (c_maybe_parse_omp_decl): Declare.
* c-parser.cc (struct c_parser): Add in_o
Hi!
The following patch adds support for attribute syntax which we have in C++11
and above since GCC 12 also for C, where OpenMP standard is going to add it
in OpenMP 6.0.
Bootstrapped/regtested on x86_64-linux and i686-linux, committed to trunk.
2023-11-04 Jakub Jelinek
gcc/c/
* c-t
Hi Martin,
This looks to be 'obvious' and is certainly OK for mainline. Backport if
you wish.
Thanks
Paul
On Fri, 3 Nov 2023 at 12:54, Martin Jambor wrote:
> Hi,
>
> when developing an otherwise unrelated patch I've discovered that the
> fnspec for the Fortran library function generate_error
12 matches
Mail list logo