Currently get_most_common_single_value could only return the max hist
, add qsort to enable this function return nth value.
Rename it to get_nth_most_common_value.
v3 Changes:
1. Move sort to profile.c after loading values from disk. Simplify
get_nth_most_common_value.
2. Make qsort stable
On 2019/7/2 4:51 PM, Richard Biener wrote:
On Tue, 2 Jul 2019, Richard Biener wrote:
On Tue, 2 Jul 2019, Li Jia He wrote:
On 2019/7/1 3:30 PM, Richard Biener wrote:
On Fri, 28 Jun 2019, Andrew Pinski wrote:
On Thu, Jun 27, 2019 at 9:55 PM Li Jia He wrote:
On 2019/6/27 11:48 PM, Je
This is a re-think of patch #6.
I have changed the TARGET_TOC to be TARGET_HAS_TOC in the aix, darwin, system
V, and Linux 64-bit headers. Then in rs6000.h, TARGET_TOC is defined in terms
of TARGET_HAS_TOC and not pc-relative referencing.
I discovered that TARGET_NO_TOC must not be set to be jus
Hi Harald and Steve,
The patch looks fine to me - it's good be committed.
Thanks
Paul
On Mon, 15 Jul 2019 at 03:34, Steve Kargl
wrote:
>
> Harald, thanks for the patch. I'm that the best person
> for reading the trans-* file, but your patch and changes
> look good to me. If no one else speak
Hi Honza,
It seems this commit caused gcc bootstrap failure on aarch64 as below,
Comparing stages 2 and 3
warning: gcc/cc1obj-checksum.o differs
Bootstrap comparison failure!
gcc/dwarf2out.o differs
gcc/var-tracking.o differs
gcc/aarch64.o differs
make[2]: *** [compare] Error 1
Do you know the r
This libgo patch by Cherry Zhang expose the thread-local g variable.
Currently, getg is implemented in C, which loads the thread-local g
variable. The g variable is declared static in C.
This CL exposes the g variable, so it can be accessed from the Go
side. This allows the Go compiler to inline
We now can always output .machine (if we output it at all for the
current target).
Committing to trunk.
Segher
2019-07-15 Segher Boessenkool
PR target/91050
* config/rs6000/rs6000.c (rs6000_file_start): Never skip emitting a
.machine directive.
---
gcc/config/rs60
Attached patch cleans TEST insn patterns by removing unneeded
alternatives from *testdi_1 (these were cargo-culted from *testsi_1,
where they are used to describe pentium pairing, but pentium is not a
64bit target).
The patch also removes manual definition of modrm attribute. This
attribute is nowa
Hello,
There are two weeks gone since the end of the patch discussion but no
one has neither objected nor approved it. Please take a look to it and
approve. Also please commit it since I have no write access.
The updated version of the patch was attached to my message
https://gcc.gnu.org/ml/
> gcc/
> * jump.c (FLAGS_EQ, FLAGS_LT, FLAGS_GT, FLAGS_UNORDERED, FLAGS_ORDER)
> (FLAGS_SIGNED, FLAGS_UNSIGNED, FLAGS_SIGN_AGNOSTIC, FLAGS_SIGNEDNESS)
> (FLAGS_TRAP_QNANS, FLAGS_TRAP_SNANS, FLAGS_TRAP_NANS, FLAGS_TRAP_NONE)
> (FLAGS_TRAPS): New constants.
> (condition_
On 7/12/19 1:16 AM, Richard Sandiford wrote:
Ping. I think this is the only one of the series left.
2019-07-05 Richard Sandiford
gcc/
* config/mips/micromips.md (*movep):
Explicitly use for the mode attribute.
OK.
Jim
libstdc++-v3/
* testsuite/30_threads/condition_variable/members/2.cc (test01):
Parameterise so that test can be run against an arbitrary clock.
(main): Test using std::chrono::steady_clock and a user-defined
clock in addition to the previous std::chrono::syste
The pthread_cond_clockwait function was recently added[1] to glibc,
and is due to be released in glibc 2.30. If this function is available
in the C library it can be used it to fix
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=41861 by supporting
std::chrono::steady_clock properly with std::conditio
The pthread_cond_clockwait function was recently added[1] to glibc, and is
due to be released in glibc 2.30. If this function is available in the C
library it can be used it to fix
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=41861 by supporting
std::chrono::steady_clock properly with std::conditio
Richard Sandiford writes:
> This patch extends the tree-level folding of variable-length vectors
> so that it can also be used on rtxes. The first step is to move
> the tree_vector_builder new_unary/binary_operator routines to the
> parent vector_builder class (which in turn means adding a new
>
Eric Botcazou writes:
>> AIUI, neither ORDERED nor UNEQ trap on signalling NaNs. Without this,
>> the follow-on patch would fold
>>
>>(and (ordered x y) (uneq x y)) -> (eq x y)
>>
>> which is the same thing for quiet NaNs but not for signalling NaNs.
>
> Note that GCC defaults to -fno-signa
On Mon, Jul 15, 2019 at 04:41:28PM +0200, Martin Liška wrote:
> On 7/15/19 4:31 PM, Segher Boessenkool wrote:
> > On Mon, Jul 15, 2019 at 04:23:18PM +0200, Martin Liška wrote:
> >> On 7/15/19 4:17 PM, Segher Boessenkool wrote:
> >>> Is that enough? Can there be two entries with the same count as w
On Mon, Jul 15, 2019 at 10:59:29AM +0200, Jakub Jelinek wrote:
> On Mon, Jul 15, 2019 at 04:50:13PM +0800, Kewen.Lin wrote:
> > In match.pd and expmed.c, we have some codes to transform lrotate to
> > rrotate if rotation count is const. But they don't consider the target
> > whether supports the
On 7/15/19 4:31 PM, Segher Boessenkool wrote:
> On Mon, Jul 15, 2019 at 04:23:18PM +0200, Martin Liška wrote:
>> On 7/15/19 4:17 PM, Segher Boessenkool wrote:
>>> Is that enough? Can there be two entries with the same count as well
>>> as value?
>>
>> Yes, it can happen very unlikely in a multi-th
On Mon, Jul 15, 2019 at 04:23:18PM +0200, Martin Liška wrote:
> On 7/15/19 4:17 PM, Segher Boessenkool wrote:
> > Is that enough? Can there be two entries with the same count as well
> > as value?
>
> Yes, it can happen very unlikely in a multi-threaded instrumentation,
> but it will not make a p
On 7/15/19 4:17 PM, Segher Boessenkool wrote:
> Is that enough? Can there be two entries with the same count as well
> as value?
Yes, it can happen very unlikely in a multi-threaded instrumentation,
but it will not make a problem.
Martin
On Mon, Jul 15, 2019 at 11:20:34AM +0200, Martin Liška wrote:
> On 7/15/19 10:20 AM, Xiong Hu Luo wrote:
> > -/* Return most common value of TOPN_VALUE histogram. If
> > - there's a unique value, return true and set VALUE and COUNT
> > +struct value_count_t {
> > + gcov_type value;
> > + gcov_
Okay I kept the TYPE_MAIN_VARIANT and dropped the accidental new line!
Hopefully this should be fine!
On Fri, Jul 12, 2019 at 6:49 PM Marek Polacek wrote:
>
> On Fri, Jul 12, 2019 at 02:38:59PM -0400, Marek Polacek wrote:
> > On Fri, Jul 12, 2019 at 02:34:37PM -0400, Matthew Beliveau wrote:
> > >
Hi.
The patch is about removal of the emission of __gnu_lto_v1.
The symbol should not be needed any longer for GCC driver.
Patch can bootstrap on x86_64-linux-gnu and survives regression tests.
Ready to be installed?
Thanks,
Martin
gcc/ChangeLog:
2019-07-15 Martin Liska
* config/av
Bootstrapped / tested on x86_64-unknown-linux-gnu, applied.
Richard.
2019-07-15 Richard Biener
PR middle-end/91162
* tree-cfg.c (move_block_to_fn): When releasing a virtual PHI
node make sure to replace all uses with something valid.
* gcc.dg/autopar/pr91162
On 7/10/19 1:16 PM, Martin Liška wrote:
> On 7/10/19 1:15 PM, Jakub Jelinek wrote:
>> On Wed, Jul 10, 2019 at 01:08:52PM +0200, Martin Liška wrote:
>>> --- a/gcc/dwarf2out.c
>>> +++ b/gcc/dwarf2out.c
>>> @@ -24460,6 +24460,13 @@ gen_producer_string (void)
>>>case OPT_fchecking_:
>>> /*
Backport PR85711 to GCC8 to fix failing testcases.
AArch64 bootstrap & regtest OK.
2019-01-23 Bin Cheng
Steve Ellcey
PR target/85711
* recog.c (address_operand): Return false on wrong mode for address.
(constrain_operands): Check for mode with 'p' constrai
On Mon, 15 Jul 2019, Andre Vieira (lists) wrote:
>
>
> On 12/07/2019 11:19, Richard Biener wrote:
> > On Thu, 11 Jul 2019, Andre Vieira (lists) wrote:
> >
> >
> > I think for code-size reason it would make sense to do it like
> >
> >if (iterations_check_for_lowest_VF ())
> > {
> >
Hi Jakub,
on 2019/7/15 下午4:59, Jakub Jelinek wrote:
> On Mon, Jul 15, 2019 at 04:50:13PM +0800, Kewen.Lin wrote:
>> In match.pd and expmed.c, we have some codes to transform lrotate to
>> rrotate if rotation count is const. But they don't consider the target
>> whether supports the rrotate. It
On 12/07/2019 11:19, Richard Biener wrote:
On Thu, 11 Jul 2019, Andre Vieira (lists) wrote:
I think for code-size reason it would make sense to do it like
if (iterations_check_for_lowest_VF ())
{
if (alias_check_for_highest_VF ())
{
vectorized_for_highest_
On 7/15/19 10:20 AM, Xiong Hu Luo wrote:
> Currently get_most_common_single_value could only return the max hist
> , add qsort to enable this function return kth value.
> Rename it to get_kth_value_count.
>
> gcc/ChangeLog:
>
> 2019-07-15 Xiong Hu Luo
>
> * ipa-profile.c (get_most
Jakub Jelinek writes:
> On Mon, Jul 15, 2019 at 04:50:13PM +0800, Kewen.Lin wrote:
>> In match.pd and expmed.c, we have some codes to transform lrotate to
>> rrotate if rotation count is const. But they don't consider the target
>> whether supports the rrotate. It leads to some suboptimal gener
On Mon, Jul 15, 2019 at 10:59 AM Jakub Jelinek wrote:
>
> On Mon, Jul 15, 2019 at 04:50:13PM +0800, Kewen.Lin wrote:
> > In match.pd and expmed.c, we have some codes to transform lrotate to
> > rrotate if rotation count is const. But they don't consider the target
> > whether supports the rrotate
On Mon, Jul 15, 2019 at 04:50:13PM +0800, Kewen.Lin wrote:
> In match.pd and expmed.c, we have some codes to transform lrotate to
> rrotate if rotation count is const. But they don't consider the target
> whether supports the rrotate. It leads to some suboptimal generated
> code since some optim
Hi all,
In match.pd and expmed.c, we have some codes to transform lrotate to
rrotate if rotation count is const. But they don't consider the target
whether supports the rrotate. It leads to some suboptimal generated
code since some optimization can't get expected result by querying
target optab
Currently get_most_common_single_value could only return the max hist
, add qsort to enable this function return kth value.
Rename it to get_kth_value_count.
gcc/ChangeLog:
2019-07-15 Xiong Hu Luo
* ipa-profile.c (get_most_common_single_value): Use
get_kth_value_count.
36 matches
Mail list logo