Re: [PATCH v2] Missed function specialization + partial devirtualization

2019-07-14 Thread Martin Liška
On 7/12/19 10:51 AM, Xiong Hu Luo wrote: > 2. Remove duplicate logic in ipa-profile. As > get_most_common_single_value could only return single value, but this > multiple indirect call needs store each hist value, will > consider specialize it later. Hi. I would like to see this patch rebase

Re: [PATCH] Generalize get_most_common_single_value to return k_th value & count

2019-07-14 Thread Martin Liška
On 7/15/19 4:42 AM, Xiong Hu Luo wrote: > Currently get_most_common_single_value could only return the max hist > , add two paramter to enable this function return kth > value if needed. > > gcc/ChangeLog: > > 2019-07-15 Xiong Hu Luo > > * value-prof.c (get_most_common_single_valu

Re: [PING^1][PATCH v4 3/3] PR80791 Consider doloop cmp use in ivopts

2019-07-14 Thread Bin.Cheng
On Fri, Jul 12, 2019 at 8:11 PM Richard Biener wrote: > > On Wed, 10 Jul 2019, Kewen.Lin wrote: > > > Hi all, > > > > I'd like to gentle ping the below patch: > > https://gcc.gnu.org/ml/gcc-patches/2019-06/msg01225.html > > > > The previous version for more context/background: > > https://gcc.gnu.

Re: [PING^1][PATCH v4 3/3] PR80791 Consider doloop cmp use in ivopts

2019-07-14 Thread Kewen.Lin
Hi Richard, on 2019/7/12 下午8:11, Richard Biener wrote: > On Wed, 10 Jul 2019, Kewen.Lin wrote: > >> Hi all, >> >> I'd like to gentle ping the below patch: >> https://gcc.gnu.org/ml/gcc-patches/2019-06/msg01225.html >> >> The previous version for more context/background: >> https://gcc.gnu.org/ml/

[PATCH] Generalize get_most_common_single_value to return k_th value & count

2019-07-14 Thread Xiong Hu Luo
Currently get_most_common_single_value could only return the max hist , add two paramter to enable this function return kth value if needed. gcc/ChangeLog: 2019-07-15 Xiong Hu Luo * value-prof.c (get_most_common_single_value): Add input params k_th and k, return the k_

Re: [Patch, fortran] PR90903 - Implement runtime checks for bit manipulation intrinsics

2019-07-14 Thread Steve Kargl
Harald, thanks for the patch. I'm that the best person for reading the trans-* file, but your patch and changes look good to me. If no one else speaks up, in the next day or so, please commit. -- steve On Sun, Jul 14, 2019 at 09:37:27PM +0200, Harald Anlauf wrote: > Ping! > > On 06/23/19 23:3

Ping agian: [PATCH V2] Loop split upon semi-invariant condition (PR tree-optimization/89134)

2019-07-14 Thread Feng Xue OS
Some time passed, so ping again. I made this patch, because it can reward us with 7% performance benefit in some real application. For convenience, the optimization to be implemented was listed in the following again. And hope your comments on the patch, or design suggestions. Thanks! Suppo

Re: [patch, fortran] Pr87233 Constraint C1279 still followed after f2008 standard revision

2019-07-14 Thread Jerry DeLisle
Could not get the use of gfc_get_errors to work right, it missed one of the errors in initialazation_30.f90. So I just did the deed. Regards, Jerry Committing to svn+ssh://jvdeli...@gcc.gnu.org/svn/gcc/trunk ... A gcc/testsuite/gfortran.dg/initialization_30.f90 M gc

Re: [PATCH] i386: Expand roundeven for SSE4.1+

2019-07-14 Thread Uros Bizjak
> This patch is for expanding roundeven inline for SSE4.1 and later. > Note that this patch is to be applied on top of > . The patch > is bootstrapped and regression tested on x86_64-linux-gnu. Actually, your patch at [1] is the way to go,

Re: [Patch, fortran] PR90903 - Implement runtime checks for bit manipulation intrinsics

2019-07-14 Thread Harald Anlauf
Ping! On 06/23/19 23:36, Harald Anlauf wrote: > Dear all, > > the attached patch provides run-time checks for the bit manipulation > intrinsic functions (IBSET/IBCLR/BTEST/SHIFT[RLA]/ISHFT/ISHFTC). > I am using only one testcase whose purpose is mainly to verify that > there are no false positives

Re: Rewrite some jump.c routines to use flags

2019-07-14 Thread Eric Botcazou
> AIUI, neither ORDERED nor UNEQ trap on signalling NaNs. Without this, > the follow-on patch would fold > >(and (ordered x y) (uneq x y)) -> (eq x y) > > which is the same thing for quiet NaNs but not for signalling NaNs. Note that GCC defaults to -fno-signaling-nans and the transformation

[PATCH, i386]: Adjust operand predicate of several test instructions

2019-07-14 Thread Uros Bizjak
Operand constraints accept only register and immediate operands, so adjust operand predicate to reject memory operands. 2019-07-14 Uroš Bizjak * config/i386/i386.md (nonmemory_szext_operand): New mode attribute. (test_ccno_1): Macroize insn pattern from testsi_ccno_1 and testdi_ccn

Re: [patch, libfortran] Adjust block size for libgfortran for unformatted reads

2019-07-14 Thread Steve Kargl
On Sun, Jul 14, 2019 at 12:07:58PM +0200, Thomas Koenig wrote: > OK, so here is a new version. > > I think the discussion has shown that enlaring the buffer makes sense, > and that the buffer size for unformatted seems to be too bad. > > I've reversed the names of the environment variables accord

Remove array_index inliner hint

2019-07-14 Thread Jan Hubicka
Hi, array_index hint marks functions contains an array reference that is indexed by value that will become constant after inlining. This hint is later used by ipa-inline in rather agressive way updating inline-insns-auto to inline-insns-single for such functions. While tuning -finline-functions fo

Re: [PATCH] gdbhooks.py: dump-fn, dot-fn: cast ret values of fopen/fclose

2019-07-14 Thread Tom de Vries
On 09-07-19 16:10, Vladislav Ivanishin wrote: > Hi, > > Without the patch, I see these error messages with gdb 8.3: > > (gdb) Python Exception 'fclose@@GLIBC_2.2.5' has > unknown return type; cast the call to its declared return type: > (gdb) Error occurred in Python: 'fclose@@GLIBC_

Re: [patch, libfortran] Adjust block size for libgfortran for unformatted reads

2019-07-14 Thread Thomas Koenig
... of course, better with the actual patch. Index: gcc/fortran/gfortran.texi === --- gcc/fortran/gfortran.texi (Revision 273183) +++ gcc/fortran/gfortran.texi (Arbeitskopie) @@ -611,6 +611,8 @@ Malformed environment variables are si

Re: [patch, libfortran] Adjust block size for libgfortran for unformatted reads

2019-07-14 Thread Thomas Koenig
OK, so here is a new version. I think the discussion has shown that enlaring the buffer makes sense, and that the buffer size for unformatted seems to be too bad. I've reversed the names of the environment variables according to Behnard's suggestion. So, OK for trunk? Also, what should we do a

Backports to 9.2

2019-07-14 Thread Jakub Jelinek
Hi! I've backported 3 patches from trunk to gcc-9-branch, bootstrapped/regtested them on x86_64-linux and i686-linux, committed to gcc-9-branch. Jakub 2019-07-14 Jakub Jelinek Backported from mainline 2019-07-04 Jakub Jelinek PR rtl-optimization/90756

[PATCH] rs6000: Shut up -Wformat-diag a little more

2019-07-14 Thread Segher Boessenkool
2019-07-14 Segher Boessenkool PR target/91148 * config/rs6000/rs6000-c.c (altivec_resolve_overloaded_builtin): Remove superfluous "builtin function" phrasing. gcc/testsuite/ * gcc.target/powerpc/bfp/scalar-extract-exp-2.c: Adjust. * gcc.target/powerpc/bf