Re: [RFA] adjust src-release following the renaming of gdb/common/ to gdb/gdbsupport/

2019-07-13 Thread Joel Brobecker
> >ChangeLog: > > > >* src-release (getver): If $tool/gdbsupport/create-version.sh > >exists, use that to determine the version number. > > > >Tested on x86_64-linux, by running the src-release script with "gdb" > >as the argument, and verifying that the name of the tarball is now >

Re: [patch, fortran] Pr87233 Constraint C1279 still followed after f2008 standard revision

2019-07-13 Thread Steve Kargl
On Sat, Jul 13, 2019 at 04:54:07PM -0700, Jerry DeLisle wrote: > Hi all, > > The attached patch removes the subject constraint for gfortran default > and -std=f2008/f2018. I had issues with repetitious errors. I tried > to get rid of it using the e->error = 1 method useded later in the > function,

[patch, fortran] Pr87233 Constraint C1279 still followed after f2008 standard revision

2019-07-13 Thread Jerry DeLisle
Hi all, The attached patch removes the subject constraint for gfortran default and -std=f2008/f2018. I had issues with repetitious errors. I tried to get rid of it using the e->error = 1 method useded later in the function, but that did not work, so I resorted to gfc_error_now which does the j

[Darwin, PPC, testsuite, committed] Require stabs support for a test.

2019-07-13 Thread Iain Sandoe
Another in my queue of minor test fixups. The test fails if the assembler doesn't support stabs (and I have at least one assembler under test that doesn’t). Solution is to require stabs support tested on powerpc-darwin9 applied to mainline thanks Iain 2019-07-13 Iain Sandoe * gcc.targ

Avoid code duplication in aliasing_component_refs_p

2019-07-13 Thread Jan Hubicka
Hi, this refactors the code a bit to avoid doing everything twice. Bootstrapped/regtested x86_64-linux, comitted. Honza * tree-ssa-alias.c (component_ref_to_zero_sized_trailing_array_p): Break out from ... (aliasing_component_refs_walk): Break out from ... (aliasi

Re: [PATCH] rs6000: Shut up -Wformat-diag somewhat

2019-07-13 Thread Segher Boessenkool
On Sat, Jul 13, 2019 at 05:26:04PM +0100, Richard Sandiford wrote: > Segher Boessenkool writes: > > We currently get lot of build warnings like > > /home/segher/src/gcc/gcc/config/rs6000/rs6000-c.c:7039:12: warning: > > misspelled term 'builtin function' in format; use 'built-in function' > > in

Re: [PATCH] rs6000: Shut up -Wformat-diag somewhat

2019-07-13 Thread Richard Sandiford
Segher Boessenkool writes: > We currently get lot of build warnings like > /home/segher/src/gcc/gcc/config/rs6000/rs6000-c.c:7039:12: warning: > misspelled term 'builtin function' in format; use 'built-in function' instead > [-Wformat-diag] > 7039 |error ("builtin function %qs not supported

[PATCH] rs6000: Shut up -Wformat-diag somewhat

2019-07-13 Thread Segher Boessenkool
We currently get lot of build warnings like /home/segher/src/gcc/gcc/config/rs6000/rs6000-c.c:7039:12: warning: misspelled term 'builtin function' in format; use 'built-in function' instead [-Wformat-diag] 7039 |error ("builtin function %qs not supported in this compiler " |

[PATCH] i386: Expand roundeven for SSE4.1+

2019-07-13 Thread Tejas Joshi
Hi. This patch is for expanding roundeven inline for SSE4.1 and later. Note that this patch is to be applied on top of . The patch is bootstrapped and regression tested on x86_64-linux-gnu. Thanks, Tejas gcc/ChangeLog: 2019-07-13 Tejas J

Re: r273212 - in /trunk/gcc/ada: ChangeLog Makefile...

2019-07-13 Thread Arnaud Charlet
> > 2019-07-08 Dmitriy Anisimkov > > > > gcc/ada/ > > > > * Makefile.rtl: Use g-sercom__linux.adb for all linuxes. > > ln: failed to create symbolic link 'rts/g-sercom.adb': File exists > make[7]: *** [/daten/riscv64/gcc/gcc-20190713

Re: r273212 - in /trunk/gcc/ada: ChangeLog Makefile...

2019-07-13 Thread Andreas Schwab
On Jul 08 2019, pmdero...@gcc.gnu.org wrote: > 2019-07-08 Dmitriy Anisimkov > > gcc/ada/ > > * Makefile.rtl: Use g-sercom__linux.adb for all linuxes. ln: failed to create symbolic link 'rts/g-sercom.adb': File exists make[7]: *** [/daten/riscv64/gcc/gcc-2019

Re: Rewrite some jump.c routines to use flags

2019-07-13 Thread Eric Botcazou
> AIUI, neither ORDERED nor UNEQ trap on signalling NaNs. Without this, > the follow-on patch would fold > >(and (ordered x y) (uneq x y)) -> (eq x y) > > which is the same thing for quiet NaNs but not for signalling NaNs. I see, thanks for explaining. -- Eric Botcazou

Re: PR90723

2019-07-13 Thread Prathamesh Kulkarni
On Thu, 11 Jul 2019 at 13:39, Richard Sandiford wrote: > > Prathamesh Kulkarni writes: > > @@ -186,6 +186,23 @@ skip_alternative (const char *p) > > /* Nonzero means volatile operands are recognized. */ > > extern int volatile_ok; > > > > +/* RAII class for temporarily setting volatile_ok. */

[Patch] Make x86-64 a generic architecture as documented

2019-07-13 Thread Allan Sandfeld Jensen
Hello Changing -march=x86-64 behaviour to match documentation and common usage. Question: Is this also good for -m32 -march=x86-64 or will generic then mean something else? Thank Allan diff --git a/gcc/ChangeLog b/gcc/ChangeLog index 364466b6b6f..90f9cbc3c35 100644 --- a/gcc/ChangeLog +++ b/gc