Our target (eSi-RISC) doesn't have DOT_PROD_EXPR or WIDEN_SUM_EXPR
operations in
the standard vector modes; however, it has a vectorized WIDEN_MULT_PLUS_EXPR
implementation with a double-vector output, which works just as well,
with a little
help from the compiler - as implemented in these patc
Implement P0318R1 unwrap_ref_decay and unwrap_reference
* include/std/type_traits (unwrap_reference, unwrap_reference_t)
(unwrap_ref_decay, unwrap_ref_decay_t): New traits and aliases.
* testsuite/20_util/unwrap_reference/1.cc: New test.
* testsuite/20_util/
Implement P1007R3 std::assume_aligned
* include/std/memory (assume_aligned): Implement for C++17.
* testsuite/20_util/assume_aligned/1.cc: New test.
* testsuite/20_util/assume_aligned/2_neg.cc: New test.
* testsuite/20_util/assume_aligned/3.cc: New test.
Te
On Mon, 2018-10-22 at 16:08 +0200, Richard Biener wrote:
> On Mon, 22 Oct 2018, David Malcolm wrote:
>
> > On Mon, 2018-10-22 at 15:56 +0200, Richard Biener wrote:
> > [...snip...]
> >
> > > This is what I finally applied for the original patch after
> > > fixing
> > > the above issue.
> > >
> >
As noted in PR65703, there was previously a reference in the manual to
-fdefer-pop but if you searched for the documentation of that option,
you wouldn't find it unless you thought to look for -fno-defer-pop
instead. This was a general problem affecting many -fno-xxx and
-mno-xxx options. I'v
PR ipa/87955 reports a problem I introduced in r265920, where I converted
the guard in report_inline_failed_reason from using:
if (dump_file)
to using
if (dump_enabled_p ()).
without updating the calls to cl_target_option_print_diff and
cl_optimization_print_diff, which assume that dump_file is
Ping.
On Tue, Oct 30, 2018 at 05:30:32PM +, Segher Boessenkool wrote:
> Hi!
>
> This is the same "asm input" patch as before, but now preceded by a patch
> that makes all orderings of volatile/goto/inline valid, also the other type
> qualifiers for C, and also repetitions for C.
>
> Tested o
This makes make_more_copies do what its documentation says, that is,
only make an intermediate pseudo if copying to a pseudo.
This regressed generated code quality when we didn't keep the original
notes that were on the copy, but since r265582 we do, and only allowing
pseudos now is a win. It als
While working on a hashtable enhancement I noticed that we are not using
the correct method to deallocate node if the constructor throws in
_ReuseOrAllocNode operator(). I had to introduce a new
_M_deallocate_node_ptr for that as node value shall not be destroy again.
I also check other places
This patch has been held up by licensing issues, specifically, awaiting
upstream's plans to relicense the code from Apache 2.0 to the libc++ license -
https://llvm.org/docs/DeveloperPolicy.html#license
We expect the relicensing to conclude within the next few weeks. At that
time I will be resub
Hi Janne,
1) It's KISS
2) I can't find anything in the code that would lead to endless
recursive invocation of the error printing functions.
So, Ok for trunk?
With async I/O, I think the possibilities of hitting
concurrent errors have increased, so I'd still prefer the
solution with wrappi
pstl-integration.patch.bz2
Description: compressed patch
New D-form instructions available on Power9 introduce new code generation
options that result in more efficient execution.
This new pass scans existing rtl expressions and replaces them with rtl
expressions that favor selection of the D-form instructions in contexts for
which the D-form instr
This patch implements the bulk of support for OpenACC 2.6 manual deep
copy for the C, C++ and Fortran front-ends, the middle end and the
libgomp runtime. I've incorporated parts of the patches previously
posted by Cesar:
https://gcc.gnu.org/ml/gcc-patches/2018-10/msg01941.html
https://gcc.gnu.or
This patch, created while trying to figure out the open-coded linked-list
handling in gimplify_scan_omp_clauses, factors out four somewhat
repetitive portions of that function into two new outlined functions.
This was done largely mechanically; the actual lines of executed code are
more-or-less th
This patch (by Cesar, with some minor additional changes) replaces usage
of several magic constants in target.c with named macros, and replaces
the flat array of size_t pairs used for coalescing host-to-device copies
with an array of a new struct with start/end fields instead.
Tested and bootstra
Hi,
This patch series adds support for OpenACC 2.6's "manual deep copy"
feature. This consists of three main parts:
* Variable lists in data clauses can specify members of structs (in
C/C++) or derived types (in Fortran). In C/C++ we allow either "." or
"->" to be used to select members
On 11/9/18 9:50 PM, Segher Boessenkool wrote:
> On Fri, Nov 09, 2018 at 02:12:22PM -0700, Jeff Law wrote:
>> On 11/8/18 1:34 PM, Segher Boessenkool wrote:
>>> On Thu, Nov 08, 2018 at 03:44:44PM +, Sam Tebbs wrote:
Does your patch fix the incorrect generation of "scvtf s1, s1"? I was
l
Thanks Kyrill.
Updated patch in attachment. Best regards,
Thomas
On Thu, 8 Nov 2018 at 15:53, Kyrill Tkachov wrote:
>
> Hi Thomas,
>
> On 08/11/18 09:52, Thomas Preudhomme wrote:
> > Ping?
> >
> > Best regards,
> >
> > Thomas
> >
> > On Thu, 1 Nov 2018 at 16:03, Thomas Preudhomme
> > wrote:
> >
Thank you for your reviews, Matthew,
> Has your copyright assignment come through for GCC? I can't access
> the copyright info at the moment to check myself. Obviously that will
> be a blocker otherwise.
I filled in and posted request-assign.future to the FSF 1 October, but I
have not heard from
On 11/9/18 11:00 PM, Jeff Law wrote:
> On 11/8/18 6:42 AM, Martin Liška wrote:
>> Hi.
>>
>> The patch is about possibility to filter which files are instrumented. The
>> usage
>> is explained in the PR.
>>
>> Patch can bootstrap and survives regression tests on x86_64-linux-gnu.
>>
>> Ready for tr
On 11/9/18 6:43 PM, Qing Zhao wrote:
> Hi, Martin,
>
> thanks a lot for the previous two new options for live-patching.
>
>
> I have two more questions below:
Hello.
>
> 1. do we still need new options to disable the following:
>A. unreachable code/variable removal?
I hope it's guarded
Hi.
Sorry for attaching a wrong patch.
Martin
>From 7d3887b1b24901eca69614e601b6e8f36e5c86eb Mon Sep 17 00:00:00 2001
From: marxin
Date: Fri, 9 Nov 2018 16:28:07 +0100
Subject: [PATCH] Come up with -flive-patching master option.
gcc/ChangeLog:
2018-11-09 Martin Liska
* common.opt: Add -fl
23 matches
Mail list logo