> So while emit_store_flag_force knows what to do upon NULL return, I'm
> not sure the other users of expand_shift/expand_shift_1 do.
Revised patch attached, tested on x86-64/Linux, OK for the mainline?
2016-09-26 Eric Botcazou
* expmed.c (expand_shift_1): Add MAY_FAIL parameter an
On 09/25/2016 09:10 PM, Arnaud Charlet wrote:
Is the above change really necessary? Would be nice to get rid of this
extra code. The rest looks OK to me.
It is required for support of environment when LFN support is either
not available or disabled for some reason (for example FreeDOS
without LF
On 25/09/16 04:50, kugan wrote:
Hi,
In make_new_ssa_for_def (tree-reassoc.c) we should use gimple_get_lhs to
get lhs instead of gimple_assign_lhs as stmt can be builtins too.
Attached patch fixes this.
Testcase from PR (attached) seems to fail. I dont any fortran so I didnt
try fixing it. Any
Hi,
May I ask if there is any decision?
Regards,
Yuan, Pengfei
> > > I also like a new param better as it avoids a new magic constant and
> > > makes playing with
> > > it easier (your patch removes the ability to do statistics like you did
> > > via the
> > > early-inlining-insns parameter by
Tested on Linux-x64.
2016-09-26 Ville Voutilainen
PR libstdc++/77727
* include/std/optional (optional(const optional<_Up>&)):
Default-initialize the base and use emplace.
(optional(optional<_Up>&&)): Likewise.
* testsuite/20_util/optional/cons/77727.cc: New.
diff --git a/li
Committed as obvious.
2016-09-25 Steven G. Kargl
PR fortran/77429
* dependency.c (gfc_check_dependency): Convert gcc_assert() to
a conditional and possible call to gfc_internal_error().
2016-09-25 Steven G. Kargl
PR fortran/77429
* gfortran.dg/p
> >Is the above change really necessary? Would be nice to get rid of this
> >extra code. The rest looks OK to me.
> It is required for support of environment when LFN support is either
> not available or disabled for some reason (for example FreeDOS
> without LFN support loaded).
Does it matter fo
On Sun, 25 Sep 2016 19:01:14 +0200
Jakub Jelinek wrote:
> On Sun, Sep 25, 2016 at 02:48:19PM +0100, Sergei Trofimovich wrote:
> > From: Sergei Trofimovich
> >
> > Today I traced AVX2 optimisation bug in gcc and
> > distilled it down to '__builtin_ia32_gatheraltdiv4si256'
> > generated by gcc.
>
On 09/25/2016 07:25 PM, Arnaud Charlet wrote:
int
__gnat_get_maximum_file_name_length (void)
{
+#if defined (__DJGPP__)
+ return (_use_lfn(".")) ? -1 : 8;
+#else
return -1;
+#endif
}
Is the above change really necessary? Would be nice to get rid of this
extra code. The rest looks OK
Committed as "obvious" even though thomas OK patch
in bugzilla audit trail.
2016-09-25 Steven G. Kargl
PR fortran/77694
* frontend-passes.c (optimize_binop_array_assignment): Check pointer
for NULL.
2016-09-25 Steven G. Kargl
PR fortran/77694
* gfor
On Sun, Sep 25, 2016 at 02:48:19PM +0100, Sergei Trofimovich wrote:
> From: Sergei Trofimovich
>
> Today I traced AVX2 optimisation bug in gcc and
> distilled it down to '__builtin_ia32_gatheraltdiv4si256'
> generated by gcc.
>
> When I attempted to use this builtin directly
> in a simple progra
> int
> __gnat_get_maximum_file_name_length (void)
> {
> +#if defined (__DJGPP__)
> + return (_use_lfn(".")) ? -1 : 8;
> +#else
>return -1;
> +#endif
> }
Is the above change really necessary? Would be nice to get rid of this
extra code. The rest looks OK to me.
Arno
Hi
Trivial patch to cleanup parallel/algo.h by generalizing usage of
std::__iterator_category.
* include/parallel/algo.h: Generalize usage of
std::__iterator_category.
Adjust whitespaces.
Tested under Linux x86_64 parallel mode.
François
Index: include/parallel/algo.h
Tested on Linux-x64.
2016-09-25 Ville Voutilainen
PR libstdc++/77717
* testsuite/21_strings/basic_string_view/operations/compare/char/1.cc:
Fix an out-of-bounds access.
diff --git
a/libstdc++-v3/testsuite/21_strings/basic_string_view/operations/compare/char/1.cc
b/libstdc++-v3/t
From: Sergei Trofimovich
Today I traced AVX2 optimisation bug in gcc and
distilled it down to '__builtin_ia32_gatheraltdiv4si256'
generated by gcc.
When I attempted to use this builtin directly
in a simple program gcc refused to recognise
it as known:
#include
void a (void) {
__builti
Hi Matthew,
On 27 July 2016 at 15:59, Ramana Radhakrishnan
wrote:
> On Tue, May 17, 2016 at 3:31 PM, Matthew Wahab
> wrote:
>> The ACLE specifies a number of intrinsics for manipulating vectors
>> holding values in most of the integer and floating point type. These
>> include 16-bit integer typ
Hi!
Currently CHECKING_P is not a boolean flag but a ternary option.
However the _P in the name implies it is a boolean.
That should be cleaned up again IMHO.
So this patch splits CHECKING_P into CHECKING_P and a new flag
ENABLE_EXTRA_CHECKING. All uses of CHECKING_P are actually of
the form
Hi,
this patch fixes PR77558, an ice-on-invalid-code 6/7 regression.
The fix for PR71602 introduced the invalid-code test-case
c-c++-common/va-arg-va-list-type.c:
...
__builtin_va_list *pap;
void
fn1 (void)
{
__builtin_va_arg (pap, double); /* { dg-error "first argument to
'va_arg' not of
Hi!
This patch makes -Wint-in-bool-context warn on suspicious integer left
shifts, when the integer is signed, which is most likely some kind of
programming error, for instance using "<<" instead of "<".
The warning is motivated by the fact, that an overflow on integer shift
left is undefined be
Hi,
This fixes a fallout that actually goes back to 5.0 but went unnoticed.
The costs for movt and movrt type of insns were not correctly reported
and ifcvt thus made some bad choices for SH. A new cset_zero pattern
variant is also required to fix the matching for some recent changes
in the middl
20 matches
Mail list logo