Re: [wwwdocs] Some stuff for porting to

2015-04-18 Thread Gerald Pfeifer
On Wed, 11 Feb 2015, Marek Polacek wrote: > Oops, I must have been thinking of __STDC_VERSION__ when writing that. > Fixed, thanks. Here is a small set of tweaks on top of this (no material changes). Applied. Gerald Index: porting_to.html ===

Re: [PATCH] remove need for store_values_directly

2015-04-18 Thread Trevor Saunders
On Fri, Apr 17, 2015 at 09:29:07AM +0200, Richard Biener wrote: > On Fri, Apr 17, 2015 at 6:38 AM, wrote: > > From: Trevor Saunders > > > > Hi, > > > > Last stage 1 I introduced a second form of hash_table that stored elements > > of > > value_type in addition to the old form that stored elemen

Re: [AArch64][PR65139] use clobber with match_scratch for aarch64_lshr_sisd_or_int_3

2015-04-18 Thread Maxim Kuvyrkov
> On Apr 18, 2015, at 8:21 PM, Richard Earnshaw > wrote: > > On 18/04/15 16:13, Jakub Jelinek wrote: >> On Sat, Apr 18, 2015 at 03:07:16PM +0100, Richard Earnshaw wrote: >>> You need to ensure that your scratch register cannot overlap op1, since >>> the scratch is written before op1 is read. >>

Re: [PATCH 1/2] PR c++/61636

2015-04-18 Thread Adam Butcher
On 2015-04-17 22:06, Adam Butcher wrote: On 2015-04-17 20:58, Jason Merrill wrote: On 04/09/2015 11:31 PM, Adam Butcher wrote: + /* For generic lambdas, resolve default captured 'this' now. */ This isn't quite right. We don't want to capture 'this' any time we see a member fun

Re: [AArch64][PR65139] use clobber with match_scratch for aarch64_lshr_sisd_or_int_3

2015-04-18 Thread Richard Earnshaw
On 18/04/15 16:13, Jakub Jelinek wrote: > On Sat, Apr 18, 2015 at 03:07:16PM +0100, Richard Earnshaw wrote: >> You need to ensure that your scratch register cannot overlap op1, since >> the scratch is written before op1 is read. > > - (clobber (match_scratch:QI 3 "=X,w,X"))] > + (clobber (matc

[Patch, fortran] PR65792 unitialized structure constructor array subcomponent

2015-04-18 Thread Mikael Morin
Hello, here is a fix for PR65792 where a structure constructor used as actual argument was not fully initialized. The test looks like the following... type :: string_t character(LEN=1), dimension(:), allocatable :: chars end type string_t type :: string_container_t type(string_t

Re: [AArch64][PR65139] use clobber with match_scratch for aarch64_lshr_sisd_or_int_3

2015-04-18 Thread Jakub Jelinek
On Sat, Apr 18, 2015 at 03:07:16PM +0100, Richard Earnshaw wrote: > You need to ensure that your scratch register cannot overlap op1, since > the scratch is written before op1 is read. - (clobber (match_scratch:QI 3 "=X,w,X"))] + (clobber (match_scratch:QI 3 "=X,&w,X"))] incremental diff shou

Re: [ARM][PR65768] Keep constants in register when expanding

2015-04-18 Thread Richard Earnshaw
On 15/04/15 08:48, Kugan wrote: > As mentioned in PR65768, ARM gcc generates suboptimal code for constant > Uses in loop. Part of the reason is that ARM back-end is splitting > constants during expansion of RTL, making it hard for the RTL > optimization passes to optimize it. Zhenqiang posted a pat

Re: patch for PR65729

2015-04-18 Thread Richard Earnshaw
On 15/04/15 13:51, Yvan Roux wrote: > Hi, > > On 14 April 2015 at 17:36, Vladimir Makarov wrote: >> On 04/14/2015 04:11 AM, Jakub Jelinek wrote: >>> >>> On Tue, Apr 14, 2015 at 10:08:24AM +0200, Yvan Roux wrote: --- a/gcc/lra-constraints.c +++ b/gcc/lra-constraints.c @@ -1656,

Re: [PATCH][ARM][cleanup] Use IN_RANGE more often

2015-04-18 Thread Richard Earnshaw
On 15/04/15 16:22, Kyrill Tkachov wrote: > Hi all, > > This patch goes through the arm backend and replaces expressions of the > form > a >= lo && a <= hi with IN_RANGE (a, lo, hi) which is that tiny bit smaller > and easier to read in my opinion. I guess there's also a chance it might > make > th

Re: [AArch64][PR65139] use clobber with match_scratch for aarch64_lshr_sisd_or_int_3

2015-04-18 Thread Richard Earnshaw
On 16/04/15 00:00, Kugan wrote: > > > On 16/04/15 08:32, Jakub Jelinek wrote: >> On Thu, Apr 16, 2015 at 08:27:24AM +1000, Kugan wrote: >>> +if ( == LSHIFTRT) >>> + { >>> +emit_insn (gen_aarch64_lshr_sisd_or_int_3 (operands[0], >>> operands[1], operands[2])); >> >> That is way t

Re: [PATCH][AArch64] PR/64134: Make aarch64_expand_vector_init use 'ins' more often

2015-04-18 Thread Richard Earnshaw
On 17/04/15 16:48, Alan Lawrence wrote: > From https://gcc.gnu.org/bugzilla/show_bug.cgi?id=64134, testcase > > #define vector __attribute__((vector_size(16))) > > float a; float b; > vector float fb(void) { return (vector float){ 0,0,b,a};} > > currently produces (correct, but suboptimal): > >

[wwwdocs] Remove "old PROBLEMS file" entries from projects/index.html

2015-04-18 Thread Gerald Pfeifer
In November 2009 I asked about these, and there was some good discussion following ( https://gcc.gnu.org/ml/gcc/2009-11/threads.html#8 ); at one point it just makes sense to remove things that were already considered old back in a decade ago. Committed. Gerald Index: index.html

[Patch, fortran, pr59678, v1] -- [F03] Segfault on equalizing variables of a complex derived type

2015-04-18 Thread Andre Vehreschild
Hi all, this patch fixes a deep copy issue, when allocatable components of an entity were not allocated. Before the patch the deep copy was run without checking if the component is actually allocated and the program crashed because a null pointer was dereferenced. Furthermore, was the code to copy