+# ubsan_finish -- called at the start of each subdir of tests
s/the start/the end/
Thanks,
Sent with AquaMail for Android
http://www.aqua-mail.com
On Mon, Jul 15, 2013 at 10:40:04PM -0500, Peter Bergner wrote:
> On Mon, 2013-07-15 at 23:03 -0400, David Edelsohn wrote:
> > On Mon, Jul 15, 2013 at 4:26 PM, Peter Bergner wrote:
> > > David, do you prefer reverting the above hunk from the Power HTM
> > > patch or should I add the associated -mno
On Mon, 2013-07-15 at 23:03 -0400, David Edelsohn wrote:
> On Mon, Jul 15, 2013 at 4:26 PM, Peter Bergner wrote:
> > David, do you prefer reverting the above hunk from the Power HTM
> > patch or should I add the associated -mno-* options to the building
> > of libitm?
>
> How is libitm built for
On Mon, Jul 15, 2013 at 4:26 PM, Peter Bergner wrote:
> On Mon, 2013-07-15 at 21:32 +0200, Jakub Jelinek wrote:
>> Have you considered trying it to work even when libitm itself isn't built
>> for zEC12 or later only? I mean, both the i?86/x86_64 and powerpc* libitm
>> HTM don't define htm_availab
Hi,
Inspired by the missing "add" in the ISA_HAS_MACC description. Committed
as obvious.
2013-07-16 Maciej W. Rozycki
gcc/
* config/mips/mips.h (ISA_HAS_MULS, ISA_HAS_MSAC, ISA_HAS_MACC):
Fix comment typos.
Maciej
Index: gcc/config/mips/mips.h
==
On Tue, Jul 16, 2013 at 01:27:00AM +0200, Jakub Jelinek wrote:
> On Mon, Jul 15, 2013 at 07:48:59PM +0200, Marek Polacek wrote:
> > Ubsan testsuite is something we've been missing for some time now, so
> > this patch adds it. Fortunately the dejagnu part was
> > quite simple, since ubsan doesn't n
Hi,
Complementing the binutils change recently committed here's one adding
IEEE 754-2008 NaN features support to GCC. Two features are supported:
1. IEEE 754-2008 NaN encoding.
As many of you have been aware it has been a long practice for software
using IEEE 754 floating-point arithmetic ru
On Mon, Jul 15, 2013 at 07:48:59PM +0200, Marek Polacek wrote:
> Ubsan testsuite is something we've been missing for some time now, so
> this patch adds it. Fortunately the dejagnu part was
> quite simple, since ubsan doesn't need similar tweaks as asan does.
> But I had to tweak gcc.c to include
On Wed, Jul 03, 2013 at 04:09:53PM +, Joseph S. Myers wrote:
> On Fri, 3 May 2013, Michael Meissner wrote:
>
> > 2013-05-03 Michael Meissner
> >
> > PR target/57150
> > * config/rs6000/rs6000.h (HARD_REGNO_CALLER_SAVE_MODE): Use DFmode
> > to save TFmode registers and DImode to
On Mon, Jul 15, 2013 at 11:18 AM, Jan Hubicka wrote:
>> On Mon, Jul 15, 2013 at 11:05 AM, Jan Hubicka wrote:
>>
>> > The next thing is how to tell GNU LD/Gold the relative order of functions.
>> > I.e. my_function_section.order.125 or something like that?
>>
>> Gold has a --section-ordering-file
On Thu, Jun 06, 2013 at 11:57:01AM -0400, David Edelsohn wrote:
> But I view this as a preliminary step. The logical instructions need
> an iterator and TImode needs to be cleaned up on 32 bit.
>
> Thanks, David
Here is my proposed cleanup of the logical support. It adds DI expanders,
which on
On Mon, Jul 15, 2013 at 02:46:56PM -0500, Peter Bergner wrote:
> > I'd say something like (but, untested and can't test it right now (and no
> > access to power8 anyway)):
>
> Do we also need to update DWARF_REG_TO_UNWIND_COLUMN similarly, which
> also uses FIRST_PSEUDO_REGISTER when the dwarf reg
On Mon, 2013-07-15 at 21:32 +0200, Jakub Jelinek wrote:
> Have you considered trying it to work even when libitm itself isn't built
> for zEC12 or later only? I mean, both the i?86/x86_64 and powerpc* libitm
> HTM don't define htm_available as unconditional true, they check in some way
> whether t
On Mon, 2013-07-15 at 21:13 +0200, Jakub Jelinek wrote:
> > Looking at the patch, you've changed FIRST_PSEUDO_REGISTER (internal gcc
> > thing, so fine), but that also changed DWARF_FRAME_REGISTER which was
> > computed based on FIRST_PSEUDO_REGISTER. Isn't that an ABI break in the
> > unwinder (t
On Fri, Jun 21, 2013 at 12:23:14PM +0200, Andreas Krebbel wrote:
> the attached patch implements support for hardware transactional
> memory in the S/390 backend.
>
> The transactional execution facility has been made available with IBM
> Enterprise EC12. Documentation can be found in the Princip
On Mon, Jul 15, 2013 at 08:44:12PM +0200, Jakub Jelinek wrote:
> On Mon, Jul 15, 2013 at 12:25:58PM -0500, Peter Bergner wrote:
> > On Mon, 2013-07-15 at 11:55 -0400, David Edelsohn wrote:
> > > Thanks for the explanation. Leave it in.
> > >
> > > Jakub was asking about the status of the HTM patc
On Jul 14, 2013, at 4:58 AM, Iain Sandoe wrote:
> The NeXT Objective C runtime and its interfaces have been evolving - and, in
> particular, interfaces deprecated at Darwin9 have now been removed from
> recent Darwin/OSX implementations.
> OK for trunk?
Ok.
> OK for open branches? (this was r
On Mon, Jul 15, 2013 at 12:25:58PM -0500, Peter Bergner wrote:
> On Mon, 2013-07-15 at 11:55 -0400, David Edelsohn wrote:
> > Thanks for the explanation. Leave it in.
> >
> > Jakub was asking about the status of the HTM patch and support, so
> > please check it in.
>
> Ok, committed to mainline
Hi,
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=57878
The bug occurs because tfreq is given higher priority than bigger mode
in reload_pseudo_compare_func. When there are multiple reload pseudos
in the same insn, and the pseudo with bigger mode has lower thread
frequency than other reload pseudos
> On Mon, Jul 15, 2013 at 11:05 AM, Jan Hubicka wrote:
>
> > The next thing is how to tell GNU LD/Gold the relative order of functions.
> > I.e. my_function_section.order.125 or something like that?
>
> Gold has a --section-ordering-file option that lets you specify the
> order in which sections
On Mon, Jul 15, 2013 at 11:05 AM, Jan Hubicka wrote:
> The next thing is how to tell GNU LD/Gold the relative order of functions.
> I.e. my_function_section.order.125 or something like that?
Gold has a --section-ordering-file option that lets you specify the
order in which sections should appear
> >> I am not sure how to update gold - I basically copied existing code in
> >> binutils
> >> for .text.unlikely group in GNU LD linker script, but I think gold is doing
> >> independent decisions somewhere.
>
> Ian committed this patch a few months ago, after a lengthy discussion
> around a pat
Cong Hou wrote:
>Hi Richard
>
>Thank you for you reply. The code generation is affected when
>generating
>conditions for alias checks using the function
>
>static void vect_create_cond_for_alias_checks (loop_vec_info
>loop_vinfo,
>tree * cond_expr)
>
>from the file
>
>*tree-vect-loop-manip.c*
>
>
> After some discussion off line, I have reworked this patch as below.
> This version is cleaner and ensures the logic is just in one place.
>
> OK for Google 4.7 and 4.8?
>
> Sterling
>
>
> 2013-07-15 Sterling Augustine
>
> * dwarf2out.c (output_pubnames): Rework assertion. Move logic
This patch is OK.
Sorry for not looking at it earlier.
Thanks.
Ian
On Mon, Jul 15, 2013 at 5:40 AM, Matthias Klose wrote:
> ping 2
>
> Am 15.05.2013 13:46, schrieb Matthias Klose:
>> ping?
>>
>> regenerated the patch for the trunk, check with builds on arm-linux-gnueabihf
>> and x86_64-linux-g
Ubsan testsuite is something we've been missing for some time now, so
this patch adds it. Fortunately the dejagnu part was
quite simple, since ubsan doesn't need similar tweaks as asan does.
But I had to tweak gcc.c to include -lubsan.
The tests are testing pretty basic stuff, however, in LLVM tes
On Mon, Jul 15, 2013 at 9:32 AM, Sterling Augustine
wrote:
> Hi Cary,
>
> Google 4.8 calculates the size of pubnames incorrectly in the presence
> of pruned enumerators. The logic in size_of_pubnames should match that
> in output_pubnames.
After some discussion off line, I have reworked this patc
>> I am not sure how to update gold - I basically copied existing code in
>> binutils
>> for .text.unlikely group in GNU LD linker script, but I think gold is doing
>> independent decisions somewhere.
Ian committed this patch a few months ago, after a lengthy discussion
around a patch originally
On Mon, 2013-07-15 at 11:55 -0400, David Edelsohn wrote:
> Thanks for the explanation. Leave it in.
>
> Jakub was asking about the status of the HTM patch and support, so
> please check it in.
Ok, committed to mainline (after another bootstrap) as revision 200960.
Thanks!
Peter
Trunk was merged to the c++-concept branch at revision 200958.
Andrew --
There aere a few conflicts surronding introduction of
can_convert_standard, between your version and the one Jason committed.
I resolved them in favour of Jason's because his version followed the
GNU coding convention (when
Hi Cary,
Google 4.8 calculates the size of pubnames incorrectly in the presence
of pruned enumerators. The logic in size_of_pubnames should match that
in output_pubnames.
The enclosed patch fixes that.
OK for google 4.8?
Sterling
gcc/ChangeLog
2013-07-12 Sterling Augustine
* dwarf
On Mon, Jul 15, 2013 at 11:23 AM, Peter Bergner wrote:
> On Thu, 2013-07-04 at 12:02 -0400, David Edelsohn wrote:
>> The expanders in htm.md should not include constraint letters.
>
> That's the way I had the code originally, since they're not
> needed for expand, but I added them later to improve
On 07/14/13 21:37, David Holsgrove wrote:
Hi Michael,
-Original Message-
From: Michael Eager [mailto:ea...@eagerm.com]
Sent: Saturday, 13 July 2013 9:33 am
To: David Holsgrove
Cc: gcc-patches@gcc.gnu.org; Edgar Iglesias; John Williams; Vinod Kathail;
Vidhumouli Hunsigida; Nagaraju Mekal
On Thu, 2013-07-04 at 12:02 -0400, David Edelsohn wrote:
> The expanders in htm.md should not include constraint letters.
That's the way I had the code originally, since they're not
needed for expand, but I added them later to improve the
error message when someone uses a builtin that takes an
int
Hi,
On Fri, 12 Jul 2013, Ian Lance Taylor wrote:
> >> It was probably a mistake to have a linker -O option at all.
> >
> >
> > Doesn't the linker produce something that is faster to link and/or smaller,
> > with this flag?
>
> For gold I think it has two effects. If you use compressed debug
> s
ping 2
Am 15.05.2013 13:46, schrieb Matthias Klose:
> ping?
>
> regenerated the patch for the trunk, check with builds on arm-linux-gnueabihf
> and x86_64-linux-gnu
>
> Matthias
>
> * libgcc2.c: Don't include .
>
> Am 14.01.2013 22:54, schrieb Matthias Klose:
>> Am 04.01.2013 20:01, sc
ping
Am 12.06.2013 09:48, schrieb Matthias Klose:
> Trying to cross build a native compiler for arm-linux on x86_64 linux
> currently
> fails to build, if the libgmp development files are not available for the
> build
> system. This works with 4.7, but fails with 4.8.
>
> The build fails with:
On Sat, Jul 13, 2013 at 6:02 PM, Jason Merrill wrote:
> As came up in the review of the concepts lite code, can_convert currently
> doesn't allow user-defined conversions. This is surprising, so we've
> renamed it to can_convert_standard and made the can_convert name allow them.
> Users that coul
Hi,
Adding support for tiny model GOT access. Regressed, committed.
/Marcus
2013-07-15 Marcus Shawcroft
* config/aarch64/aarch64-protos.h (aarch64_symbol_type):
Define SYMBOL_TINY_GOT, update comment.
* config/aarch64/aarch64.c
(aarch64_load_symref_appropria
On 07/08/2013 09:47 PM, Janis Johnson wrote:
Tests gcc.target/powerpc/20020118-1.c and
gcc.c-torture/execute/nest-align-1.c sometimes fail because they expect
a stack alignment that is greater than that required for powerpc-eabi.
This patch forces stack alignment to 128 bits by passing "-mno-eabi
40 matches
Mail list logo