Re: [RFA:] fix PR55030, wrong code from __builtin_setjmp_receiver

2012-11-25 Thread Hans-Peter Nilsson
Thanks for the reviews! On Mon, 19 Nov 2012, Eric Botcazou wrote: > Thanks for the analysis. I don't think that the redundancy of the clobber > list matters here: the clobbers are added to all asm statements, volatile or > not, so they aren't intended to make the volatile statements more precise

Re: [PATCH] Section anchors and thread-local storage

2012-11-25 Thread David Edelsohn
On Sun, Nov 25, 2012 at 3:07 PM, Jakub Jelinek wrote: > Do you want to handle TLS_MODEL_EMULATED that way? If not, the test > should be DECL_THREAD_LOCAL_P (decl) (I believe you want that), > if yes, perhaps DECL_TLS_MODEL (decl) != TLS_MODEL_NONE. Thanks for pointing this out. I should have u

Re: Rewrite lto-symtab to work on symbol table

2012-11-25 Thread H.J. Lu
On Sun, Nov 25, 2012 at 9:55 AM, H.J. Lu wrote: > On Mon, Sep 24, 2012 at 9:10 AM, H.J. Lu wrote: >> On Mon, Sep 24, 2012 at 8:50 AM, Martin Jambor wrote: >>> Hi, >>> >>> On Tue, Sep 18, 2012 at 03:35:45PM +0200, Jan Hubicka wrote: Hi, this patch reorganize lto-symtab to work across sy

Re: Fix twolf -funroll-loops -O3 miscompilation (a semi-latent web.c bug)

2012-11-25 Thread Steven Bosscher
On Sun, Nov 25, 2012 at 9:44 PM, Steven Bosscher wrote: > On Sat, Nov 24, 2012 at 2:09 AM, Steven Bosscher wrote: >> On Fri, Nov 23, 2012 at 11:45 PM, Steven Bosscher wrote: >>> Removing the note is easier but it may hurt optimization later on: >>> CSE2 puts the note back in but this introduces a p

Re: [patch] reorg.c janitor patch 2: handle DEBUG_INSN

2012-11-25 Thread Steven Bosscher
On Sun, Nov 25, 2012 at 11:09 PM, Jakub Jelinek wrote: > On Sun, Nov 25, 2012 at 12:59:48PM +0100, Steven Bosscher wrote: >> stop_search_p will reach the default case on DEBUG_INSN, and the >> default case is "gcc_unreachable()". I suppose this means nobody is >> using DWARF3+ on a dbr_sched targe

Re: [patch] reorg.c janitor patch 2: handle DEBUG_INSN

2012-11-25 Thread Jakub Jelinek
On Sun, Nov 25, 2012 at 12:59:48PM +0100, Steven Bosscher wrote: > stop_search_p will reach the default case on DEBUG_INSN, and the > default case is "gcc_unreachable()". I suppose this means nobody is > using DWARF3+ on a dbr_sched target, it can't possibly ever have > worked. Eric? Isn't dbr sch

[PATCH, i386]: Add -mtune=generic to gcc.target/i386/sw-1.c

2012-11-25 Thread Uros Bizjak
Hello! Otherwise, we can generate real memcpy call for certain targets (corei7) that interferes with shrink-wrapping. 2012-11-25 Uros Bizjak * gcc.target/i386/sw-1.c (dg-options): Add -mtune=generic. Tested on x86_64-linux-gnu, committed to mainline SVN. Uros. Index: gcc.target/i386

Re: [patch] reorg.c janitor patch 2: handle DEBUG_INSN

2012-11-25 Thread Hans-Peter Nilsson
On Sun, 25 Nov 2012, Steven Bosscher wrote: > stop_search_p will reach the default case on DEBUG_INSN, and the > default case is "gcc_unreachable()". I suppose this means nobody is > using DWARF3+ on a dbr_sched target, it can't possibly ever have > worked. Eric? There must be something else (som

Re: Fix twolf -funroll-loops -O3 miscompilation (a semi-latent web.c bug)

2012-11-25 Thread Steven Bosscher
On Sat, Nov 24, 2012 at 2:09 AM, Steven Bosscher wrote: > On Fri, Nov 23, 2012 at 11:45 PM, Steven Bosscher wrote: >> Removing the note is easier but it may hurt optimization later on: >> CSE2 puts the note back in but this introduces a pass ordering >> dependency. Perhaps that's not a big problem,

[PATCH, i386]: Fix handling of TARGET_SSE_TYPELESS_STORES in unaligned move RTXes

2012-11-25 Thread Uros Bizjak
Hello! When unaligned moves were split to unaligned store/loads, mode calculation didn't get updated. Attached patch fixes this oversight. 2012-11-25 Uros Bizjak * config/i386/sse.md (_loadu): Do not depend on TARGET_SSE_TYPELESS_STORES. (_loaddqu): Ditto. (_st

Re: [PATCH] Section anchors and thread-local storage

2012-11-25 Thread Jakub Jelinek
On Sun, Nov 25, 2012 at 02:02:05PM -0500, David Edelsohn wrote: > I have been working to enable native thread-local storage on AIX. One > problem I encountered is the AIX assembler has difficulty with the > anchor symbol for TLS CSECTs. While the section anchors machinery > uses a separate pool fo

[Patch, libquadmath, committed] PR 55462 - rounding fix

2012-11-25 Thread Tobias Burnus
Committed as Rev. 193796. I forgot to change the condition after changing how the rounding mode is detected. Tobias Index: libquadmath/ChangeLog === --- libquadmath/ChangeLog (Revision 193792) +++ libquadmath/ChangeLog (Arbeitskopie

Re: [Patch, Fortran, OOP] PR 54881: [4.8 Regression] [OOP] ICE in fold_convert_loc, at fold-const.c:2016

2012-11-25 Thread Mikael Morin
Le 11/10/2012 23:49, Janus Weil a écrit : Hi all, here is an OOP patch for the above PR, which has two disconnected parts: 1) It fixes a problem with ASSOCIATED, when it is fed a CLASS-valued function as argument (i.e. the ICE in the bug title). This is the trans-intrinsic part of the patch. In

Re: [PATCH] Update source location for PRE inserted stmt

2012-11-25 Thread Xinliang David Li
On Sun, Nov 25, 2012 at 4:40 AM, Richard Biener wrote: > On Thu, Nov 15, 2012 at 5:46 PM, Eric Botcazou wrote: >>> But UNKNOWN_LOCATION is effectively wrong as well. If other >>> optimizations move the statements above the inserted instruction, then >>> the new instruction ends up inheriting wha

Re: [Patch, Fortran] PR 54997: -Wunused-function gives false warnings for procedures passed as actual argument

2012-11-25 Thread Mikael Morin
Le 22/10/2012 16:49, Janus Weil a écrit : Minor update to the patch: It now also sets TREE_USED for entry masters in order to avoid bogus warnings for procedures with ENTRY (cf. comment 6 in the PR, which like comment 0 is a 4.8 regression). Still regtests cleanly. Ok? OK with an extra test fo

[PATCH] Section anchors and thread-local storage

2012-11-25 Thread David Edelsohn
I have been working to enable native thread-local storage on AIX. One problem I encountered is the AIX assembler has difficulty with the anchor symbol for TLS CSECTs. While the section anchors machinery uses a separate pool for TLS entries, should section anchor blocks be used for TLS symbols at a

Re: [patch] reorg.c janitor patch 3: remove rare_destination()

2012-11-25 Thread Richard Sandiford
Steven Bosscher writes: > On Sun, Nov 25, 2012 at 6:13 PM, Richard Sandiford wrote: >> Steven Bosscher writes: >>> Hello, >>> >>> reorg.c:rare_destination() tries to determine whether a given insn is >>> a likely destination of a branch. To make this determination, it walks >>> the insns chain fro

Re: [Patch, fortran] PR46897 - [OOP] type-bound defined ASSIGNMENT(=) not used for derived type component in intrinsic assign

2012-11-25 Thread Mikael Morin
Hello Paul, Le 18/11/2012 18:09, Paul Richard Thomas a écrit : Dear Mikael, Thank you for the last review of my patch for this PR. Since then, I have had difficulty to find time for gfortran for both personal and professional reasons. thanks for your continued work despite that. In a momen

Re: Rewrite lto-symtab to work on symbol table

2012-11-25 Thread H.J. Lu
On Mon, Sep 24, 2012 at 9:10 AM, H.J. Lu wrote: > On Mon, Sep 24, 2012 at 8:50 AM, Martin Jambor wrote: >> Hi, >> >> On Tue, Sep 18, 2012 at 03:35:45PM +0200, Jan Hubicka wrote: >>> Hi, >>> this patch reorganize lto-symtab to work across symtab's symbol table >>> instead >>> of building its own.

Re: [patch] reorg.c janitor patch 3: remove rare_destination()

2012-11-25 Thread Steven Bosscher
On Sun, Nov 25, 2012 at 6:13 PM, Richard Sandiford wrote: > Steven Bosscher writes: >> Hello, >> >> reorg.c:rare_destination() tries to determine whether a given insn is >> a likely destination of a branch. To make this determination, it walks >> the insns chain from insn and stops at barriers, lab

Re: [patch] reorg.c janitor patch 3: remove rare_destination()

2012-11-25 Thread Richard Sandiford
Steven Bosscher writes: > Hello, > > reorg.c:rare_destination() tries to determine whether a given insn is > a likely destination of a branch. To make this determination, it walks > the insns chain from insn and stops at barriers, labels, return insns, > or if more than 10 jumps have been followed

Re: [RFA 8/8] validate_failures.py: New directives @include, @remove.

2012-11-25 Thread Diego Novillo
On Sat, Nov 24, 2012 at 6:02 PM, Doug Evans wrote: > 2012-11-24 Doug Evans > > * testsuite-management/validate_failures.py: Add support for > @include, @remove > directives in manifest files. OK. Thanks for all the cleanups and features! Diego.

Re: [RFA 7/8] validate_failures.py: New options --manifest_subdir, --manifest_name

2012-11-25 Thread Diego Novillo
On Sat, Nov 24, 2012 at 5:58 PM, Doug Evans wrote: > Hi. > This seventh patch adds new options --manifest_subdir, --manifest_name. > Useful when using validate_failures.py with a different tool, instead of gcc. > > Ok to check in? > > 2012-11-24 Doug Evans > > * testsuite-management/val

Re: [RFA 5/8] validate_failures.py: make options a global

2012-11-25 Thread Diego Novillo
On Sat, Nov 24, 2012 at 5:52 PM, Doug Evans wrote: > Hi. > This fifth patch makes options a global variable. > As validate_failures.py becomes more complex, passing it around everywhere > becomes cumbersome with no real gain. > > Ok to check in? > > 2012-11-24 Doug Evans > > * testsuite

[patch libstdc++]: Fix PR target/55445 Always defined __SEH__ when build from trunk

2012-11-25 Thread Kai Tietz
Hi, this patch fixes used exception-mechanism for SEH-enabled targets, which are requesting for SjLj-exception-mechanism. See also patch for libgcc. ChangeLog 2012-11-25 Kai Tietz PR target/55445 * libsupc++/eh_personaltity.cc (__SEH__): Additional check for not being S

Re: [RFA 4/8] validate_failures.py: rename --manifest to --manifest_path

2012-11-25 Thread Diego Novillo
On Sat, Nov 24, 2012 at 5:50 PM, Doug Evans wrote: > Hi. > This fourth patch renames option --manifest to --manifest_path. > I have a later patch that adds a --manifest_name option, making "--manifest" > too confusing/ambiguous. > > Ok to check in? > [I still have to update invocations that use --

Re: [RFA 3/8] validate_failures.py: pass options.results for clean build case

2012-11-25 Thread Diego Novillo
On Sat, Nov 24, 2012 at 5:47 PM, Doug Evans wrote: > > Hi. > This third patch passes options.results to GetSumFiles when fetching the > results > for the clean build. > It is useful in my use cases, but I'm not sure it's useful for upstream. > [An alternative is to add another option to specify th

[patch libgcc]: Fix PR target/55445 Always defined __SEH__ when build from trunk

2012-11-25 Thread Kai Tietz
Hi, the issue here is that the predefined macro __SEH__ does just indicate that SEH-infrastructure is present. It doesn't mean that SEH is used as exception-mechansim. Therefore the checks in libgcc's (and as followup in libstdc++'s) eh exception-mechansim for SEH were not regarding that there m

Re: [RFA 2/8] validate_failures.py: use target_alias

2012-11-25 Thread Diego Novillo
On Sat, Nov 24, 2012 at 5:43 PM, Doug Evans wrote: > 2012-11-24 Doug Evans > > * testsuite-management/validate_failures.py: Use > instead of > . Minor whitespace changes. OK. Diego.

Re: [RFA 1/8] validate_failures.py: add TestResult ordinal

2012-11-25 Thread Diego Novillo
On Sat, Nov 24, 2012 at 5:41 PM, Doug Evans wrote: > 2012-11-24 Doug Evans > > * testsuite-management/validate_failures.py: Record ordinal with > TestResult. OK. Diego.

[patch i386} Fix PR 55171 - [4.7/4.8 Regression] incorrect virtual thunk on mingw

2012-11-25 Thread Kai Tietz
Hi, the following patch adjusts used registers for thiscall-calling convention thunks, so that there aren't register-collisions. Issue was that thiscall-convention has different register-usage as regparam, but it wasn't handled. ChangeLog 2012-11-25 Kai Tietz PR target/55171

Re: VEC re-write [patch 01/25]

2012-11-25 Thread Diego Novillo
On Sun, Nov 25, 2012 at 8:11 AM, Richard Biener wrote: > Doesn't that mean that a non-GCC host compiler might fail to build > 4.8 during stage1? Yes. Fixed last week. vec<> needed to become a pure POD. So sad. Diego.

Re: *ping* [patch, fortran] PR 30146, errors for INTENT(OUT) and INTENT(INOUT) for DO loop variables

2012-11-25 Thread Steven Bosscher
On Sun, Nov 25, 2012 at 2:11 PM, Thomas Koenig wrote: > Ping**2? This is OK. Ciao! Steven

[patch] reorg.c janitor patch 3: remove rare_destination()

2012-11-25 Thread Steven Bosscher
Hello, reorg.c:rare_destination() tries to determine whether a given insn is a likely destination of a branch. To make this determination, it walks the insns chain from insn and stops at barriers, labels, return insns, or if more than 10 jumps have been followed. The function is supposed to retur

Re: [tsan] Don't instrument clobber stmts, minor cleanups

2012-11-25 Thread Richard Biener
On Fri, Nov 23, 2012 at 2:39 PM, Jakub Jelinek wrote: > Hi! > > var ={v} {CLOBBER}; > stmts shouldn't be tsan instrumented, those aren't stores, just > markups that var's scope ends. Additionally this patch removes the > IMHO unneeded TODO_update_address_taken (discussed earlier already) > and f

Re: [PATCH]: Fix compiler segfault failure in cd_dce pass

2012-11-25 Thread Richard Biener
On Wed, Nov 21, 2012 at 10:35 PM, Xinliang David Li wrote: > In compiling one of the very large C++ source, the compiler hit a > segfault in cddce -- the ssa_name of a vuse operand has a null def > stmt. > > The def stmt was a PHI node, and later got removed by the phicprop > pass (in eliminate_de

Re: [PATCH] Fix VRP MULT_EXPR handling (PR tree-optimization/54471)

2012-11-25 Thread Richard Biener
On Wed, Nov 21, 2012 at 9:38 PM, Jakub Jelinek wrote: > Hi! > > If a type has 2 * HWI precision, sizem1 is maximum double_int (all ones) > and thus size = sizem1 + double_int_one overflows into 0. If either min0 > or min1 is also zero, we might wrongly canonicalize the range into a signed > one.

Re: *ping* [patch, fortran] PR 30146, errors for INTENT(OUT) and INTENT(INOUT) for DO loop variables

2012-11-25 Thread Thomas Koenig
Am 17.11.2012 10:09, schrieb Thomas Koenig: I wrote: Attached is the new version of the patch, regression-tested. http://gcc.gnu.org/ml/gcc-patches/2012-11/msg00836.html Thanks for the review! OK for trunk? Ping? Ping**2? Thomas

Re: VEC re-write [patch 01/25]

2012-11-25 Thread Richard Biener
On Sun, Nov 18, 2012 at 6:12 PM, Diego Novillo wrote: > On Sun, Nov 18, 2012 at 12:05 PM, Hans-Peter Nilsson > wrote: >> On Sat, 17 Nov 2012, Diego Novillo wrote: >>> I have now committed all 25 parts of this patch as rev 193595. Please >>> CC me on any problems that you think may be related to

Re: [patch] Remove DECL_RESTRICTED_P

2012-11-25 Thread Richard Biener
On Fri, Nov 16, 2012 at 6:15 PM, Eric Botcazou wrote: > Hi, > > that's not really a bugfix, but I don't see the point in keeping this flag, > which was already dead in 4.7, one more release. > > Tested on x86_64-suse-linux, OK for the mainline? Ok. Thanks, Richard. > > 2012-11-16 Eric Botcazou

Re: [PATCH] Update source location for PRE inserted stmt

2012-11-25 Thread Richard Biener
On Thu, Nov 15, 2012 at 5:46 PM, Eric Botcazou wrote: >> But UNKNOWN_LOCATION is effectively wrong as well. If other >> optimizations move the statements above the inserted instruction, then >> the new instruction ends up inheriting whatever location happens to be >> in the previous statement. >

Re: Reduce complette unrolling & peeling limits

2012-11-25 Thread Dominique Dhumieres
My mailer has eaten a line in my previous mail. One should read: I have found another fall out: I have some avatars of the polyhedron tests where the REAL(8) have been replaced with REAL(10). Some of them are now ~50% slower with the new value of max-completely-peeled-insns. Should I open a new PR

Re: Reduce complette unrolling & peeling limits

2012-11-25 Thread Dominique Dhumieres
> ... I believe I posted a patch? Yes: http://gcc.gnu.org/ml/gcc-patches/2012-11/msg01799.html I have found another fall out: I have some avatars of the polyhedron tests where the REAL(8) have been replaced with REAL(10). Some of them are now Should I open a new PR for that? Cheers, Dominique

[patch] reorg.c janitor patch 2: handle DEBUG_INSN

2012-11-25 Thread Steven Bosscher
Hi, stop_search_p will reach the default case on DEBUG_INSN, and the default case is "gcc_unreachable()". I suppose this means nobody is using DWARF3+ on a dbr_sched target, it can't possibly ever have worked. Eric? Anyway, also obvious: Don't stop on DEBUG_INSNs. Ciao! Steven * reorg.

[patch] reorg.c janitor patch: use return hard_reg_set_intersect_p

2012-11-25 Thread Steven Bosscher
One to be committed as obvious. * reorg.c (resource_conflicts_p): Use hard_reg_set_intersect_p. Index: reorg.c === --- reorg.c (revision 193787) +++ reorg.c (working copy) @@ -292,18 +292,7 @@ resource_conflicts_p (st

Re: Minor fixes to ipa-inline-analysis.c

2012-11-25 Thread Richard Biener
On Wed, Nov 7, 2012 at 10:25 AM, Jan Hubicka wrote: > Hi, > while analyzing c-ray I noticed two issues. First is that I originally set > number > of size/time entries to 32. Once we reach this limit we conservatively > account > everything as unconditional. This limit is not met on relatively