Hi Janus,
could you also patches, which you commit as obvious to the mailing lists?
Regarding the last patch, the GNU style puts a line break after the ")" in:
+ if (!sym) return NULL;
+
Tobias
commit 12c8610481cc199a6019cd41d07dbdf8906032d0
Author: janus
Date: Thu Sep 15 17:48:27 2011 +00
The Go frontend had a bug when a function with named result parameter
called defer on a function which did not call recover. The caller would
execute a return statement to return the updated values of the named
result parameters. This was wrong when the deferred function did not
call recover and
On Thu, Sep 15, 2011 at 2:04 PM, Michael Meissner
wrote:
> It would help if I included the patches:
>
> [gcc-4.6]
> 2011-09-15 Alan Modra
> Michael Meissner
>
> PR target/50341
> * config/rs6000/rs6000.md (call_indirect_aix32): Do not split the
> load of the in
Hi,
tested x86_64-linux, committed to mainline.
Paolo.
//
2011-09-15 Paolo Carlini
* include/std/tuple (make_tuple, forward_as_tuple): Declare constexpr.
(_Tuple_impl<>::_Tuple_impl(_Tuple_impl<>&&)): Likewise.
* testsuite/20_util/tuple/creation_f
This one is more controversial and I need input from a coarray-fluent guy, for
example Tobias.
As I introduced the want_coarray flag (see previous patch), it made sense to me
to also set want_coarray for coarray dummies. After some more thought,
I decided to restrict further want_coarray to assume
This patch was necessary on a previous version of the patchset (I was calling
gfc_get_corank on non-coarrays with e->symtree == NULL, and it was segfaulting
on the first e->symtree dereferencing). In the current version, it is optional,
but I propose it anyway as (I think) it makes some sense.
Th
In the next patches, we are going to evaluate cobounds out of the scalarizer.
This needs to be done before the call to gfc_get_array_type_bounds (which takes
[co]bounds as input).
As a result we need to know the corank before that call.
Furthermore, as we are going to remove coarray support in the
This uses the just set codim (see patch 5) as argument to
gfc_get_array_type_bounds.
OK?
2011-09-14 Mikael Morin
* trans-array.c (gfc_conv_expr_descriptor): Use codim instead of
loop.codimen as argument to gfc_get_array_type_bounds.
diff --git a/trans-array.c b/trans-array.c
in
The Changelog says it all.
OK?
2011-09-14 Mikael Morin
* trans-array.c (gfc_conv_section_startstride): Factor common
array ref references.
diff --git a/trans-array.c b/trans-array.c
index 0f5f29c..7cc86ba 100644
--- a/trans-array.c
+++ b/trans-array.c
@@ -3187,12 +3187,14 @@ g
Currently, gfc_walk_variable_expr changes codimension's type from
DIMEN_THIS_IMAGE to DIMEN_RANGE so that it looks like a regular array.
We are going to remove that but still want to call gfc_conv_section_startstride
on the coarray dimensions to get the cobounds.
This patch relaxes an assertion in
This patch sets cobounds in a coarray's gfc_ss struct without relying on the
scalarizer doing it automatically.
The convention to have the bounds and cobounds stored in the loop::from
and loop::to arrays while calling gfc_get_array_type_bounds is not changed,
so we need to set the loop.from[n] and
We have two contradictory needs:
we want to make gfc_walk_expr free of coarray hacks as much as possible,
we want to have a gfc_ss generated for scalar coarrays suitable for
gfc_conv_expr_descriptor.
This patch creates a wrapper around gfc_walk_expr, so that in the scalar case
(i.e. value returne
This removes the gfc_loopinfo::codimen field and the code associated with it.
OK?
2011-09-14 Mikael Morin
* trans.h (gfc_loopinfo): Remove codimen field.
* trans-array.c (gfc_set_vector_loop_bounds,
gfc_trans_scalarizing_loops, gfc_conv_loop_setup): Update loop upper
This patch, like the previous one, removes one argument from
gfc_conv_section_startstride.
We have to be more careful here as the two callers use different values
for the flag.
gfc_conv_ss_startstride calls gfc_conv_section_startstride with coarray=false.
Thus removing every !coarray condition shou
This patch removes gfc_ss::codimen field and any code depending on it.
OK?
2011-09-14 Mikael Morin
* trans.h (gfc_ss_info): Remove codimen field.
* trans-array.c (gfc_get_array_ss): Don't set codimen field.
(gfc_trans_create_temp_array): Don't set descriptor's cobounds
This merges two identical switch cases. It didn't fit anywhere else, so here
it is, alone.
OK?
2011-09-14 Mikael Morin
* trans-array.c (gfc_conv_ss_startstride): Merge two switch cases.
diff --git a/trans-array.c b/trans-array.c
index a034886..86eb6c8 100644
--- a/trans-array.c
+++ b/
At this point, gfc_conv_section_startstride has two callers, and for both
of them, the last argument (coarray_last) has the value false.
This patch removes the argument.
OK?
2011-09-14 Mikael Morin
* trans-array.c (gfc_conv_section_startstride): Remove coarray_last
argument. R
In the following patches, we are going to use gfc_conv_section_startstride
to calculate cobounds. The problem is that we don't want to calculate the last
ucobound. As a result, we should have a way to evaluate the lower bound
and the upper bound independently.
This patch moves bound evaluation to a
This removes the coarray code in gfc_walk_variable_expr.
See the ChangeLog for details.
OK?
2011-09-14 Mikael Morin
* trans-array.c (gfc_walk_variable_expr): Remove scalar coarray
handling. Don't reset array ref's corank and codimensions' types
in the full array ref c
This prevents a regression.
The problem is in the full array case, ar->dimen is not set at resolution time.
As a result, the code seting ar->dimen_type to DIMEN_THIS_IMAGE (see patch 2)
sets codimensions' types starting at index 0 (as if it was a scalar coarray).
Later, gfc_walk_variable_expr sets
This removes the gfc_ss::data::temp::codimen field and the code depending on
it.
OK?
2011-09-14 Mikael Morin
* trans.h (gfc_ss): Remove data.temp.codimen field.
* trans-array.c (gfc_conv_resolve_dependencies,
gfc_conv_expr_descriptor): Don't set temp's codimen field.
d
We are going to remove the gfc_loopinfo::codimen field.
The following assertion in gfc_conv_ss_startstride:
gcc_assert (loop->dimen + loop->codimen != 0);
is going to fail for scalar coarrays when updated to
gcc_assert (loop->dimen != 0);
However, gfc_conv_expr_descriptor, requires (if we don
In gfc_conv_expr_descriptor, the code setting the descriptor cobounds (copied
from the non-coarray case) has unnecessary stuff irrelevant to coarrays:
as codimensions can't be transposed, the condition dim[n] == n is guaranteed
to hold true for the codimensions.
This patch removes unnecessary code
compare_spec_to_ref, despite its name, has the side effect of writing to the
array ref it is supposed to check (in the coarray case). I found this very
surprising, hence this patch which moves the relevant code to
resolve_array_ref, just after the call to compare_spec_to_ref (so that the
code path
Hello,
the scalarizer is there to generate loops for assignments over more than
one element. Tobias extended it at various places to support coarrays,
but this should not be necessary as coarrays in assignments either refer
to the array present on the local image or to the one on the remote image
There are two functions checking that an expression is a coarray.
This keeps the public one (which seems to be the more complete) and removes
the other one.
OK?
PS: As this changes a rejects-valid into an ice-on-valid (see PR 50420
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=50420), it can be del
On Tue, 2011-09-13 at 18:51 +0100, Richard Sandiford wrote:
> As per the subject. Tested by making sure that there were no new
> warnings building ia64-linux-gnu, and that there were no changes
> in the assembly output for the C and C++ testsuite. OK to install?
>
> Richard
Looks OK to me.
Ste
On 09/15/2011 05:49 PM, Jason Merrill wrote:
On 09/15/2011 05:14 PM, Richard Henderson wrote:
On 09/15/2011 02:03 PM, Andrew MacLeod wrote:
a template calling that particular method was probably not invoked.
The joys of c++ templates eh :-)
Isn't there an extension that forces an entire cla
On 09/15/2011 05:14 PM, Richard Henderson wrote:
On 09/15/2011 02:03 PM, Andrew MacLeod wrote:
On 09/15/2011 04:47 PM, Richard Henderson wrote:
On 09/09/2011 01:29 PM, Andrew MacLeod wrote:
! { return __sync_mem_add__fetch(&_M_i, 1, memory_order_seq_cst); }
On 09/15/2011 05:14 PM, Richard Henderson wrote:
On 09/15/2011 02:03 PM, Andrew MacLeod wrote:
a template calling that particular method was probably not invoked. The joys of
c++ templates eh :-)
Isn't there an extension that forces an entire class template to be
instantiated?
It's stand
On 09/15/2011 02:03 PM, Andrew MacLeod wrote:
> On 09/15/2011 04:47 PM, Richard Henderson wrote:
>> On 09/09/2011 01:29 PM, Andrew MacLeod wrote:
>>> ! { return __sync_mem_add__fetch(&_M_i, 1, memory_order_seq_cst); }
>>
>> ^^ typo
>>
>> Which begs the questi
On 09/15/2011 02:06 PM, Andrew MacLeod wrote:
>> Please don't embed = inside IF conditions.
>>
> sure, i just figured the extra parenthesis covered that.
It covers the -Wall warning, but I still find it significantly
harder to read. And in this case all it does is make the IF
line too long.
r~
On 09/15/2011 05:02 PM, Richard Henderson wrote:
! /* Initialize the fields for each supported opcode. */
! static struct op_functions add_op = { sync_mem_fetch_add_optab,
! sync_mem_add_fetch_optab,
! sync_mem_add_optab,
!
On 09/15/2011 04:47 PM, Richard Henderson wrote:
On 09/09/2011 01:29 PM, Andrew MacLeod wrote:
! { return __sync_mem_add__fetch(&_M_i, 1, memory_order_seq_cst); }
^^ typo
Which begs the question of how this didn't get caught
in the testsuite somewhere?
> ! /* Initialize the fields for each supported opcode. */
> ! static struct op_functions add_op = { sync_mem_fetch_add_optab,
> ! sync_mem_add_fetch_optab,
> ! sync_mem_add_optab,
> ! sync_old_ad
On Mon, Mar 7, 2011 at 20:47, Mike Stump wrote:
> On Mar 7, 2011, at 5:30 PM, Diego Novillo wrote:
>> This is the patch I had in mind for trunk.
>
>> OK for 4.7?
>
> Ok. I'll just note here, that this is necessary for canadian, but not always
> sufficient. It is monotonically better however. I
On 09/15/2011 04:35 PM, Richard Henderson wrote:
* c-family/c-common.c (sync_resolve_params, sync_resolve_return): Only
tweak parameters that are the same type size.
(resolve_overloaded_builtin): Use new param for __sync_mem builtins.
* testsuite/gcc.dg/sy
The following patch permits to use equivalences to restore pseudo values
around the call.
As side effect the patch solves SPECFP2000 art degradation on x86-64 and
possibly on ppc64 (unfortunately the score results for art is too
unstable on power7).
The patch was successfully bootstrapped on
On 09/09/2011 01:29 PM, Andrew MacLeod wrote:
> ! { return __sync_mem_add__fetch(&_M_i, 1, memory_order_seq_cst); }
^^ typo
Which begs the question of how this didn't get caught
in the testsuite somewhere?
Otherwise it looks ok.
r~
> * expr.h: Remove prototypes.
> * sync-builtins.def (BUILT_IN_SYNC_MEM_FLAG_TEST_AND_SET,
> BUILT_IN_SYNC_MEM_FLAG_CLEAR): Remove.
> * optabs.h (enum direct_optab_index): Remove DOI_sync_mem_flag_*.
> * optabs.c (expand_sync_lock_test_and_set): Remove.
> (expand
On Thu, Sep 15, 2011 at 16:37, Easwaran Raman wrote:
> This patch adds l-ipo.h to PLUGIN_HEADERS. Ok for gcc-4_6 branch?
> -Easwaran
> 2011-09-15 Easwaran Raman
> * Makefile.in (PLUGIN_HEADERS): Add l-ipo.h.
OK. Also needed in google/main, I think.
Diego.
> * c-family/c-common.c (sync_resolve_params, sync_resolve_return): Only
> tweak parameters that are the same type size.
> (resolve_overloaded_builtin): Use new param for __sync_mem builtins.
>
> * testsuite/gcc.dg/sync-mem-param.c: New testcase to check correct
>
Latest results for 4.6.x
-tgc
Testresults for 4.6.1:
i386-pc-mingw32
mips-sgi-irix6.5
Index: buildstat.html
===
RCS file: /cvs/gcc/wwwdocs/htdocs/gcc-4.6/buildstat.html,v
retrieving revision 1.6
diff -u -r1.6 buildstat.html
--- b
On 09/14/2011 06:12 PM, Bernd Schmidt wrote:
> + unsigned int orig_regno = REGNO (reg);
> + int nregs = hard_regno_nregs[orig_regno][GET_MODE (reg)];
> + while (nregs-- > 0)
The rest of the file seems to use targetm.dwarf_register_span.
This probably ought to do the same.
r~
Hello!
No functional change.
2011-09-15 Uros Bizjak
* config/i386/i386.c (output_fp_compare): Return %v prefixed
instruction mnemonics for TARGET_AVX.
* config/i386/i386.md (*movdf_internal_rex64): use cond RTX in
"type" attribute calculation.
(*movdf_
> +The elements of the input vectors are numbered from left to right across
> +one or both of the vectors. Each element in the mask specifies a number
> +of element from the input vector(s). Consider the following example.
It would be more preferable to talk about the memory ordering of the
elemen
On Sep 15, 2011, at 1:20 AM, Tom de Vries wrote:
> On 09/14/2011 06:35 PM, Zdenek Dvorak wrote:
>> Hi,
>>
>>> The attached patch fixes PR50322.
>>>
>>> The test-case is supposed to succeed if the loop counter data-type has the
>>> same
>>> size as a pointer. The patch defines TYPE to be an int d
On Thu, Sep 15, 2011 at 11:07:43AM -0700, Andrew Pinski wrote:
> On Thu, Sep 15, 2011 at 10:52 AM, Michael Meissner
> wrote:
> > The recent changes for the new code models tickled a latent bug in the GCC
> > 4.6
> > and 4.7 compilers with the AIX calling sequence (PR 50341). When you call a
> >
On Thu, 2011-09-15 at 11:07 -0700, Andrew Pinski wrote:
> It was originally splitting before reload and I had changed it to be
> splitting after reload assuming the dependencies would be correct.
> What is the instruction which is being described as not dependent on
> the load of r2?
Alan describe
On Wed, Sep 14, 2011 at 04:00:02AM -0400, David Miller wrote:
>
> Eric, this is a preliminary version of the FMA patch I've been
> working on. Just so you can see what I'm doing.
>
> First, ignore the fact that there are two configure tests for the
> presence of support for these instructions.
On Thu, Sep 15, 2011 at 10:52 AM, Michael Meissner
wrote:
> The recent changes for the new code models tickled a latent bug in the GCC 4.6
> and 4.7 compilers with the AIX calling sequence (PR 50341). When you call a
> function indirectly, the compiler has to save the current function's TOC
> poi
It would help if I included the patches:
[gcc-4.6]
2011-09-15 Alan Modra
Michael Meissner
PR target/50341
* config/rs6000/rs6000.md (call_indirect_aix32): Do not split the
load of the indirect function's TOC from the call to prevent the
compiler fr
The recent changes for the new code models tickled a latent bug in the GCC 4.6
and 4.7 compilers with the AIX calling sequence (PR 50341). When you call a
function indirectly, the compiler has to save the current function's TOC
pointer that is in r2 on the stack frame, and then load the new functi
Hi!
Here is an updated version of the support patch for the tree-ssa-strlen.c
optimization. The only change is the propagation of gimple_block
to the new call from the old call, otherwise Wobjsize-1.c testcase
fails when we optimize that __strcpy_chk into __memcpy_chk, but don't
propagate its BLO
Since NULLPTR_TYPE can be a member (though I don't see the point), we
need to know how to count it.
Tested x86_64-pc-linux-gnu, applying to trunk.
commit 435875780fc2c4d6b3bc70ca6fb2d2ff8608dfe0
Author: Jason Merrill
Date: Tue Sep 13 06:15:16 2011 -0400
PR c++/50361
* expr.c (count
I forgot to fix the other test in my patch for 49691. Oops.
Tested x86_64-pc-linux-gnu, applying to trunk.
commit 5e0bb3e7f8287cd88f09b8f10c126e5b5f0711b2
Author: Jason Merrill
Date: Thu Sep 15 10:06:19 2011 -0400
PR c++/50365
* parser.c (cp_parser_late_return_type_opt): Check qual
On 15/09/11 03:27, Bin Cheng wrote:
> Hi,
> Bug PR46934 exists on all thumb1 targets, for example cortex-m0.
> This patch removes "-march=armv5te" option for testcase pr46934.c,
> allowing the test to be run on all thumb1 targets, not just armv5te.
>
> Is it ok? Thanks.
>
> gcc/testsuite/ChangeLo
On 07/25/2011 07:00 PM, Rainer Orth wrote:
>> * Also, the definition of HAVE_DESIGNATED_INITIALIZERS was wrong for g++
>>on Solaris which again defines __STDC_VERSION__ 199901L. To fix this,
>>I never define H_D_I if __cplusplus.
>
> Is this a valid definition of __STDC_VERSION__ at a
On 15 September 2011 03:27, Bin Cheng wrote:
> Hi,
> Bug PR46934 exists on all thumb1 targets, for example cortex-m0.
> This patch removes "-march=armv5te" option for testcase pr46934.c,
> allowing the test to be run on all thumb1 targets, not just armv5te.
>
> Is it ok? Thanks.
>
> gcc/testsuite/
Bootstrapped and tested on powerpc64-suse-linux.
Committed to trunk.
Ira
ChangeLog:
* tree-vect-data-refs.c (vect_analyze_data_ref_dependence): Allow
read-after-read dependencies in basic block SLP.
testsuite/ChangeLog:
* gcc.dg/vect/bb-slp-25.c: New.
Index: tree-vect-dat
On 15/09/11 03:41, Bin Cheng wrote:
> Hi,
> The linker should do endian swizzling at link-time according to "--be8"
> option.
> This patch modifies BE8_LINK_SPEC by adding cortex-m processors in the specs
> string.
>
> Since R-profile supports configurable big-endian instruction fetch, I didn't
>
On 15/09/11 09:48, James Greenhalgh wrote:
> Hi,
>
> This patch adds a predefined macro __ARM_FEATURE_UNALIGNED
> which is set when unaligned access is supported in hardware and
> enabled by users.
>
> Thanks,
> James Greenhalgh
>
> gcc/
>
> 2011-09-14 James Greenhalgh
>
> * config/ar
Hi,
this patch updates inline heuristics so we could analyse also non-SSA vars. I.e.
in:
int aaa(int a)
{
if (a>4)
bbb(&a);
}
We are still able to work out that bbb is called only when a>4 despite the fact
that A has address taken.
The patch also makes dataflow to simplify a bit the solution,
This patch takes advantage of CLOCK_MONOTONIC (when calling clock_gettime)
when supported by the OS (so far, only AIX and FreeBSD. Linux only supports
it on recent systems, so this is not enabled for now), and defaults to
CLOCK_REALTIME when not available.
Tested on x86_64-pc-linux-gnu, committed
This patch simplifies the expansion of expression functions, and ensures that
proper warnings are generated for unused formals, if present.
The following compilation:
gcc -c -gnat12 -gnatwa -gnatc ada12.ads
must yield:
ada12.ads:6:24: warning: formal parameter "Self" is not referenced
Hi,
This patch adds a predefined macro __ARM_FEATURE_UNALIGNED
which is set when unaligned access is supported in hardware and
enabled by users.
Thanks,
James Greenhalgh
gcc/
2011-09-14 James Greenhalgh
* config/arm/arm.h (TARGET_CPU_CPP_BUILTINS):
New builtin macro.
diff --
On 09/14/2011 06:35 PM, Zdenek Dvorak wrote:
> Hi,
>
>> The attached patch fixes PR50322.
>>
>> The test-case is supposed to succeed if the loop counter data-type has the
>> same
>> size as a pointer. The patch defines TYPE to be an int datatype of the same
>> size
>> as a pointer, and uses it.
67 matches
Mail list logo