On Thu, Dec 05, 2019 at 10:37:33PM +, Jonathan Wakely wrote:
> On Thu, 5 Dec 2019 at 22:19, Segher Boessenkool wrote:
> > Or you could write
> >
> > auto __c = (__builtin_memcmp(&*__first1, &*__first2, __len) <=> 0);
> > if (__c)
> > return __c;
> >
> > which is much easier to rea
On Thu, 5 Dec 2019 at 22:19, Segher Boessenkool wrote:
> Or you could write
>
> auto __c = (__builtin_memcmp(&*__first1, &*__first2, __len) <=> 0);
> if (__c)
> return __c;
>
> which is much easier to read, to my eyes anyway. And it is exactly the
> same for the compiler.
In this ca
On Thu, 5 Dec 2019 at 22:19, Segher Boessenkool wrote:
>
> On Thu, Dec 05, 2019 at 08:56:35PM +, Jonathan Wakely wrote:
> > On Thu, 5 Dec 2019 at 20:07, Segher Boessenkool
> > wrote:
> > > On Thu, Dec 05, 2019 at 05:03:43PM +, Jonathan Wakely wrote:
> > > > C++17 introduces a nice feature,
On Thu, Dec 05, 2019 at 08:56:35PM +, Jonathan Wakely wrote:
> On Thu, 5 Dec 2019 at 20:07, Segher Boessenkool
> wrote:
> > On Thu, Dec 05, 2019 at 05:03:43PM +, Jonathan Wakely wrote:
> > > C++17 introduces a nice feature, with rationale similar to declaring
> > > variables in a for-loop
On Thu, Dec 05, 2019 at 03:38:15PM -0500, Marek Polacek wrote:
> On Thu, Dec 05, 2019 at 02:06:50PM -0600, Segher Boessenkool wrote:
> > > When you're forced to uglify every variable with a leading __ you run
> > > out of characters pretty damn quickly.
> >
> > If using this "nice feature" forces
Joseph Myers :
> On Thu, 5 Dec 2019, Joseph Myers wrote:
>
> > On Thu, 5 Dec 2019, Eric S. Raymond wrote:
> >
> > > Joseph Myers :
> > > > I just tried a leading-segment load up to r14877, but it didn't
> > > > reproduce
> > > > the problems I see with r14877 in a full repository conversion - i
Joseph Myers :
> On Thu, 5 Dec 2019, Eric S. Raymond wrote:
>
> > Joseph Myers :
> > > I just tried a leading-segment load up to r14877, but it didn't reproduce
> > > the problems I see with r14877 in a full repository conversion - it seems
> > > the combination with something later in the histo
On Thu, 5 Dec 2019 at 20:07, Segher Boessenkool
wrote:
>
> Hi!
>
> On Thu, Dec 05, 2019 at 05:03:43PM +, Jonathan Wakely wrote:
> > C++17 introduces a nice feature, with rationale similar to declaring
> > variables in a for-loop init-statement:
> >
> > if (auto var = foo(); bar(var))
>
> Simil
On Thu, 5 Dec 2019, Joseph Myers wrote:
> On Thu, 5 Dec 2019, Eric S. Raymond wrote:
>
> > Joseph Myers :
> > > I just tried a leading-segment load up to r14877, but it didn't reproduce
> > > the problems I see with r14877 in a full repository conversion - it seems
> > > the combination with so
On Thu, Dec 5, 2019 at 11:51 AM Michael Matz wrote:
> Hello,
>
> (oh a flame bait :) )
>
> On Thu, 5 Dec 2019, Thomas Schwinge wrote:
>
> > So, I formally propose that we lift this characters per line restriction
> > from IBM punch card (80) to mainframe line printer (132).
> >
> > Tasks:
> >
> >
On Thu, Dec 05, 2019 at 02:06:50PM -0600, Segher Boessenkool wrote:
> Hi!
>
> On Thu, Dec 05, 2019 at 05:03:43PM +, Jonathan Wakely wrote:
> > C++17 introduces a nice feature, with rationale similar to declaring
> > variables in a for-loop init-statement:
> >
> > if (auto var = foo(); bar(var
On Thu, Dec 05, 2019 at 11:54:04AM -0700, Martin Sebor wrote:
> >> if (present)
> >>ptr
> >> = gfc_build_conditional_assign_expr (block,
> >> present,
> >> ptr,
On Thu, Dec 05, 2019 at 05:04:12PM +0100, Jakub Jelinek wrote:
> On Thu, Dec 05, 2019 at 04:46:45PM +0100, Thomas Schwinge wrote:
> > On 2019-12-05T16:15:15+0100, Jakub Jelinek wrote:
> > > [...] much more indented though, but you could
> > > use a temporary, like:
> > > tree nulla
On Thu, 5 Dec 2019, Eric S. Raymond wrote:
> Joseph Myers :
> > I just tried a leading-segment load up to r14877, but it didn't reproduce
> > the problems I see with r14877 in a full repository conversion - it seems
> > the combination with something later in the history may be necessary to
> >
On Thu, Dec 05, 2019 at 04:44:21PM +, Michael Matz wrote:
> (oh a flame bait :) )
I will blissfully ignore that warning.
> On Thu, 5 Dec 2019, Thomas Schwinge wrote:
> I object to cluttering code in excuse for using sensible function names or
> temporaries that otherwise can help clearing up
Hi!
On Thu, Dec 05, 2019 at 05:03:43PM +, Jonathan Wakely wrote:
> C++17 introduces a nice feature, with rationale similar to declaring
> variables in a for-loop init-statement:
>
> if (auto var = foo(); bar(var))
Similar to GNU C statement expressions, which are *also* only a good
idea to u
All,
As a certified Old Guy (coding in FORTRAN since 1967) my default mode is to
stop at 72 characters. It would be nice to push the max out a bit, but I’ll
most likely keep my lines (and my function and variable names!) short. As
always, brevity is the soul of wit.
And yes, please keep up t
On 12/5/19 8:46 AM, Thomas Schwinge wrote:
Hi!
;-P Jakub, thanks for furnishing me a fit occasion here:
On 2019-12-05T16:15:15+0100, Jakub Jelinek wrote:
[...] much more indented though, but you could
use a temporary, like:
tree nullarg = null_pointer_node;
I object to
My IBM Selectric golfball electronic printer only does 90 characters on A4 in
portrait mode………(at 10 cps)
(as for my all electric TELEX Teleprinter machine !)
Is this debate for real ?! - or is this a Christmas spoof ?
External observer…..keep up the great work. :)
(while I punch out a few
On 12/5/19, Andrew Stubbs wrote:
> On 05/12/2019 16:17, Joseph Myers wrote:
>> Longer lines mean less space for multiple terminal / editor windows
>> side-by-side to look at different pieces of code. I don't think that's
>> an
>> improvement.
>
> Here's a data-point
>
> My 1920 pixel-wide sc
On Thu, Dec 05, 2019 at 05:03:43PM +, Jonathan Wakely wrote:
> On Thu, 5 Dec 2019 at 16:44, Michael Matz wrote:
> >
> > Hello,
> >
> > (oh a flame bait :) )
> >
> > On Thu, 5 Dec 2019, Thomas Schwinge wrote:
> >
> > > So, I formally propose that we lift this characters per line restriction
> >
On 05/12/2019 16:17, Joseph Myers wrote:
Longer lines mean less space for multiple terminal / editor windows
side-by-side to look at different pieces of code. I don't think that's an
improvement.
Here's a data-point
My 1920 pixel-wide screen, in the default font, allows 239 columns; not
‐‐‐ Original Message ‐‐‐
On Thursday, December 5, 2019 4:44 AM, Richard Biener
wrote:
...
...
...
> >
> > I'm trying to identify the source code which needs modification but I need
> > help proceeding.
> > I am comparing two compilations: The first is a simple file with a call to
>
Joseph Myers :
> I just tried a leading-segment load up to r14877, but it didn't reproduce
> the problems I see with r14877 in a full repository conversion - it seems
> the combination with something later in the history may be necessary to
> reproduce the issue.
Great :-(
Well, there's a bise
On Dec 5 2019, Michael Matz wrote:
(oh a flame bait :) )
Quite. I shall try not to make it too much worse, but there's another point
that needs mentioning.
I find long names hard to read, with either short or long lines, especially
when combined with variants like negotiate_twisty_little_pas
On Thu, 5 Dec 2019, Eric S. Raymond wrote:
> I was much more worried about the conversion before we figured out
> that most of the remaining content mismatches seem to radiate out from
> something weird that happened at r14877. That's early enough that a
> leading-segment load including it doesn'
Joseph Myers :
> I think we currently have the following reposurgeon issues open for cases
> where the present code results in incorrect tree contents and we're hoping
> the new code will fix that (or make it much easier to find and fix the
> bugs). These are the issues that are most critical f
On Thu, 5 Dec 2019 at 16:44, Michael Matz wrote:
>
> Hello,
>
> (oh a flame bait :) )
>
> On Thu, 5 Dec 2019, Thomas Schwinge wrote:
>
> > So, I formally propose that we lift this characters per line restriction
> > from IBM punch card (80) to mainframe line printer (132).
> >
> > Tasks:
> >
> >
* Paul Koning:
> That's certainly a general rule. There is a reason why books aren't
> wide, and why newspapers have columns. The eye can't deal well with
> long lines. So while 132 column lines are certainly possible with
> modern computers, it doesn't mean they are desirable.
If the line sta
Hello,
(oh a flame bait :) )
On Thu, 5 Dec 2019, Thomas Schwinge wrote:
> So, I formally propose that we lift this characters per line restriction
> from IBM punch card (80) to mainframe line printer (132).
>
> Tasks:
>
> - Discussion.
I object to cluttering code in excuse for using sensibl
On 12/5/19 9:24 AM, Paul Koning wrote:
>
>
>> On Dec 5, 2019, at 11:17 AM, Joseph Myers
>> wrote:
>>
>> On Thu, 5 Dec 2019, Thomas Schwinge wrote:
>>
>>> In the relevant session at the GNU Tools Cauldron 2019, Michael
>>> Meissner stated that even he is not using a 80 x 24 terminal
>>> anymore
> On Dec 5, 2019, at 11:17 AM, Joseph Myers wrote:
>
> On Thu, 5 Dec 2019, Thomas Schwinge wrote:
>
>> In the relevant session at the GNU Tools Cauldron 2019, Michael Meissner
>> stated that even he is not using a 80 x 24 terminal anymore, and that
>> should tell us something. ;-)
>>
>> So,
On Thu, 5 Dec 2019, Thomas Schwinge wrote:
> In the relevant session at the GNU Tools Cauldron 2019, Michael Meissner
> stated that even he is not using a 80 x 24 terminal anymore, and that
> should tell us something. ;-)
>
> So, I formally propose that we lift this characters per line restricti
On 12/5/19 7:08 AM, Martin Liška wrote:
On 12/5/19 9:00 AM, Nicholas Krause wrote:
Greetings,
Seems that the extend_trucks return values are not returned when
called in both,
cnode::assemble_thunks_and_aliases and cnode::create_wrapper. I'm not
sure
if this is a set of edge case bugs or the
On Thu, Dec 05, 2019 at 04:46:45PM +0100, Thomas Schwinge wrote:
> Hi!
>
> ;-P Jakub, thanks for furnishing me a fit occasion here:
>
> On 2019-12-05T16:15:15+0100, Jakub Jelinek wrote:
> > [...] much more indented though, but you could
> > use a temporary, like:
> > tree nulla
Hi!
;-P Jakub, thanks for furnishing me a fit occasion here:
On 2019-12-05T16:15:15+0100, Jakub Jelinek wrote:
> [...] much more indented though, but you could
> use a temporary, like:
> tree nullarg = null_pointer_node;
I object to cluttering the code by introducing tempora
Richard Earnshaw (lists) :
> Ok, this is one to keep an eye on. There are a number of anomalous commmits
> at present, which Eric is working on with a new approach to replaying the
> SVN data into reposurgeon. Once that is done we're hoping that this sort of
> problem will go away.
Best case is
Those of you with a direct interest in the conversion might want
to watch #reposurgeon on freenode. This is where Daniel Brooks,
Julien Rivaud and I are working on it.
Here's where the code lives:
reposurgeon: https://gitlab.com/esr/reposurgeon
The conversion recipe: https://gitlab.com/esr/gcc-
Joseph Myers :
> The avoidance of '.' in branch and tag names is, I'm pretty sure, a legacy
> of CVS restrictions on valid names for branches and tags. Those
> restrictions are not relevant to git or SVN; if picking any new convention
> it seems appropriate for the tag for GCC 10.1 to say "10.1
On Thu, 5 Dec 2019, Richard Earnshaw (lists) wrote:
> Ok, this is one to keep an eye on. There are a number of anomalous commmits
> at present, which Eric is working on with a new approach to replaying the SVN
> data into reposurgeon. Once that is done we're hoping that this sort of
> problem wi
On 12/5/19 9:00 AM, Nicholas Krause wrote:
Greetings,
Seems that the extend_trucks return values are not returned when called in both,
cnode::assemble_thunks_and_aliases and cnode::create_wrapper. I'm not sure
if this is a set of edge case bugs or there was a reason for this. Seems not as
its
ch
On Thu, 5 Dec 2019 at 10:41, Jonathan Wakely wrote:
>
> On Thu, 5 Dec 2019 at 10:36, Richard Earnshaw (lists)
> wrote:
> >
> > On 05/12/2019 10:32, Jonathan Wakely wrote:
> > > On Thu, 5 Dec 2019 at 10:25, Jonathan Wakely
> > > wrote:
> > >>
> > >> On Wed, 4 Dec 2019 at 23:52, Richard Earnshaw
On Thu, 5 Dec 2019 at 10:36, Richard Earnshaw (lists)
wrote:
>
> On 05/12/2019 10:32, Jonathan Wakely wrote:
> > On Thu, 5 Dec 2019 at 10:25, Jonathan Wakely wrote:
> >>
> >> On Wed, 4 Dec 2019 at 23:52, Richard Earnshaw (lists) wrote:
> >>> I've just pushed a new trial conversion:
> >>>
> >>> ht
On 05/12/2019 10:32, Jonathan Wakely wrote:
On Thu, 5 Dec 2019 at 10:25, Jonathan Wakely wrote:
On Wed, 4 Dec 2019 at 23:52, Richard Earnshaw (lists) wrote:
I've just pushed a new trial conversion:
https://gitlab.com/rearnsha/gcc-trial2-20191130
The main differences between this and the pre
On Thu, 5 Dec 2019 at 10:25, Jonathan Wakely wrote:
>
> On Wed, 4 Dec 2019 at 23:52, Richard Earnshaw (lists) wrote:
> > I've just pushed a new trial conversion:
> >
> > https://gitlab.com/rearnsha/gcc-trial2-20191130
> >
> > The main differences between this and the previous trial are:
> > - The
On Wed, 4 Dec 2019 at 23:52, Richard Earnshaw (lists) wrote:
> I've just pushed a new trial conversion:
>
> https://gitlab.com/rearnsha/gcc-trial2-20191130
>
> The main differences between this and the previous trial are:
> - The author attributions should now be fixed, please let me know if you
>
On Wed, Dec 4, 2019 at 9:53 PM GT wrote:
>
> ‐‐‐ Original Message ‐‐‐
> On Wednesday, November 27, 2019 3:19 AM, Richard Biener
> wrote:
>
> ...
>
> > > Questions:
> > >
> > > 1. Should we aim to provide a vectorized version of __builtin_cexpi? If
> > > so, it would have
> > > to b
On 05/12/2019 08:55, Maxim Kuvyrkov wrote:
On Dec 3, 2019, at 11:10 PM, Richard Earnshaw (lists)
wrote:
On 03/12/2019 18:56, Segher Boessenkool wrote:
On Tue, Dec 03, 2019 at 09:16:43AM +, Richard Earnshaw (lists) wrote:
On 03/12/2019 00:56, Segher Boessenkool wrote:
That sounds simpler
> On Dec 3, 2019, at 11:10 PM, Richard Earnshaw (lists)
> wrote:
>
> On 03/12/2019 18:56, Segher Boessenkool wrote:
>> On Tue, Dec 03, 2019 at 09:16:43AM +, Richard Earnshaw (lists) wrote:
>>> On 03/12/2019 00:56, Segher Boessenkool wrote:
That sounds simpler than it is... After using
Greetings,
Seems that the extend_trucks return values are not returned when called
in both,
cnode::assemble_thunks_and_aliases and cnode::create_wrapper. I'm not sure
if this is a set of edge case bugs or there was a reason for this. Seems
not as its
checked in the third function caller in the
50 matches
Mail list logo