Re: Fully flow and context sensitive points-to analysis in GCC 4.6.0

2012-10-17 Thread Uday Khedker
On Saturday 13 October 2012 02:34 AM, Xinliang David Li wrote: Somewhere it is mentioned that heap is handled conservatively. Does it mean the algorithm can not disambiguate heap objects all all, or it can but does not track pointer values stored in heap objects? How about field sensitivity?

Re: RFD: HAVE_* pattern flags

2012-10-17 Thread Richard Henderson
On 2012-10-17 10:31, Joern Rennecke wrote: > - What would a good naming scheme be? > - Change the semantics of the HAVE_pattern macros for officially named > patterns so that they are defined as 0 when the pattern is not provided? > That choice would actually force people to change #ifdef

Re: New dump infrastructure

2012-10-17 Thread Xinliang David Li
On Wed, Oct 17, 2012 at 1:40 PM, Sharad Singhai wrote: > On Tue, Oct 16, 2012 at 11:17 PM, Georg-Johann Lay wrote: > >> How are dumps from the backend handled then? > > I haven't really looked at backends. Perhaps they can be converted at > the cost of extra dispatch functions defined in dumpfile

Re: RFD: HAVE_* pattern flags

2012-10-17 Thread Richard Henderson
On 2012-10-18 00:39, Joseph S. Myers wrote: > Note: for patterns that involve a machine mode, I think it's better to > generate a macro (or function) that takes the mode as a parameter. This > is because most references to modes such as SImode or DFmode in > architecture-independent code are in

Re: New dump infrastructure

2012-10-17 Thread Sharad Singhai
On Tue, Oct 16, 2012 at 11:17 PM, Georg-Johann Lay wrote: > How are dumps from the backend handled then? I haven't really looked at backends. Perhaps they can be converted at the cost of extra dispatch functions defined in dumpfile.c. For example, we can add methods like 'dump_rtl_single ()' and

Re: RFD: HAVE_* pattern flags

2012-10-17 Thread Richard Henderson
On 2012-10-17 10:31, Joern Rennecke wrote: > - What would a good naming scheme be? > - Change the semantics of the HAVE_pattern macros for officially named > patterns so that they are defined as 0 when the pattern is not provided? > That choice would actually force people to change #ifdef

Re: New dump infrastructure

2012-10-17 Thread Xinliang David Li
On Wed, Oct 17, 2012 at 2:08 AM, Richard Biener wrote: > On Wed, Oct 17, 2012 at 9:05 AM, Xinliang David Li wrote: >> A more simpler use model is not to guard the dump statement at all -- >> just express the intention a) what to dump; b) as what kind or to >> where >> >> >> 1) I want to dump the

Re: RFD: HAVE_* pattern flags

2012-10-17 Thread Joseph S. Myers
On Tue, 16 Oct 2012, Joern Rennecke wrote: > - Change the semantics of the HAVE_pattern macros for officially named >patterns so that they are defined as 0 when the pattern is not provided? >That choice would actually force people to change #ifdef into if (), >without the possibility

Re: When is char_type_node available in plugins?

2012-10-17 Thread Richard Biener
On Wed, Oct 17, 2012 at 11:02 AM, Basile Starynkevitch wrote: > > Hello All, > > While coding (in MELT) > https://github.com/bstarynk/melt-examples/tree/master/ex06 > (which is essentially a MELT extension using the MELT 0.9.7 plugin from > http://gcc-melt.org/ ) > I noticed that the char_type_n

Re: How to add pass filtering for -fopt-info

2012-10-17 Thread Richard Biener
On Wed, Oct 17, 2012 at 9:32 AM, Sharad Singhai wrote: >> I don't like B), it is unlike everything else a pass does. You seem to >> use the new field to indicate a group - that makes it a flat hierarchy >> which might make it limiting (for example 'vect' may include both loop >> and scalar vector

Re: New dump infrastructure

2012-10-17 Thread Richard Biener
On Wed, Oct 17, 2012 at 9:05 AM, Xinliang David Li wrote: > A more simpler use model is not to guard the dump statement at all -- > just express the intention a) what to dump; b) as what kind or to > where > > > 1) I want to dump the something as optimized message: > > dump_printf (MSG_OPTIMIZED

When is char_type_node available in plugins?

2012-10-17 Thread Basile Starynkevitch
Hello All, While coding (in MELT) https://github.com/bstarynk/melt-examples/tree/master/ex06 (which is essentially a MELT extension using the MELT 0.9.7 plugin from http://gcc-melt.org/ ) I noticed that the char_type_node tree from gcc/tree.h is not available (i.e. is still NULL) when the plu

Re: How to add pass filtering for -fopt-info

2012-10-17 Thread Sharad Singhai
> I don't like B), it is unlike everything else a pass does. You seem to > use the new field to indicate a group - that makes it a flat hierarchy > which might make it limiting (for example 'vect' may include both loop > and scalar vectorization, but would 'loop' also include loop vectorization?).

Re: New dump infrastructure

2012-10-17 Thread Xinliang David Li
A more simpler use model is not to guard the dump statement at all -- just express the intention a) what to dump; b) as what kind or to where 1) I want to dump the something as optimized message: dump_printf (MSG_OPTIMIZED, "blah...") dump_printf_loc (MSG_OPTIMIZED, "blah") 2) I want to du